Jump to content

VNAO T-45 Goshawk


MadMaxter

Recommended Posts

well, this tume you know there is such a problem, can anyone help to fix it?
Sorry, I have both stable 2.5.6 and OB 2.7.x installed, so I have only tested on 2.7.x.
I suggest you read some of the posts above. Maybe somebody made it work.
I'll have a look though.
Cheers!

Sent from my MAR-LX1A using Tapatalk

Link to comment
Share on other sites

23 minutes ago, PhilTheBeat said:

Hello everyone and first of all thank you for this FREE module .

 

I have a question. I think i´ve set everything in the right way.

 

I want it to try it using the mission editor i set the plane as "client", i can choose in the slot windows but once on the tarmac the AI control it. Am i missing something?

 

Thanks.

 

 

DCS_b46YbaONNC.jpg

 

 

 

I did have the same issue (as quite some other persons here also seem to have) and posted my very own solution approach to this issue a couple pages earlier:

 

Norton AntiVirus defined the VNAOT45FM.dll as malware and constantly quarantined it. I set this file as an exception, re-installed the mod, and now I can enter the cockpit without any issues!

 

Also, you may want to check to have the right plane selected: it shows "Hawk" in your screenshot.  🙂

 

Good luck!  🙂

 

  • Like 1
Link to comment
Share on other sites

First of all, congratulations! We´re having a streak of very well conceived and built mods lately. Your plane is gorgeous! One single question: the plane is constantly moving in idle condition, and I need to keep brakes applied all the time (until is time to move, of course). Is this behavior normal?

 

  • Like 2
Link to comment
Share on other sites

4 minutes ago, Direwolf said:

First of all, congratulations! We´re having a streak of very well conceived and built mods lately. Your plane is gorgeous! One single question: the plane is constantly moving in idle condition, and I need to keep brakes applied all the time (until is time to move, of course). Is this behavior normal?

 

I noticed that, too. I use the emergency break to avoid having to press the toe brakes all the time. But I'm curious if this is a normal aircraft behavior in RL. Somehow I doubt that little engine will be able to move the airframe at idle. 

Link to comment
Share on other sites

13 hours ago, sobe said:

I am trying to run the plane with two screens with the second screen displaying the 2 MFDs and I have two questions.

 

The right MFDR displays on my second screen but the left MFDL will not do so. 

I use the following command in the MFDL init.lua file

dofile(LockOn_Options.common_script_path.."ViewportHandling.lua")
try_find_assigned_viewport("VANO_45T_LEFT_MFCD")

 

Is this my error?

 

Second, while I programmed the MFD buttons in the game controls to match the buttons on my TM Cougar MFDs, my TM Cougar MFD buttons do not change the in game display.  However, both the in game display and the display on my second screen do change if I click on a button on the game MFD.  Is that the current status?

 

 

where do you find the MFDL init.lua file ?

[sIGPIC]https://forums.eagle.ru/signaturepics/sigpic70550_3.gif[/sIGPIC]

Asus Z390-H - SSD M.2 EVO 970 - Intel I9 @5.0ghz - 32gb DDR4 4000 - ZOTAC 2080ti AMP Extreme Core - Cougar FSSB + Cougar NN_Dan + HOTAS Warthog + Virpil WRBRD + Hornet Stick - Thrustmaster TPR Pedals - Track IR5

Link to comment
Share on other sites

made a new loading image image for the T-45 theme

 

loadin10.png

 

goes into \Saved Games\DCS.openbeta\Mods\Aircraft\VNAO_T45\Theme\ME

 

name

 

loading-window.png

 

 


Edited by FZG_Immel
  • Like 6

[sIGPIC]https://forums.eagle.ru/signaturepics/sigpic70550_3.gif[/sIGPIC]

Asus Z390-H - SSD M.2 EVO 970 - Intel I9 @5.0ghz - 32gb DDR4 4000 - ZOTAC 2080ti AMP Extreme Core - Cougar FSSB + Cougar NN_Dan + HOTAS Warthog + Virpil WRBRD + Hornet Stick - Thrustmaster TPR Pedals - Track IR5

Link to comment
Share on other sites

39 minutes ago, FZG_Immel said:

 

where do you find the MFDL init.lua file ?

Works for me. As I believe that you already have your 2nd screen setup for LEFT_MFCD and RIGHT_MFCD like me, I just reused these definitions by adding:

- into:  Cockpit\Scripts\Displays\MFDL\Indicator\initi.lua  I added: 

dofile(LockOn_Options.common_script_path.."ViewportHandling.lua")
try_find_assigned_viewport("LEFT_MFCD")

- into:  Cockpit\Scripts\Displays\MFDR\Indicator\initi.lua  I added: 

dofile(LockOn_Options.common_script_path.."ViewportHandling.lua")
try_find_assigned_viewport("RIGHT_MFCD")

 

 

Link to comment
Share on other sites

2 hours ago, jjl9999 said:

Works for me. As I believe that you already have your 2nd screen setup for LEFT_MFCD and RIGHT_MFCD like me, I just reused these definitions by adding:

- into:  Cockpit\Scripts\Displays\MFDL\Indicator\initi.lua  I added: 

dofile(LockOn_Options.common_script_path.."ViewportHandling.lua")
try_find_assigned_viewport("LEFT_MFCD")

- into:  Cockpit\Scripts\Displays\MFDR\Indicator\initi.lua  I added: 

dofile(LockOn_Options.common_script_path.."ViewportHandling.lua")
try_find_assigned_viewport("RIGHT_MFCD")

 

 

 

doest work for me. 

 

Can you show me WHERE you put it in the init.lua ?

 

EDIT: got it working by adding it at the end !!! THANKS !!!


Edited by FZG_Immel
  • Like 1

[sIGPIC]https://forums.eagle.ru/signaturepics/sigpic70550_3.gif[/sIGPIC]

Asus Z390-H - SSD M.2 EVO 970 - Intel I9 @5.0ghz - 32gb DDR4 4000 - ZOTAC 2080ti AMP Extreme Core - Cougar FSSB + Cougar NN_Dan + HOTAS Warthog + Virpil WRBRD + Hornet Stick - Thrustmaster TPR Pedals - Track IR5

Link to comment
Share on other sites

1 hour ago, MAXsenna said:

Did you make sure engine switch goes back to ON from START, and then use the fingerlifts?
Also make sure your throttle is set as a slider.
Hope this helps!
Cheers!
 

Let me try again.  Thanks.

  • Like 1

VR Flight Guy in PJ Pants -- this is how I fly

We do not fly at treetop height, we fly between trees(TM)

YouTube: https://www.youtube.com/channel/UCc9BDi-STaqgWsjNiHbW0fA

Link to comment
Share on other sites

Quote
31 minutes ago, FZG_Immel said:

 

doest work for me. 

 

Can you show me WHERE you put it in the init.lua ?

 

EDIT: got it working by adding it at the end !!! THANKS !!!

 

 

I´m working on my .lua for two extern screens - but I can´t get it to work!

 

Can you explain in a detail way how you do it?

“The uninitiated non-believers think an airplane is a collection of moving parts and miles of wiring.

We know better.”

 

Marshall “War Dog” Lefavor

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

The fonts on the MFDs is somehow broken. Perhaps this is already known. I wanted to share this with you.

2021-04-25 15_04_12-Window.png


Edited by Bishop_DE

 

 

Rechner: AMD 2700X, 32GB RAM, 2x SSD (500Gb u. 128Gb), Warthog Joystick, Rift S, GTX 1080, Monstertech Flightstand

Link to comment
Share on other sites

2 hours ago, Flipper said:

I´m working on my .lua for two extern screens - but I can´t get it to work!

 

Can you explain in a detail way how you do it?

 

 

first question is.. Do you already have external MFD's working on another airplane ? Like the F/A-18C or the F-16C ?

 

because the explanations are going to be much longer if you dont. If you already have some working, and that your MonitorSetup file already includes that, its going to be easier

2 hours ago, Bishop_DE said:

The fonts on the MFDs is somehow broken. Perhaps this is already known. I wanted to share this with you.

2021-04-25 15_04_12-Window.png

 

 

I agree, the fonts are a bit strange, and also the right column of the MFD's is a bit off screen

[sIGPIC]https://forums.eagle.ru/signaturepics/sigpic70550_3.gif[/sIGPIC]

Asus Z390-H - SSD M.2 EVO 970 - Intel I9 @5.0ghz - 32gb DDR4 4000 - ZOTAC 2080ti AMP Extreme Core - Cougar FSSB + Cougar NN_Dan + HOTAS Warthog + Virpil WRBRD + Hornet Stick - Thrustmaster TPR Pedals - Track IR5

Link to comment
Share on other sites

Quote
8 minutes ago, FZG_Immel said:

 

 

first question is.. Do you already have external MFD's working on another airplane ? Like the F/A-18C or the F-16C ?

 

because the explanations are going to be much longer if you dont. If you already have some working, and that your MonitorSetup file already includes that, its going to be easier

 

 

Yes, I have 😉 - this is my very well working .lua for the hornet:

Thanks for reply!😀


Edited by Flipper

“The uninitiated non-believers think an airplane is a collection of moving parts and miles of wiring.

We know better.”

 

Marshall “War Dog” Lefavor

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

2 hours ago, PhilTheBeat said:

Hello everyone and first of all thank you for this FREE module .

 

I have a question. I think i´ve set everything in the right way.

 

I want it to try it using the mission editor i set the plane as "client", i can choose in the slot windows but once on the tarmac the AI control it. Am i missing something?

 

Thanks.

 

 

DCS_b46YbaONNC.jpg

 

You selected the wrong plane...

  • Like 1
Link to comment
Share on other sites

FZG_Immel

 

I assume that you got both MFDs to display on your second screen.  I will try again later.  Perhaps I have just made a typo somewhere.

 

Do you have Cougar MFDs and if so did you try to program the buttons to work in game?  Again I could not get that to work.

Trackir4 using the latest Trackir 5 software, Win10 Pro [Creator Update] updated from Win7Pro Pro 64Bit, Intel® Core™ i5-2500 3.30 GHz 6M Intel Smart Cache LGA115 , GigaByte GA-Z68XP-UD4 Intel Z68 Chipset DDR3 16GB Ram, GTX MSI Gaming 1060 [6 GB] Video Card, Main Monitor 1 on left 1920x1080 Touchscreen Monitor 2 on right 1920x1080 .

Link to comment
Share on other sites

This is absolutely brilliant, unfortunately the aircraft crashes when taking off from Nellis as soon as the gear goes up. This should be an official module.

 

Mizzy

Link to comment
Share on other sites

2 hours ago, sobe said:

FZG_Immel

 

I assume that you got both MFDs to display on your second screen.  I will try again later.  Perhaps I have just made a typo somewhere.

 

Do you have Cougar MFDs and if so did you try to program the buttons to work in game?  Again I could not get that to work.

 

yes to both

[sIGPIC]https://forums.eagle.ru/signaturepics/sigpic70550_3.gif[/sIGPIC]

Asus Z390-H - SSD M.2 EVO 970 - Intel I9 @5.0ghz - 32gb DDR4 4000 - ZOTAC 2080ti AMP Extreme Core - Cougar FSSB + Cougar NN_Dan + HOTAS Warthog + Virpil WRBRD + Hornet Stick - Thrustmaster TPR Pedals - Track IR5

Link to comment
Share on other sites

Ok, so this is what I did :

 

first I created two new entries in my MonitorSetup file ((modify the file you currently use in DCS; but make a back up copy of said file first) that you can find here  \Eagle Dynamics\DCS World OpenBeta\Config\MonitorSetup

 

here are the entries for the monitorsetup file that must be added.

 

Quote

MFDL = 
{
     x = 3963.0;
     y = 258.0;
     width = 383;
     height = 390;
}
MFDR = 
{
     x = 5232.0;
     y = 258.0;
     width = 383;
     height = 390;
}

 

 

for coordinates and sizes, you can initially copy those that you already use for the other exports you have there, but you will need then need to finetune them, because  for this airplane these exports need to be a little smaller, to fit the Cougar MFD's...

 

for reference, here are the lines I use for the hornet, for example. You can see the difference (up there the sizes are smaller compared to the one I created for the Goshawk)

Quote

LEFT_MFCD = 
{
     x = 3953.0;
     y = 248.0;
     width = 406;
     height = 406;
}
RIGHT_MFCD = 
{
     x = 5222.0;
     y = 248.0;
     width = 406;
     height = 406;
}
CENTER_MFCD = 
{
     x = 4585.0;
     y = 438.0;
     width = 406;
     height = 406;
}

 

 

 

then, you need to add the following lines to your MFDR init.lua file that you can find here (add it at the VERY END of the file):

\Saved Games\DCS.openbeta\Mods\Aircraft\VNAO_T45\Cockpit\Scripts\Displays\MFDR\Indicator

 

Quote

------------------------ added by Capt Zeen
dofile(LockOn_Options.common_script_path.."ViewportHandling.lua")
try_find_assigned_viewport("MFDR")
------------------------------------- end of added by Capt Zeen

 

 

then, you need to add the following lines to your MFDL init.lua file that you can find here (add it at the VERY END of the file) :

\Saved Games\DCS.openbeta\Mods\Aircraft\VNAO_T45\Cockpit\Scripts\Displays\MFDL\Indicator

 

Quote

------------------------ added by Capt Zeen
dofile(LockOn_Options.common_script_path.."ViewportHandling.lua")
try_find_assigned_viewport("MFDL")
------------------------------------- end of added by Capt Zeen

 

for reference, here is how the complete init.lua file looks like (with the addition put in bold).
 

Quote

dofile(LockOn_Options.common_script_path.."devices_defs.lua")

indicator_type    = indicator_types.COMMON
init_pageID     = 1
purposes        = {render_purpose.GENERAL,render_purpose.HUD_ONLY_VIEW}

--subset ids
BASE    = 1
MENU    = 2
STORES     = 3
HSI        = 4
ADI        = 5
ENGINE    = 6
DATA    = 7
HUD        = 8
ACFT    = 9
GPS        = 10
BIT        = 11


page_subsets  = {
[BASE]        = LockOn_Options.script_path.."Displays/MFDL/Indicator/base_page.lua",
[MENU]        = LockOn_Options.script_path.."Displays/MFDL/Indicator/menu_page.lua",
[STORES]    = LockOn_Options.script_path.."Displays/MFDL/Indicator/stores_page.lua",
[HSI]        = LockOn_Options.script_path.."Displays/MFDL/Indicator/hsi_page.lua",
[ADI]        = LockOn_Options.script_path.."Displays/MFDL/Indicator/adi_page.lua",
[ENGINE]    = LockOn_Options.script_path.."Displays/MFDL/Indicator/eng_page.lua",
[DATA]      = LockOn_Options.script_path.."Displays/MFDL/Indicator/data_page.lua",
[ACFT]      = LockOn_Options.script_path.."Displays/MFDL/Indicator/acft_page.lua",
[GPS]       = LockOn_Options.script_path.."Displays/MFDL/Indicator/gps_page.lua",
[HUD]       = LockOn_Options.script_path.."Displays/MFDL/Indicator/hud_page.lua",
}


pages ={{BASE,MENU,STORES,HSI,ADI,ENGINE,DATA,ACFT,GPS,HUD},}

 

------------------------ added by Capt Zeen
dofile(LockOn_Options.common_script_path.."ViewportHandling.lua")
try_find_assigned_viewport("MFDL")
------------------------------------- end of added by Capt Zeen

 

there you go. this should work. works for me perfectly

 


Edited by FZG_Immel
  • Like 1

[sIGPIC]https://forums.eagle.ru/signaturepics/sigpic70550_3.gif[/sIGPIC]

Asus Z390-H - SSD M.2 EVO 970 - Intel I9 @5.0ghz - 32gb DDR4 4000 - ZOTAC 2080ti AMP Extreme Core - Cougar FSSB + Cougar NN_Dan + HOTAS Warthog + Virpil WRBRD + Hornet Stick - Thrustmaster TPR Pedals - Track IR5

Link to comment
Share on other sites

FZG_Immel

 

I gave up trying to find my typos so I just copied your viewport and init.lua changes and it works.   As for the MFD buttons, I had assigned the right mfd to my 3rd Cougar MFD.  Perhaps that was the error so I changed it to Cougar MFD #2 and now everything works.  That is the joy of DCS.  Trying to unravel mysteries.  Just when you think you know everything, something crazy happens.

  • Like 1

Trackir4 using the latest Trackir 5 software, Win10 Pro [Creator Update] updated from Win7Pro Pro 64Bit, Intel® Core™ i5-2500 3.30 GHz 6M Intel Smart Cache LGA115 , GigaByte GA-Z68XP-UD4 Intel Z68 Chipset DDR3 16GB Ram, GTX MSI Gaming 1060 [6 GB] Video Card, Main Monitor 1 on left 1920x1080 Touchscreen Monitor 2 on right 1920x1080 .

Link to comment
Share on other sites

FZG_Immel

Now if I can only figure out how to get the UFC to work in Helios.  Right now I don't believe that is possible as there are no key commands and using the generic interface is to complicated.

  • Like 1

Trackir4 using the latest Trackir 5 software, Win10 Pro [Creator Update] updated from Win7Pro Pro 64Bit, Intel® Core™ i5-2500 3.30 GHz 6M Intel Smart Cache LGA115 , GigaByte GA-Z68XP-UD4 Intel Z68 Chipset DDR3 16GB Ram, GTX MSI Gaming 1060 [6 GB] Video Card, Main Monitor 1 on left 1920x1080 Touchscreen Monitor 2 on right 1920x1080 .

Link to comment
Share on other sites

4 hours ago, PhilTheBeat said:

Hello everyone and first of all thank you for this FREE module .

 

I have a question. I think i´ve set everything in the right way.

 

I want it to try it using the mission editor i set the plane as "client", i can choose in the slot windows but once on the tarmac the AI control it. Am i missing something?

 

Thanks.

 

 

DCS_b46YbaONNC.jpg

 

 

I saw that i don´t have the possibility in the list menu to choose "player" and the Hawk is greyed , not yellow.

 

Any help will be welcome.

 

 

DCS_c9k4leuJul.jpg

 I7 4770K / 1080 TI / 16GB RAM / VR Q2 / 3X IIYAMA 27 / T.16000M FCS TWCS / TRACK IR PRO

A-10C II / F/A18 C / F-14 / F16-C / M-2000C / F-86F Sabre / C-101 / SPITFIRE LF / P-51D / FW 190 D-9 / FW 190 A-B / Bf 109 K-4

CHRISTEN EAGLE II / YAK-52 / UH-1H Huey / SA 342

CHANNEL MAP / NEVADA / NORMANDY /  PERSIAN / SYRIA / SUPERCARRIER /

TAKE OFF FRANCE.FR

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...