Jump to content

DCS Server Control


Recommended Posts

I believe I read somewhere that a "pause when no players connected" option is available for DCS server. Is it a thing or am I imagining things?

 

 

It is there. On the web control interface in server settings (gears icon), advanced, and near bottom of window there are 3 options starting "Resume...". The last one, "Resume with clients", pauses the server when it is empty.

Intel Core i7 9700K@4.6GHz|ASUS Strix Z390-H|G.Skill DDR4 32GB@3200MHz|MSI GeForce RTX 2080 Ti|2xSSD 500GB Samsung 970 EVO M.2 RAID0|SSD Samsung 850 EVO|Corsair HX 750W|Fractal Design Define R6 Blackout|UWQHD 34"|Valve Index|Logitech G9|MS Natural Ergonomic Keyboard 4000|VPC WarBRD Base+MongoosT-50CM2 Grip|VPC MongoosT-50 Throttle|VKB T-Rudder|Beyerdynamic DT770|Boom mic|Windows 10 Home

Link to comment
Share on other sites

  • 4 weeks later...

In my other thread, ED reported that the webui not responding was related to a compiler issue and systems without AES-NI. Once I had my host move my VM to a machine that would expose AES-NI to me, my webui started working again.

Link to comment
Share on other sites

  • 1 month later...

So I am having a really weird issue with the Dedicated server and the WebGUI. Everything is working fine and all ports needed are opened etc , however whenever I actually launch my server (the dedicated app npt the actual client running as a server) my servers always show up in the webgui browser as in some sort of offline manual mode, as soon as I click the Server # xxxxxx name it lets me in and im able to start the server normally , howevever the server refuses to start up when i run the exe file it just puts itself into this sleep like state!

 

Anyone got any ideas why? heres my auto exec and my serversettings/lua:

 

 

cfg =

{

["current"] = 0,

["missionList"] =

{

[1] = "C:\\Users\\MCMac\\Saved Games\\Missions\\Operation Clear Field v111.miz",

[2] = "C:\\Users\\MCMac\\Saved Games\\Missions\\Operation Clear Field W-MODS v111.miz",

}, -- end of ["missionList"]

["require_pure_textures"] = false,

["advanced"] =

{

["allow_change_tailno"] = true,

["disable_events"] = false,

["allow_ownship_export"] = true,

["allow_object_export"] = true,

["pause_on_load"] = false,

["allow_sensor_export"] = true,

["event_Takeoff"] = true,

["pause_without_clients"] = false,

["client_outbound_limit"] = 0,

["client_inbound_limit"] = 0,

["server_can_screenshot"] = true,

["event_Role"] = true,

["allow_change_skin"] = true,

["event_Connect"] = true,

["event_Ejecting"] = true,

["event_Kill"] = true,

["event_Crash"] = true,

["resume_mode"] = 1,

["maxPing"] = 200,

}, -- end of ["advanced"]

["port"] = "10308",

["listLoop"] = false,

["bind_address"] = "",

["isPublic"] = true,

["uri"] = "startServer",

["password"] = "",

["description"] = "",

["name"] = "MM SERVER SMACK OPERATION CLEAR FIELD",

["listShuffle"] = false,

["version"] = 1,

["require_pure_models"] = false,

["require_pure_clients"] = false,

["maxPlayers"] = "100",

} -- end of cfg

 

 

options.graphics.fullScreen = false

options.graphics.width = 640

options.graphics.height = 480

options.graphics.maxfps = 20

options.graphics.render3D = false

if not net then net = {} end

net.download_speed = 131072000

net.upload_speed = 131072000

disable_write_track = true

webgui_port = 8088

 

my switches im running the exe';s with are as follows:

 

E:\DCS\bin\DCS.exe --norender --server -w Instance1

 

I have 3 instance but am only running 2 due to ED's temporary limitations

 

JPEG_20191109_164657.jpg

 

JPEG_20191109_164533.jpg

 

JPEG_20191109_164515.jpg

 

JPEG_20191109_164149.jpg


Edited by Badass1982
Link to comment
Share on other sites

Nope not fixed. Now the servers show up by name in the remote web browser but when i click on them they both say offline.

 

I can bring up both when loading the index.htm file (local webgui) on the server but it asks for the port (when i enter the webgui port for that instance the server loads as it should)

 

 

 

 

EDIT: played around with my ports and it APPEARS they weren't forwarded correctly. everything working now.


Edited by Badass1982
Link to comment
Share on other sites

Something has changed. Remote admin works again, and I changed nothing other than update my dedicated server files. Happy days :)

Windows 10 64bit, Intel i7 6700K, 32GB Corsair 2400Mhz, 970 NVMe 500Gb SSD, GeForce 2080 super, HP Reverb, VKB GF PRO, Thrustmaster Warthog throttle, Thrustmaster Pendular rudders, Windows + DCS :thumbup:

 

My youtube channel

Link to comment
Share on other sites

It will not the first time that the best bugfix was not metioned in the releasenotes. :smilewink:

SYSTEM: Mainboard MSI Z270 Krait | CPU i7 7700k @ 4.8 GHz | RAM 32 GB @ 3200 MHz | GPU GIGABYTE RTX 3080 | 1 TB SSD | Win 10 x64

DEVICES: ASUS 27" LCD | TrackIR 5 | LukeClip | Rift S & HP Reverb G2 | PointCTRL | TM Warthog | MFG Crosswind | Throttle Quadrant Logitech | TableMount MonsterTech

MODULES: All

 

PROJECTS: OpenFlightSchool: DE / EN

 

Link to comment
Share on other sites

Sorry to say but remote admin has stopped working again :(

 

I can connect using DCS to my server from my client machine. The Server list in my ED profile reports my server as running, but when view the server dashboard it reports server not connected. I have made no changes to server nor client other then the update yesterday.

Windows 10 64bit, Intel i7 6700K, 32GB Corsair 2400Mhz, 970 NVMe 500Gb SSD, GeForce 2080 super, HP Reverb, VKB GF PRO, Thrustmaster Warthog throttle, Thrustmaster Pendular rudders, Windows + DCS :thumbup:

 

My youtube channel

Link to comment
Share on other sites

  • 2 weeks later...

Each time I restart the server, I can see it in the server list and on the remote page for about 24 hours then only reachable via IP...

i9 9900k, 64 Go RAM, RTX 2080 TI, Warthog HOTAS Throttle & Stick, Saitek Combat Rudder, MFD Cougar (with Cubesim monitors), Trackir 5 Pro, (Oculus Rift S when I want some VR)

http://www.twitch.tv/zarma4074 /  https://www.youtube.com/user/Zarma4074 

 

Copy-of-DCS-A-10C-User-Bar-CMR-ConvertImage.jpg

Link to comment
Share on other sites

Hey there!

How can i change a mission , to a mission of my list?

Can i force Dedicated server to just load next mission from my mission list every X hours?

Without having to "Mission Edit" every mission in the list.

 

Thanks in advance.

Link to comment
Share on other sites

Hey there!

How can i change a mission , to a mission of my list?

Can i force Dedicated server to just load next mission from my mission list every X hours?

Without having to "Mission Edit" every mission in the list.

 

Thanks in advance.

 

From my experience in order for a mission rotation to occur you would indeed need to set an "END MISSION" trigger on every mission, and on the playlist file you should enable either shuffle or loop.

 

Cheers

IAF.ViFF

 

http://www.preflight.us

Israel's Combat Flight Sim Community Website

Link to comment
Share on other sites

Each time I restart the server, I can see it in the server list and on the remote page for about 24 hours then only reachable via IP...

How do you link to your server by IP - by IP in URL to host page, or in game?

 

@all, I am guessing I will need to change my server port from 10309 with the VOIP implementation?

Windows 10 64bit, Intel i7 6700K, 32GB Corsair 2400Mhz, 970 NVMe 500Gb SSD, GeForce 2080 super, HP Reverb, VKB GF PRO, Thrustmaster Warthog throttle, Thrustmaster Pendular rudders, Windows + DCS :thumbup:

 

My youtube channel

Link to comment
Share on other sites

  • 2 months later...

Hi, I create a dedicated server, from the PC where de Open Beta Server its located i connect to the webgui, load a mision, tweak the settings, etc eBUT when i try to enter de remote web gui from the DCS webpage, the server its shown on my server list and when i click it on the name and enter the webgui interface it shows the server as offline and i unable to see the mision list, settings, etc...

 

any clues?

Link to comment
Share on other sites

+1 Same issue after 2.5.6

:pilotfly:

[sIGPIC][/sIGPIC]

 

:gun_smilie:

 

229th Assault Helicopter Battalion - Always Recruiting

 

If you have a passion for helicopter flight simulation and would like to fly in a friendly and supportive online multiplayer environment, then you’ve just put your skids down safely on the right page…!

 

DCS Squadron Recruiting Page for the 229th

https://forums.eagle.ru/showthread.php?t=267081

 

For details see our website at:

http://1stcavdiv.forumotion.net/

Link to comment
Share on other sites

Hi All, can anyone tell me how to change the default webgui port from 8088 to 80xx on the new 2.5.6 open beta dedicated server..?

By default I no longer see an autoexec.cfg file and adding one appears to make no difference.

I’ve had to do a complete removal and reinstall after the first 2.5.6 update. FYI the original 2.5.5 was working correctly for a long time on 8087 so it can’t be a router port issue.

Many thanks

 

Additional... even on the default 8088 the local webgui can see the server but the remote webgui (using google not windows browser) can not connect.


Edited by Space Cadet

:pilotfly:

[sIGPIC][/sIGPIC]

 

:gun_smilie:

 

229th Assault Helicopter Battalion - Always Recruiting

 

If you have a passion for helicopter flight simulation and would like to fly in a friendly and supportive online multiplayer environment, then you’ve just put your skids down safely on the right page…!

 

DCS Squadron Recruiting Page for the 229th

https://forums.eagle.ru/showthread.php?t=267081

 

For details see our website at:

http://1stcavdiv.forumotion.net/

Link to comment
Share on other sites

Hi, just an update from the question above. I still haven’t found a method of setting the default webgui port to anything other than the default 8088, so if any knows a method I’d appreciate your input.

Ava Good’n Y’all...

:pilotfly:

[sIGPIC][/sIGPIC]

 

:gun_smilie:

 

229th Assault Helicopter Battalion - Always Recruiting

 

If you have a passion for helicopter flight simulation and would like to fly in a friendly and supportive online multiplayer environment, then you’ve just put your skids down safely on the right page…!

 

DCS Squadron Recruiting Page for the 229th

https://forums.eagle.ru/showthread.php?t=267081

 

For details see our website at:

http://1stcavdiv.forumotion.net/

Link to comment
Share on other sites

Hi, just an update from the question above. I still haven’t found a method of setting the default webgui port to anything other than the default 8088, so if any knows a method I’d appreciate your input.

Ava Good’n Y’all...

 

I would try adding an inbound rule in your firewall for the port you want to use.

 

Cheers!

IAF.ViFF

 

http://www.preflight.us

Israel's Combat Flight Sim Community Website

Link to comment
Share on other sites

I would try adding an inbound rule in your firewall for the port you want to use.

 

Cheers!

 

Thank you Viff, I do have the inbound rule set. But appreciate your thoughts mate.


Edited by Space Cadet

:pilotfly:

[sIGPIC][/sIGPIC]

 

:gun_smilie:

 

229th Assault Helicopter Battalion - Always Recruiting

 

If you have a passion for helicopter flight simulation and would like to fly in a friendly and supportive online multiplayer environment, then you’ve just put your skids down safely on the right page…!

 

DCS Squadron Recruiting Page for the 229th

https://forums.eagle.ru/showthread.php?t=267081

 

For details see our website at:

http://1stcavdiv.forumotion.net/

Link to comment
Share on other sites

  • 2 weeks later...

so there is no way to have let's say my friend use this tool to control the server only the pc that has the sever installed on it can use this tool? any plans to make it to where you can have remote access of server that is not tied to DCS account maybe login via server IP or what not?

Link to comment
Share on other sites

We have created a new DCS account for each of our servers. So it is not a big problem to give someone the password. But I hope ED will add a real rights management to the server, so we can give other DCS accounts rights to the server and are able to remove them also.

SYSTEM: Mainboard MSI Z270 Krait | CPU i7 7700k @ 4.8 GHz | RAM 32 GB @ 3200 MHz | GPU GIGABYTE RTX 3080 | 1 TB SSD | Win 10 x64

DEVICES: ASUS 27" LCD | TrackIR 5 | LukeClip | Rift S & HP Reverb G2 | PointCTRL | TM Warthog | MFG Crosswind | Throttle Quadrant Logitech | TableMount MonsterTech

MODULES: All

 

PROJECTS: OpenFlightSchool: DE / EN

 

Link to comment
Share on other sites

  • 1 month later...

Cant load missions

 

Hi guys,

 

I am in need of some help please.

Trying to host a server using the webgui, but for some reason i cant add any missions.

The server starts up, gui connects, but when i click add mission the screen comes up blank

 

 

I have deleted the server settings, and even the entire webgui folder in DCS.

I have run a repair, and clean, the pc running DCS is clean, with no extra modules except the maps and missions.

I have tried chrome and firefox, same thing.

 

ANY help please?

Link to comment
Share on other sites

Hi guys,

 

I am in need of some help please.

Trying to host a server using the webgui, but for some reason i cant add any missions.

The server starts up, gui connects, but when i click add mission the screen comes up blank

 

 

I have deleted the server settings, and even the entire webgui folder in DCS.

I have run a repair, and clean, the pc running DCS is clean, with no extra modules except the maps and missions.

I have tried chrome and firefox, same thing.

 

ANY help please?

 

Hi I will try to help you...

 

Are you sure the webGUI is connecting? are there any missions in the C:/Users/[my username]/Saved Games/DCS/Missions folder?

 

Please post your autoexec.cfg and serversettings.lua

 

Cheers

IAF.ViFF

 

http://www.preflight.us

Israel's Combat Flight Sim Community Website

Link to comment
Share on other sites

You need at least one mission in the serversettings.lua list. Then the server would fully load and you'd be able to edit the list.

My controls & seat

 

Main controls: , BRD-N v4 Flightstick (Kreml C5 controller), TM Warthog Throttle (Kreml F3 controller), BRD-F2 Restyling Bf-109 Pedals w. damper, TrackIR5, Gametrix KW-908 (integrated into RAV4 seat)

Stick grips:

Thrustmaster Warthog

Thrustmaster Cougar (x2)

Thrustmaster F-16 FLCS

BRD KG13

 

Standby controls:

BRD-M2 Mi-8 Pedals (Ruddermaster controller)

BRD-N v3 Flightstick w. exch. grip upgrade (Kreml C5 controller)

Thrustmaster Cougar Throttle

Pilot seat

 

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...