Jump to content

Recommended Posts

  • Replies 655
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi!   There are several ways to do this, but the most simple way is to add an "END MISSION" trigger conditioned to a timer (4 hours is 14,400 seconds) in all the missions you have on the server.   U

Thanks Rudel. :) Exactly what processor are you running? Intel? What GHz?

 

:) dont laugh, but I did my first tests of the dedicated server by running it on my gaming PC in parallel with the DCS regular sim and at that point found that it really didnt seem to use much resources. So, at that point I tought I would give a try to use older components that I already had lying around and if the performance turned awful I would then purchase something new.

 

So, this old processor is actually an AMD APU .. an A4-6300 to be precise, with a single thread passmarg of around 1350 ... much lower than the 1850 passmark of my gaming Ryzen 5 1500x, but seems to actually be enough for the task .. here you can see the cpu utilization when the server is running with a single client .. I've yet to get more people to try it under load:

 

0Zyeip5.jpg

 

... keep us up to date how it works when you get some players in there. And if you fly the F/A18 see how many M84 CBU's you can drop without it failing. :thumbup:

 

I will :D

 

A man of culture, I see!

 

:) .. yeah, the best single thing of the Falcon 4.0 was the binded manual .. I dont play it anymore, but couldnt part with such a nice manual .. so much better than a PDF :)

 

Cheers

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites
you might be better with the FQDN of the service rather than a physical/logical IP address, sometimes IP addresses change quite a bit..

 

For a person that's attempting to be security conscious, it actually fine if the IP changes (though not a frequent concern for most company IPs), cause then you'd simply have to update it. Its far easier to exploit the DNS system than public IP addressing.

Link to post
Share on other sites

Dear users,

 

Our DCS web server utilize primary IP 54.36.51.100 to connect to your server web port. Our API uses server-to-client connection, so your server IP address and web port are not exposed via web browser. You can easily restrict your firewall only to this IP for DCS web port and access webgui from your site account.

image_259187.png.12ec9a78d99caec431e08ab83fd4ee4d.png

 

Link to post
Share on other sites
Dear users,

 

Our DCS web server utilize primary IP 54.36.51.100 to connect to your server web port. Our API uses server-to-client connection, so your server IP address and web port are not exposed via web browser. You can easily restrict your firewall only to this IP for DCS web port and access webgui from your site account.

 

Thank you for this helpful information, const. Very much appreciated. :thumbup:

Link to post
Share on other sites

NOTE (added by const):

 

You should disable uPnP in DCS in case of using manual address or port translation in your router for DCS application. Add line to your autoexec.cfg:

 

net.use_upnp = false

 

Otherwise DCS will try to automatically open ports in your router on default router IP via uPnP


Edited by USSR_Rik

El pueblo unido jamás será vencido

 

 

DCS World 2.5: Часто задаваемые вопросы

Link to post
Share on other sites

Quick question.

Happily running my server on an old laptop.

Is there a cmd line command that I can use to not only load the server and primary mission, but also to autostart it, as against put it on pause on load?

 

 

Edit: Typical, found the answer 2 mins later, it's a check box in the advanced options.

System: 9700, 64GB DDR4, 2070S, NVME2, Rift S, Jetseat, Thrustmaster F18 grip, VPC T50 stick base and throttle, CH Throttle, MFG crosswinds, custom button box, Logitech G502 and Marble mouse.

Server: i5 2500@3.9Ghz, 1080, 24GB DDR3, SSD.

Link to post
Share on other sites
Quick question.

Happily running my server on an old laptop.

Is there a cmd line command that I can use to not only load the server and primary mission, but also to autostart it, as against put it on pause on load?

 

 

Edit: Typical, found the answer 2 mins later, it's a check box in the advanced options.

 

I have the problem where if I do pause on load I can't get it unpaused. I have verified the keybindings and used the correct ones but it will not unpause.

AMD RYZEN 7 2700 / 32GB / RTX2070 / 500GB M.2 with Windows and DCS / 2 - 500GB SSD / Rift S/ TM Warthog with F18 stick and Virpil WarBRD / Foxx Mounts/ MFG Crosswind rudders + 3 MFD's | Now enjoying VR with PointCTRL controllers + Gamematrix JetSeat

Link to post
Share on other sites

Rik is there any update on when this "Web GUI is currently on maintenance" Issue

is going to be fixed so we can control the servers again?

2133173213_Screenshot2019-03-1420_08_57.thumb.png.295e818cbb013119771b6e001fb24488.png

i7 8700k, ASrock Tachi 32gb Fury X DDR4, Warthog HOTAS, HP Reverb VR, trackir, win 10, RTX 3070

TGW Dedicated Server Admin, Australian PVE/PVP gameplay.

Link to post
Share on other sites

Well, with the recently released tomcat, I ran into a problem: The server kicks me before DCS managed to load the cat for idle timeout. So, Ill get a SSD for DCS in #2weeks but in the meantime, is there a way to prevent the server from kicking idle clients?

Link to post
Share on other sites
Rik is there any update on when this "Web GUI is currently on maintenance" Issue

is going to be fixed so we can control the servers again?

 

What's the update on this?

I haven't seen either an acknowledgement of this issue from ED nor a fix.

I know this is Open Beta but there's absolutely no information on what's causing the error, nor feedback from the developers working on a fix.

"The natural function of the wing is to soar upwards and carry that which is heavy up to the place where dwells the race of gods.

More than any other thing that pertains to the body it partakes of the nature of the divine." — Plato, Phaedrus.

Link to post
Share on other sites
NOTE (added by const):

 

You should disable uPnP in DCS in case of using manual address or port translation in your router for DCS application. Add line to your autoexec.cfg:

 

net.use_upnp = false

 

Otherwise DCS will try to automatically open ports in your router on default router IP via uPnP

 

Where is the autoexec.cfg file located? I have looked everywhere in the DCS root folder and all subfolders but I have only see autoexec.lua...

--Maulkin

 

 

Windows 10 64-bit - AMD Ryzen 9 5900X @ 3.7 GHz - 32 GB DDR4 3600MHz RAM - EVGA FTW3 RTX 3080 - Asus Crosshair VIII Hero motherboard - Samsung EVO Pro 1 TB SSD - TrackIR 4 Pro - Thrustmaster Warthog - Saitek rudder pedals - Lilliput UM-80/C with TM Cougars

Link to post
Share on other sites

Does anyone have an answer on how you get the dedicated server software to automatically start the mission list when the exe starts? I am not talking about the mission being paused when it starts, I'm talking about the step before that to where you don't have to manually start the mission list every single time when you run the exe.

 

Where I'm getting at with this, I have my virtual server I host on a daily reboot schedule. I am able to get it where the "DCS.exe --server --norender etc..." starts up on boot, but it won't autostart the mission list nor is there an option for it. I do have "resume on load" enabled, and that works when I manually start the mission list, the missions start unpaused. However I do not want to manually start the mission list. I really hope someone understands my question as I already had a bunch of confused people on this thread and other discussions try to understand what I'm saying. I can only assume that either this feature isn't implemented yet, or that it works already with everyone else except me. I can't seem to find any example on the internet to go off of for this. Thank you in advanced for the help.

Link to post
Share on other sites
Where is the autoexec.cfg file located? I have looked everywhere in the DCS root folder and all subfolders but I have only see autoexec.lua...

 

 

If you have it, it will be in your "C:\Users\<username>\Saved Games\DCS\Config" folder. If it does not show up there, you need to create it as explained on page 1 of this thread. If you use the -w switch on your exe startup command, you will look for the directory ...\Saved Games\<whatever your instance name is>\Config\.


Edited by Trinacria
Link to post
Share on other sites

Hi, I made à fresh install of DCS on my dedicated machine, and launch le GUI from the bin folder with command "dcs --webgui".

 

But when I go in "My servers" on my DCS account, click on the server launch, it show "404".

Any idea ?

Link to post
Share on other sites
Hi, I made à fresh install of DCS on my dedicated machine, and launch le GUI from the bin folder with command "dcs --webgui".

 

But when I go in "My servers" on my DCS account, click on the server launch, it show "404".

Any idea ?

 

On your server, in the DCS root, theres a folder called WebGUI. Start index.html.

Link to post
Share on other sites
Does anyone have an answer on how you get the dedicated server software to automatically start the mission list when the exe starts? I am not talking about the mission being paused when it starts, I'm talking about the step before that to where you don't have to manually start the mission list every single time when you run the exe.

 

Where I'm getting at with this, I have my virtual server I host on a daily reboot schedule. I am able to get it where the "DCS.exe --server --norender etc..." starts up on boot, but it won't autostart the mission list nor is there an option for it. I do have "resume on load" enabled, and that works when I manually start the mission list, the missions start unpaused. However I do not want to manually start the mission list. I really hope someone understands my question as I already had a bunch of confused people on this thread and other discussions try to understand what I'm saying. I can only assume that either this feature isn't implemented yet, or that it works already with everyone else except me. I can't seem to find any example on the internet to go off of for this. Thank you in advanced for the help.

 

Try loading it first in normal UI. Start a new server and create your prioritized list in the game UI. Launch the mission, then exit out and start in norender. It should start the same mission that you set up in the normal UI.

Ryzen 9 3900X / Asus Crosshair VI Hero X370 / Corsair H110i / Sapphire Nitro+ 6800XT / 32Gb G.Skill TridentZ 3200 / Samsung 960 Evo M.2 / Virpil Warbrd base + VFX and TM grips / Saitek X56 Throttle / Saitek Pro Combat pedals / Rift S

Link to post
Share on other sites

is this error not happening for everyone trying to remotely administer their servers by logging into the ED site? Sounds like it works for some, but not for others (like me). I have tried in an incognito browser, no luck. The local admin scripts work fine when you are logged onto the server directly.

 

"Web GUI is currently on maintenance"

 

dcsserver.png


Edited by Zyll
Link to post
Share on other sites

Thank you Lennox85OC, it works :)

 

2 questions :

 

How did I change the name of the "server player" conected ? Actually it is juste "player" ?

 

Is it possible to launch a Persian Gulf mission without having the module on the account of the server ?

Link to post
Share on other sites
Does anyone have an answer on how you get the dedicated server software to automatically start the mission list when the exe starts? I am not talking about the mission being paused when it starts, I'm talking about the step before that to where you don't have to manually start the mission list every single time when you run the exe.

 

I'd use the old serverSettings.lua file to achieve that. Notice the version field and the missing uri and current fields.

 

cfg = 
{
   ["listShuffle"] = false,
   ["isPublic"] = true,
   ["description"] = "",
   ["require_pure_textures"] = true,
   ["version"] = 1,
   ["missionList"] = 
   {
       [1] = "C:\\Users\\USERNAME\\Saved Games\\DCS.openbeta\\Missions\\awesome.miz",
   }, -- end of ["missionList"]
   ["advanced"] = 
   {
       ["allow_change_tailno"] = true,
       ["allow_ownship_export"] = false,
       ["allow_object_export"] = false,
       ["pause_on_load"] = false,
       ["allow_sensor_export"] = false,
       ["event_Takeoff"] = false,
       ["pause_without_clients"] = false,
       ["client_outbound_limit"] = 0,
       ["client_inbound_limit"] = 0,
       ["event_Role"] = true,
       ["allow_change_skin"] = true,
       ["event_Connect"] = true,
       ["event_Ejecting"] = false,
       ["event_Kill"] = true,
       ["event_Crash"] = true,
       ["resume_mode"] = 1,
       ["maxPing"] = 200,
   }, -- end of ["advanced"]
   ["require_pure_models"] = true,
   ["require_pure_clients"] = true,
   ["name"] = "SERVER TEST",
   ["port"] = "10308",
   ["password"] = "",
   ["listLoop"] = false,
   ["bind_address"] = "",
   ["maxPlayers"] = 50,
} -- end of cfg


Edited by riojax
typo
Link to post
Share on other sites

Noob quetion here....created a server room, there are 5 of us flying the Skyhawk....we can all join in no issues....but within a minute, people start getting disconnected from the server, at any stage, in flight, taxying, about to land, doesnt matter where.

I have 32G RAM, with an i7 Devils Canyon CPU...never had this issue before...is there a setting I am missing? I am using the following command:

--server --norender --force_disable_VR -w

Link to post
Share on other sites

"Web GUI is currently on maintenance"

 

I get this error when trying to remotely access my computer from another PC other than the server it is running on withing my LAN

 

I can access the WebGUI from work and from the computer thats running the server , but NOT from any other PC's on my LAN which is the same as the network the server is running on.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...