Jump to content

Recommended Posts

  • Replies 655
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi!   There are several ways to do this, but the most simple way is to add an "END MISSION" trigger conditioned to a timer (4 hours is 14,400 seconds) in all the missions you have on the server.   U

Would also like to see Server Admin name be a different color in chat. White color gets lost and ignored in chat by players.

Maybe Orange?

That's a good idea, but orange is already used for messages when player is talking, he sees his text in orange.

Why not green ?

Link to post
Share on other sites
Run two DCS instances with:

 

dcs.exe --server --norender -w instance1

and

dcs.exe --server --norender -w instance2

 

You should end up with 2 DCS splash screens running simultaneously.

 

If you need to define which missions load etc, start DCS normally and start a MP server. Then close it and look in your Saved Games\DCS\Config folder. You need the serverSettings.lua file. Copy that ServerSettings.lua to the instance1\config and instance2\config folders and edit them accordingly.

 

Should get you going.

 

I tried this and its asking me for login credentials. Is there a work around this or will my credential work with both instances?

 

cheers

1st_CVW_EDsig.png.1f2be0eb45d45098d3777965a273c030.png
 

Alienware New Aurora R9 | Windows® 10  64bit, Intel(R) Core(TM) 9th Gen Intel Core i9-9900K | NVIDIA GeForce RTX 2080Ti OC 11GB | 2 X 1TB SSD | 48GB Dual Channel Hyper X FURY at 2666MHz | 850W EPA Gold Liquid Cooled power supply | HP G2 VR Headset | WinWing Orion

Link to post
Share on other sites
I tried this and its asking me for login credentials. Is there a work around this or will my credential work with both instances?

 

 

 

cheers

 

 

 

It’ll work on both instances.

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites
Good news that there's finally an official dedicated server option. But, as I understand it, this really isn't something new? Whats new is the webgui control interface. We already had a "render3d = false" option (not sure if it worked in 2.5). And to be honest, I don't get why you make it unnecessarily difficult, still requiring an account to host. Easy is the key.

 

I believe you are dramaticly oversimplifying what's been done...this isn't just a different interface to the same process. When running server using "render3d=false" my server box with 16 go of RAM averaged 8-10 GB of ram usage and 25-40% CPU Usage...

 

Using the dedicated server those numbers drop to 2.3GB and 10-15% CPU usage. Significantly different numbers. This is a pretty good indicstion there is more going on than just a new way to implement the same server.


Edited by Sierra99

[sIGPIC][/sIGPIC]

Primary Computer

ASUS Z390-P, i7-9700K CPU @ 5.0Ghz, 32GB Patriot Viper Steel DDR4 @ 3200Mhz, ZOTAC GeForce 1070 Ti AMP Extreme, Samsung 970 EVO M.2 NVMe drives (1Tb & 500 Gb), Windows 10 Professional, Thrustmaster Warthog HOTAS, Thrustmaster Warthog Stick, Thrustmaster Cougar Throttle, Cougar MFDs x3, Saitek Combat Rudder Pedals and TrackIR 5.

 

-={TAC}=-DCS Server

Gigabyte GA-Z68XP-UD3, i7-3770K CPU @ 3.90GHz, 32GB G.SKILL Ripjaws DDR3 @ 1600Mhz, ZOTAC GeForce® GTX 970.

Link to post
Share on other sites
I believe you are dramaticly oversimplifying what's been done...this isn't just a different interface to the same process.
Exactly. Programmers did a great work with internal DCS processes in order to get suitable result, this work was finished in general approx. month ago. The big issue was an interaction of external scripts with DCS frames running without render, we spent a lot of time.

El pueblo unido jamás será vencido

 

 

DCS World 2.5: Часто задаваемые вопросы

Link to post
Share on other sites
I believe you are dramaticly oversimplifying what's been done...this isn't just a different interface to the same process. When running server using "render3d=false" my server box with 16 go of RAM averaged 8-10 GB of ram usage and 25-40% CPU Usage...

 

Using the dedicated server those numbers drop to 2.3GB and 10-15% CPU usage. Significantly different numbers. This is a pretty good indicstion there is more going on than just a new way to implement the same server.

 

Its funny that you chose to quote my comment from page 3 of this thread, when we're now at page 25. There has been numerous similar comments and opinions about this, had you read the thread. I think it's safe to say that obviously ED wasnt clear enough on its original post on what this was, technically, which lead to people questioning its usefulness. And through pages and pages after my comment it has obviously been validated that the new --norender switch is not the same thing as the old render3d = false option.

 

EDIT: While this is all very very good indeed and I offcourse appreciate the efforts that went into this adaption, I can't deny that I was expecting a "proper" standalone dedicated server once it was released. And by "proper" I mean a slimmed down standalone package without the need of an account and without the need for all game data to be there. But they already said they are looking into expanding the functionality of this adaption to e.g. allow hosting terrains not owned, so there's that already on the way probably. And I'm still hoping that it will come to that a downloadable standalone DS package that contains only the data needed to host the server and no texture data or other data that is not needed.


Edited by chrisofsweden
Link to post
Share on other sites
I believe you are dramaticly oversimplifying what's been done...this isn't just a different interface to the same process. When running server using "render3d=false" my server box with 16 go of RAM averaged 8-10 GB of ram usage and 25-40% CPU Usage...

 

Using the dedicated server those numbers drop to 2.3GB and 10-15% CPU usage. Significantly different numbers. This is a pretty good indicstion there is more going on than just a new way to implement the same server.

 

exactly !

 

You can run it on 2 cores and as low as 8-10GB sys-RAM = with a good machine you can run 4-8 servers.

 

I have loaded missions that took more RAM but overall, the sys requirements are a fraction of what it used to be.

 

Now let them address the issues we have pointed out and talked about and I am very sure, this will be a winner.

Asus Z370-E - 8700K@5G_delidded - 32GB - 1080GTX-Ti EK-waterblock - 1x 960Evo 250GB - 3x Samsung 850/860Pro 256GB Raid-0 - 1x Samsung 870 Evo 1TB - 2x Seagate 2TB - 32GB PageFile - Heatkiller IV - MoRa3-360LT@4x180mm fans - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win10Pro64 

Link to post
Share on other sites
Its funny that you chose to quote my comment from page 3 of this thread, when we're now at page 25. There has been numerous similar comments and opinions about this, had you read the thread. I think it's safe to say that obviously ED wasnt clear enough on its original post on what this was, technically, which lead to people questioning its usefulness. And through pages and pages after my comment it has obviously been validated that the new --norender switch is not the same thing as the old render3d = false option.

 

EDIT: While this is all very very good indeed and I offcourse appreciate the efforts that went into this adaption, I can't deny that I was expecting a "proper" standalone dedicated server once it was released. And by "proper" I mean a slimmed down standalone package without the need of an account and without the need for all game data to be there. But they already said they are looking into expanding the functionality of this adaption to e.g. allow hosting terrains not owned, so there's that already on the way probably. And I'm still hoping that it will come to that a downloadable standalone DS package that contains only the data needed to host the server and no texture data or other data that is not needed.

 

Imho, it is self-explaining thzat they have to strip it down, adjust credentials and polish the GUI.

 

Switch perspective, enjoy that we can test and use it now instead of waiting another 6 month until they fixed it all with limited internal testers and feedback.

 

A mature piece of anything needs time to ripe :smilewink:

Asus Z370-E - 8700K@5G_delidded - 32GB - 1080GTX-Ti EK-waterblock - 1x 960Evo 250GB - 3x Samsung 850/860Pro 256GB Raid-0 - 1x Samsung 870 Evo 1TB - 2x Seagate 2TB - 32GB PageFile - Heatkiller IV - MoRa3-360LT@4x180mm fans - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win10Pro64 

Link to post
Share on other sites
Its funny that you chose to quote my comment from page 3 of this thread, when we're now at page 25. There has been numerous similar comments and opinions about this, had you read the thread.

 

My friend at 5:30 am I was only paging through the forums trying to get back to sleep after taking our dogs out. I was amazed to see this thread had grown to 25 pages. The comment struck me as less than accurate in light of what I was seeing. I referenced a photo I took early Friday afternoon of the servers RAM & CPU load that I had sent to a friend to make sure I was posting accurate information, made the comment and was ready to go back to sleep...

 

It was not my intention to pile on telling you you were wrong...nor was it my intention to read the entire thread...

[sIGPIC][/sIGPIC]

Primary Computer

ASUS Z390-P, i7-9700K CPU @ 5.0Ghz, 32GB Patriot Viper Steel DDR4 @ 3200Mhz, ZOTAC GeForce 1070 Ti AMP Extreme, Samsung 970 EVO M.2 NVMe drives (1Tb & 500 Gb), Windows 10 Professional, Thrustmaster Warthog HOTAS, Thrustmaster Warthog Stick, Thrustmaster Cougar Throttle, Cougar MFDs x3, Saitek Combat Rudder Pedals and TrackIR 5.

 

-={TAC}=-DCS Server

Gigabyte GA-Z68XP-UD3, i7-3770K CPU @ 3.90GHz, 32GB G.SKILL Ripjaws DDR3 @ 1600Mhz, ZOTAC GeForce® GTX 970.

Link to post
Share on other sites
I created a Shortcurt with the --server --norender parameters but the sim just starts regularly as client. Any idea what could have gone wrong?

 

Try adding -w "Server write folder name HERE"

This will create a server write folder in your saved games folder. For me for some reason when I try to run it without the write folder it starts as client, and when running with write folder it starts as server.

 

That's a good idea, but orange is already used for messages when player is talking, he sees his text in orange.

Why not green ?

 

I don't know and don't really care what color, as long as it's not white.

 

PS : heard some people had SLmod running on a dedicated server. If I run as a client it works, if I run a dedicated server it does not.


Edited by do_ob

"Слепой" :pilotfly:

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

DCS Remote Server Control or Standalone Server

 

Seems those terms are being used interchangeably here..Even though they are completely different animals!!!

 

All I have seen is,a, DCS Remote Server Control, added to the Sim files..

Nice,, thank you,,

Scoured downloads looking for a Standalone server download, to no avail..

So I assume you haven't made one yet..

So when are you going to release a "Standalone Server app?? Is one even planned??

yes I am using it (DCS Remote Server Control)..So please no explanations of how to use, just answer to Q if answer is known..

Link to post
Share on other sites

Very nice

 

Thanks for this. Question, I've noticed that certain MODs are not been carrier over into the missions. I see a lot of objects particularly ships that and the navy equipment not showing up.

 

As well as I noticed that Simod or SSR scripts are not working. Do I need to bring over any other folders into each server directory other then what is created.

 

Thanks

Wood

 

EDIT:

 

Ok disregard the previous. I did carrier over the other files/folders such as (Mods) and got everything working properly. However, Would there be away to utilize where you can just read from the main mods folder instead of having each separate server have its own mods folder. would like to save space.


Edited by Wood

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
Why i cant connect to , maybe localhost:12345, per browser?

 

 

I have created an autoexec.cfg under C:\Users\<Name>\Saved Games\DCS.openbeta and insert "webgui_port = 12345", but i become an Error in Browser:

405 Method Not Allowed

 

Whats wrong?

 

I'm getting the same 405 Method Not Allowed when trying to use the webinterface through… well, the actual web interface. If I just load the local index.html then it works very nicely; if I try to actually connect over the network, even if it's on the same machine the server is running on, I get the 405 error.

Link to post
Share on other sites

... Would there be away to utilize where you can just read from the main mods folder instead of having each separate server have its own mods folder. would like to save space.

 

I use Windows' MKLINK /J command to create links to centralized folders ... very useful not only for the Mods folder, but also for the Missions and Liveries folders.

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites
Seems those terms are being used interchangeably here..Even though they are completely different animals!!!

 

All I have seen is,a, DCS Remote Server Control, added to the Sim files..

Nice,, thank you,,

Scoured downloads looking for a Standalone server download, to no avail..

So I assume you haven't made one yet..

So when are you going to release a "Standalone Server app?? Is one even planned??

yes I am using it (DCS Remote Server Control)..So please no explanations of how to use, just answer to Q if answer is known..

 

So I assume you haven't made one yet..

So you know the answer to the question you asked, and you're just demonstrating your superior knowledge of terminology ?

Or trolling ?

Cheers.

Link to post
Share on other sites
I'm getting the same 405 Method Not Allowed when trying to use the webinterface through… well, the actual web interface. If I just load the local index.html then it works very nicely; if I try to actually connect over the network, even if it's on the same machine the server is running on, I get the 405 error.

 

You only use the local webGUI located in DCS World main program folder. Just click the index.html file. Enter 8088 or if you change the port in autoexec.cfg then you need to key in that number. To start off, just use the default 8088 port and let autoexec.cfg be empty.

 

EDIT: The dedicated server will only show the DCS LOGO page and will seem like a crash, it is not a crash, the server has started.

Link to post
Share on other sites
You only use the local webGUI located in DCS World main program folder. Just click the index.html file. Enter 8088 or if you change the port in autoexec.cfg then you need to key in that number. To start off, just use the default 8088 port and let autoexec.cfg be empty.

Yes. The point was that only the local file is working — connecting over a network throws a 405 error.

Link to post
Share on other sites
Yes. The point was that only the local file is working — connecting over a network throws a 405 error.

 

Because you need to be logged in on ED shop with your server account. You also need to open TCP port 8088 on your firewall. Or if you changed the port you need to open the same port in your firewall.

Link to post
Share on other sites

I've looked through the thread and can't find an answer thus far. Does anyone know the IP range to the DCS centralized servers? I would like to allow the remote management feature of our server with minimal security risk. I personally don't feel 100% comfortable with 8088, secondary, to the n-th range of ports being opened to the entire world.

Link to post
Share on other sites
I've looked through the thread and can't find an answer thus far. Does anyone know the IP range to the DCS centralized servers? I would like to allow the remote management feature of our server with minimal security risk. I personally don't feel 100% comfortable with 8088, secondary, to the n-th range of ports being opened to the entire world.

 

excellent point for an outbound rule !

Asus Z370-E - 8700K@5G_delidded - 32GB - 1080GTX-Ti EK-waterblock - 1x 960Evo 250GB - 3x Samsung 850/860Pro 256GB Raid-0 - 1x Samsung 870 Evo 1TB - 2x Seagate 2TB - 32GB PageFile - Heatkiller IV - MoRa3-360LT@4x180mm fans - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win10Pro64 

Link to post
Share on other sites

@USSR_Rik:

 

Can the server handle IPv4 and IPv6 connections simultaneously?

How to bind one (or two, if IPv4 and IPv6) IP address to the server if the operating system has multiple IP addresses?

Simpit Software by SDA "SIMPIT DEVELOPER ASSOCIATION"

  • DCS ExportScript
  • D.A.C. DCS to Arcaze Communicator
  • Ikarus a new Virtual Cockpit Software

Deutscher Forums Thread

English Forums Thread

 

Hard/Software: AMD Ryzen 7 1800X, 32 GiB RAM, extra SSD for Windows 10 and DCS World, AMD Vega Frontier Edition with 16 GiB VRAM

Link to post
Share on other sites
I've looked through the thread and can't find an answer thus far. Does anyone know the IP range to the DCS centralized servers? I would like to allow the remote management feature of our server with minimal security risk. I personally don't feel 100% comfortable with 8088, secondary, to the n-th range of ports being opened to the entire world.

 

Good question but I believe they must change the user (admin) access to something located locally on each dedicated server. That is what all other dedicated servers do.

Link to post
Share on other sites
@USSR_Rik:

 

Can the server handle IPv4 and IPv6 connections simultaneously?

How to bind one (or two, if IPv4 and IPv6) IP address to the server if the operating system has multiple IP addresses?

It seems the server will bind to any and all addresses on a system. When testing on my machine I saw my server twice in the server browser. Both ipv6.

 

Sent from my Pixel using Tapatalk

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...