Jump to content

Recommended Posts

When I bring up the "score" menu, the "end mission" button, does not seem to have any effect, I press the button it depresses, but i'm left in the score window the mission does not end... the only way I have to exit a mission seems to be to quit from the "esc" menu? is that correct/expected behaviour?

  • Like 2

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites
  • 11 months later...

I too have encountered this problem, and recently.

 

I have, on at least 3 occasions, ran into long standing mostly minor but, mostly really frustrating issues, like this, that have been around in this sim for months, even years before they are addressed, if ever.

 

The other two issues that I can think of off of the top of my head right now persisted for YEARS before they were finally resolved. Not only did they persist for years, they were never even really acknowledged by the developer. Nothing was said, by the developer, about them knowing about and looking into the problem and no help or temporary solution was offered to alleviate the enjoyment killing experience caused by the issue.

 

It seems, from the fact that this post has languished with no reply since November 2018, (a full year prior to my encountering the same issue) that this is yet another example.

Link to post
Share on other sites
I too have encountered this problem, and recently.

 

I have, on at least 3 occasions, ran into long standing mostly minor but, mostly really frustrating issues, like this, that have been around in this sim for months, even years before they are addressed, if ever.

 

 

....

 

 

It seems, from the fact that this post has languished with no reply since November 2018, (a full year prior to my encountering the same issue) that this is yet another example.

 

 

In the case of this issue, while I can understand how it it would be frustrating for you, the fact that it has had no replies until now also suggests it is a random and not very common issue which might explain why it hasn't had much attention from ED. Yes, we'd all like zero bugs (big or small), but reality is that something like this may only affect a small number of users with a very specific hardware combination or combination of other software on their computer or who knows why. If a bunch of other people respond that they've had the issue (and it seems like something that people would report), maybe it'll get looked at.

Link to post
Share on other sites
  • 5 months later...
When I bring up the "score" menu, the "end mission" button, does not seem to have any effect, I press the button it depresses, but i'm left in the score window the mission does not end... the only way I have to exit a mission seems to be to quit from the "esc" menu? is that correct/expected behaviour?

 

Sorry to bring up a old thread but did you get a fix for this? Just flown a mission for 2 hours and I am unable to end the mission :helpsmilie:

i5 9600K @3.7 Ghz

MSI MPG Z390 GE AC

MSI RTX 2070

HyperX 32GB Ram @3200MHz

CoolMaster Master Liquid 240l

Link to post
Share on other sites
Sorry to bring up a old thread but did you get a fix for this? Just flown a mission for 2 hours and I am unable to end the mission :helpsmilie:

 

Hit the ESC key...expected behavior.

Link to post
Share on other sites
Won’t mission progress be lost though?

No. ESC > Quit. You get debriefing then.

🖥️ i3-10100F 3.6-4.3GHz, 16GB DDR4 2666, GTX970 4GB, SSD SATA3, 27" LCD FullHD, Rift S   🕹️ T16000M HOTAS, customTiR   ✈️ FC3, F-14A/B   🌍 NTTR, PG   🚢 Supercarrier

Link to post
Share on other sites
AFAIK in campaign play mode you must end mission with "end mission" button, only here functioning

 

Correct but I never did this from ingame score screen. Always esc, quit and "end mission" from debriefing screen.

🖥️ i3-10100F 3.6-4.3GHz, 16GB DDR4 2666, GTX970 4GB, SSD SATA3, 27" LCD FullHD, Rift S   🕹️ T16000M HOTAS, customTiR   ✈️ FC3, F-14A/B   🌍 NTTR, PG   🚢 Supercarrier

Link to post
Share on other sites
  • 2 months later...

Just had this happen on the debrief screen after hitting quit from ESC menu. The score screen was all funky, like it didn't know what the mission file was, or who the player was. The "End Mission" button did nothing, it depressed but performed no action. The only thing I was allowed to do was an action that lost the progress of having flown the mission.

 

I saved Track and Debrief if that is useful to anyone.

  • Like 1
Link to post
Share on other sites
  • 8 months later...

Had this problem, and repairing DCS didn't help.

In the attached file, on line 440 there is a GUI error related to logbook, so I tried deleting my logbook at ...\Saved Games\DCS\MissionEditor. This seems to have solved the problem for me: With a new logbook the button works. It is possible that at some point I have somehow broken my logbook.lua with erroneous editing.

 

Now I hope that the problem doesn't somehow resurface. :)

dcs_buttonerror.log

Link to post
Share on other sites
  • 2 weeks later...

Issue happened to me, here's some logs and stuff, happy debugging 🙂 . 

 

Mission : mission 8 in campaign "caucasus" from module Mirage 2000 (the BD campaign coming with the module). It's the ELINT/CSAR mission.

DCS Version : OpenBeta 2.7.0.4625

 

Issue : On the debriefing screen after the mission, clicking on "End Mission" does not work. Visually the button animation works but the debriefing dialog does not close and the campaign does not progress. 

Expected result : close the debriefing dialog, update logbook, and advance the campaign. 🙂

(Note: I didn't check if my logbook.lua was modified or not, or even if it was corrupted...)

 

Attached : 

- dcs.log      with a nice callstack pinpointing a null ref in the debrief parsing logic to update the pilot's logbook

- debriefing.log     for the current mission (probably featuring an unexpected nil somewhere causing the parsing code in 'updateUserStatistics' to fail, I would guess event 1158)

- logbook.lua for      the current pilot (after the failed call)

 

 

PS: I have no way of knowing for sure but I would guess that moving the "if unitTarget" in me_logbook.lua:1122  *before* unitTarget is used (on lines 1118 and 1120) could solve the issue.

 

HTH,

Buzz

debrief_BUG_ENDMISSION.log dcs.log logbook.lua

Link to post
Share on other sites

Fun fact : killing friendly ships increases your score without it being marked as friendly fire, that's just below. The code checks for FF on every type of target except ships... 

 

me_logbook.lua :

if isInsideCoalition(coal, country_idTarget) then --попали по своим
if (victimType == "helicopter") or (victimType == "plane") then 
   faa = faa + 1
elseif victimType == "vehicle" or victimType == "static" then
   fag = fag + 1
end
(...)

 

(and some dev might also have a look at the lostLA update logic a few lines below, it looks suspicious)


Edited by BuzzLine
  • Like 1
Link to post
Share on other sites
Il 16/4/2021 at 01:15, BuzzLine ha scritto:

Issue happened to me, here's some logs and stuff, happy debugging 🙂 . 

 

Mission : mission 8 in campaign "caucasus" from module Mirage 2000 (the BD campaign coming with the module). It's the ELINT/CSAR mission.

DCS Version : OpenBeta 2.7.0.4625

 

Issue : On the debriefing screen after the mission, clicking on "End Mission" does not work. Visually the button animation works but the debriefing dialog does not close and the campaign does not progress. 

Expected result : close the debriefing dialog, update logbook, and advance the campaign. 🙂

(Note: I didn't check if my logbook.lua was modified or not, or even if it was corrupted...)

 

Attached : 

- dcs.log      with a nice callstack pinpointing a null ref in the debrief parsing logic to update the pilot's logbook

- debriefing.log     for the current mission (probably featuring an unexpected nil somewhere causing the parsing code in 'updateUserStatistics' to fail, I would guess event 1158)

- logbook.lua for      the current pilot (after the failed call)

 

 

PS: I have no way of knowing for sure but I would guess that moving the "if unitTarget" in me_logbook.lua:1122  *before* unitTarget is used (on lines 1118 and 1120) could solve the issue.

 

HTH,

Buzz

debrief_BUG_ENDMISSION.log 208 kB · 4 download dcs.log 83 kB · 3 download logbook.lua 190 kB · 4 download

 

Same thing here after a 2 hour successful mission in a campaign... now I have to refly again. It happens regularly?

1.jpg

Link to post
Share on other sites

Well, I've never had this issue, and I'd like to find what's broken.

@Parameter pointed out an error in the log about the logbook.lua file, which holds records of one's campaigns progress. I haven't looked at BuzzLine's logbook yet, but I might use more than one anyway.

 

This means I have 2 good reasons to ask for your logbook.lua:

  • Find whatever may be wrong in it to find the source of this bug,
  • Update your campaign data so it shows your mission succeeded. If you're up to it, I simply need to know which campaign you're flying.

Edited by Flappie
Link to post
Share on other sites
29 minutes ago, Flappie said:

Well, I've never had this issue, and I'd like to find what's broken.

 

What's broken is the code in "me_logbook.lua" that is fragile and fails when targetMissionID is empty. Now why targetMissionID is empty and whether it should is another question.

But anyways, moving the "if unitTarget" test a few lines above should do the trick, see around line 1118.  

 

 

 

Link to post
Share on other sites

For the bravest, the impatient, and those who don't mind tinkering with their install, below is a possible fix. Or at least a workaround. I don't know, I'm not an ED dev. 🙂 

 

Open file DCSWorld/MissionEditor/modules/me_logbook.lua in your favorite code editor. Look around line 1120 and move the "if unitTarget then" line up four lines.

Here is the code with a bit of context :

-- только убийства игроком
if (event.type == 'kill' and event.initiatorMissionID ~= nil and playerTable.playerUnitId == event.initiatorMissionID) then				
	if event.initiatorMissionID ~= event.targetMissionID then  
		local unitTarget  = MissionModule.unit_by_id[event.targetMissionID]
		if unitTarget then             -- <<<<<<<<<< Buzz: I moved this up here ...
			local coal = playerTable.coalition
			local country_idTarget = unitTarget.boss.boss.id
			local victim = unitTarget
			local victimType = victim.boss.type
		-- if unitTarget then          -- >>>>>>>>>>> Buzz: ... from here 
			if isInsideCoalition(coal, country_idTarget) then --попали по своим
				if (victimType == "helicopter") or (victimType == "plane") then 
					faa = faa + 1
				elseif victimType == "vehicle" or victimType == "static" then 
					fag = fag + 1
				end

 

Note : make a backup before you edit, or just repair your install to revert the change. 

Note 2 : if you don't have a favorite code editor or are confused about all this, then I suggest you wait for an official ED fix. 

 

 

HTH, **caveat emptor**,

Buzz

 

 

  • Like 2
  • Thanks 4
Link to post
Share on other sites

Just experienced this for the first time after completing a mission in Black Sea Resolve (F-5E DLC campaign). This was the first time I flew a campaign mission after upgrading to OB 2.7.

 

 

I'm Softball on Multiplayer. Dell XPS-8500 24GB, i7-3770@3.40GHz, Win 10Pro, Nvidia GeForce GTX 1060 6GB, TiR, VKB Gunfighter III with MCG Ultimate grip, CH throttle and pedals, all maps, most modules

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...