Jump to content

VR Shaders mod for better VR experience


Recommended Posts

  • Replies 2.4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I was slightly frustrated with poor performance when playing in VR with the new deferred rendering engine, so I had a look what would be possible to remove/simplify from the shaders to improve the fra

I added an update to the first post for DCS 2.7.0.4625. Everything else is the same, except the HMD mask feature is removed since DCS now has a correctly implemented mask. I didn't do much testing wit

yes they still work...

FYI, if you're annoyed with the double lens flare effect, you can mod :

 

...\DCSWorld\Bazar\shaders\PostEffects\lensEffect.fx

 

pass Ghosts    PASS_BODY(vsGhost(),    psGhost(),    aberrationBlend)

Change the last argument to "disableColorOutput", so it looks like :

pass Ghosts    PASS_BODY(vsGhost(),    psGhost(),    disableColorOutput)

This pass IC. ;)

Intel 9900KF @ 5.1GHz / RTX 2080S OC @ 1.93GHz / ASUS Prime Z390-A / 2x16Gb DDR4 @ 3333 CL16 / Corsair TX850M / Samsung NVME 970 EVO+ / TM warthog Thr. / VKB Gunfighter mkIII + MCG / MFG Crosswind mk3 / Valve Index

Link to post
Share on other sites
  • 2 weeks later...
Is there a way to have it validated for integrity check?

Yes. You have to remove some of the files but you still get a boost. I don't remember which files exactly, but you can figure it out by going into Multiplayer and clicking on the red Integrity Check icon.

 

That will tell you which files are causing you to fail. Restore the original files and you're good to go.

 

I use OvGME and have an MP and SP version of the mod so I can swap back and forth. It works pretty well since my computer recreates the Shaders pretty quickly.

Link to post
Share on other sites

yes

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

apparently I can...now. I removed the files that came up as IC in-compatible, then got an error about the nvd_common.hsl restored that file from my back up, and was able to connect to a mp server and pass the IC check.

| CyperPower PC | AMD Ryzen 7 3700X @ 4.4 GHz | 64Gb DDR4 3200 MHz | Radeon RX 5700 8Gb | 32" Samsung Curve| Oculus Rift S | Thrustmaster T160000 HOTAS + Rudder Pedals | Windows 10-64 |

Link to post
Share on other sites
  • 4 weeks later...

that's on page 1

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

Had the same Problem.

Deleted the shadow file in the deferred folder before applying the mod. Worked for me.

Win10 Pro, Intel i9 9700k @5GHz, GeForce RTX 2080 TI, 32GB G.Skill Ripjaw DDR4 @3200MHz RAM, MSI z390 Gaming Plus, HP Reverb Pro, TM Warthog, Virpil WarBRD Base, Samsung SSD 850 EVO 500GB (for DCS), Samsung SSD 850 EVO 250GB (for Win10), Philips PHL 274E

Link to post
Share on other sites
Had the same Problem.

Deleted the shadow file in the deferred folder before applying the mod. Worked for me.

Сan you explain which files need to delete from which specific folders?

VR Samsung HMD Odyssey, Monitor Samsung C32HG70, CPU Ryzen 5800Х, MSI X570 ACE, RAM CMK32GX4M2F4000C19 2X16Gb (@3800), M.2 960PRO 500Gb, M.2 2000Gb, VGA VEGA 64LC (@1800/1050)

Link to post
Share on other sites

Hi, thanks for this great patch. Am using it for months.

 

 

Since the latest open beta update, 2.5.5.40269, the patch does not compile any more for me (patch version 2.5.5.34644). Directly after starting DCS, I get the compile error:

 

 

Shader 'bazar/shaders/deferred/Compose.fx' failed to compile. Reason:

warning X4717: Effects deprecated for D3DCompiler_47

deferred/shadows.hlsl(49,30-45): error X3018: invalid subscript 'w'

deferred/shadows.hlsl(49, 15-45): error X3012: 'radius': missing initial value

 

 

I have heard that also others have this issue. Does the patch need an update?

 

You can also read that a solution is to delete the shadows.hlsl, but I do not know what the impact on the patch would be when doing this.

Link to post
Share on other sites

????...excuse my question, is it possible to get working in the latest patch or not?

 

Thank you

 

McDan out

Gigabyte Aorus Master Z390| i9 9900K 5.2GHz | 32GB DDR4-4266 | GTX 1080ti | TM Warthog / Virpil Stick | MFG Crosswind V2 | Windows 10 64-bit | SSD Samsung | 4K Philips BDM4065UC Monitor | Oculus Rift S | Rseat S1 Cockpit

Link to post
Share on other sites

Yes, the current workaround as per post #914 is to delete the file DCS doesn't like from the mod package before applying it: bazar\shaders\deferred\shadows.hlsl

Do that or wait until someone publishes a fixed shadows.hlsl and/or the official download is updated :)

Link to post
Share on other sites
Yes, the current workaround as per post #914 is to delete the file DCS doesn't like from the mod package before applying it: bazar\shaders\deferred\shadows.hlsl

Do that or wait until someone publishes a fixed shadows.hlsl and/or the official download is updated :)

 

Thank you,

 

but it just keeps hanging on the loading screen without any error message, I guess I just wait for the update...:noexpression:

 

McDan out

Gigabyte Aorus Master Z390| i9 9900K 5.2GHz | 32GB DDR4-4266 | GTX 1080ti | TM Warthog / Virpil Stick | MFG Crosswind V2 | Windows 10 64-bit | SSD Samsung | 4K Philips BDM4065UC Monitor | Oculus Rift S | Rseat S1 Cockpit

Link to post
Share on other sites

Something is simply broken in this game. Every time I play it I get wildly different performance visuals requiring another set of HOURS to find the cure. Then its play musical chairs with hundreds of settings ad nauseum until I can find that one good temp setting... From reading all of these threads I can see one thing. There is no cure for any two different people.

 

I see people with far less hardware saying they get good results with this game in VR.

 

On my 8700k/2080/32ddr4/eidehd Im running almost everything full low and it still stutters badly in high g turns.

 

I play American Truck Sim, Project Cars and IL2 and all run perfectly fine as expected. Not this. Frustration level 98%....

Link to post
Share on other sites

@mitchelrobertson

 

 

 

 

We have a group of 3 people playing together online all in VR.

 

 

Here are the things that improved performance in VR for us and you might try out if it also improves VR performance for you :

 

 

 

- Set your preload radius to maximum (according to your specs your pc should easily handle it)

 

 

- make sure the VR window (if mirrored on the desktop is in fullscreen)

 

 

- apply the shader mod

Link to post
Share on other sites
  • Kegetys changed the title to VR Shaders mod for better VR experience
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...