Jump to content

VR Shaders mod for better VR experience


Kegetys

Recommended Posts

Nope this one needs @Kegetysto fix. Found a hack

 

 


Edited by speed-of-heat
Found a hack

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

Ok I might have something, just doing some tests.

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

I think this seems to work:

 

 DCS VR Shaders mod for 2.7.6 Hotfix.zip

 

note you will need to completely uninstall the existing mod and or repair before applying this fix.

 

This hack simply removes the files in the 5.1 directory which includes speedtrees and speedtrees shadows which was causing the error.

 

there may be some performance implications, I honestly haven’t measured how much. 
 

it’s a hack not a fix, for that we need @Kegetysto fix the code.

 

After you have repaired or completely uninstalled, You just need to install the hotfix, it has everything you need.


Edited by speed-of-heat
The butcher has been in session
  • Like 2
  • Thanks 2

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

Make sure the 5.1 files are commented out in the metashaders\terrain sub directory of the mod

You also have to uninstall the mod first..or repair.

If you just install this version over the old version it will still break as the 5.1 files will still be modded


Edited by speed-of-heat
  • Thanks 1

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

1 hour ago, speed-of-heat said:

Working as usual for me. 

 

Repaired DCS prior to install. I'm not sure if that works to uninstall the old version, since I stupidly don't use a mod manager, but no errors here on Syria.

 

Thanks again speed-of-heat, you rock buddy!

  • Thanks 1
Link to comment
Share on other sites

13 hours ago, falcon_120 said:

It seems with latest update i cannot join servers in MP. It says "pure client is required" even when directly launching DCS and trying to connect

This mod nearly always caused an IC fail, it’s not new.

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

I'm getting this strange issue when using the mod - some cockpit textures appear "spotted" with tiny specks with a shiny/metallic look to them. This issue is very evident in the Mosquito, while I can't discern it in the Tomcat. Everything is fine with the mod turned off. Any idea?

Link to comment
Share on other sites

No

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

Just the hotfix, it has all you need.

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

16 hours ago, Picchio said:

I'm getting this strange issue when using the mod - some cockpit textures appear "spotted" with tiny specks with a shiny/metallic look to them. This issue is very evident in the Mosquito, while I can't discern it in the Tomcat. Everything is fine with the mod turned off. Any idea?

 

I have the same in the A10C-2 if I turn on cockpit lighting. Looks like Jackson Pollock’s been in with the grey paint, or like some sort of urban camouflage.

Link to comment
Share on other sites

On 9/17/2021 at 1:33 PM, speed-of-heat said:

Caucuses ok

marianas fail,

Nevada ok,

Normandy fail,

Persian Gulf ok,

syria fail,

the channel fail.


 

newer maps, seems to be the issue,lemmie look for a quick hack.

 

 

 

This matches my experience. Glad to have this figured out, I was worried I'd pooched something! 😰

 

I've noticed you can still go ahead and play the mission (just keep clicking ignore to the errors), but there won't be any trees. Normandy looks it was attacked by hordes of beavers! 😅

 

Here's hoping a fix is relatively easy, this is such a great mod! 

"Though I fly through the Valley of Death, I shall fear no evil, for I am at 80,000 feet and climbing"

GTX 1080Ti 2025MHz, Ryzen 5 5600x 4.9GHz, MSI MPG B550 Gaming, 32 GB DDR4 RAM 3200 MHz, a bunch of SSDs,

Oculus Quest 2.

No water cooling but enough fans that my rig just hovers around the room now.

Link to comment
Share on other sites

35 minutes ago, Sandmonkee said:

Here's hoping a fix is relatively easy, this is such a great mod! 

Errr… right here 

 

 

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

I wish there was some way to set DCS to rebuild all the shaders after an update. A batch. File I could run after install and then an hour later or whatever it's done. No loading a new terrain and airframe and wait 5-10 minutes every time. 

  • Like 2

"It takes a big man to admit he is wrong...I'm not a big man" Chevy Chase, Fletch Lives

 

3700x - 32gb ram - RTX3080 - Windows 10

Link to comment
Share on other sites

45 minutes ago, speed-of-heat said:

Errr… right here 

 

 

Ahh, sorry, too many mods, not enough brain cells!

  • Like 1

"Though I fly through the Valley of Death, I shall fear no evil, for I am at 80,000 feet and climbing"

GTX 1080Ti 2025MHz, Ryzen 5 5600x 4.9GHz, MSI MPG B550 Gaming, 32 GB DDR4 RAM 3200 MHz, a bunch of SSDs,

Oculus Quest 2.

No water cooling but enough fans that my rig just hovers around the room now.

Link to comment
Share on other sites

7 minutes ago, DayGlow said:

I wish there was some way to set DCS to rebuild all the shaders after an update. A batch. File I could run after install and then an hour later or whatever it's done. No loading a new terrain and airframe and wait 5-10 minutes every time. 

What I do its passing all objects, aircrafts, tanks etc... thorught the encyclopedia. Just to create all shaders.

Link to comment
Share on other sites

That's a lot of clicking. Wish you could just set it as part of the instalol, leave and come back

  • Like 1

"It takes a big man to admit he is wrong...I'm not a big man" Chevy Chase, Fletch Lives

 

3700x - 32gb ram - RTX3080 - Windows 10

Link to comment
Share on other sites

Yes some sort of batch to let DCS run through the mods and rebuild would be real nice. But it became second nature to manually reload all the shaders and go through the motions etc, so no biggie. Every couple of weeks a couple of hours reloading is well worth it in the end. My lesson learned is to not allow DCS to update on flight nights. 🙂 Many thanks @speed-of-heat for the Hotfix! Much appreciated!

  • Thanks 1

--

I Fly A-10C II exclusively in VR and record my journey in DCS: https://www.youtube.com/channel/UCm1MRJcn9K-89F6qnK0DVIQ 

SYSTEM SPECS: Ryzen 7 5800X, RTX3080, Reverb G2, VKB Gunfigher MKIII MCG Ultimate with 10cm extension, TM Warthog Throttle, TM TPR Rudders. 64GB RAM, W10, VoiceAttack, VAICOM PRO, TACView, SRS, Monstertech deskmounts. Gametrix Jetseat. Still waiting for PointCTRL.
Flight Group: Wildcats 378th VEAW 163rd https://dcswildcats.online/

Link to comment
Share on other sites

Having just spent the last couple of hours trouble shooting various shader mods and then rebuilding every time to see if it worked, I would love to see something that builds your shaders in the background! Something you could just click and walk away while it somehow opens all your modules and all your maps in the background. Fantastic idea! 

  • Like 1

"Though I fly through the Valley of Death, I shall fear no evil, for I am at 80,000 feet and climbing"

GTX 1080Ti 2025MHz, Ryzen 5 5600x 4.9GHz, MSI MPG B550 Gaming, 32 GB DDR4 RAM 3200 MHz, a bunch of SSDs,

Oculus Quest 2.

No water cooling but enough fans that my rig just hovers around the room now.

Link to comment
Share on other sites

×
×
  • Create New...