Jump to content

Windows Mixed Reality (Discussion Only)


Recommended Posts

2 hours ago, speed-of-heat said:

Set up Viacom to run as a scheduled task as administrator, create a shortcut to that task launch the short cut...

 

Elevated Program Shortcut without UAC Prompt - Create - Windows 7 Help Forums (sevenforums.com) works for 8 and 10 as well

 

 

That works perfectly, thank you sir !

RYZEN 5900X | 32GB | ASUS Strix RTX3090 | 500GB NVMe OS 1000GB NVMe DCS | Warthog HOTAS | HP Reverb G2 | VA & ViacomPRO

Link to post
Share on other sites
  • Replies 919
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

There is a little pause button in the bottom middle of the WMR screen press it and it will not display the WMR mirror, you will need to hover over it for it to show ...   

You mean outside of WMR?  If so, because you can get 6 DOF issues (and occasional mouse control issues) if not synced with WMR first.  Yes, it will work 90% of the time, and it all depends on your roo

I was getting similar issues with icons disappearing. This registry entry fixed it for me.   Use a wmr headset? Give this a try - Virtual Reality - ED Forums (eagle.ru)

44 minutes ago, shaun57 said:

 

That works perfectly, thank you sir !

My pleasure 

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites

I'm hoping someone can help with sorting out this issue.

 

I have a shortcut on my desktop to DCS OpenBeta.  As soon as I launch WMR the DCS shortcut disappears!!  What is odd is the DCS shortcut for the release version of DCS does not disappear.  The only difference is that I have VR enabled for Open Beta in the DCS settings.  Any ideas???  Thanks

 

EDIT - I found a workaround I pinned the DCS OpenBeta shortcut to my taskbar and it does not disappear when I open WMR.  Still be curious if others have had this issue?


Edited by CrackerJack

Win 10 64-bit, Intel Core i7-7700k@4.2GHz, MSI 1080Ti , 16 GB, 500GB SSD, LG 34UM95, Acer T232HL, TrackIR 5 Pro, Thrustmaster Warthog HOTAS, Saitek Combat Rudder Pedals.

Link to post
Share on other sites

I guess the desktop icon returns  when you drop back to regular windows?
 

if so,  their is a bug, between synchronising the desktop between wmr and windows... 

 

Cut the icon, and then fire up wmr, then paste it back... it should fix it

SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.1 GHz, 32Gb RAM, EVGA 3090 XC3, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb G2 @ 2836 x 2768
SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

 

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to post
Share on other sites
3 hours ago, oz555 said:

I was getting similar issues with icons disappearing. This registry entry fixed it for me.

 

Use a wmr headset? Give this a try - Virtual Reality - ED Forums (eagle.ru)

 

That fixed it!  Thanks for the help!

Win 10 64-bit, Intel Core i7-7700k@4.2GHz, MSI 1080Ti , 16 GB, 500GB SSD, LG 34UM95, Acer T232HL, TrackIR 5 Pro, Thrustmaster Warthog HOTAS, Saitek Combat Rudder Pedals.

Link to post
Share on other sites
16 hours ago, oz555 said:

I was getting similar issues with icons disappearing. This registry entry fixed it for me.

 

Use a wmr headset? Give this a try - Virtual Reality - ED Forums (eagle.ru)

 

Yep same here, what happens is WMR adds virtual monitors which screws up desktop arrangement.

After doing the registry fix problem solved.

  • Like 1

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | 

Link to post
Share on other sites

After doing this you won't be able to open (for example) a browser window inside your game anymore. It will drop you back to the WMR home scene with a blank browser window. At least it does this on my system. (didnt test in DCS, but did test in Elite)

[sIGPIC][/sIGPIC]

 

 

Asus Z390-E, 32GB Crucial Ballistix 2400Mhz, Intel i7 9700K 5.0Ghz, Asus GTX1080 8GB, SoundBlaster AE-5, G15, Streamdeck, DSD Flight, TM Warthog, VirPil BRD, MFG Crosswind CAM5, TrackIR 5, KW-908 Jetseat, Win 10 64-bit

 

”Pilots do not get paid for what they do daily, but they get paid for what they are capable of doing.

However, if pilots would need to do daily what they are capable of doing, nobody would dare to fly anymore.”

Link to post
Share on other sites
58 minutes ago, Yskonyn said:

After doing this you won't be able to open (for example) a browser window inside your game anymore. It will drop you back to the WMR home scene with a blank browser window. At least it does this on my system. (didnt test in DCS, but did test in Elite)

 

Yeah I think I heard something like that - not an issue on my end. I would think there might be some way though to get it to work, as I believe these virtual monitors were only being pre-allocated. I don't know though that is way beyond my pay grade.


Edited by dburne

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | 

Link to post
Share on other sites

1st thks to imacken for the tip on starting DCS from a desktop view in the WMR cliff house (don't have controllers and had not though about using the keyboards's Win key to bring up the menu... 😞 ).  

 

2nd: I have a G2 and a quest 2 but only use the G2 for DCS (much better)... I also have Skatezilla's DCS utility installed.  I noticed that when I launch DCS (either through DCS utility or just directly through the DCS desktop icon) it opens steamVR (normal) but also the oculus app.  Also noticed that in Skatezilla's utility, under application settings and then VR it has both steam Vr and Oculus there and Oculus has a ticked box next to it but SteamVR's box is unticked and I cannot untick or tick any of them.

 

Someone knows how I can prevent this oculus app from launching automatically with DCS? 


Edited by Brainfreeze

i7 10700@2.6Ghz / RTX 3080 / Reverb G2 / TrackIR / Virpil Wrbrd + Alpha Stick + CM2 throttle / Thrustmaster TRP Rudder

Link to post
Share on other sites

Wondering if someone could help me please. Just got my Reverb G2 and generally things going really well, nice stable 45 most the time with crisp graphics etc. However - I have noticed that trees draw in at different distances, meaning that there are two different 'versions' of every tree leading to very disorienting looking trees in general.

(So close one eye and trees are 'growing' into the sim at the tree draw distance, but then if you swap eyes there are no trees there yet till you get a bit closer). This then means all trees around me while flying don't quite 'look' right as if there are two different trees at each location.

Anyone that has seen two different versions of an object in each eye overlaid before will know what I mean. I also see a similar effect with distant terrain/hills also - so they seem to 'ghost' and not quite look to be in the right place.

 

I previously got a similar effect in my Rift S when I tried the parser line in autoexec.cfg file with shorelines etc - so the water would be in one place at the shore in one eye compared to the other eye - so both combined looked VERY strange. So quickly removed that line from the file.

 

If anyone could help with this strange fault then I would be very appreciative - as this is really the only issue I am having with the G2 in DCS and it is a bit of a show stopper really.

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
12 hours ago, VampireNZ said:

Wondering if someone could help me please. Just got my Reverb G2 and generally things going really well, nice stable 45 most the time with crisp graphics etc. However - I have noticed that trees draw in at different distances, meaning that there are two different 'versions' of every tree leading to very disorienting looking trees in general.

(So close one eye and trees are 'growing' into the sim at the tree draw distance, but then if you swap eyes there are no trees there yet till you get a bit closer). This then means all trees around me while flying don't quite 'look' right as if there are two different trees at each location.

Anyone that has seen two different versions of an object in each eye overlaid before will know what I mean. I also see a similar effect with distant terrain/hills also - so they seem to 'ghost' and not quite look to be in the right place.

 

I previously got a similar effect in my Rift S when I tried the parser line in autoexec.cfg file with shorelines etc - so the water would be in one place at the shore in one eye compared to the other eye - so both combined looked VERY strange. So quickly removed that line from the file.

 

If anyone could help with this strange fault then I would be very appreciative - as this is really the only issue I am having with the G2 in DCS and it is a bit of a show stopper really.

Hi VampireNZ, not sure what specs and settings you got so difficult to help but have you tried Taz1004' better trees mod for caucus?  I use it (dark version) and do not have this pb (and trees look a lot better!).  Post your specs and setting though if you want an answer


Edited by Brainfreeze

i7 10700@2.6Ghz / RTX 3080 / Reverb G2 / TrackIR / Virpil Wrbrd + Alpha Stick + CM2 throttle / Thrustmaster TRP Rudder

Link to post
Share on other sites
24 minutes ago, Brainfreeze said:

Hi VampireNZ, not sure what specs and settings you got so difficult to help but have your tries Taz1004' better trees mod for caucus?  I use it (dark version) and do not have this pb (and trees look a lot better!).  Post your specs and setting though if you want an answer

 

Cheers, yea my specs used to be in my sig, but I guess that stuff has changed with the new forum. In any case the Q was more for ppl who know what is causing the issue/have also had the same problem and fixed it as there are lots of other ppl here with G2's- not so much guessing what it might be based on my system specs. Also I wasn't getting the issue with my Rift S so is G2 specific.

 

Also yes I have V5 of the tree mod - seemed pretty obvious this might be causing it so tried with and without it and get the same issue. Also the tree mod is only for one map, I get the same thing with all trees on all maps.

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

I spent a lot of time in the Hornet off the Supercarrier today whilst I was working out bindings for my new CM3 Throttle.

For some reason today I could not help but gawk at the incredible image in my Reverb G2, the lighting was just incredible.

DCS is absolutely stunning in VR. Can't wait for the new clouds.

  • Like 2

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | 

Link to post
Share on other sites

For anyone interested currently the Microsoft Store has Reverb G2 in stock.

https://www.microsoft.com/en-us/p/hp-reverb-g2-vr-headset/93qb262d0514?activetab=pivot:overviewtab

  • Like 1

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | 

Link to post
Share on other sites
  • 2 weeks later...
Latest Nvidia drivers 457.30 messed up the refresh rate on my Odyssey plus. I have a RTX2080ti and I started getting Error 13-14 which means it could not start my WMR at the refresh rate I set, which was 90hz. I could run it in 60hz but the flicker bugged the crap out of me. So I rolled the drivers back to 456.71 and it all works again. If anyone else has issues, give that a try.
Just a follow up, I was using the USB-c virtuallink port on my 2080ti for my headset, and that appears to be the culprit. I plugged my headset directly into the HDMI on the card and the USB3 on the PC and it works with the latest drivers, but it's crashing a lot. Does anyone else use the virtual link port on their card?

Sent from my Pixel 3a XL using Tapatalk

F-14B, F-16, F-18C, A-10C, F-5E, F-86, FC3, BF-109, FW-190, P-51, Spitfire, UH-1,AJS-37 Viggen, MIG-15, MIG-19, MIG-21, AV-8B Harrier, P-47D

Persian Gulf, Caucuses, NTTR, Normandy, The Channel, Syria

Combined Arms, WWII Assets,Super Carrier

TM Warthog, Virpil VFX,BuddyFox UFC, Saitek Pro Flight quadrant & Switch Panel, Odyssey+ VR, Jet Pad w/ SSA, Voice Attack w/Viacom Pro

GeForce RTX2080TI OC, Intel Core i7-7700K 4.5Ghz, 64GB DDR4, Dedicated 1TB SSD

Link to post
Share on other sites
  • 2 weeks later...
On 1/14/2021 at 1:14 PM, dburne said:

For anyone interested currently the Microsoft Store has Reverb G2 in stock.

https://www.microsoft.com/en-us/p/hp-reverb-g2-vr-headset/93qb262d0514?activetab=pivot:overviewtab

 

It's already out of stock at least in the UK.

 

Mine packed up, neither Windows Mixed Reality nor Steam VR could detect it, I had a refund from the HP provider and bought some nice G.SKILL RAM kit with it.

 

I'll spend a little in a second hand headset and wait until the new generation come out at lower price and hopefully better FoV, the G2 is good, but from my point of view HP shot themselves in the foot releaseing it with too little improvement to stan its own vs newer headsets, the technology is progressing very fast and we'll see better pretty soon.

 

That said, after the Oculus CV1 it was quiet a joy to use, I only have 3 issues with V.R sets: Limited FoW and the weight of the set itself which make the recorded image shaking at every head movement, amplifying it because of the forward weight inertia, then the recording was decentred vertically, I never was able to set it up (didn't have time to do so before it packed up to be honnest) and from VR to full screen recording didn't completely show what I was looking at.

 

 

 

 

 

 

 


Edited by Thinder

MSI B450 GAMING PLUS MAX 7B86vHB1(Beta version) BIOS, AMD Ryzen 5 5600X, EVGA NVIDIA GeForce GTX 1080 Ti 11GB, 32GB G.SKILL TridentZ RGB (4 x 8GB) DDR4 3200 CL14, Thrustmaster T.16000M FCS HOTAS. My G2 is DEAD, I'll get VR again when headsets will be better.

M-2000C. F/A-18C Hornet. F-15C. MiG-29 "Fulcrum". 

Avatar: Escadron de Chasse 3/3 Ardennes.

 

Link to post
Share on other sites
On 2/4/2021 at 10:34 AM, Thinder said:

 

It's already out of stock at least in the UK.

 

Mine packed up, neither Windows Mixed Reality nor Steam VR could detect it, I had a refund from the HP provider and bought some nice G.SKILL RAM kit with it.

 

I'll spend a little in a second hand headset and wait until the new generation come out at lower price and hopefully better FoV, the G2 is good, but from my point of view HP shot themselves in the foot releaseing it with too little improvement to stan its own vs newer headsets, the technology is progressing very fast and we'll see better pretty soon.

 

That said, after the Oculus CV1 it was quiet a joy to use, I only have 3 issues with V.R sets: Limited FoW and the weight of the set itself which make the recorded image shaking at every head movement, amplifying it because of the forward weight inertia, then the recording was decentred vertically, I never was able to set it up (didn't have time to do so before it packed up to be honnest) and from VR to full screen recording didn't completely show what I was looking at.

 

 

 

 

 

 

 

 

Thinder You a motorhead fan? only i see snaggletooth in your channel.

 

I saw them many times first line up Lemmy.Animal,Eddie back in the day newer line up later on. 

 

I was at Port vale also which was probably the longest show ever,

 

Sorry to go off topic and if you are not a fan the above is irrelevant lol. 

  • Like 2
Link to post
Share on other sites
4 hours ago, freehand said:

Thinder You a motorhead fan? only i see snaggletooth in your channel.

 

I saw them many times first line up Lemmy.Animal,Eddie back in the day newer line up later on. 

 

I was at Port vale also which was probably the longest show ever,

 

Sorry to go off topic and if you are not a fan the above is irrelevant lol. 

 

No problem... Yeah. Bomber!

06dc051c6d6f1fe3645a7ded30f559c7.png

 


Edited by Thinder
  • Like 2

MSI B450 GAMING PLUS MAX 7B86vHB1(Beta version) BIOS, AMD Ryzen 5 5600X, EVGA NVIDIA GeForce GTX 1080 Ti 11GB, 32GB G.SKILL TridentZ RGB (4 x 8GB) DDR4 3200 CL14, Thrustmaster T.16000M FCS HOTAS. My G2 is DEAD, I'll get VR again when headsets will be better.

M-2000C. F/A-18C Hornet. F-15C. MiG-29 "Fulcrum". 

Avatar: Escadron de Chasse 3/3 Ardennes.

 

Link to post
Share on other sites
5 hours ago, freehand said:

Thinder You a motorhead fan? only i see snaggletooth in your channel.

 

I saw them many times first line up Lemmy.Animal,Eddie back in the day newer line up later on. 

 

I was at Port vale also which was probably the longest show ever,

 

Sorry to go off topic and if you are not a fan the above is irrelevant lol. 

 

Newcastle City Hall, March 79', Overkill tour.

 

Camped out overnight in a sleeping bag in the ticket queue outside the venue to get seats down the front.

 

My ears are still ringing 😉

  • Like 2

RYZEN 5900X | 32GB | ASUS Strix RTX3090 | 500GB NVMe OS 1000GB NVMe DCS | Warthog HOTAS | HP Reverb G2 | VA & ViacomPRO

Link to post
Share on other sites

New user here. 

 

I use the Reverb G2, and never had issues in other games, but in DCS it is....weird.

 

View is very large, and the cockpit "swims" around as I move my head. Ie, as I loom left, the cockpit moves right, but not the outside world.

 

How can I fix the VR view? Thanks

Link to post
Share on other sites

At the risk of getting into a “have you tried this?” Marathon:  make sure you turn off hardware accelerated gpu scheduling, or hags. I did a test this week where i reenabled it using a working, prexisting setup and it causes all sort of swimming and weird stuttery issues like you describe.  It causes this trippy, swirly stuttering than what you normally see. 

Link to post
Share on other sites
28 minutes ago, captainHelmet said:

At the risk of getting into a “have you tried this?” Marathon:  make sure you turn off hardware accelerated gpu scheduling, or hags. I did a test this week where i reenabled it using a working, prexisting setup and it causes all sort of swimming and weird stuttery issues like you describe.  It causes this trippy, swirly stuttering than what you normally see. 

It's already off.

Link to post
Share on other sites
7 hours ago, Steeljockey said:

New user here. 

 

I use the Reverb G2, and never had issues in other games, but in DCS it is....weird.

 

View is very large, and the cockpit "swims" around as I move my head. Ie, as I loom left, the cockpit moves right, but not the outside world.

 

How can I fix the VR view? Thanks

With something weird like this I would start as clean as possible... i.e default settings on the GPU control panel then have the steamvR settings as used by @speed-of-heat and default settings in DCS.  Need to find a config that does not do that to start with.  

i7 10700@2.6Ghz / RTX 3080 / Reverb G2 / TrackIR / Virpil Wrbrd + Alpha Stick + CM2 throttle / Thrustmaster TRP Rudder

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...