Jump to content

No microstutters but scenery passes by stuttering!


rajdary
 Share

Recommended Posts

So, i have tried many things but probably not all the possibilities to try and get this smoothness:

https://forums.eagle.ru/showpost.php?p=3398931&postcount=18

 

My overall performance is good but when i fly down and low and looking to my sides, the trees and buildings or even ships when i am at sea, they all pass by stuttering, i have tried it out with the A10C and AV8B both the same.

 

Has anyone had this, any tip to correct it?

Thanks

 

Phanteks Enthoo Evolv Tempered Glass, Asus ROG Maximus IX Hero, Intel i7 7700K @ 4.8, Corsair HX 1000i, Nzxt Kraken 62, 32gb DDR4 3000Mhz Corsair Dominator Platinum, Nvme SSD Samsung 960 Evo 1Tb, Asus Strix OC 1080ti, Philips 43" 4K Monitor + 2 x Dell 24" U2414H, Warthog HOTAS, Track IR 5, Obutto R3volution, Buttkicker Gamer 2, MFG Crosswind pedals, Occulus Rift CV1, Windows 10 Pro.

Link to comment
Share on other sites

Even running at a constant framerate, the game has terribly inconsistent frametimes and will sometimes microstutter when flying low over trees, if you have them set too high for your pc. Unfortunately i cannot capture a graph overlay, but even in regular flight, instead of a smooth flat line you will see a rather jagged mess, and this definitely needs to be addressed at some point.

 

In the meantime though, I've tried countless combinations trying to fix this, since it bothers me to no end as well. Rivatuner's limiter does not seem to work in DCS, and it's usually a go-to for fixing this sort of thing.

 

The best solution that i've found so far is to disable the ingame vsync and try using nvidia inspector's standard vsync, alongside a 60.7 fps cap. Vsync alone doesn't seem to smooth out the passing terrain, but in combination with the limiter, it seems to do a decent job preventing the jittering scenery. No idea if this will help you, but it certainly helps me.

Windows 10 64 Bit, i7-4790K @ 4.4GHz, 16GB RAM, STRIX GTX 970, Thrustmaster T.16000M HOTAS

Link to comment
Share on other sites

SOLVED

 

After lots of testing, undoing overclock, Turning off XMP, Vsync on or Off, Alt tab full screen Etc... It was one of the last things that i tried, the culprit was the Monitor overclock!!! Its native setup is 60hz but i had it overclocked at 63Hz, i just left it back native and now i have that fantastic smooth performance:doh:

 

@KCferrari, thanks for the help anyway.

 

Phanteks Enthoo Evolv Tempered Glass, Asus ROG Maximus IX Hero, Intel i7 7700K @ 4.8, Corsair HX 1000i, Nzxt Kraken 62, 32gb DDR4 3000Mhz Corsair Dominator Platinum, Nvme SSD Samsung 960 Evo 1Tb, Asus Strix OC 1080ti, Philips 43" 4K Monitor + 2 x Dell 24" U2414H, Warthog HOTAS, Track IR 5, Obutto R3volution, Buttkicker Gamer 2, MFG Crosswind pedals, Occulus Rift CV1, Windows 10 Pro.

Link to comment
Share on other sites

Ok so one guy fixes it by setting max performance, another guy fixes with core affinity, another with enabling 16x pcie bus, and now monitor clocks.

 

What the heck is going on? Every other game performs fine, but DCS seems to require the Perfect computer. And by perfect I mean the exact computer that the developer is using. Not just the same make and model, but literally the one sitting on his desk.

  • Like 1
Link to comment
Share on other sites

Well,not exactly, i didnt have the common microstutter, which means micro pauses caused by spikes in the cpu while its loading something or doing some other work.

My problem was scenery stuttering whilst going fast very low, the rest of the sim was working very well and smooth.

I cant believe it was the monitor overclock, hence why it was one of the last things i checked.

 

Phanteks Enthoo Evolv Tempered Glass, Asus ROG Maximus IX Hero, Intel i7 7700K @ 4.8, Corsair HX 1000i, Nzxt Kraken 62, 32gb DDR4 3000Mhz Corsair Dominator Platinum, Nvme SSD Samsung 960 Evo 1Tb, Asus Strix OC 1080ti, Philips 43" 4K Monitor + 2 x Dell 24" U2414H, Warthog HOTAS, Track IR 5, Obutto R3volution, Buttkicker Gamer 2, MFG Crosswind pedals, Occulus Rift CV1, Windows 10 Pro.

Link to comment
Share on other sites

I have the same but only in VR despite 45 fps. In 2d it is smooth as butter.

System Specs: i7 8700k @ 5.0GHz (not delidded), ASRock Extreme4 Z370 MOBO, EVGA GTX 1080 SC 8GB, 32GB Corsair Vengeance LPX 3200MHz DDR4 RAM, Samsung Evo 240GB SSD, Samsung Evo 500GB SSD, 1TB HDD, Noctura NH-D15S Heat Sink, Acer VE278H 27" 1080p Monitor, Ocukus Rift CV1.

 

Controllers: TrackIR 5, Thrustmaster HOTAS X, Saitek Throttle Quadrant (with DIY removable collective mod), Saitek Pro Flight Rudder Pedals.

 

Just trying to keep my number of takeoffs and landings equal!

Link to comment
Share on other sites

Ok so one guy fixes it by setting max performance, another guy fixes with core affinity, another with enabling 16x pcie bus, and now monitor clocks.

 

What the heck is going on? Every other game performs fine, but DCS seems to require the Perfect computer. And by perfect I mean the exact computer that the developer is using. Not just the same make and model, but literally the one sitting on his desk.

DCS 2.5 is in OpenBeta and people on the forum have mixed amounts of computer knowledge. People are having a panic, changing core affinities and other stuff that probably only messes up their computers, at the same time as DCS 2.5 has known memory issues that are being worked on... if everyone could just calm themselves for three months, that would be great, methinks.

 

Personally, I play it with a Haswell CPU and 1060 graphics card (cheap stuff) and can max almost everything out in 1920x1200, without any real bugs other than crashes while benchmarking repeatedly.

Read my DCS 2.5 Optimisation Guide (version 2.5.4):

https://forums.eagle.ru/showthread.php?p=3828073

Link to comment
Share on other sites

So, i have tried many things but probably not all the possibilities to try and get this smoothness:

https://forums.eagle.ru/showpost.php?p=3398931&postcount=18

 

My overall performance is good but when i fly down and low and looking to my sides, the trees and buildings or even ships when i am at sea, they all pass by stuttering, i have tried it out with the A10C and AV8B both the same.

 

Has anyone had this, any tip to correct it?

Thanks

 

Try to pause your trackir (default key is F9) , then move around with the numpad and tell me if you got stuttering.

  • CPU : Intel i7 8700k@5.0ghz cooled by Noctua NH-D15 / Motherboard:Asorck Z370 Taichi / RAM: 32GB GSkill TridentZ @3600mhz / SSD: 500GB Nvme Samsung 970 evo+1 TB Sabrent Nvme M2 / GPU:Asus Strix OC 2080TI / Monitor: LG 34KG950F Ultrawide / Trackir 5 proclip/ VIRPIL CM2 BASE + CM2 GRIP + F148 GRIP + 200M EXTENSION /VKB T-Rudder MKIV rudder /Case: Fractal Design R6 Define black

Link to comment
Share on other sites

Well,not exactly, i didnt have the common microstutter, which means micro pauses caused by spikes in the cpu while its loading something or doing some other work.

My problem was scenery stuttering whilst going fast very low, the rest of the sim was working very well and smooth.

I cant believe it was the monitor overclock, hence why it was one of the last things i checked.

 

No, what you had was EXACTLY microstutter. I watched your video and you did not have stuttering, and THAT is "pauses caused by spikes in the cpu while its loading something or doing some other work". You had micro-stutter probably because your framerate and refresh rate were completely out of sync. 60 fps with a 63hz refresh will mean that 3 times per second your monitor repeats a frame, which means that 3 times per second an object that your eye was trying to track is not where it was expected to be. That is a micro-stutter.

 

You have "fixed" it by returning to 60hz, but the problem will forever exist unless you have Gsync or Freesync... or have a 500hz monitor (doesn't exist unfortunately). If you lock your framerate with a frame limiter to say 58fps, you will see exactly the same thing. Go ahead and try it.

System specs: i7 3820 @4.75Ghz, Asus P9X79LE, EVGA GTX1080SC @2100mhz, 16GB Gskil DDR3 @ 2000mhz, 512GB 960EVO m.2, 2 X 512GB 860EVO SATA3 in RAID0, EVGA Supernova 850W G2, Phantek Entho Luxe White. CPU and GPU custom water-cooled with 420mm rad and lots of Noctua fans.

ASUS PG348Q. VKB Gladiator Pro w/MCG, X-55 throttle and MFG Crosswind.

Link to comment
Share on other sites

No, what you had was EXACTLY microstutter. I watched your video and you did not have stuttering, and THAT is "pauses caused by spikes in the cpu while its loading something or doing some other work". You had micro-stutter probably because your framerate and refresh rate were completely out of sync. 60 fps with a 63hz refresh will mean that 3 times per second your monitor repeats a frame, which means that 3 times per second an object that your eye was trying to track is not where it was expected to be. That is a micro-stutter.

 

You have "fixed" it by returning to 60hz, but the problem will forever exist unless you have Gsync or Freesync... or have a 500hz monitor (doesn't exist unfortunately). If you lock your framerate with a frame limiter to say 58fps, you will see exactly the same thing. Go ahead and try it.

 

You are correct about your explanation but that video is not mine, i just linked it as an example of what i was looking forward to obtain.

 

Phanteks Enthoo Evolv Tempered Glass, Asus ROG Maximus IX Hero, Intel i7 7700K @ 4.8, Corsair HX 1000i, Nzxt Kraken 62, 32gb DDR4 3000Mhz Corsair Dominator Platinum, Nvme SSD Samsung 960 Evo 1Tb, Asus Strix OC 1080ti, Philips 43" 4K Monitor + 2 x Dell 24" U2414H, Warthog HOTAS, Track IR 5, Obutto R3volution, Buttkicker Gamer 2, MFG Crosswind pedals, Occulus Rift CV1, Windows 10 Pro.

Link to comment
Share on other sites

Try to pause your trackir (default key is F9) , then move around with the numpad and tell me if you got stuttering.

I already tried that and i had the same, it was the monitor. Now i dont have that stuttering and instead a smooth like butter flow of the scenery!

 

Phanteks Enthoo Evolv Tempered Glass, Asus ROG Maximus IX Hero, Intel i7 7700K @ 4.8, Corsair HX 1000i, Nzxt Kraken 62, 32gb DDR4 3000Mhz Corsair Dominator Platinum, Nvme SSD Samsung 960 Evo 1Tb, Asus Strix OC 1080ti, Philips 43" 4K Monitor + 2 x Dell 24" U2414H, Warthog HOTAS, Track IR 5, Obutto R3volution, Buttkicker Gamer 2, MFG Crosswind pedals, Occulus Rift CV1, Windows 10 Pro.

Link to comment
Share on other sites

My FPS are comfortably locked at 60fps with plenty of GPU performance to spare but looking around is very choppy with the deferred rendering.

 

The stuttering feels just like when you have mirrors activated, so maybe 2.5 has introduced reflective elements to the terrain/cockpits/liveries and these are causing trouble?

Link to comment
Share on other sites

My FPS are comfortably locked at 60fps with plenty of GPU performance to spare but looking around is very choppy with the deferred rendering.

 

The stuttering feels just like when you have mirrors activated, so maybe 2.5 has introduced reflective elements to the terrain/cockpits/liveries and these are causing trouble?

 

EXACTLY Like when you have mirrors activated...it's strange..

  • CPU : Intel i7 8700k@5.0ghz cooled by Noctua NH-D15 / Motherboard:Asorck Z370 Taichi / RAM: 32GB GSkill TridentZ @3600mhz / SSD: 500GB Nvme Samsung 970 evo+1 TB Sabrent Nvme M2 / GPU:Asus Strix OC 2080TI / Monitor: LG 34KG950F Ultrawide / Trackir 5 proclip/ VIRPIL CM2 BASE + CM2 GRIP + F148 GRIP + 200M EXTENSION /VKB T-Rudder MKIV rudder /Case: Fractal Design R6 Define black

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...