Jump to content

Exit Auto Hover = Death


Flit
 Share

Recommended Posts

I have been having some issues with the Ka-50. I hadn't flown the Ka-50 since 2010, so I assumed I was out of touch and making an error with my button pushing, but I was chatting in the Steam DCS section and it seems I am not the only one experiencing this issue.

 

Here is my problem:

 

I'm in auto hover, happily blasting tanks et al, and when I'm all spent I reset the targeting mode, deactivate auto hover and attempt to fly off in another direction.

 

It's at this point when I seem to frequently run into trouble. It's as if my trim isn't working, or it's got some other haunted idea and my demise in mind... and so I end up fighting the damned thing as I try to correct it - it's like riding an angry rodeo bull - it wobbles and pulls and throws and eventually I plow into the dirt.

 

Anybody else experienced this lately? I'm not sure if this is a 2.5 bug or a pilot error.

Link to comment
Share on other sites

Did you forget to disable your autopilot channels when leaving hover? The buttons don't illuminate properly in 2.5 right now, so it's easy to forget if you left them on, and that would certainly screw with your flight if you're fighting it. You also might want to check your stick trim setting in options. One of the options requires you to center the stick for the trim input to function, and that would also mess you up if you had that on by accident and weren't aware of it. The rudder trim setting can also be a dangerous one.


Edited by KCferrari

Windows 10 64 Bit, i7-4790K @ 4.4GHz, 16GB RAM, STRIX GTX 970, Thrustmaster T.16000M HOTAS

Link to comment
Share on other sites

Did you forget to disable your autopilot channels when leaving hover?

Disable them? He should not have to do that, I never do and I'm perfectly fine. The only channel I turn of after a hover hold is the altitude hold, it doesn't mess up my flight like described by flit if I leave it ON though.

To me it sounds like you really do turn of the AP channels by accident, and it would definitely mean your trim wouldn't work. For the trim to work the AP channels need to be active.

If you're altitude hold are still ON, to change altitude you need to pres the collective brake handle, and not release it until you stabilized on the new altitude. I seldom use altitude hold.

If you are on 2.5 you need to be aware there is a bug with the lightening, making the AP buttons not only hardly readable, but inverted. So when they are ON they are dark, and lit up when OFF. Will be corrected hopefully soon.

Helicopters and Viggen

DCS 1.5.7 and OpenBeta

Win7 Pro 64bit

i7-3820 3.60GHz

P9X79 Pro

32GB

GTX 670 2GB

VG278H + a Dell

PFT Lynx

TrackIR 5

Link to comment
Share on other sites

To me it sounds like you really do turn of the AP channels by accident, and it would definitely mean your trim wouldn't work. For the trim to work the AP channels need to be active.

 

Well that's not quite true, trim works without autopilot, but in a slightly different way. Without it, trim is pretty much just regular stick trim. With autopilot channels on though, trimming also actively attempts to hold the current pitch/heading/etc. The reason i bring it up, is if you usually fly with it off, the autopilot will try to pull the nose back to where you last trimmed, which could mess you up, I guess. Either way though, the description here seems like it would be more severe than anything autopilot would do.

 

Exiting auto hover has only ever been smooth for me though, even with the most recent 2.5 patches. The only button that has ever caused me to completely lose it is accidentally bumping the trim reset button.. That never goes well.. :music_whistling:


Edited by KCferrari

Windows 10 64 Bit, i7-4790K @ 4.4GHz, 16GB RAM, STRIX GTX 970, Thrustmaster T.16000M HOTAS

Link to comment
Share on other sites

The only button that has ever caused me to completely lose it is accidentally bumping the trim reset button..

Indeed! :-)

 

@Flit

I just saw this:

https://forums.eagle.ru/showthread.php?t=202780

Comon factor is Steam. He also mentions the hover bug. Maybe something in the Steam version? You are the only two to mention it here so far, but both of you implies more reports in the Steam community. For how long have you had this issue?

Helicopters and Viggen

DCS 1.5.7 and OpenBeta

Win7 Pro 64bit

i7-3820 3.60GHz

P9X79 Pro

32GB

GTX 670 2GB

VG278H + a Dell

PFT Lynx

TrackIR 5

Link to comment
Share on other sites

Flit. I didn't have this problem but if you can re-produce it in single player mode and provide a track, you'll save us from arguing this for pages. :)

i7-2600 @3.4GHz | Corsair 16GB @1600MHz. | MSI GTX1660Ti Gaming X | Samsung 256GB SSD (Win7HPx64)

Samsung 32" | Saitek X-55 Rhino & Rudder | Trustmaster MFD Cougars & 2 x 8"TFTs | Logitech G13, G230, G510, PZ55 SwitchPanel & Farming Sim Panel | TIR5

>>MY MODS<< | Discord: Devrim#1068

Link to comment
Share on other sites

@Flit

I just saw this:

https://forums.eagle.ru/showthread.php?t=202780

Comon factor is Steam. He also mentions the hover bug. Maybe something in the Steam version? You are the only two to mention it here so far, but both of you implies more reports in the Steam community. For how long have you had this issue?

 

Actually, that is the guy who I was talking to in Steam. I know because he calls this problem a 'cobra'. lol. He tried to guess what I was doing wrong in the Steam forums, then went off and experienced the same problem as I had, so it appeared.

 

I am not using a Steam version of DCS - standalone 2.5.

 

edit add: I'll see if I can make a track of it now ...how do I put it up?


Edited by Flit
Link to comment
Share on other sites

I am not using a Steam version of DCS - standalone 2.5.

If it really is a bug we'll hear more about it soon. I'll try it out myself when I get the time, I'm on standalone 2.5 hotfix 3, haven't flown the Shark since hotfix 2.

Helicopters and Viggen

DCS 1.5.7 and OpenBeta

Win7 Pro 64bit

i7-3820 3.60GHz

P9X79 Pro

32GB

GTX 670 2GB

VG278H + a Dell

PFT Lynx

TrackIR 5

Link to comment
Share on other sites

Actually, that is the guy who I was talking to in Steam. I know because he calls this problem a 'cobra'. lol. He tried to guess what I was doing wrong in the Steam forums, then went off and experienced the same problem as I had, so it appeared.

 

I am not using a Steam version of DCS - standalone 2.5.

 

edit add: I'll see if I can make a track of it now ...how do I put it up?

Yep that'd be me :thumbup: using steam open beta 2.5 version. calling it a cobra due to the similarity of the action to the Pugachev's cobra (only in a helicopter, with predictable aftermath) noticed that the auto recover only occurs if autopilot channels are on, if not then expect to crash and die upon releasing the stick with any foward movement, just verifying my game cache in case a file error is to blame, if not we'll see what the next updates bring to this beauty.

Link to comment
Share on other sites

Yeah she's still doing the rearing up and acting like she's on auto hover constantly.:helpsmilie::doh:
The AP channel lights are inverted. Could it be that the auto hover is as well? What happens if you actually try to activate auto hover (in forward flight, not in hover)? Behaves the same?

Helicopters and Viggen

DCS 1.5.7 and OpenBeta

Win7 Pro 64bit

i7-3820 3.60GHz

P9X79 Pro

32GB

GTX 670 2GB

VG278H + a Dell

PFT Lynx

TrackIR 5

Link to comment
Share on other sites

This video shows the moment the accident happened. I turned on the control helper to better see what's going on. Just after you gain forward speed it shows a large uncorrected cyclic input to the right which rolls you into the ground.

 

 

 

I also tried taking control just after you switched off auto-hover but everything worked OK.

 

So the problem is/was an unwanted cyclic input to the right. Looks like a control input issue - maybe a conflict?

Link to comment
Share on other sites

Hi

 

I have tried to reproduce but everything seems normal to me after disengaging auto hover. I dont see any un-commanded stick movement.

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

Is it possible I could have a control input issue consistently at this point of flight. Auto hover off = control input issue?

 

I'm not saying I disagree with you, I just can't fathom how it would only become apparent at this very exact point of the flight.

 

And if it is functioning as it should the rest of the time, how do i see i have a problem?

 

Edit add: I shall tinker. I wondered if it possible the mission has corrupted. Anyway, I shall check everything. Thanks for your time gents.


Edited by Flit
afterthought
Link to comment
Share on other sites

[ATTACH]179226[/ATTACH]

 

Ok... here is a track of the issue. As you'll see I turned off auto hover, dipped the nose (no problems), a slight tweak to the right - and then it just rolls right on over and I can't get it out of that.

 

And this is what I did after took control from you. I hope you can see the video. I shared in limited mode, not for public.

By the way; I didn't like your trimming mode. After trim, joystick input freezes until you move the stick center. I don't use that mode. It can be dangerous sometimes. :)

 


Edited by Devrim

i7-2600 @3.4GHz | Corsair 16GB @1600MHz. | MSI GTX1660Ti Gaming X | Samsung 256GB SSD (Win7HPx64)

Samsung 32" | Saitek X-55 Rhino & Rudder | Trustmaster MFD Cougars & 2 x 8"TFTs | Logitech G13, G230, G510, PZ55 SwitchPanel & Farming Sim Panel | TIR5

>>MY MODS<< | Discord: Devrim#1068

Link to comment
Share on other sites

.. Just after you gain forward speed it shows a large uncorrected cyclic input to the right which rolls you into the ground.

 

So the problem is/was an unwanted cyclic input to the right. Looks like a control input issue - maybe a conflict?

 

Just to clarify, I had given it a slight bank to the right, trimmed it, it kept rolling over more than I felt I'd banked it, I tried correcting it by moving stick to the left and re-trimming, there was no response at all to the corrections, it kept right rolling me into my grave.

 

...

By the way; I didn't like your trimming mode. After trim, joystick input freezes until you move the stick center. I don't use that mode. It can be dangerous sometimes. :)

 

The problem occurs for me when I go into a turning bank after releasing auto hover, it's as if it exaggerates my input and ignores any attempted corrections. I could fly straight ahead across the whole map with no problem, as you did.

 

I am interested in your comment above. But, I don't understand. What is it you think I am doing?

Link to comment
Share on other sites

The trimming method may be your problem.

 

I use Default trimming mode (SPECIAL tab for Ka-50 in OPTIONS page). With Default mode, my stick input never freezes after trimming.

You use Central Trimming Mode or something?

 

If I'm not wrong, (as I wrote above) that mode waits (or freezes) until you move your stick to center. That's why many many pilots died. :)

 

I suggest you to try (select) other trimming methods.

i7-2600 @3.4GHz | Corsair 16GB @1600MHz. | MSI GTX1660Ti Gaming X | Samsung 256GB SSD (Win7HPx64)

Samsung 32" | Saitek X-55 Rhino & Rudder | Trustmaster MFD Cougars & 2 x 8"TFTs | Logitech G13, G230, G510, PZ55 SwitchPanel & Farming Sim Panel | TIR5

>>MY MODS<< | Discord: Devrim#1068

Link to comment
Share on other sites

...I had given it a slight bank to the right, trimmed it, it kept rolling over more than I felt I'd banked it, I tried correcting it by moving stick to the left and re-trimming, there was no response at all to the corrections, it kept right rolling me into my grave...
I flew your track again. After disengaging autohover, I pushed the cyclic forward. After gaining some speed, applied slight right bank but autopilot (heading) channel tried to maintain my heading. Ka-50 only slightly laid to the right and kept flying.

 

As we mentioned above, choose and try other Trimmer Modes.

Screen_180216_171542.thumb.jpg.83147684286448afbbc7d6f132fde457.jpg

  • Like 1

i7-2600 @3.4GHz | Corsair 16GB @1600MHz. | MSI GTX1660Ti Gaming X | Samsung 256GB SSD (Win7HPx64)

Samsung 32" | Saitek X-55 Rhino & Rudder | Trustmaster MFD Cougars & 2 x 8"TFTs | Logitech G13, G230, G510, PZ55 SwitchPanel & Farming Sim Panel | TIR5

>>MY MODS<< | Discord: Devrim#1068

Link to comment
Share on other sites

Good trimming is essential.

If that's OK, check the Hover lamp in overhead panel,

and check the circle on HUD.

 

Make sure you didn't engage Flight Director autopilot button.

i7-2600 @3.4GHz | Corsair 16GB @1600MHz. | MSI GTX1660Ti Gaming X | Samsung 256GB SSD (Win7HPx64)

Samsung 32" | Saitek X-55 Rhino & Rudder | Trustmaster MFD Cougars & 2 x 8"TFTs | Logitech G13, G230, G510, PZ55 SwitchPanel & Farming Sim Panel | TIR5

>>MY MODS<< | Discord: Devrim#1068

Link to comment
Share on other sites

@ Flit, watched your track. After you disengaged the autohover you've trimmed the controls right and forward, that caused the crash. Just use the Controls Indicator (rctrl+enter), it's not cheating, so you can always monitor the trimmer position. When I disengage the Autohover the same time I engage the Flight Director. That way you don't have to "fight" the autopilot. Of course at the begining I messed up the trimmer position as well, lot of time. It takes time to master the autopilot in Ka-50, but when you've done it, it's very easy to fly this awesome helicopter!

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

So... stupid question, but how do I engage auto hover? I turn on all the autopilot channels and hit the auto hover button while at a hover and it doesn't take over. I know I'm missing something.

 

You need to get into a hover by yourself and trim it, make sure you're not in Director Mode (so you can't see = = on the HUD) and then engage auto-hover.

 

It's not a miracle worker, though. If you're poorly trimmed and drifting when you engage hover the autopilot will try its best but you'll likely carry on drifting into a tree.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...