Jump to content

Triple buffering is not working, can get either 30 or 60FPS.


GeorgeLKMT
 Share

Recommended Posts

Windows 10

Nvidia GTX960 2GB

388.71

 

It seems that triple buffering is getting ignored in 2.5 and there's no way to get it working. I tried different settings:

 

- DCS VSync ON, everything "application controlled" in drivers: 30 or 60 FPS.

 

- DCS VSync ON and Triple Buffering forced in drivers: 30 or 60 FPS.

 

- DCS VSync OFF and VSync with TB forced in drivers: 30 or 60 FPS.

 

Only solution that works is to force Fast or Adaptive VSync in drivers, but that's nVidia-specific setting, so I don't know how this works for AMD users. Either way, if I force regular VSync and TB in drivers, it should work like it used to. Is anybody else having this problem?

Link to comment
Share on other sites

Xmmm

My Hardware: Z390 AORUS Master - Intel 8700K 3.7 GHz @ 4.9 ghz (Delid Copper IHS) - G.SKILL 32GB DDR4 3200 (14-14-14-34 CL) - GigaByte 2080ti OC 11gb - 2 EVO Nvme 500GB - Virpil Warbird Base T-50CM2 and TM Throttle + Trackhat + G25 + AOC AG271QG 27"

 

My Modules: JF-17, F-16C, AV-8N/A, F-18C, ASJ37, MiG-15Bis, MiG-21Bis, Fw-190D, Bf-109K, P-51D, F-86F, Ka-50, UH-1H, Mi-8MTV2, NS430, FC3, A-10C, Mirage 2000C, L-39, F-5E-3, SA342, Spitfire.

 

My Maps: Nevada, Normandy, Persian Gulf, Syria.

Link to comment
Share on other sites

Alt-Enter

 

DCS does not always run in fullscreen even though you have fullscreen selected. If it is running in fullscreen and you switch to another program or the desktop, DCS will be in windowed when you return. Sometimes it will be in windowed from the start. Alt-enter will toggle between windowed/fullscreen.

 

Nvidia has an issue with windowed apps and vsync. I found that if vsync is set to on in DCS and DCS is running windowed, fps will get capped to half refresh rate. If vsync is off in DCS, then it will run with "fast sync" even though I don't have that selected.

 

I recommend vsync on in the Nvidia Control Panel and vsync off within all games you run.

System specs: i7 3820 @4.75Ghz, Asus P9X79LE, EVGA GTX1080SC @2100mhz, 16GB Gskil DDR3 @ 2000mhz, 512GB 960EVO m.2, 2 X 512GB 860EVO SATA3 in RAID0, EVGA Supernova 850W G2, Phantek Entho Luxe White. CPU and GPU custom water-cooled with 420mm rad and lots of Noctua fans.

ASUS PG348Q. VKB Gladiator Pro w/MCG, X-55 throttle and MFG Crosswind.

Link to comment
Share on other sites

  • 2 weeks later...
Alt-Enter

 

DCS does not always run in fullscreen even though you have fullscreen selected. If it is running in fullscreen and you switch to another program or the desktop, DCS will be in windowed when you return. Sometimes it will be in windowed from the start. Alt-enter will toggle between windowed/fullscreen.

 

Nvidia has an issue with windowed apps and vsync. I found that if vsync is set to on in DCS and DCS is running windowed, fps will get capped to half refresh rate. If vsync is off in DCS, then it will run with "fast sync" even though I don't have that selected.

 

I recommend vsync on in the Nvidia Control Panel and vsync off within all games you run.

 

alt+enter has no more effect for me in 2.5,.either I press alt+enter or not I see no changes in fps, likewise it seems to me that al+enter is lowering fps and going out of vsync


Edited by Goa
updated info

  • CPU : Intel i7 8700k@5.0ghz cooled by Noctua NH-D15 / Motherboard:Asorck Z370 Taichi / RAM: 32GB GSkill TridentZ @3600mhz / SSD: 500GB Nvme Samsung 970 evo+1 TB Sabrent Nvme M2 / GPU:Asus Strix OC 2080TI / Monitor: LG 34KG950F Ultrawide / Trackir 5 proclip/ VIRPIL CM2 BASE + CM2 GRIP + F148 GRIP + 200M EXTENSION /VKB T-Rudder MKIV rudder /Case: Fractal Design R6 Define black

Link to comment
Share on other sites

Triple buffering only affects OpenGL programs. DCS is DirectX. Instead, you'll need to change the maximum pre rendered frames.


Edited by KCferrari

Windows 10 64 Bit, i7-4790K @ 4.4GHz, 16GB RAM, STRIX GTX 970, Thrustmaster T.16000M HOTAS

Link to comment
Share on other sites

Triple buffering only affects OpenGL programs. DCS is DirectX. Instead, you'll need to change the maximum pre rendered frames.

 

could you please tell me more abot pre-rendering frames?

  • CPU : Intel i7 8700k@5.0ghz cooled by Noctua NH-D15 / Motherboard:Asorck Z370 Taichi / RAM: 32GB GSkill TridentZ @3600mhz / SSD: 500GB Nvme Samsung 970 evo+1 TB Sabrent Nvme M2 / GPU:Asus Strix OC 2080TI / Monitor: LG 34KG950F Ultrawide / Trackir 5 proclip/ VIRPIL CM2 BASE + CM2 GRIP + F148 GRIP + 200M EXTENSION /VKB T-Rudder MKIV rudder /Case: Fractal Design R6 Define black

Link to comment
Share on other sites

could you please tell me more abot pre-rendering frames?

 

Well, without triple buffering, you only have a front and a back buffer. Once the back buffer is full, The GPU is at a standstill if it's waiting for the screen refresh. With triple buffering, the gpu can still be pumping out an extra frame to display. Pre rendered frames is basically the same thing, but works for DirextX, and you can choose how many additional frames it will prerender. In other words, 2 prerendered frames would mean 2 back buffers, which is the same thing as triple buffering. Therefore, if you set it as such, it should provide you with a little extra leeway for frame drops, and hold 60fps more easily.

 

The more frames you pre render however, the more input lag it may cause. For instance, if you're some sort of madman and set it to 10, what you're seeing could be frames rendered up to 10 frames ago. It will of course only fill up the back buffers when it has time to, though. Set it to a reasonable number like 2 or 3 if you're using it. It is a standard option available in your gpu options, like triple buffering. Also, i'd highly recommend not using DCS vsync. Driver vsync gives much smoother results in my experience.


Edited by KCferrari

Windows 10 64 Bit, i7-4790K @ 4.4GHz, 16GB RAM, STRIX GTX 970, Thrustmaster T.16000M HOTAS

Link to comment
Share on other sites

OK, it sounds like you are jumping back and forth between Full Screen Exclusive and borderless window (using Alt-Enter)

 

in borderless window, Windows’ applies it's native V-Sync implementation, which is also triple-buffered (and acts similar to "Fast Sync" <=meaning framerates are not "locked")

 

with Full Screen Exclusive, the Nvidia control panel vsync settings are applied. So, if Vsync is ON then your framerates are "locked" to 60,30,20, etc. (unless you use "Fast Sync", etc.)

 

edit: Personally, I like NVCP's Fast Sync/Smooth/Adaptive but theoretically it can induce microstutters or "judder" because you will usually have an odd frame that doesn't match the monitor refresh rate, so either a frame gets dropped or one gets repeated


Edited by prccowboy
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...