Jump to content

Installer confusion


Mikkall
 Share

Recommended Posts

Ok

 

How about ya'll throw the dumber of us out there a proverbial bone.

 

Here's what I knew a few days ago.

 

1) Ya gotta have 1.5 OPENBETA to "update" to 2.5.

 

2) Won't work with 1.5 Stable

 

3) Won't work with OpenAlpha

 

4) Release version in 2 weeks

 

So, I sit and calmly wait. It's not like I'm not used to it... no big deal. TODAY, and with much happiness and surprise I see what ~appears~ to be a fresh install method for 2.5OpenBeta plastered all over the DCS Home Page. So I hit the web page download button and then run the happy little installer.

 

--and it immediately starts copying stuff from my STABLE version of 1.5--

 

Is this anywhere close to being a complete and total bust? I mean, what the heck, are you guys trying to give me a stroke?

Link to comment
Share on other sites

It is most likely copying your modules to avoid a lengthy download. It will copy terrains from OpenAlpha if you have that installed.

 

So you're saying the update to 2.5OpbenBeta from 1.5Stable wouldn't work (and I guess still won't) but now the installer you download from the Webpage "Download" button will install 2.5OpenBeta fresh AND use files from 1.5Stable AND OpenAlpha.

 

Am I getting that right? I mean... it's clear as mud

Link to comment
Share on other sites

Its recommended that you update your Open Beta to 2.5, but you can force update any version to any version really.

 

You can use:

 

DCS_Updater.exe update @openbeta

 

Installer will always search your computer for files it can copy and use instead of downloading.


Edited by NineLine

SigDCSNew.png
Forum RulesMy YouTube • My Discord - NineLine#0440• **How to Report a Bug**

1146563203_makefg(6).png.82dab0a01be3a361522f3fff75916ba4.png  80141746_makefg(1).png.6fa028f2fe35222644e87c786da1fabb.png  28661714_makefg(2).png.b3816386a8f83b0cceab6cb43ae2477e.png  389390805_makefg(3).png.bca83a238dd2aaf235ea3ce2873b55bc.png  216757889_makefg(4).png.35cb826069cdae5c1a164a94deaff377.png  1359338181_makefg(5).png.e6135dea01fa097e5d841ee5fb3c2dc5.png

Link to comment
Share on other sites

Its recommended that you update your Open Beta to 2.5, but you can force update any version to any version really.

 

You can use:

 

DCS_Updater.exe update @openbeta

 

Installer will always search your computer for files it can copy and use instead of downloading.

 

Yeah... well, I didn't have an OpenBeta. Honest, I thought I'd been running OB for quite awhile. I guess some time ago I dumped my OB and went to Stable (talking 1.5 here). That is unless the updater has a magic way of updating from OB to Stable without stupid people like me noticing. Anyway, a couple days ago, naturally, nothing worked due to my 1.5 Stable version (I didn't hear about @openbeta till it was too late). I wasn't worried about it because patience is a virtue... Grandpappy said so.

 

Which brings me back to today. I have kinda slow ADSL so, nothing happens fast. I mean, they say 12mb down, but yeah-right, right? It's more like, 1mb. Then there's the problem with doing it torrent style... I believe my fine hickbilly ISP is either throttling me, or trying to annoy me to the point I just give up as it dumps me totally offline about every 2 or 3 minutes (torrent). If I do the HTTP version, that seems somewhat stable, but (get this) HTTP makes it a bigger download, like 5GB bigger. Please don't ask why, or tell me that's normal... I'll only feel obligated to dye my hair blonde.

 

So what's happening right now is, I'm 7GB into a 14GB download (HTTP method). I had 1.5 Stable and 2.2Alpha already. I know when I started the DL'r (from the DCS Home Page) it got busy grabbing files from 1.5Stable--that's when I went and had lunch. I don't know if it grabbed from 2.2 or not. I kinda doubt it but hey, I think someone said it might, or would or something, who knows as I'm past caring at this point, I've moved on.

 

At this point, I'm only concerned that after my 10hr+ download I'll find it's borked and have to start over. That would mean 2 MORE days of waiting because I don't dare tell the wife she can't be hogging my bandwidth surfing ButtNovel while I download my fantasy hero generator program (again). Not so much that she minds, it's more because even using the HTTP DL method, connecting to Twittface (or anything else) on her computer is risking a nice disconnect from the internet... resulting in yours truly being on the receiving end of much wailing and gnashing of teeth. You know, because it's my fault someone broke the internets.

 

Thanks

Fingers crossed

Mikkall


Edited by Mikkall
Link to comment
Share on other sites

Yeah... well, I didn't have an OpenBeta. Honest, I thought I'd been running OB for quite awhile. I guess some time ago I dumped my OB and went to Stable (talking 1.5 here). That is unless the updater has a magic way of updating from OB to Stable without stupid people like me noticing. Anyway, a couple days ago, naturally, nothing worked due to my 1.5 Stable version (I didn't hear about @openbeta till it was too late). I wasn't worried about it because patience is a virtue... Grandpappy said so.

 

Which brings me back to today. I have kinda slow ADSL so, nothing happens fast. I mean, they say 12mb down, but yeah-right, right? It's more like, 1mb. Then there's the problem with doing it torrent style... I believe my fine hickbilly ISP is either throttling me, or trying to annoy me to the point I just give up as it dumps me totally offline about every 2 or 3 minutes (torrent). If I do the HTTP version, that seems somewhat stable, but (get this) HTTP makes it a bigger download, like 5GB bigger. Please don't ask why, or tell me that's normal... I'll only feel obligated to dye my hair blonde.

 

So what's happening right now is, I'm 7GB into a 14GB download (HTTP method). I had 1.5 Stable and 2.2Alpha already. I know when I started the DL'r (from the DCS Home Page) it got busy grabbing files from 1.5Stable--that's when I went and had lunch. I don't know if it grabbed from 2.2 or not. I kinda doubt it but hey, I think someone said it might, or would or something, who knows as I'm past caring at this point, I've moved on.

 

At this point, I'm only concerned that after my 10hr+ download I'll find it's borked and have to start over. That would mean 2 MORE days of waiting because I don't dare tell the wife she can't be hogging my bandwidth surfing ButtNovel while I download my fantasy hero generator program (again). Not so much that she minds, it's more because even using the HTTP DL method, connecting to Twittface (or anything else) on her computer is risking a nice disconnect from the internet... resulting in yours truly being on the receiving end of much wailing and gnashing of teeth. You know, because it's my fault someone broke the internets.

 

Thanks

Fingers crossed

Mikkall

 

You never needed to have the openbeta installed previously to install the 2.5 update, the command sithspawn reffered to will work with the stable branch aswell as it will convert the stable install to beta.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...