Jump to content

1.5.8 and 2.2.0 to 2.5 transition Discussion


USSR_Rik
 Share

Recommended Posts

It is really simple

 

If you are running 1.5.8 Stable --> you must convert to Open beta version

 

open a command promt in DCS World/Bin folder and type:

 

DCS_updater.exe update 1.5.8@openbeta

 

When it is done, start DCS World open beta and it should automatically update to 2,5 open beta.

 

Done.

 

Right, you must convert 1.5.8 stable to open beta.

Uhm, no! You don't have to go to 1.5.8 OB. You can go directly from 1.5.8 Stable to 2.5 OB by using the following command: DCS_updater.exe update @openbeta


Edited by QuiGon

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

  • Replies 1k
  • Created
  • Last Reply

Top Posters In This Topic

excuse me excuse me excuse me. I'm italian i don't speak english very well. Please, can you write the entire procedure, step to step, to how install this 2.5 ob, for me, and other people, who must do fresh install?

Now, I'm downloading 1.5. When i finish, I'll have 1.5 stable or 1.5.8 stable? I'm confused.

You download 1.5 stable and then use the updater to convert it to 2.5 OB, like I said here:

If you don't have the Open Beta installed, use the updater with DCS_Updater.exe update @openbeta to convert your 1.5.8 Stable Release installation to the Open Beta branch and download 2.5.

More info on how to use the updater can be found here: https://forums.eagle.ru/showthread.php?t=114030

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

Uhm, no! You don't have to go to 1.5.8 OB. You can go directly from 1.5.8 Stable to 2.5 OB by using the following command: DCS_updater.exe update @openbeta

 

Ok, my bad then. I went from 1.5.8 stable to 1.5.8 open beta and then to 2.5 open beta.

 

I followed ED guide where it says:

 

Stage 1: 2.5.0 Open Beta. The 1.5.8 Open Beta will be updated to the 2.5.0 Open Beta. The updater will check for 2.2.0 (Open Alpha) and add necessary modules from 2.2.0 to 2.5.0 to avoid unnecessary downloads.


Edited by Kilrah

ASUS Z370, i7 8086K @ 5,2 Ghz, ASUS Strix GTX 1080, 16GB Ram, TM HOTAS Warthog, TrackIR 5, Saitek combat rudders, 25" 1440p monitor, Oculus Rift

Link to comment
Share on other sites

what is simple is this....

 

DCS World download section has a file called DCS update to 2.5 all versions and when you click on it it takes all versions to 2.5 beta

 

What isnt simple is DCS World Download section with 1.5 and 2.1 alpha and just a news release when you search 2.5.0 updater.

 

It couldn't have been any more difficult.

Link to comment
Share on other sites

I must say it is so dang nice to have only one version of DCS once again after all this time.

My gaming SSD is certainly breathing a big sigh of relief now lol.

 

Great job ED!

 

:thumbup:

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | Valve Index| Vive Pro 2 |

Link to comment
Share on other sites

My 1.5.8 wont update anything, and 2.5 downloadlink is not working. Seems like I can't fly with 2.5. Damn.. :(

 

Edit: I mean this https://updates.digitalcombatsimulator.com/

 

Go read the first post in this thread. 1.5.8 Release will not update until next week. Only 1.5.8 Open Beta is updating today.

When you hit the wrong button on take-off

hwl7xqL.gif

System Specs.

Spoiler
System board: MSI X99A GAMING 9 ACK Memory: 16GB DDR4-3000 G.Skill Ripjaw System disk: Samsung SSD 970 EVO Plus 1TB
CPU: Intel Core i7-5820K @ 3800MHz PSU: Corsair AX860i PSU Monitor: ASUS MG279Q, 27"
CPU cooling: Noctua NH-D15 Graphics card: Zotac Nvidia GeForce GTX 1080 Ti Amp! Extreme VR: Oculus Rift CV1
 
Link to comment
Share on other sites

So when the 2.5 will be ready? Hope it will have improved ground terrain textures, because now trees dont look like trees (and this is in maximum settings).

 

You've been living under a boulder the last few months haven't you?

 

He's probably been living under this deluge of endless pages of repeat questions. No sooner do I get an email saying 'a new post' than I face another 10 pages. I think I'll get off this thread before I get motion sickness.

klem

56 RAF 'Firebirds'

ASUS ROG Strix Z390-F mobo, i7 8086A @ 5.0 GHz with Corsair H115i watercooling, Gigabyte 2080Ti GAMING OC 11Gb GPU , 32Gb DDR4 RAM, 500Gb and 256Gb SSD SATA III 6Gb/s + 2TB , Pimax 8k Plus VR, TM Warthog Throttle, TM F18 Grip on Virpil WarBRD base, Windows 10 Home 64bit

Link to comment
Share on other sites

He's probably been living under this deluge of endless pages of repeat questions. No sooner do I get an email saying 'a new post' than I face another 10 pages. I think I'll get off this thread before I get motion sickness.

Indeed, I'm really getting tired here. I have to use an entire page of comments to explain somewhen how to get 2.5, just so that the next one asks the same question on the following page...

 

Guys, it's really not that hard and it's all explained here!


Edited by QuiGon

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

Yea it's really not that hard. Those of you having issues with powershell should use command prompt. After that windows 10 anniversary update, command prompt in the right click menu changed to powershell.

 

The difference in scripting is that powershell is similar to Unix and Linux commands where a "." Is placed in front of the command.

 

Normally I never had to include the "." because it would do it automatically for me when ever I typed dcs_updater.exe update.

 

Also I'm not sure if some of you were putting quotes with the command which should not be done. If you are getting anything like command not found your syntax is either off or you are missing the updater.exe file.

 

Hopefully today the beta 2.5 installer will be up and this won't be an issue anymore.

 

Also if upgrading to 2.5 and Nevada does not copy over, just install it from within the game. I had to redownload NTTR and my Nevada campaigns from within 2.5.

 

I tried manually copying the files from my 2.2 install but it told me that it needed activation. Once I installed it from within the game module manager this wasn't an issue and all my campaign progress transferred over too.

 

Well except for the Georgian war campaign..I seem to have lost all my progress there and I was about 7 misisons in.

Asus ROG Strix Z370-E | Core i7 8700k @4.9Ghz-NZXT Kraken X73 | 32GB DDR4 Corsair Vengence LPX 3000 | Lots of SSD's | Asus Strix OC 1080Ti | Reverb G2

Link to comment
Share on other sites

Updateing 2.2OA to 2.5 worked for me as described in post 723 in this thread.

https://forums.eagle.ru/showpost.php?p=3372712&postcount=723

 

Nice, this way i can keep my 1.5.8ob for the time being until i delete manually.

Great to hear, thanks! :thumbup:

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

Go read the first post in this thread. 1.5.8 Release will not update until next week. Only 1.5.8 Open Beta is updating today.

I’m very sorry, but my english sucks big time. I don’t have a slightest idea what the first post is trying to say. What a mess.... :doh:

Link to comment
Share on other sites

Hi!

 

May I ask something stupid: can I install the 2.5OB and convert it to the release one when available? Just don't want to live with both versions when release is available.

 

Pretty sure- same as it was with 1.5.8 OB and 1.5.8 release (stable).

But you can leave it at 2.5 OB for good reasons: you´ll get every update FIRST (as OB is used as testing platform). It fully works like the release version - only downside: if there are bugs included in the OB update you´ll get them as well, but even then it´s easy to revert to the previous OB version. Did this all the time back with 1.5.8 if there was a game braking bug.

 

So no worries.....get 2.5OB and go flying - it´s worth doing so.

[sIGPIC][/sIGPIC]my rig specs: i7-4790K CPU 4.50GHz, 32GB RAM, 64bit WIN10, NVidia GeForce GTX 980 Ti, SSD+

 

A10C, UH-1H, M2C, F5E, Gazelle, KA 50, F18C, DCS 2.5x OB

Link to comment
Share on other sites

Hi!

 

May I ask something stupid: can I install the 2.5OB and convert it to the release one when available? Just don't want to live with both versions when release is available.

Yes, you can switch between them anytime you want. That's how I do it for 2-3 years now, switching between Stable Release and OB as I want to.

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

I am updating mine now. It took a bit to get "IT" figured out on where to go, but got it started and thanks for the step by step walk through. It helped me!!

 

 

Thanks Again for everything you do and continue to do with DCS!! BRAVO!!!

Wayne Wilson

AKA: hrnet940

Alienware Aurora R3, i7 3820 3.5GHz(4.2GHz setting) processor, EVGA Nvidia RTX 2070 8GB Graphics, 16GB Ram, 1TB SSD.

Link to comment
Share on other sites

How do I get this ”ob” -version?

You either do this:

If you don't have the Open Beta installed, use the updater with DCS_Updater.exe update @openbeta to convert your 1.5.8 Stable Release installation to the Open Beta branch and download 2.5.

More info on how to use the updater can be found here: https://forums.eagle.ru/showthread.php?t=114030

Or you wait till the standalone installer for 2.5 OB is available which can happen any moment now.

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

Yes, you can switch between them anytime you want. That's how I do it for 2-3 years now, switching between Stable Release and OB as I want to.

 

By switching you mean replace one with another not living with both right?

 

That's what I'd like to do actually. Don't need the LATEST version ever, don't want to have two versions at the same time... but WANT to test that 2.5 OB as soon as I can see if my computer handles it better.

Link to comment
Share on other sites

By switching you mean replace one with another not living with both right?

 

That's what I'd like to do actually. Don't need the LATEST version ever, don't want to have two versions at the same time... but WANT to test that 2.5 OB as soon as I can see if my computer handles it better.

Yes, replacing. Well, it's not really replacing as they are usally 99% identical :D

But replacing the remaining 1%, yes. That means I have only one installation of DCS, which I often change to Open Beta or Stable Release depending on what I want at the time. Switching from OB to Stable Relase and back is just a simple command through the updater.

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

Indeed, I'm really getting tired here. I have to use an entire page of comments to explain somewhen how to get 2.5, just so that the next one asks the same question on the following page...

 

Guys, it's really not that hard and it's all explained here!

 

Simple solution here is to not explain it again.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...