Jump to content

1.5.8 and 2.2.0 to 2.5 transition Discussion


USSR_Rik
 Share

Recommended Posts

I managed to update DCS 1.5.8 none beta today to 2.5 Open beta

 

All I did was open the CMD prompt, I did not use powershell like others have said and pointed it to my DCS folder which was in

 

E:\DCS World 1.5\bin

 

Once the CMD was pointing to that folder I typed the following without the "" "dcs_updater.exe update @openbeta"

 

This updated the installer and then it ran and updated 1.5.8 and when finished I had 2.5 Openbeta, I then had to install the Nevada terrain as it did not drag it from my 2.2 directory, but gave me a prompt in the game to do this.

Link to comment
Share on other sites

  • Replies 1k
  • Created
  • Last Reply

Top Posters In This Topic

You need to wait for the stable release in a couple of weeks. Then your 2.2OA will update to 2.5.0

The only way to get 2.5Beta right now is to update from 1.5.8OB

Win10 x64, Intel core I9 9900k@5ghz, 32GB DDR4, RTX2080 ti, MSI Z370 Tomahawk mobo, M.2 SSD, Warthog HOTAS, home made trackIr, Pimax 8K

Link to comment
Share on other sites

Read the entire thread and I'm still not seeing a clear, definitive path to update 2.2OA to 2.5OB.

 

I've never had 1.5.8. I Currently have 2.2 (that's it) and I want to go to 2.5. I don't care if it's a one way street. I tried the updater and it finds there's nothing to update. Now what?

This is supposed to work: https://forums.eagle.ru/showpost.php?p=3372712&postcount=723

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

I tried updating 1.5.8 because wi-fi disconnected midway yesterday. I also tried using the dcs_updater.exe but it just installed 1.5.8 again. So I uninstalled Open Beta just now, only to find out that the "Element is Not Found" when I went to re-download the Open Beta from here:

 

https://updates.digitalcombatsimulator.com/

 

wtf? Is it just me, or has the download link for Open Beta been removed?

Link to comment
Share on other sites

I tried updating 1.5.8 because wi-fi disconnected midway yesterday. I also tried using the dcs_updater.exe but it just installed 1.5.8 again. So I uninstalled Open Beta just now, only to find out that the "Element is Not Found" when I went to re-download the Open Beta from here:

 

https://updates.digitalcombatsimulator.com/

 

wtf? Is it just me, or has the download link for Open Beta been removed?

It has been removed. If you want 2.5 immediately you need to install 1.5.8 Stable and use the updater to convert it to 2.5 Open Beta. If you can wait a few hours or days you will get the standalone installer for the 2.5 Open Beta as it should be very soon.

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

I have both 1.5 and 2.2 (but not installed as I formatted some days ago). What is the procedure to install the 2.5 OB?

The 2.5 OB includes both Caucasus and Nevada map?

Use the updater to convert to 2.5 OB. Caucasus is included for free in 2.5, while Nevada (and Normandy) are optional modules that have to be purchased first.

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

Use the updater to convert to 2.5 OB. Caucasus is included for free in 2.5, while Nevada (and Normandy) are optional modules that have to be purchased first.

 

Thanks.

Some questions:

1) Where can I find the updater?

2) I have purchased Nevada mounths ago, but, now, I have not installed any dcs version or module as I formatted some days ago. So, tell me if I'm wrong, first I must to install 1.5 stable, then 2.2 OA, then, with updater, convert all in 2.5 OB. Is it true?

Or can I skip to re install Nevada map as the updater download it?

Link to comment
Share on other sites

Thanks.

Some questions:

1) Where can I find the updater?

2) I have purchased Nevada mounths ago, but, now, I have not installed any dcs version or module as I formatted some days ago. So, tell me if I'm wrong, first I must to install 1.5 stable, then 2.2 OA, then, with updater, convert all in 2.5 OB. Is it true?

Or can I skip to re install Nevada map as the updater download it?

 

1) It's included in your installation. You just have to run it with the correct command:

If you don't have the Open Beta installed, use the updater with DCS_Updater.exe update @openbeta to convert your 1.5.8 Stable Release installation to the Open Beta branch and download 2.5.

More info on how to use the updater can be found here: https://forums.eagle.ru/showthread.php?t=114030

 

2) You don't need 2.2 OA. Just install 1.5 stable and use the updater to convert it to 2.5 OB.

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

 

 

2) You don't need 2.2 OA. Just install 1.5 stable and use the updater to convert it to 2.5 OB.

 

Pretty sure you need the 1,5 open beta version.... ?

ASUS Z370, i7 8086K @ 5,2 Ghz, ASUS Strix GTX 1080, 16GB Ram, TM HOTAS Warthog, TrackIR 5, Saitek combat rudders, 25" 1440p monitor, Oculus Rift

Link to comment
Share on other sites

Pretty sure you need the 1,5 open beta version.... ?

If you have it already. If not you have to convert the 1.5.8 stable release, because the Open Beta is not available anymore.

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

I cant for the life of me update 1.5.8 to 2.5? I use the updater and it simply says "the installed version 1.5.8.12823.414 is up to date" If i use power shell and type the update command i simple get the below on my screen? I even installed a fresh 1.5.8 and tried from in there and i still have this same message? Please anyone?? :(

 

dcs_updater.exe : The term 'dcs_updater.exe' is not recognized as the name of a cmdlet, function, script file, or

operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try

again.

At line:1 char:1

+ dcs_updater.exe

+ ~~~~~~~~~~~~~~~

+ CategoryInfo : ObjectNotFound: (dcs_updater.exe:String) [], CommandNotFoundException

+ FullyQualifiedErrorId : CommandNotFoundException

 

 

Suggestion [3,General]: The command dcs_updater.exe was not found, but does exist in the current location. Windows PowerShell does not load commands from the current location by default. If you trust this command, instead type: ".\dcs_updater.exe". See "get-help about_Command_Precedence" for more details.

PS E:\DCS World new\bin>

My Files.....

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Seems like you haveen't executed the command in the correct folder. You need to execute the command in the bin folder where the updater.exe is located.

It's all explained here: https://forums.eagle.ru/showthread.php?t=114030

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

If you have it already. If not you have to convert the 1.5.8 stable release, because the Open Beta is not available anymore.

 

Yeah, that´s what I meant :thumbup:

ASUS Z370, i7 8086K @ 5,2 Ghz, ASUS Strix GTX 1080, 16GB Ram, TM HOTAS Warthog, TrackIR 5, Saitek combat rudders, 25" 1440p monitor, Oculus Rift

Link to comment
Share on other sites

Had the same problem and it's important to put .\ in front of the command

Oh, good point. I think that only applies to power shell though. If you use the normal Windows Command Line Interface (CMD) instead of Power Shell then you don't have to do this.

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

I used CMD and this:

 

Updating or Switching an Install Between "Open Beta" and "Release" Version Branches (1.2.8.):

In the Command Prompt Windows:

Type: dcs_updater.exe update <branch>:<version> (ie dcs_updater.exe update openbeta:1.2.7 )

Type: dcs_updater.exe update <branch>:<version.subversion> (ie dcs_updater.exe update openbeta:1.2.7.23803)

 

UPDATER VERSION 2.6.8.41 And Newer Use:

Type: dcs_updater.exe update <version>@Branch (ie DCS_updater.exe update 1.5.1@openbeta, DCS_updater.exe update 2.0.0@openalpha )

DCS_updater.exe update @release

DCS_updater.exe update @openbeta

DCS_updater.exe update @openalpha

 

Example: DCS_updater.exe update 1.5.8@openbeta

ASUS Z370, i7 8086K @ 5,2 Ghz, ASUS Strix GTX 1080, 16GB Ram, TM HOTAS Warthog, TrackIR 5, Saitek combat rudders, 25" 1440p monitor, Oculus Rift

Link to comment
Share on other sites

Sorry missed the first line... As you can see it is in the bin folder. Its called 'DCS World new' as its the fresh install i did last night. I just dont understand??

 

PS E:\DCS World new\bin> dcs_updater.exe

dcs_updater.exe : The term 'dcs_updater.exe' is not recognized as the name of a cmdlet, function, script file, or

operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try

again.

At line:1 char:1

+ dcs_updater.exe

+ ~~~~~~~~~~~~~~~

+ CategoryInfo : ObjectNotFound: (dcs_updater.exe:String) [], CommandNotFoundException

+ FullyQualifiedErrorId : CommandNotFoundException

 

 

Suggestion [3,General]: The command dcs_updater.exe was not found, but does exist in the current location. Windows PowerShell does not load commands from the current location by default. If you trust this command, instead type: ".\dcs_updater.exe". See "get-help about_Command_Precedence" for more details.

PS E:\DCS World new\bin>

My Files.....

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Have you tried using the CMD instead? I don't have much experience with Power Shell and don't know its quirks, so I can't say whats wrong here. CMD is more than enough for what you want to do. No need for the more complex Power Shell.

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

how is this all not confusing?

 

...

It's really not. Its just that some people make it really confusing, because they have special need and requirements.

Intel i7-4790K @ 4x4GHz + 16 GB DDR3 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

1) It's included in your installation. You just have to run it with the correct command:

 

 

2) You don't need 2.2 OA. Just install 1.5 stable and use the updater to convert it to 2.5 OB.

 

But after i have installed 1.5 stable, I must directly install 2.5 ob with updater, or after i installed 1.5 stable i must convert to 1.5.8 beta then install 2.5 ob?

Link to comment
Share on other sites

It is really simple

 

If you are running 1.5.8 Stable --> you must convert to Open beta version

 

open a command promt in DCS World/Bin folder and type:

 

DCS_updater.exe update 1.5.8@openbeta

 

When it is done, start DCS World open beta and it should automatically update to 2,5 open beta.

 

Done.

ASUS Z370, i7 8086K @ 5,2 Ghz, ASUS Strix GTX 1080, 16GB Ram, TM HOTAS Warthog, TrackIR 5, Saitek combat rudders, 25" 1440p monitor, Oculus Rift

Link to comment
Share on other sites

But after i have installed 1.5 stable, I must directly install 2.5 ob with updater, or after i installed 1.5 stable i must convert to 1.5.8 beta then install 2.5 ob?

 

Right, you must convert 1.5.8 stable to open beta.

ASUS Z370, i7 8086K @ 5,2 Ghz, ASUS Strix GTX 1080, 16GB Ram, TM HOTAS Warthog, TrackIR 5, Saitek combat rudders, 25" 1440p monitor, Oculus Rift

Link to comment
Share on other sites

Right, you must convert 1.5.8 stable to open beta.

 

excuse me excuse me excuse me. I'm italian i don't speak english very well. Please, can you write the entire procedure, step to step, to how install this 2.5 ob, for me, and other people, who must do fresh install?

Now, I'm downloading 1.5. When i finish, I'll have 1.5 stable or 1.5.8 stable? I'm confused.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...