Jump to content

1.5.8 and 2.2.0 to 2.5 transition Discussion


Recommended Posts

Gentlemen, here is some explanations how your current 1.5 (and/or 2.2) will be converted to 2.5, please take a look the attached diagram. Transition will be made in 2 stages:

Stage 1: 2.5.0 Open Beta. The 1.5.8 Open Beta will be updated to the 2.5.0 Open Beta. The updater will check for 2.2.0 (Open Alpha) and add necessary modules from 2.2.0 to 2.5.0 to avoid unnecessary downloads.

 

The 2.2.0 Open Alpha and 1.5.8 Release will remain at this stage so you can continue to play online with those still using 1.5.8 or 1.2.2.

 

Over the next one to two weeks, we will be carefully monitoring 2.5.0 Open Beta reports in order to move to Stage 2.

 

Stage 2: 2.5.0 Release. The 1.5.8 Release version will be updated to the 2.5.0 Release version. You will be prompted before updating to 2.5.0, and you will have an option to save a 1.5.8 Final version to a separate directory.

 

The 2.2.0 Open Alpha will no longer be supported. The 2.2.0 Open Alpha will be updated to the 2.5.0 Release version.

 

Modules from 2.2.0 Open Alpha (or 2.5.0 Open Beta - see Stage 1) will be used during the 2.5.0 Release installation, after which, version 2.2.0 will be uninstalled after prompting you.

 

The 2.2.0 Open Alpha will no longer be supported. If you only have the 2.2.0 Open Alpha, the updater will suggest that you download the 2.5.0 installer - it will then install the 2.5.0 Release version and remove the 2.2.0 Open Alpha.

 

Home Folders (Saved Games\DCS) will remain in the same location (Saved Games\DCS and Saved Games\DCS.openbeta). New Saved Games\DCS.release_1_5 will be created for the 1.5.8 Final version and all its content will be copied into it from Saved Games\DCS. We also strongly suggest that you remove the Saved Games\DCS\Config\options.lua file and set up your graphics settings from scratch, given the significant differences between 1.5.8 and 2.5.0.

 

Old Caucasus will be updated to new one automatically.

 

Activations. All activation keys are saved in the Windows Registry and NO additional activation will be required.

 

1.5.8 Final version installer will be available on DCS site.

 

Transition planned in January 2018.

1992284286_DCS2Transitionc.png.1bd428eeffe9cf37fee72130bf0626df.png


Edited by BIGNEWY
Picture replaced
  • Like 4

El pueblo unido jamás será vencido

 

 

DCS World 2.5: Часто задаваемые вопросы

Link to post
Share on other sites
  • Replies 1k
  • Created
  • Last Reply

Top Posters In This Topic

Aaarrrggghhhh. I just uninstalled my 1.5.8 OB to make way for 2.5 and for more disk space!! I should have realised the OB would be first to change. Ahh, well, what’s another couple of weeks?

MSI M5 z270 | Intel i5 7600k (OC) 4.8GHz | MSI GTX1080ti Gaming X 11Gb | 500gb Samsung 970 Evo NVME M.2 (DCS World) | 500gb Samsung 850 Evo SSD (OS and Apps) | 32Gb 2400MHz DDR4 - Crucial Ballistix | Be Quiet Silent Loop 240mm | NZXT H440 case |

 

Thrustmaster Warthog - 47608 with Virpil Mongoose joystick base | MFG Crosswinds - 1241 | Westland Lynx collective with Bodnar X board | Pilot's seat from ZH832 Merlin | JetSeat | Oculus Rift S | Windows 10 | VA |

Link to post
Share on other sites
is there a way to force update? nothing is happening for me.

 

not released yet

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites

Can we update from release to 2.5 openbeta trough cmd (dcs_updater.exe update @openbeta)?

If you are a dedicated pilot, a team player ... join us !!!

14thVFS Samurais Discord: https://discord.gg/uc9c7Vz 

Teamspeak: 14vfs.teamspeak3.com

Quote

Немој ништа силом, узми већи чекић!

MSI Tomahawk MAX | Ryzen 7 3700x | 32GB DDR4 3200MHz | RX 5700 XT OC Red Dragon 8GB

Link to post
Share on other sites
Aaarrrggghhhh. I just uninstalled my 1.5.8 OB to make way for 2.5 and for more disk space!! I should have realised the OB would be first to change. Ahh, well, what’s another couple of weeks?

 

I don't see a problem here. You'll just download the new 2.5.0 Open Beta installer once it's released. Any older files to be reused will be copied from the 2.2.0 Open Alpha installation only, anyway.

i386DX40@42 MHz w/i387 CP, 4 MB RAM (8*512 kB), Trident 8900C 1 MB w/16-bit RAMDAC ISA, Quantum 340 MB UDMA33, SB 16, DOS 6.22 w/QEMM + Win3.11CE, Quickshot 1btn 2axis, Numpad as hat. 2 FPH on a good day, 1 FPH avg.

 

DISCLAIMER: My posts are still absolutely useless. Just finding excuses not to learn the F-14 (HB's Swansong?).

 

Annoyed by my posts? Please consider donating. Once the target sum is reached, I'll be off to somewhere nice I promise not to post from. I'd buy that for a dollar!

Link to post
Share on other sites

So 2.2 OA to 2.5 OB isn't possible?

Or will there be a 2.5 OB installer I can use, that doesn't touch 1.5 release (or require separate module activation)?

Helicopters and Viggen

DCS 1.5.7 and OpenBeta

Win7 Pro 64bit

i7-3820 3.60GHz

P9X79 Pro

32GB

GTX 670 2GB

VG278H + a Dell

PFT Lynx

TrackIR 5

Link to post
Share on other sites
what about all skins and such?, I mean, should we save them before installing 2.5? I ask because of the "uninstallation promp" which may remove ALL folders including custom skins and/or files...

 

 

thanks!!

 

You should handle this update like any other.

spacer.png
Forum RulesMy YouTube • My Discord - NineLine#0440• **How to Report a Bug**

1146563203_makefg(6).png.82dab0a01be3a361522f3fff75916ba4.png  80141746_makefg(1).png.6fa028f2fe35222644e87c786da1fabb.png  28661714_makefg(2).png.b3816386a8f83b0cceab6cb43ae2477e.png  389390805_makefg(3).png.bca83a238dd2aaf235ea3ce2873b55bc.png  216757889_makefg(4).png.35cb826069cdae5c1a164a94deaff377.png  1359338181_makefg(5).png.e6135dea01fa097e5d841ee5fb3c2dc5.png

Link to post
Share on other sites

"Some time (maybe one-two weeks, we hope no more) for wide test of this procedure."

 

Does this now mean you will be missing the "End of January" deadline you have promised?

 

One week takes us to the 31st, and 2 weeks takes us to February. If you're testing it on the 31st you are sure as hell cutting it fine!

Link to post
Share on other sites
2.2.0 branch will be 'dead' when 2.5 update released, so the only one possiblilty is to run separate installer. It will take all necessary files from 2.2.0, install 2.5 and ask to kill old and obsolete 2.2.0
Yes I understood that, but for the 2.5 release right?

I'm asking about 2.5 open beta. Will there be a way to install 2.5 open beta without 1.5.8 open beta (only release), and then deinstall 2.2 open alfa (automatically or manually)?

Helicopters and Viggen

DCS 1.5.7 and OpenBeta

Win7 Pro 64bit

i7-3820 3.60GHz

P9X79 Pro

32GB

GTX 670 2GB

VG278H + a Dell

PFT Lynx

TrackIR 5

Link to post
Share on other sites

Is going to be for download an .exe file to install 2.5 Open Beta and 2.5 Release from scratch?

 

I mean with not a single DCS version installed on any drive be able to download an .exe file to start from zero a complete DCS 2.5 install?

 

Thanks

" You must think in russian.."

[sIGPIC][/sIGPIC]

 

Windows 7 Home Premium-Intel 2500K OC 4.6-SSD Samsung EVO 860- MSI GTX 1080 - 16G RAM - 1920x1080 27´

 

Hotas Rhino X-55-MFG Crosswind Rudder Pedals -Track IR 4

Link to post
Share on other sites
Yes I understood that, but for the 2.5 release right?

I'm asking about 2.5 open beta. Will there be a way to install 2.5 open beta without 1.5.8 open beta (only release), and then deinstall 2.2 open alfa (automatically or manually)?

We will publish 2.5 installer but maybe day later after update started. I'm not sure, it depends on servers load (we expect a huge traffic).

El pueblo unido jamás será vencido

 

 

DCS World 2.5: Часто задаваемые вопросы

Link to post
Share on other sites
We will publish 2.5 installer but maybe day later after update started. I'm not sure, it depends on servers load (we expect a huge traffic).
Thanks.

Helicopters and Viggen

DCS 1.5.7 and OpenBeta

Win7 Pro 64bit

i7-3820 3.60GHz

P9X79 Pro

32GB

GTX 670 2GB

VG278H + a Dell

PFT Lynx

TrackIR 5

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...