Jump to content

VAICOM PRO plugin for VoiceAttack


Hollywood_315

Recommended Posts

Hollywood - hopefully you have access to an early release of F-14's Jester AI commands for implementation into your already great product. This is going to be a game changer !

Intel i9 7980XE @4.4Hz

64GB DDR4 RAM at 2666MHz

GTX 1080Ti with 11GB GDDR5X

Reverb Pro HMD

HOTAS: TM Warthog throttle / TM F18 Grip

Dual H640P Huion tablets used with VRK (Virtual Kneeboard ) software

Gametrix JetSeat with SimShaker

DOF Reality P6, 6 axis Motion Platform

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Hollywood,

I checked the POV box for my Warthog throttle and was able to get it to recognize commands, but was not able to get it work in the game with the free version.

 

Is there a way I can go back so I can use the old F-15 profile in voice attack. I would gladly pay for the license but I want to make sure it VAICOM pro works first.

 

Thanks!

Link to comment
Share on other sites

DEG had a tip for getting Voice Attack to recognize buttons on TM's Warthog HOTAS when it responds with "waiting". His suggestion is posted below:

 

"I had a similar problem with getting my Warthog throttle (I only have the throttle) to work with Voice Attack. VA would work with my T16000, but not the Warthog. I found the answer elsewhere on the web. In Windows, open up the Game Controllers and select the Warthog, and look at the properties. Make sure all 32 of the throttle buttons are off (not sure what it looks like with both a throttle and a stick - you'll have to figure that part out yourself). Note: 2 buttons (29 and 30 on mine) are the throttle Off detents (took me a couple mins to figure that out). Once I set them all to Off, VA recognized the Warthog as a Joystick Option and the Test button recognized the Mic switch."

 

Thanks Don!

Link to comment
Share on other sites

I dedusted my PC during the Christmas break and updated to VA 2.5.7.

 

So far there was always a louder noise, if I had pressed my transmission button. Now it is hardly to be heard any more. How can I get the sound or the noise louder, find it helpful with VR to hear that I hold the right key pressed...!?

 

Many thanks in advance!

Thermaltake Core V1 | MSI Z270I Gaming Pro Carbon | Intel I7700K | EVGA GTX 1080 TI SC | 32 GB RAM DDR4-3000 | Corsair H90 | 250 & 500 GB Samsung Evo850 SSD | WIN 10 64bit Pro | TM Hotas Warthog | TM Pendular Rudder | Oculus Rift S

Link to comment
Share on other sites

I'm updating to the latest release and working through the Finish step in the Keywords Editor. A dialog is displayed by VAICOM with a note which says to make sure "multipart commands are consolidated" in VA. I'm not sure how to configure this is VA??

Win 10 64-bit, Intel Core i7-7700k@4.2GHz, MSI 1080Ti , 16 GB, 500GB SSD, LG 34UM95, Acer T232HL, TrackIR 5 Pro, Thrustmaster Warthog HOTAS, Saitek Combat Rudder Pedals.

Link to comment
Share on other sites

At the bottom left there is a little icon which toggles between showing a single line or three lines (I believe - sorry not at pc so can't do a screen shot). Click on it to show only a single line. This 'consolidates' the majority of Vaicom's commands into a single one. It is into this single command that you can paste the updated commands to FINISH the update.

 

This stumped me for a while too.

CPU:5600X | GPU:RTX2080 | RAM:32GB | Disk:860EVOm.2

Link to comment
Share on other sites

Dear Hollywood,

 

 

happy new year and many thanks for the great Tool/Profil.

 

 

Do have any plans with the Tomcat in near Future for support with your Profile? Or must a user create own settings with Key bindings?

 

 

Many thanks in advance and best wishes for this Year for you and your Family.

Link to comment
Share on other sites

Hi all...if I get viacom, will it work with the free version of voiceattack, or do I need to unlock voiceattack first?

My DCS Missions: Band of Buds series | The End of the T-55 Era | Normandy PvP | Host of the Formation Flight Challenge server

 

Supercarrier Reference Kneeboards

 

IRL: Private Pilot, UAS Test Pilot, Aircraft Designer, and... eh hem... DCS Enthusiast

Link to comment
Share on other sites

All the best for 2019 guys.. promises to be a really great year for DCS! :thumbup:

 

If I delete voice attack and reinstall it, do I need to retrain the voice engine for my voice?

Your training data is stored deep inside Windows: unless you re-install Windows you do not lose it.

 

So far there was always a louder noise, if I had pressed my transmission button.
Loudness of the plugin PTT squelch sound hasn't changed. For VR, make sure your HMD is set as Windows default audio device so that all Windows audio is fed to your headphones.

 

will it work with the free version of voiceattack

For using VAICOM PRO you need to have VA's licensed version.

 

Do have any plans with the Tomcat

 

A RIO dialog extension is high on the priority list, preparations have already started.

Stay tuned!

 

Grtz

There is no spoon.

 

Avatar_old_80x80.gif.0c105925ce4b9f5b87697ea37cbde317.gif

VAICOM PRO plugin for DCS World

www.vaicompro.com

Link to comment
Share on other sites

The blinking menu persists. I've followed every step given in regards to fixing this. It's happening with the licensed pro version. I've gone as far as deleting EVERYTHING regarding VP and uninstalling VA. Set the custom path and checked the Beta box. Have manually installed the lua files. Have gone through and verified that the lua files have the additions to them required.

 

Weeks of this and I still cannot fix the issue.

Your Search-Fu is far better than mine!

Link to comment
Share on other sites

@Strike Funny. I'm assuming your logs don't show anything specific.

Blinking has been reproducible only when RadioCommandDialogsPanel.lua is not properly installed.

Check that file specifically: i.e. delete it and verify it gets replaced automatically on VA restart.

Confirm your Windows account has sufficient admin rights (UAC) to write to the DCS folders, disable antivirus if needed.

In Saved Games check that files are updated in the DCS.openbeta folder.

There is no spoon.

 

Avatar_old_80x80.gif.0c105925ce4b9f5b87697ea37cbde317.gif

VAICOM PRO plugin for DCS World

www.vaicompro.com

Link to comment
Share on other sites

@Hollywood

I have problem looks like PTT control stuck... I've try A-10, Ka-50 etc....

 

I've click on dial and then... see screenshot

Module isn't recognized, dial stuck in between values, I can switch TX with arrows buttons and oper/man switch do no much.....

 

Any idea, how to reset it... or collect any logs.

PS. still happy license user ;)

a10.jpg

Take a look my mods :joystick: dcs_icons_32.png

CPU: i7 7700 | GPU: GeForce GTX 1080 8GB DDR5 | Motherboard: ASUSTeK PRIME B250M-A | RAM: 2x16GB DDR4-2400 | Output: Kingston HyperX Cloud II | Edifier C2XD 2.1 | Controlls: Saitek X-56 Rhino | Saitek Flight Rudder Pedals | Saitek Multi/Radio/Switch Panels | Thrustmaster MFD Cougar | Logitech G13 | OpenTrack with LaserClip | VoiceAttack with VAICOM Pro plugin

Link to comment
Share on other sites

Just got VAICOM installed. The issue I'm having is that all of the commands are repeated even though I only voice the command a single time. So if I request landing VAICOM sends the request landing command twice. Here is a bit of the log from my recent flight. Any ideas?? Thanks!

 

2:37:42 PM - Listening suspended

2:37:42 PM - Joystick : 'Transmit TX1 release'

2:37:41 PM - TX1 | SEL/AUTO: [ ],[ ],[ ] [ ] [ ]

2:37:41 PM - TX1 | SEL/AUTO: [ ATC ],[ ],[ ] Request Landing [ ] [ ]

2:37:41 PM - Recognized : 'ATC request landing' (contains 'atc')

2:37:41 PM - Recognized : 'ATC request landing' (contains 'request landing')

2:37:38 PM - Listening resumed

2:37:38 PM - Joystick : 'Transmit TX1 press'

2:35:11 PM - Listening suspended

2:35:11 PM - Joystick : 'Transmit TX1 release'

2:35:09 PM - TX1 | SEL/AUTO: [ ATC ],[ ],[ ] Inbound [ ] [ ]

2:35:09 PM - TX1 | SEL/AUTO: [ ATC ],[ ],[ ] Inbound [ ] [ ]

2:35:09 PM - Recognized : 'ATC inbound' (contains 'inbound')

2:35:09 PM - Recognized : 'ATC inbound' (contains 'atc')

Win 10 64-bit, Intel Core i7-7700k@4.2GHz, MSI 1080Ti , 16 GB, 500GB SSD, LG 34UM95, Acer T232HL, TrackIR 5 Pro, Thrustmaster Warthog HOTAS, Saitek Combat Rudder Pedals.

Link to comment
Share on other sites

I do a lot keyword training since my english is really bad, and during session often I got messages:

 

21:39:52 - Keyword recognized: Abort Takeoff with confidence 89 %

21:39:50 - Success.

21:39:50 - Building master labels table...

21:39:50 - Success.

21:39:50 - Building master keywords table...

21:39:50 - Adding 0 imported ATC aliases.

21:39:50 - Success.

21:39:50 - Loading keywords database...

21:38:34 - Keyword recognized: Abort Takeoff with confidence 93 %

 

What it means???

Take a look my mods :joystick: dcs_icons_32.png

CPU: i7 7700 | GPU: GeForce GTX 1080 8GB DDR5 | Motherboard: ASUSTeK PRIME B250M-A | RAM: 2x16GB DDR4-2400 | Output: Kingston HyperX Cloud II | Edifier C2XD 2.1 | Controlls: Saitek X-56 Rhino | Saitek Flight Rudder Pedals | Saitek Multi/Radio/Switch Panels | Thrustmaster MFD Cougar | Logitech G13 | OpenTrack with LaserClip | VoiceAttack with VAICOM Pro plugin

Link to comment
Share on other sites

I purchased the license version. I am a former VA 2.0 user. I only fly the F-15C. I watched the YouTube tutorial but still am not getting it. I am thinking that it is a case of user error.

 

It seem I am able to get the PTT to work in DCS world. I press the PTT button on my Warthog throttle and I hear the radio response. I tried some basic commands like "Darkstar request picture." I am not able to get to work.

 

Am I suppose to program a keyword for every command I intended to use, or am I not using the correct phrases?

 

Thanks!

Link to comment
Share on other sites

@Strike Funny. I'm assuming your logs don't show anything specific.

Blinking has been reproducible only when RadioCommandDialogsPanel.lua is not properly installed.

Check that file specifically: i.e. delete it and verify it gets replaced automatically on VA restart.

Confirm your Windows account has sufficient admin rights (UAC) to write to the DCS folders, disable antivirus if needed.

In Saved Games check that files are updated in the DCS.openbeta folder.

 

The RadioCommandDialogsPanel.lua is in the Dcs save game

 

Scripts\UI\RadioCommandDialogsPanel\RadioCommandDialogsPanel.lua?

 

The RadioCommandDialogsPanel.lua is in the Dcs save game

 

Scripts\UI\RadioCommandDialogsPanel\RadioCommandDialogsPanel.lua?

 

It's not replacing the file. I have UAC turned off, Virus protection off and all of the files and folders open to be written to. I've also manually installed the files from the export menu option in VC. I even deleted the one from the Dcs main install folder, and repaired DCs . The DCS repair put RadioCommandDialogsPanel.lua back in to the main install of DCS.

 

I don't understand what the issue is, nothing has changed since the initial install of the plugin. Same windows 10, same computer, no hardware or software changes. I just started doing it after DCS updated one day. I was able to fix it once by uninstalling and reinstalling VA and VC. But the very next day I updated DCS and it's been doing it again ever since. I'm using the beta version of DCS. The logs are blank.

 

EDIT: Issue SOLVED. It was indeed an install path issue. Inside my install folder \DCS World was another folder named 2.5. IT was this folder that I needed to point Viacom pro to. I was just pointing it to \DCS World not \DCS World\2.5 If you're having the issue with a flashing menu in game while Viacom pro is running, make sure under the control panel for Viacom that you have it pointed to the correct path. Double check that you don't have a sub folder in your main install directory that houses the main install. This would only come up if you installed DCS to a custom folder and not the default one created by the install wizard.

 

Thank you Hollywood for your help . I'd like to thank Yomo from CSG-1 VFS for spotting this issue.


Edited by strike277

Your Search-Fu is far better than mine!

Link to comment
Share on other sites

Hi, I downloaded the steam version of Voice Attack and the free version of Vaicom to check it out before I buy it. After adding the plugin I get the following errors:

-No DCS World Installation was automatically detected on this machine.

-Use the plugin Configuration page to set a custom DCS instal path......

 

But when I press LCtrl+LAlt+C for config nothing happens at all.

 

Any Ideas?

 

EDIT: I had to Import the profile first :)

It is working now.


Edited by Kayos

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...