Jump to content

VAICOM PRO plugin for VoiceAttack


Hollywood_315

Recommended Posts

Yeah, I've tried and every other combo I can imagine. Even if I manually tune the radio to Batumi, then say inbound...Kolkhi answers.
 
I almost had it working by turning off DCS easy comms, VComm selector to normal. Made it through a few commands, then VA seems to have crashed with several errors like it was waiting for other commands to complete. And even though I have the UI sounds and use audio hints selected, I frequently hear no beeps or clicks when keying the mic.
Sorry if I am dense, but your answer wasn't 100 percent clear.
If you tune your radio to Batumi, and then say "Batumi inbound".
I'm asking because from time to time, it seems VAICOM gets stuck to the first or nearest recipient when spawning. Then it will cue that no matter what in less I use "recipient command" in every command.
Cheers!

Sent from my MAR-LX1A using Tapatalk

Link to comment
Share on other sites

1 hour ago, MAXsenna said:

Sorry if I am dense, but your answer wasn't 100 percent clear.
If you tune your radio to Batumi, and then say "Batumi inbound".
I'm asking because from time to time, it seems VAICOM gets stuck to the first or nearest recipient when spawning. Then it will cue that no matter what in less I use "recipient command" in every command.
Cheers!

Sent from my MAR-LX1A using Tapatalk
 

 

 

That appears to be what's happening. I have noticed also, several times as I'm going to close it, there are multiple instances (VA icons in the system tray.)

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites



 
 
That appears to be what's happening. I have noticed also, several times as I'm going to close it, there are multiple instances (VA icons in the system tray.)


I guess VA has crashed a couple of times then. And Windows just haven't cleared up in the system tray.

Sent from my MAR-LX1A using Tapatalk

Link to comment
Share on other sites

Now if I can just keep the audio hints going. When they go off, I figure something has crashed or maybe I said some sort of magic word.

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

Now if I can just keep the audio hints going. When they go off, I figure something has crashed or maybe I said some sort of magic word.
Well, if I understand you correctly it's easily fixed. Don't run VA, run the VAICOM tray app instead. It will start VA and whenever it crashes, restart it for you. Come to think of it, after starting using the tray app, VA seldom crashes now, and it has been totally immune after going 64bit. For me that is.

Sent from my MAR-LX1A using Tapatalk

Link to comment
Share on other sites

17 hours ago, MAXsenna said:

Well, if I understand you correctly it's easily fixed. Don't run VA, run the VAICOM tray app instead. It will start VA and whenever it crashes, restart it for you. Come to think of it, after starting using the tray app, VA seldom crashes now, and it has been totally immune after going 64bit. For me that is. emoji4.png

Sent from my MAR-LX1A using Tapatalk
 

 

Yeah using the Vaicom tray app works great for me also.

  • Like 1

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | Valve Index| Vive Pro 2 |

Link to comment
Share on other sites

20 hours ago, MAXsenna said:

Well, if I understand you correctly it's easily fixed. Don't run VA, run the VAICOM tray app instead. It will start VA and whenever it crashes, restart it for you. Come to think of it, after starting using the tray app, VA seldom crashes now, and it has been totally immune after going 64bit. For me that is. emoji4.png

Sent from my MAR-LX1A using Tapatalk
 

Will give that a shot. Thanks.

  • Like 1

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

On 7/7/2021 at 10:37 AM, MAXsenna said:


 

 


Yes. Seems the license keys are kept in registry, so one needs to re-activate.
I had bought VAICOM licenses on multiple emails, so I got a little anxious at first, but found them all. Now they're all in a TXT file, saved several places. emoji4.png
You say "new C drive". Is the old one still available? I made a snapshot of my old one, but haven't had time to check the registry on it as I solved it, but I guess their not really stored there, just the activation.

I'm sure Hollywood will get back to you, but if you have the purchase confirmations, it's strange that the licenses are not in email adjacent to them though. Have you search through all your emails for VAICOM with the correct filter?
Hope you'll solve this soon!
Cheers!

Sent from my MAR-LX1A using Tapatalk
 

 

Thanks MAXsenna, I had moved the purchase receipt to an archive folder but never did the same with the keys!! My keys were emailed to me the day after I posted, sorry for the delay, I have been doing a lot of overtime recently so I have avoided the PC. Always stay up way too late once its booted up.lol. Thanks for the reply..

  • Like 1
Link to comment
Share on other sites

Thanks MAXsenna, I had moved the purchase receipt to an archive folder but never did the same with the keys!! My keys were emailed to me the day after I posted, sorry for the delay, I have been doing a lot of overtime recently so I have avoided the PC. Always stay up way too late once its booted up.lol. Thanks for the reply..
You got it sorted. That's perfect!

Sent from my MAR-LX1A using Tapatalk

Link to comment
Share on other sites

Every now and again the transmit sound disappears when using my PTT, I have to toggle it several times and it eventually returns, not sure what the cause is ?

i7 9400 @ 2.9 Ghz

32 GB RAM

1 TB SSD

RTX 2060 8GB

Windows 10 64 bit

Link to comment
Share on other sites

3 hours ago, Oban said:

Every now and again the transmit sound disappears when using my PTT, I have to toggle it several times and it eventually returns, not sure what the cause is ?

same here

  • Like 1

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

I just got this and I'm doing some training to get it to recognize my speech patterns better.  I'm following insructions from p.41 of the manual

Quote

• Once you are done with training you will need to manually close the MSVR window yourself, the plugin will not do this for you.
• Click on the square microphone icon again to exit Training Mode.

I presume it is okay to stop in the middle of the words list?  There is currently 900+ words and I can't do it in one sitting.

 

After I close MSVR and the square microphone icon, is that it done?  Does it auto-save or something?  Or do I need to click the FINISH button too?

 

I've added a few words that it's not recognized but when I re-do the training, the program still has issues recognizing the word.  Do I need to restart Viacom/Voice Attack or restart the PC for these changes/additions to work?

 

Thanks!

- Ice

Link to comment
Share on other sites



I just got this and I'm doing some training to get it to recognize my speech patterns better.  I'm following insructions from p.41 of the manual
• Once you are done with training you will need to manually close the MSVR window yourself, the plugin will not do this for you.
• Click on the square microphone icon again to exit Training Mode.
I presume it is okay to stop in the middle of the words list?  There is currently 900+ words and I can't do it in one sitting.
 
After I close MSVR and the square microphone icon, is that it done?  Does it auto-save or something?  Or do I need to click the FINISH button too?
 
I've added a few words that it's not recognized but when I re-do the training, the program still has issues recognizing the word.  Do I need to restart Viacom/Voice Attack or restart the PC for these changes/additions to work?
 
Thanks!


The VAICOM training has never worked for me. But it has for others, they say. But even so, the training you really want to do anyway, is the core training of the Microsoft Speech Recognition, because MS Speech Recognition, is what is actually doing the recognition, neither VAICOM nor VoiceAttack.
As for your other questions, there are no saves or nothing. Just close it per the instructions in the manual. No need for the finish step unless you changed any keyword/alias. No need to restart VA. So yes. You can stop whenever you want in the middle of the keywords list.

I haven't done ANY keywords training on my fresh Windows installation/VAICOM installation.
BUT I really trained MSSR. The recommended number you'll find anywhere is three. But I did both "paths" 10 times, meaning I did it 20 times. Yes, boring as hell. But worth it for me as a non native English speaker. I also did half of it in a monotone voice like MSSR instructs you too, and the other half in a natural way.
I have added a few stubborn words to the dictionary. Well, words? Airfields actually.
VAICOM has the airfield Maykop-Khanskaya (F10 map) as Khanskaya in the keywords, while in game, at least for me the ATC is actually called Sokrat. So while playing the Oilfield Campaign today, I added it as an alias, applied, finish, pasted in the profile, worked like a charm without exiting or restart of DCS or VA.
I love when things just works as expected!
Cheers!

Sent from my MAR-LX1A using Tapatalk

Link to comment
Share on other sites

Hi everyone! I recently bought VoiceAttack and VAICOM PRO license. I want to use it for my communication with RIO in F-14. I tried to configure everything as in the manuals on youtube. But I can't do anything. I have two questions.

Is it possible to use viacom pro and the Jester control wheel at the same time?

Can someone help me set everything up correctly? We can use discord or something else.  Unfortunately, English is not my native language. Reading and watching manuals is very difficult for me.

AMD Ryzen 7 3700X/MSI MPG X570 GAMING PRO CARBON WIFI/32Gb DDR4 3600MHz/GeForce RTX2080 Super/3840x2160/TrackIR v5/Thrustmaster HOTAS WARTHOG+VPC War BRD+BRD педальки

Link to comment
Share on other sites

I think i solved my problems. There is one question left.

Is it possible to use viacom pro and the Jester control wheel at the same time?

AMD Ryzen 7 3700X/MSI MPG X570 GAMING PRO CARBON WIFI/32Gb DDR4 3600MHz/GeForce RTX2080 Super/3840x2160/TrackIR v5/Thrustmaster HOTAS WARTHOG+VPC War BRD+BRD педальки

Link to comment
Share on other sites

I think i solved my problems. There is one question left.
Is it possible to use viacom pro and the Jester control wheel at the same time?
No. VAICOM disables the Jester wheel currently, but adds it's own.
Try "Jester... Options" or something.

Sent from my MAR-LX1A using Tapatalk

  • Thanks 1
Link to comment
Share on other sites

19 минут назад, MAXsenna сказал:

No. VAICOM disables the Jester wheel currently, but adds it's own.
Try "Jester... Options" or something. emoji4.png

Sent from my MAR-LX1A using Tapatalk
 

I found just "Jester". But it's doesn't work.  Any other ideas? 

AMD Ryzen 7 3700X/MSI MPG X570 GAMING PRO CARBON WIFI/32Gb DDR4 3600MHz/GeForce RTX2080 Super/3840x2160/TrackIR v5/Thrustmaster HOTAS WARTHOG+VPC War BRD+BRD педальки

Link to comment
Share on other sites

Well, quite honestly. I don't use any of the"wheels", and I don't intend to. I printed out the pages from the manual with the AIRIO commands. Once you learn them, you don't want the wheel anyway.
Also, if you go to the unofficial Discord, some dude posted kneeboards of all the. AIRIO commands some days ago.
Cheers!

Sent from my MAR-LX1A using Tapatalk

  • Thanks 1
Link to comment
Share on other sites

 

On 7/28/2021 at 11:40 AM, Vasilich said:

I think i solved my problems. There is one question left.

Is it possible to use viacom pro and the Jester control wheel at the same time?

Disable AIRIO. That's what disables your Jester Command Wheel and enables voice commands instead. Now whether the voice commands work along with the wheel after disabling AIRIO idk, you have to test that out for yourself. I just opened the VAICOM PRO manual, which has ALL of the VAICOM commands listed.


Edited by adirtynurse
Link to comment
Share on other sites

Also remember, that VAICOM PRO has adapted some of the commands (shorter and easier words) and might not be exactly the same as shown in-game. And that you're talking to a robot (voice rec) and you kind of have to talk like a robot, phrase by phrase, keyword by keyword. Took my dumb brain embarrassingly long time to figure that one out 😄


Edited by adirtynurse
Link to comment
Share on other sites

Is there any good reason why a tanker will not answer back after "request for refuel"?

 

I made a map to practice AA refueling, 2 client aircraft FA-18 & an A-10CII. I get answered back from the FA-18 but not the A-10.

I've checked and double checked I'm on the tankers freq, but nothing.

 

Also, the tanker is the type with with a boom and and baskets.

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

3 hours ago, adirtynurse said:

 

Disable AIRIO. That's what disables your Jester Command Wheel and enables voice commands instead. Now whether the voice commands work along with the wheel after disabling AIRIO idk, you have to test that out for yourself. I just opened the VAICOM PRO manual, which has ALL of the VAICOM commands listed.

 

Disabling ARIO in the VAICOM settings will not restore the original wheel. Instead you need to remove the ARIO DLL file from the VAICOM installation. That will disable ARIO voice commands, but not other VAICOM voice commands. 

  • Like 1

I'm Softball on Multiplayer. Dell XPS-8500 24GB, i7-3770@3.40GHz, Win 10Pro, Nvidia GeForce GTX 1060 6GB, TiR, VKB Gunfighter III with MCG Ultimate grip, CH throttle and pedals, all maps, most modules

Link to comment
Share on other sites

3 hours ago, Sr. said:

Is there any good reason why a tanker will not answer back after "request for refuel"?

 

I made a map to practice AA refueling, 2 client aircraft FA-18 & an A-10CII. I get answered back from the FA-18 but not the A-10.

I've checked and double checked I'm on the tankers freq, but nothing.

 

Also, the tanker is the type with with a boom and and baskets.

The command is "approaching for refuel" if I recall correctly. Secondly, you can do funky things with VAICOM on the the A-10 radios, such as select an AM recipient on an FM radio, and that may cause a recipient to not respond. Make sure you are using the right radio. And use a "Select" command first to make sure you have selected the right tanker if there is more than one. Simply tuning to a frequency is not sufficient to make sure that a VAICOM radio call goes to the right recipient.

  • Like 1

I'm Softball on Multiplayer. Dell XPS-8500 24GB, i7-3770@3.40GHz, Win 10Pro, Nvidia GeForce GTX 1060 6GB, TiR, VKB Gunfighter III with MCG Ultimate grip, CH throttle and pedals, all maps, most modules

Link to comment
Share on other sites

6 hours ago, sthompson said:

The command is "approaching for refuel" if I recall correctly. Secondly, you can do funky things with VAICOM on the the A-10 radios, such as select an AM recipient on an FM radio, and that may cause a recipient to not respond. Make sure you are using the right radio. And use a "Select" command first to make sure you have selected the right tanker if there is more than one. Simply tuning to a frequency is not sufficient to make sure that a VAICOM radio call goes to the right recipient.


Roger that. I know the commands and I can see them being sent via the onscreen dialog in the upper left of the window. And I can see the radio tune to 251.000 when I say select 2 5 1 decimal zero

Ryzen R5 5600X | 64GB DDR4 3600| ASRock Radeon RX 6900 XT  | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...