Jump to content

VAICOM PRO plugin for VoiceAttack


Recommended Posts

Anyone have issues with VIACOM after this weeks patch? I have it running but it constantly keeps opening and closing the Comms menu on screen and commands are recognized but not doing anything? 

Link to post
Share on other sites
  • Replies 6.8k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

A known issue with 2.7 at the moment - @Hollywood_315will be release a new version once 2.7 has settled down

Just wanted to say thank you to @Hollywood_315. Great app, bought the bundle which was an amazing price for what you’ve done. Tested tonight, AIRIO is smile inducing to say the least. My son jumped in

Stable version will be updated to 2.7 tomorrow. I hope VAICOM PRO will soon be updated, too. Can't wait to play 2.7 with everything working as before.

37 minutes ago, CypherBlue said:

Anyone have issues with VIACOM after this weeks patch? I have it running but it constantly keeps opening and closing the Comms menu on screen and commands are recognized but not doing anything? 

Try closing both DCS and VA, remove the export.lua file in your saved games\scripts folder and then restart VA / Vaicom and then DCS

  • Thanks 1

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites
1 hour ago, hornblower793 said:

Try closing both DCS and VA, remove the export.lua file in your saved games\scripts folder and then restart VA / Vaicom and then DCS

Thank you I will try this tonight and report back. 

Link to post
Share on other sites

Hello Guys,

 

I bought VAICOM Pro + Voice Attack.

It's really good and I have just one problem about the kneeboard.

I understand if I call "Kneeboard", it appears or disappears and it is the case.

But it appears or disappears in many cases, for example when I make a little noise with my mouth or my warthog or my mouse or ....

Problem with VAICOM or VoiceAttack ?

 

If you have an explanation/solution for me, thks a lot 

Link to post
Share on other sites
On 4/17/2021 at 4:53 AM, JSpidey said:

Anybody else having issues with Vaicom Pro's Interactive Kneeboard in 2.7? When contacting marshal I don't get all the info displayed on the ATC menu anymore.. ?

Same here....no radio replies from ATC, AWACS, or air tanker shown on kneeboard.  This started with 2.7 update.

i9 10900KF 3.70GHz (5.30GHz Turbo), ASUS ROG STRIX GeForce RTX 3090 OC 24GB, ASUS Z590-E GAMING Motherboard, CORSAIR Vengeance 32GB DDR4 3600MHz, 2TB Intel 660P M.2 NVMe SSD, Virpil Alpha, T-50, MFG Xwind

Link to post
Share on other sites

Anyone have any recommendations on how to reset VA/VCP and DCS?  Upon starting up VA for some reason this week (after the recent DCS update) I see all sorts of messages that were never there before (see screenshot) so me thinks something got corrupted somewhere with this new update this week.  The end result of which none of the ATC commands are working with the Supercarrier (I get message "Selected Unit is not a Supercarrier")

 

Will a complete uninstall & reinstall of VA clean this up?  (noting I have to backup and reapply the C:\Users\<user>\AppData\Roaming\VoiceAttack\VoiceAttack.dat file).


One of the ancillary issues is that VA still thinks I have a Stable install of DCS on my system, when in fact I don't anymore.  I'd like to clean this up and sort out the issue.

 

Any recommendations?

 

 

 

 

 

Untitled1.jpg

i9-9900K @ 5.0GHz, ASUS ROG Z390 MAXIMUS XI HERO, ASUS GeForce RTX 2080Ti 11GB, 32GB DDR4 @ 3866MHZ, 1TB Intel 660P M.2 NVMe SSD, 1TB WD Black SN750 NVMe SSD, Oculus Rift S

Link to post
Share on other sites
2 hours ago, Tshark said:

Same here....no radio replies from ATC, AWACS, or air tanker shown on kneeboard.  This started with 2.7 update.

 

I too have not had much luck using that kneeboard extension.

I am pretty much not using it for now.

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | Valve Index|

Link to post
Share on other sites

I'm having problems with the kneeboard in the f18.  PTT works and the sim responds to commands, but when I bring up the kneeboard all the the vaicompro tabs on the page are empty.  All other pages display fine.  I reran the vaicompro setup and selected repair, which didnt help.  I'm using the latest release version not 2.7, although  I do have 2.7 installed.  Anyone else see/solve this?

 

Link to post
Share on other sites
5 hours ago, Twwhitey said:

Anyone have any recommendations on how to reset VA/VCP and DCS?  Upon starting up VA for some reason this week (after the recent DCS update) I see all sorts of messages that were never there before (see screenshot) so me thinks something got corrupted somewhere with this new update this week.  The end result of which none of the ATC commands are working with the Supercarrier (I get message "Selected Unit is not a Supercarrier")

 

Will a complete uninstall & reinstall of VA clean this up?  (noting I have to backup and reapply the C:\Users\<user>\AppData\Roaming\VoiceAttack\VoiceAttack.dat file).


One of the ancillary issues is that VA still thinks I have a Stable install of DCS on my system, when in fact I don't anymore.  I'd like to clean this up and sort out the issue.

 

Any recommendations?

 

 

 

 

 

 

Ok update - a clean out of the C:\Program Files (x86)\VoiceAttack\Apps\VAICOMPRO folder cleared up the mess of all the never seen before "building" & "reset" messages noted above upon starting VA. Those folders get recreated by the .dll when you run VA with VAICOMPRO.dll in the proper place so that cleared up the mess I noted above.  I've also renamed and moved the C:\Users\<username>\Saved Games\DCS.openbeta\Scripts\export.lua file (which also gets recreated) so good there...

 

I've then done a complete Repair of DCS (including scan and removal of all added files) and I'm still getting "Selected recipient is not a Supercarrier unit" in both standard F/A-18 SUPERCARRIER-HORNET-CASE I RECOVERY missions (both Caucasus and Persian Gulf).  What's interesting is that upon entering the mission, VoiceAttack is noting that the "Nearest ATC: DDG Arleigh Burke IIa" (see screenshot) - that doesn't seem right at all.  I have to think this has something to do with the recent update to 2.7.0.5518... AM I really the only person seeing this?

 

@Hollywood_315  What am I doing wrong here?

 

I've literally had zero issues with VA/VCP for 2 years and this is the first time I've seen anything like this.  

 

(Minor rant: between the week+ of near constant DCS and OS re-tweaking & testing in an effort to reclaim lost performance in VR and now this 2.7 has been a complete nightmare.. zero fun so far)

 

 

Untitled2.jpg


Edited by Twwhitey

i9-9900K @ 5.0GHz, ASUS ROG Z390 MAXIMUS XI HERO, ASUS GeForce RTX 2080Ti 11GB, 32GB DDR4 @ 3866MHZ, 1TB Intel 660P M.2 NVMe SSD, 1TB WD Black SN750 NVMe SSD, Oculus Rift S

Link to post
Share on other sites
22 minutes ago, Twwhitey said:

Ok update - a clean out of the C:\Program Files (x86)\VoiceAttack\Apps\VAICOMPRO folder cleared up the mess of all the never seen before "building" & "reset" messages noted above upon starting VA. Those folders get recreated by the .dll when you run VA with VAICOMPRO.dll in the proper place so that cleared up the mess I noted above.  I've also renamed and moved the C:\Users\<username>\Saved Games\DCS.openbeta\Scripts\export.lua file (which also gets recreated) so good there...

 

I've then done a complete Repair of DCS (including scan and removal of all added files) and I'm still getting "Selected recipient is not a Supercarrier unit" in both standard F/A-18 SUPERCARRIER-HORNET-CASE I RECOVERY missions (both Caucasus and Persian Gulf).  What's interesting is that upon entering the mission, VoiceAttack is noting that the "Nearest ATC: DDG Arleigh Burke IIa" (see screenshot) - that doesn't seem right at all.  I have to think this has something to do with the recent update to 2.7.0.5518... AM I really the only person seeing this?

 

@Hollywood_315  What am I doing wrong here?

 

I've literally had zero issues with VA/VCP for 2 years and this is the first time I've seen anything like this.  

 

(Minor rant: between the week+ of near constant DCS and OS re-tweaking & testing in an effort to reclaim lost performance in VR and now this 2.7 has been a complete nightmare.. zero fun so far)

 

 

Untitled2.jpg

 

 

Ok last update... I'm convinced something wonky is going on with DCS and/or the default set of missions in DCS or ship units associated within a Supercarrier group.  Pulling up the ATC "menu" it appears that all of the ships units associated with the SuperCarrier in the default F/A-18 Supercarrier Case 1 (standard) missions all apparently show up as ATC options for channel 127.5 (see screenshot). As these missions were my "test" missions this is why I'm getting the "Selected recipient is not a supercarrier".  Great way to spend hours and hours the past 2 days......  Creating a custom mission with only a lone supercarrier (and no affiliated units) VA/VCP command messages work fine.    Good lord...

Screen_210423_210917.png

i9-9900K @ 5.0GHz, ASUS ROG Z390 MAXIMUS XI HERO, ASUS GeForce RTX 2080Ti 11GB, 32GB DDR4 @ 3866MHZ, 1TB Intel 660P M.2 NVMe SSD, 1TB WD Black SN750 NVMe SSD, Oculus Rift S

Link to post
Share on other sites

All ships in the group being set to 127.5 has happened for a long time. It is the default frequency in the ME. Marking Moms as the first call usually sorts this as that is SC specific

Sent from my SM-T835 using Tapatalk

  • Like 1

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

Hi,

 

I've searched for the answers but cant find them so wondering if anyone is able to help.

 

My Vaicom Pro has been excellent and easy to update and import the new commands when I purchase a new extension, but I am having real issues when trying to update the keyword commands with the new kneeboard extension.

 

I have validated the licene and go to copy the new commands into the Vaicom Pro profile, but every time I click done I get the message 'The profile already contains the spoken phrase; 'my target' and it won't then update.

 

I have tried reloading the original Vaicom Pro profile, but always get the same message when it comes to importing the new phrases.

 

Has anyone experienced this before and have a solution?

 

Many thanks in advance.

Link to post
Share on other sites
11 hours ago, Twwhitey said:

Anyone have any recommendations on how to reset VA/VCP and DCS?  Upon starting up VA for some reason this week (after the recent DCS update) I see all sorts of messages that were never there before (see screenshot) so me thinks something got corrupted somewhere with this new update this week.  The end result of which none of the ATC commands are working with the Supercarrier (I get message "Selected Unit is not a Supercarrier")

 

Will a complete uninstall & reinstall of VA clean this up?  (noting I have to backup and reapply the C:\Users\<user>\AppData\Roaming\VoiceAttack\VoiceAttack.dat file).


One of the ancillary issues is that VA still thinks I have a Stable install of DCS on my system, when in fact I don't anymore.  I'd like to clean this up and sort out the issue.

 

Any recommendations?

 

 

 

 

 

Untitled1.jpg

If you are meaning the black squares that means you have Vaicom debug turned on

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites
1 hour ago, Waynos said:

Hi,

 

I've searched for the answers but cant find them so wondering if anyone is able to help.

 

My Vaicom Pro has been excellent and easy to update and import the new commands when I purchase a new extension, but I am having real issues when trying to update the keyword commands with the new kneeboard extension.

 

I have validated the licene and go to copy the new commands into the Vaicom Pro profile, but every time I click done I get the message 'The profile already contains the spoken phrase; 'my target' and it won't then update.

 

I have tried reloading the original Vaicom Pro profile, but always get the same message when it comes to importing the new phrases.

 

Has anyone experienced this before and have a solution?

 

Many thanks in advance.

When you have pressed the FINISH button in Vaicom config, paste the results into Notepad - does the phrase my target appear in there more than once on its own (I have 'my Target' and 'What is my Target')?

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites
30 minutes ago, hornblower793 said:

When you have pressed the FINISH button in Vaicom config, paste the results into Notepad - does the phrase my target appear in there more than once on its own (I have 'my Target' and 'What is my Target')?

Hi, Thanks for the reply.

 

My Target appears only once. Like you I have 'my target' and 'what is my target'

Link to post
Share on other sites

OK - how are you trying to add the commands to the VA profile?

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

I am opening VA, pressing ctrl, Alt and C to bring up the config window. Once this is open I go to the editor, click the orange Finish button. I then go back to VA, click the edit profile button, double click the AI communications part in keywords collection. Once it opens, I delete all the text in the 'when I say' box, press ctrl+V to paste the new commands and click apply. Everytime it brings up the message.

 

I have also tried creating a new profile, import the default Vaicom Pro profile and then doing the steps above. When I do this, I don't get the error message, but it only imports 77 commands.

Link to post
Share on other sites
3 hours ago, Waynos said:

I am opening VA, pressing ctrl, Alt and C to bring up the config window. Once this is open I go to the editor, click the orange Finish button. I then go back to VA, click the edit profile button, double click the AI communications part in keywords collection. Once it opens, I delete all the text in the 'when I say' box, press ctrl+V to paste the new commands and click apply. Everytime it brings up the message.

 

I have also tried creating a new profile, import the default Vaicom Pro profile and then doing the steps above. When I do this, I don't get the error message, but it only imports 77 commands.

How many commands does the Vaicom editor tab say you have?

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

Editor is saying 922 commands

20 minutes ago, hornblower793 said:

How many commands does the Vaicom editor tab say you have?

Editor is saying 922 commands

Link to post
Share on other sites

That sounds right - if you use the FINISH button and then paste into notepad does it look like 900+ commands or 77 commands.

If it looks like a lot, try copying from notepad and then pasting into the VA profile

  • Like 1

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites
13 hours ago, Twwhitey said:

I've then done a complete Repair of DCS (including scan and removal of all added files) and I'm still getting "Selected recipient is not a Supercarrier unit" in both standard F/A-18 SUPERCARRIER-HORNET-CASE I RECOVERY missions (both Caucasus and Persian Gulf).  What's interesting is that upon entering the mission, VoiceAttack is noting that the "Nearest ATC: DDG Arleigh Burke IIa" (see screenshot) - that doesn't seem right at all.  I have to think this has something to do with the recent update to 2.7.0.5518... AM I really the only person seeing this?

 

Unfortunately, that is correct behavior. You need to select the supercarrier as recipient before giving the inbound or marking moms call if there is another valid ATC that is closer. It was true before 2.7.

 

  • Like 1

I'm Softball on Multiplayer. Dell XPS-8500 24GB, i7-3770@3.40GHz, Win 10Pro, Nvidia GeForce GTX 1060 6GB, TiR, VKB Gunfighter III with MCG Ultimate grip, CH throttle and pedals, all maps, most modules

Link to post
Share on other sites
7 hours ago, hornblower793 said:

That sounds right - if you use the FINISH button and then paste into notepad does it look like 900+ commands or 77 commands.

If it looks like a lot, try copying from notepad and then pasting into the VA profile

I copied it into notepad and its over 2000 words, and looks a lot more than 77 commands. 

 

I copied and pasted into word and notepad and once I copy it over, the default Vaicom Pro profile goes from 520+ commands to 77 once I paste the new ones in and apply. I do get a message popping up saying it is importing over 23000 dynamic commands. See the pictures attahced. Once I click ok, it shows only 77 commands in the keyword section. 

Vaicom Message.JPG

Vaicom Message 2.JPG

Vaicom Message 3.JPG

Link to post
Share on other sites
8 hours ago, sthompson said:

Unfortunately, that is correct behavior. You need to select the supercarrier as recipient before giving the inbound or marking moms call if there is another valid ATC that is closer. It was true before 2.7.

 

I subsequently figured out why I was getting the “Selected Unit is not a SuperCarrier” message.  This weeks DCS update must have reset ‘Easy Communications” to ON which royally screws up how VCP works when your not expecting it.  Turning off easy Comms fixed my issue.  Great way to spend hours...

  • Like 1

i9-9900K @ 5.0GHz, ASUS ROG Z390 MAXIMUS XI HERO, ASUS GeForce RTX 2080Ti 11GB, 32GB DDR4 @ 3866MHZ, 1TB Intel 660P M.2 NVMe SSD, 1TB WD Black SN750 NVMe SSD, Oculus Rift S

Link to post
Share on other sites
I subsequently figured out why I was getting the “Selected Unit is not a SuperCarrier” message.  This weeks DCS update must have reset ‘Easy Communications” to ON which royally screws up how VCP works when your not expecting it.  Turning off easy Comms fixed my issue.  Great way to spend hours...
Good find though!

Sent from my MAR-LX1A using Tapatalk

Link to post
Share on other sites
×
×
  • Create New...