Jump to content

VAICOM PRO plugin for VoiceAttack


Hollywood_315

Recommended Posts

Hi guys,

 

I´m a new VAICOM user, bought the pro version today but I´m not getting it to work.

 

I have done the installation and the setup of both VoiceAttack and VAICOM as per the manual. Also it´s running as admin. Microphone and speech recognition are working. I don´t have SRS installed.

 

I noticed something really strange:

Here is the thing, wich makes me wonder if I´m not understanding something or if indeed something is broken: As long as I´m in the DCS main menu or have loaded a flight and pressed escape to get the "mission paused" prompt with the usual options, it seems to work. If I push a PTT button, the VoiceAttack window shows "Joystick: TX1 (or any other) press" --> "Listening resumed" And that´s the case as long as I hold the button. If I release, VoiceAttack says "Listening suspended". I can even use some voice comands, which are recognized like "checked".

 

But as soon as I´m actual in the cockpit without any DCS menus open, and push my PTT button, VoiceAttack shows:

 

DCS mission / Su25 - Nevada Cold Start

Player (Name) entered Module SU-25 Frogfoot, unit callsing 103

Listing suspended

 

And the listening is suspended immediately, although I´m still holding the PTT button.

I used the easy communications in an FC3 plane to ensure there is nothing wrong with frequencies, even started the engines for electrical power. As soon as I push the (any) PTT again, VoiceAttack shows the same three lines again (and again, and again).

 

Is this a normal behaviour? And if not, any hints what might be wrong here?

 

Thanks and best regards

Jano

Link to comment
Share on other sites

Are we supposed to paste in new keywords when an update comes across like this?

Only reason I ask is seems like we used to be prompted to do that, can't say I have been prompted for that in a while.

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | Valve Index| Vive Pro 2 |

Link to comment
Share on other sites

Thanks for the new update!

 

 

When I try to import the "Viacom pro airio.vap" to update the copmmands I get an "Error loading profile data. [There is an error in XML document (1,1).] Data at the root level is invalid. Line 1, position 1." error message. Am I doing something wrong? Should I first delete some old commands?

 

 

Best Regards,

 

 

Marcel

Link to comment
Share on other sites

Thanks for the new update!

 

 

When I try to import the "Viacom pro airio.vap" to update the copmmands I get an "Error loading profile data. [There is an error in XML document (1,1).] Data at the root level is invalid. Line 1, position 1." error message. Am I doing something wrong? Should I first delete some old commands?

 

 

Best Regards,

 

 

Marcel

 

I am having the same issue, an not new command from page 38 (NAVGRID)...


Edited by hreich

[sIGPIC][/sIGPIC]

Pilot from Croatia

Link to comment
Share on other sites

Hi @Hollywood_315

I update to latest version and try import new changes for AIRIO but I got msgbox with:

 

Error loading profile data

[Ther is an eror in XML document (1,1).]

Data at the root level in invalid. Line1, position 1.

 

So I try installation of vaicom from scratch. But now main vaicom profile is completly empty. I can't acces to configuration window to master reset.

 

How can it wipe everything and do clean install....

 

EDIT: I remove viaocom form export.lua and etc. and vorm VA folder, clean-up/repair DCS but still I see icons in main window of DCS


Edited by emc

Take a look my mods :joystick: dcs_icons_32.png

CPU: i7 7700 | GPU: GeForce GTX 1080 8GB DDR5 | Motherboard: ASUSTeK PRIME B250M-A | RAM: 2x16GB DDR4-2400 | Output: Kingston HyperX Cloud II | Edifier C2XD 2.1 | Controlls: Saitek X-56 Rhino | Saitek Flight Rudder Pedals | Saitek Multi/Radio/Switch Panels | Thrustmaster MFD Cougar | Logitech G13 | OpenTrack with LaserClip | VoiceAttack with VAICOM Pro plugin

Link to comment
Share on other sites

Just installed. Everything seems to load plugin-wise when I start VoiceAttack and load the profile, no issues... except when I try to actually do something. The PTT window doesn't update with my current plane and commands recognized by VoiceAttack don't do anything in-game. Setting the custom path to my DCSWorld folder in my Steam directory didn't fix it.

Link to comment
Share on other sites

Try deleting exports.lua

SYSTEM SPECS: Hardware Intel Corei7-12700KF @ 5.1/5.3p & 3.8e GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

open the config panel, select editor, if finish is illuminated press it and follow the instructions, then press reload...

SYSTEM SPECS: Hardware Intel Corei7-12700KF @ 5.1/5.3p & 3.8e GHz, 64Gb RAM, EVGA 3090 XC3, Dell S2716DG, Virpil T50CM3 Throttle, T-50CM2 Base & Constellation Alpha + MFG Crosswinds V2, HP Reverb G2
SOFTWARE: Microsoft Windows 11, VoiceAttack & VIACOM PRO

VR Stuff:   My Settings for 3090 and G2  My Settings for 1080ti  Shaders MOD for VR  My variant of Kegetys mod with clear water and also IC PASS for current beta & stable, Patch Status

1569924735_WildcardsBadgerFAASig.jpg.dbb8c2a337e37c2bfb12855f86d70fd5.jpg

Link to comment
Share on other sites

VAICOM PRO plugin update: release 2.5.14

- New PTT hot release function (page 27).

 

That is what I needed! Just tested and works well. I can control my plane now without PTT and with VAICOM PTT commands. AMAZING!

Thank you very much, Hollywood and happy holidays.

Smoke me a kipper I'll be back for breakfast! (Ken Gatward before his solo Beaufighter mission 1943)See vid here

HW: i7-7700K@OC(delid) to 5.0 GHz, 32 GB RAM, MB ASUS Z270-A, GTX 3080, LCD UltraWQHD (3440x1440) G-SYNC 120Hz,TrackIR5, VKB Gunfighter III (KG12 WWII), MFG Crosswind, GVL Throttle, Windows 10 64-bit

http://www.warbirds-blog.cz/

Link to comment
Share on other sites

VoiceAttack does NOT want to recognize "Radio Tune" command. Like, at all. It'll recognize other things, but not this one. "TACAN Tune" also tends to have some trouble being picked up, but none of these appear in the editor. I feel like adding an alternate command like "set radio" or "set tacan" would help but I don't know what the effect of editing them straight from the VA editor would have.

 

 

[EDIT] Apparently the "Scan Sector" and "Radio Tune" addon commands have a pretty low chance of activating. VoiceAttack literally reads "scan sector angels 14 at 30" and it wasn't recognized. TACAN Tune is in the editor though (missed it the first time), so there might be a correlation.


Edited by The Burrito
Link to comment
Share on other sites

Hi guys, quick question...I somehow messed up the presentation of my Viacom profile commands. Everything was initially split into nice clean categories with borders making the creating of new voice commands nice a easy. Somehow I changed how the orders are listed and now they present as one big mess. Yes I can still sort by category of command but the borders and clean look are gone making it a mess. Any thoughts on how to get it back to its original separation/organization?

Thanks, jason

Win 10 Pro, Intel i9 9900k overclocked to 5.1 (water cooled), 64 gb Corsair Dominator platinum RAM (3444 MHz)

Titan RTX overclocked and water cooled

1.1 TB SSD 2 TB M.2 SSD

TM Warthog Stick and throttle

MFG Crosswinds

Reverb VR

Buttkicker LFE, SimShaker, Jetseat.

All DCS modules

Link to comment
Share on other sites

There are lots of items here and I can't find one that matches my problem. I got the latest versions of Voice Attack and VAICOM Pro today. I have the chatter and Jester add-ons. I haven't tried the Jester one yet. I can get chatter to play on the speakers and VAICOM uses the headset for comms. I can only hear the thud tone no matter what I do. I have been testing on F-18 and have the latest update for the open beta. DCS can see VAICOM and I have directed VAICOM to the correct folder (chatter works and VAICOM knows it's an F18). I'm not sure where to go now. Any help appreciated - including directing me to a FAQ answer, or somehow logging the interactions.

Link to comment
Share on other sites

X2QkAVq.png

 

I can't fix this bloody error and the only language I've got on my PC is good old ENGLISH!!!!!!!!!!

 

All possible language settings are set to american english now and it still things its not a valid configuration for windows speech... if I can't train this app, I can't use it!

 

Edit: make sure you have the touch keyboard & handwriting service enabled in windows services for this to work!! Some power users may disable this and that was my problem...


Edited by squid1

[sIGPIC][/sIGPIC]



Saitek x45 Hotas

Canadian!

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...