Jump to content

Mission Editor not closing


Recommended Posts

Anyone else getting this? It's in 1.5.8 - when I have finished editing a mission, the editor refuses to close. Each time I try to exit the editor (regardless which way) I get a message asking if I want to save the changes - even when there weren't any or after multiple times where I chose "Yes" to save.

 

Regardless what I choose, the editor doesn't close. I end up having to use the task manager.

 

Is this a known bug? I couldn't find anything with a search.

Link to comment
Share on other sites

01862.150 ALERT LUACOMMON: Error: GUI Error: [string "./MissionEditor/modules/me_aircraft.lua"]:2077: attempt to index field 'group' (a nil value)

GUI debug.traceback: stack traceback:

[C]: ?

[string "./MissionEditor/modules/me_aircraft.lua"]:2077: in function 'onSpinUnitOf'

[string "./MissionEditor/modules/me_aircraft.lua"]:1720: in function 'verifySingleInFlight'

[string "./MissionEditor/modules/me_aircraft.lua"]:742: in function 'changeType'

[string "./MissionEditor/modules/me_aircraft.lua"]:1193: in function 'setType'

[string "./MissionEditor/modules/me_aircraft.lua"]:1088: in function 'changeCountry'

[string "./MissionEditor/modules/me_aircraft.lua"]:1572: in function 'fillCountries'

[string "./MissionEditor/modules/me_aircraft.lua"]:1526: in function 'updateCountries'

[string "./MissionEditor/modules/me_mission.lua"]:1496: in function 'load'

[string "./MissionEditor/modules/me_mission.lua"]:3387: in function 'save'

[string "./MissionEditor/modules/me_mission.lua"]:3311: in function <[string "./MissionEditor/modules/me_mission.lua"]:3305>

(tail call): ?

[string "./MissionEditor/modules/me_toolbar.lua"]:633: in function 'saveMission'

[string "./MissionEditor/modules/me_toolbar.lua"]:644: in function 'onChange'

[string "./dxgui/bind/ToggleButton.lua"]:20: in function 'callback'

[string "./dxgui/bind/Widget.lua"]:330: in function <[string "./dxgui/bind/Widget.lua"]:325>

01865.959 ALERT LUACOMMON: Error: GUI Error: [string "./MissionEditor/modules/me_bullseye.lua"]:89: attempt to index field 'bullseye' (a nil value)

 

My guess is an unofficial mod left in during the update, remove all unofficial mods and try a cleanup and repair.

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

  • 3 weeks later...

Even after repair, this is rearing it's ugly head.

 

Seems the longer I spend in the editor, the more likely it is to have the problem.

 

I've noticed that when this happens, the save icon remains highlighted all the time.

 

In the task manager, all seems normal with DCS values fluctuating as they would under normal use - it's not a freeze.

 

So I would say it is certainly a saving issue - the strange thing being, after closing using the Task Manager, I find that it had indeed saved the latest mission edit state - so why it gets stuck is a mystery. It's like it hasn't registered the fact that it has successfully saved the mission.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...