Jump to content

RWR audio?


Sandman1330
 Share

Recommended Posts

Kind of need the people who do hear sounds to say where they have DCs installed,

or

someone that doesn’t hear them say the do have it installed in the default location.

 

I tried looking through the files but

A) don’t really know what I’m looking at

B) didn’t find any reference to the sound files in my search

 

On another note, do you guys have bitching Betty audio?

I don’t get her giving altitude warnings, and only get a master caution for bingo fuel.

There are sound files for the above in the AV8B directory.

Link to comment
Share on other sites

  • Replies 117
  • Created
  • Last Reply

Top Posters In This Topic

Kind of need the people who do hear sounds to say where they have DCs installed,

or

someone that doesn’t hear them say the do have it installed in the default location.

 

I tried looking through the files but

A) don’t really know what I’m looking at

B) didn’t find any reference to the sound files in my search

 

On another note, do you guys have bitching Betty audio?

I don’t get her giving altitude warnings, and only get a master caution for bingo fuel.

There are sound files for the above in the AV8B directory.

 

 

 

In the case of bitching Betty, the sounds are still placeholders and will be updated later on, I have heard about this before. But are there sound files in place for altitude and all of that already?

 

 

Sent from my iPhone using Tapatalk

Rig Specs: i7 8700k @ 5ghz, ROG Strix z390e, 32GB DDR4 3200mhz, EVGA FTW3 1080 ti, Corsair rm750, Cooler Master ml240l RGB, Cooler Master h500p mesh

Link to comment
Share on other sites

I only get the chirp and have DCS installed in the default location, on my windows drive.

Ryzen 9 3900X / Asus Crosshair VI Hero X370 / Corsair H110i / Sapphire Nitro+ 6800XT / 32Gb G.Skill TridentZ 3200 / Samsung 960 Evo M.2 / Virpil Warbrd base + VFX and TM grips / Saitek X56 Throttle / Saitek Pro Combat pedals / Rift S

Link to comment
Share on other sites

In the case of bitching Betty, the sounds are still placeholders and will be updated later on, I have heard about this before. But are there sound files in place for altitude and all of that already?

 

Yeah, there's a folder called betty inside the av8bna/sounds/effects directory with 24 sound files.

 

I only get the chirp and have DCS installed in the default location, on my windows drive.

 

Cheers Sandman, save me moving my install dir to test.

Link to comment
Share on other sites

And bumping this again; looks like there was an update, can’t test it today so can anyone post up how the RWR sounds are with this new update?

 

 

Sent from my iPhone using Tapatalk

Rig Specs: i7 8700k @ 5ghz, ROG Strix z390e, 32GB DDR4 3200mhz, EVGA FTW3 1080 ti, Corsair rm750, Cooler Master ml240l RGB, Cooler Master h500p mesh

Link to comment
Share on other sites

Has anyone tried using different sound files for the rwr? Similar to how there’s an engine sound mod

 

Yep, I have. I've tried it with the Mirage which suffers from the same problem. It only plays the first fraction of a second of the sound. I don't know why and I can't fix it.

 

RAZBAM needs to make an ALR67_param.lua which clearly sets out the acquisition / lock / guidance tones for each individual threat. The same as ALR69_param.lua is for the A-10C.

[spoiler=PC SPECS]

Intel i5-8600k @3.60GHz

EVGA GTX 1070Ti

Windows 10

16GB RAM 3200 MHz

500 GB Samsung 850 SSD

2TB Seagate SSHD

Some cool LED fans that light up

 

 

Link to comment
Share on other sites

There's a reference to it here in this post - https://forums.eagle.ru/showthread.php?t=196582 - but Zeus hasn't updated the post in a while. Whether he's still up to date on it or not I don't know.

[spoiler=PC SPECS]

Intel i5-8600k @3.60GHz

EVGA GTX 1070Ti

Windows 10

16GB RAM 3200 MHz

500 GB Samsung 850 SSD

2TB Seagate SSHD

Some cool LED fans that light up

 

 

Link to comment
Share on other sites

I don't think it's localized at all, I haven't heard anything from the RWR ever. I'm sure it's on a long list of items to be looked at and worked on.

Sager Laptop, i7-6700k 4.00GHz, 16GB RAM, GTX 980M, 1920x1080, TIR 5, Windows 10

Link to comment
Share on other sites

Just going to bump this again. I recently had a friend buy the Harrier and the sounds work perfectly for them. However, he also bought the Mirage 2000 and it got me to thinking...

 

Of all of you who have RWR sound issues, how many of you have the Mirage 2000?

 

 

Sent from my iPhone using Tapatalk

Rig Specs: i7 8700k @ 5ghz, ROG Strix z390e, 32GB DDR4 3200mhz, EVGA FTW3 1080 ti, Corsair rm750, Cooler Master ml240l RGB, Cooler Master h500p mesh

Link to comment
Share on other sites

Just going to bump this again. I recently had a friend buy the Harrier and the sounds work perfectly for them. However, he also bought the Mirage 2000 and it got me to thinking...

 

Of all of you who have RWR sound issues, how many of you have the Mirage 2000?

 

 

Sent from my iPhone using Tapatalk

 

 

 

I don’t own the mirage and have sound issues on the harrier

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Depending on how people respond we may be closer to finding the common thread here, at least hopefully. If Zeus can’t tell us what we can do to help then we have to figure it out ourselves

 

 

Sent from my iPhone using Tapatalk

Rig Specs: i7 8700k @ 5ghz, ROG Strix z390e, 32GB DDR4 3200mhz, EVGA FTW3 1080 ti, Corsair rm750, Cooler Master ml240l RGB, Cooler Master h500p mesh

Link to comment
Share on other sites

RWR audio?

 

Ah, I was hoping we were close...I was about to buy the mirage JUST to test it out (though I still want to buy it anyway cause it’s an awesome aircraft)

 

 

Sent from my iPhone using Tapatalk

Rig Specs: i7 8700k @ 5ghz, ROG Strix z390e, 32GB DDR4 3200mhz, EVGA FTW3 1080 ti, Corsair rm750, Cooler Master ml240l RGB, Cooler Master h500p mesh

Link to comment
Share on other sites

I've just realized that RWR sound can be heard when running the sim in x2 speed (ctrl+z) or more. It's not audible in realtime or slower.

 

It looks like it's an audio triggering issue instead of an audibility problem.

 

 

So I've tried changing the RWR_NewThreat.sdef and added the line "pitch = 2.00" . Now the sound plays a bit more before getting cut. I'll research more into the .sdef files of other aircrafts to see if there's a parameter which changes the ADSR or playback time values of each sound. Will report back soon.

 

-----------------------------

 

UPDATE:

okay. I've added "release = 1.00" to the newthreat sound. Now the sound plays longer without a modified pitch (I can actually hear beeeepbepbepbep). The only problem now is a bad ADSR curve (because I've only added a release parameter.) I'll test each sound with some parameters such as "decay" or "sustain" to see if those parameters are supported, and add "looping" to those which are looping sounds.

 

---------------------------

 

UPDATE 2:

I've fiddled around with those settings and found a new parameter I can use in .sdef files:

-- PLAYMODE:

detached = false

-- set to true if the sound should always play the whole sample (explosions, gunshots etc.)

 

this parameter only has any effect on some RWR sounds, but it actually let me understand what's the problem with harrier's RWR. The sounds actually start playing every frame with the harrier. For example, instead of getting "beep-beep-beep-beep"'s when launched upon, you do get "bbbbbbbbbbbbbbbbbbbbb" (which is unaudible because it only gets to play a really tiny fraction of that sound which is quiet - replacing with another sound proves that point. The original launch warning sound has a tiny bit of silence in the beginning). I think i'm stumped here since I can't locate any other .lua files that modify how a sample is played back. I'll look around for a little bit more before leaving this matter to dev's hands.

 

--------------------------

 

UPDATE 3:

I've found one more file. Cockpit/Scripts/EWS/RWR_Init.lua . Most other aircraft I have has this file (sometimes named differently) with parameters designating how long does a sound play etc. (AJS even procedurally sets beep interval and frequencies using this file - AJS37->Cockpit->Scripts->RWR->Device->init.lua . Check it out it's really interesting!).

I don't know if the problem is there because our harrier is completely devoid of these parameters. A-10C seems to be missing them as well, but functions as it should even though they share the same sounds with the Harrier.

 

That's it from me for tonight and I hope RAZBAM someday decides to look into this issue :dunno: . I'm aware that this is an early access product but it's actually terrifying considering this has been an issue for such a long time.


Edited by exnihilodub
Link to comment
Share on other sites

To be honest, there are so many features missing from the RWR/ECM/CM system that it's going to need a lot of work before the module releases. It's only partially implemented. If you look at the Hornet and how the counter measures system works there, that's pretty much how the AV-8's is supposed to work. It's the same system I believe?

 

I imagine Zeus is waiting until he gets to this to fix any bugs with the RWR.


Edited by BritTorrent
Link to comment
Share on other sites

I have the AV8B and the M2K. At first, I thought it wasn't working, but The Mirage it definitely does, and as regards the harrier, I am not sure about AA threats. But, in a training server with friends, we've got a few TOR's setup at an airfield, and I got all the beeps from popping up, being locked and also altered to a missile launch. One thing I did make sure, to the right of the MFD, the volume switch for the RWR audio, I turn it up to max. Yet to test to see if it is AA locks that are missing/ having issues with.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...