Jump to content

Newcomer Help


Recommended Posts

Hey guys. I have been flying DCS on steam for a couple of years at least.

 

I want to make the jump out of steam as there are more advantages to using the DCS page etc.

 

so, I have several DLCS that I bought on steam but I also want to get into the Nevada training map and the WWII map.

 

What should I download 1.5 or 2.0? im kind of confused about this. Also, will my steam keys work for the 2.0 maps?

 

 

Thanks.

 

JDW

Link to post
Share on other sites

Terrain works as follows:

Version 1.5 supports only Caucasus map.

Version 2.0 supports Nevada and Normandy, but not Caucasus.

 

Most (all?) standard missions (e.g. training) that you get with the aircraft module require Caucasus map and therefore v1.5.

 

However, you can easily install both v1.5 and v2.0 in parallel.

Any aircraft modules you buy can be installed in both, because you get a number (I think 8?) activations per module.

 

You'll need to buy Nevada and/or Normandy to start v2.0.

 

So, if you want Nevada, the procedure could be:

- Download and install v1.5

- Try to activate your Steam modules (no experience with Steam so no idea if this works)

- Buy Nevada and/or Normandy (and any aircraft you want)

- Download and install v2.0

- Activate all terrains / aircraft in v2.0

- Activate all aircraft in v1.5

 

I personally use a tool called DCS Updater Utility, which works very well for me.

Modules: Bf 109, C-101, CE-II, F-5, Gazelle, Huey, Ka-50, Mi-8, MiG-15, MiG-19, MiG-21, Albatros, Viggen, Mirage 2000, Hornet, Yak-52, FC3

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...