Jump to content

[REPORTED]Invisible trains in multiplayer


Recommended Posts

Querying a bug regarding trains on Normandy map in multiplayer.

 

A couple of us are experiencing an issue with trains being invisible in multiplayer: the server host alone can see the train (and carriages) but any clients joining the server cannot.

 

I’ve put together a very basic mission to test this (see attached file). If I host I can see the train but my test partners cannot and vice versa.

 

Has anyone else found this with their missions? Is this a bug in multiplayer or are we doing something wrong?

 

Thanks.

train test 01.miz

dcs_train_01.thumb.png.517275a51d37b48a34c16f96ed2a1204.png

dcs_train_02.thumb.png.e690bfa6f8e90d58721352ef7a8c11f4.png

My PC specs: Win10 64 Pro, CPU i7-3820 4.4GHz, 16GB RAM, GPU Nvidia 1070 (8gb vram).



Controls: Microsoft FFB2, Thrustmaster Warthog Throttle, MFG Crosswind Pedals, TrackIR5.

My DCS Youtube Videos https://www.youtube.com/user/No64Bounder

Link to post
Share on other sites

If I recall correctly (someone correct me if I'm wrong), trains in DCS are programmed like civilian traffic and clouds, i.e. they're only local machine dependent scenery fillers and they're not synchronized between users in multiplayer.

i7 9700K @ stock speed, single GTX1070, 32 gigs of RAM, TH Warthog, MFG Crosswind, Win10.

Link to post
Share on other sites
If I recall correctly (someone correct me if I'm wrong), trains in DCS are programmed like civilian traffic and clouds, i.e. they're only local machine dependent scenery fillers and they're not synchronized between users in multiplayer.

 

 

 

There are two "types" of trains.

1. Civilian traffic trains (in the Caucasus map these run on the base map, just like civvy traffic)

2. Placeable mission editor trains. These exist in the normandy map and "snap" to the rail lines. They are programmed in to spawn and move about on waypoints just like road vehicle units, and UNLIKE the type-1 trains above

 

Bounder is right. The 2nd type of trains do not show.

Even as a host, or in single player, the 2nd type of trains do not show for me at all in Normandy map.

On YouTube: https://www.youtube.com/philstylenz

Storm of War WW2 server website: https://stormofwar.net/

 

 

AMD 3700x, GTX 1080Ti, 32GB 3200 RAM, Auros Pro X570, 2TB M.2 drive

Link to post
Share on other sites
Hi,

 

There is a tab to configure the train : Locomotive + waggon

 

Exactly. And after you set up the train only the host can see it in multiplayer. When you test the mission in single player it shows up. Sometimes I can't see them at all when I'm the host sometimes I can in multiplayer.

Georgian Spring Server: Join the Revolution!

http://georgianspring.enjin.com/

 

Training for Sabre Pilots

http://1-fighter-otu.enjin.com/

 

http://www.il2aceshigh.com/

Link to post
Share on other sites
  • 4 weeks later...

used to be a problem with boats like this... im curious if you spawn some speedboats will your wingmen see them the same as host? old problem may have returned?

""This was not in the Manual I did not read", cried the Noob" - BMBM, WWIIOL

Link to post
Share on other sites

I can confirm that boats are still an issue. We've been tearing our hair out trying to get a few of our 355th ops with moving ships working for everyone.

 

What seems to mostly work (after being destroyed, ships will "teleport" back to their starting position to burn but they are otherwise fine) is if no unit movement is late-triggered; all ships must be moving at mission start for all users to see them in the same position.

 

Sorry for the brief hijack! I haven't checked your .miz but if your train's movement is late-activated, or the train itself is late-activated by trigger, it might be worth a test to see if everyone sees it when it's moving at mission start.


Edited by feefifofum
Link to post
Share on other sites
  • 2 months later...

convoy train

 

Hello everyone, in the mission editor I create a train with locomotive and wagon and waypoints, but they are still invisible in the game. Near the train I placed a vehicle to observe the train, in the game I see the vehicle not the train. In the mission above, in the list of countries there is the third reich, I did not find it, I made a repair of DCS, now I have the third reich but still no train. Thanks for your

Link to post
Share on other sites
  • 1 month later...

Does anyone know if this issue is receiving attention, probably not to important considering the other serious issues with 2.5 beta. But it is VERY FRUSTRATING

Asus ROG MAXIMUS X Formula

Intel i7- 8700K 4.8ghz

Asus GTX 2080ti OC edition

64 Gb RAM at 3200mhz

Kraken X 72 cooler

Samsung CHG90 monitor at 144 htz

DCS on M.2 drive 500 Gb

Link to post
Share on other sites
  • 2 years later...

+1

 

Yeah,3 years.....this beggars belief does'nt it ?.....come on Ed,our patience is coming to an end :thumbdown:

Chillblast Fusion Cirrus 2 FS Pc/Intel Core i7-7700K Kaby Lake CPU/Gigabyte Nvidia GTX 1070 G1 8GB/Seagate 2TB FireCuda SSHD/16GB DDR4 2133MHz Memory/Asus STRIX Z270F Gaming Motherboard/Corsair Hydro Series H80i GT Liquid Cooler/TM Warthog with Sahaj 15cm Extension/MFG Crosswind Pedals/Saitek Cessna Trim Wheel & Throttle Quadrants/TrackiR4/Windows 10 Home/Sense of humour,I find it comes in handy !

Link to post
Share on other sites

Same in Channel map.

 

I remember way back when the A10C came out we had MP missions with trains as targets. The Tank cars would blow up nicely when hit. No issues then for clients. Something changed.

 

Would love to see this fixed.

Thing is....Zuckerberg is definitely an Alien... Some Kind of Grey Hybrid

 

Cooler Master HAF XB EVO Test Bench, ASUS P8Z77-V, i7-3770K @ 4.6GHz, Noctua AC, 32GB Corsair Vengeance Pro, EVGA 1080TI 11GB, 2 Samsung 840 Pro 540GB SSDs Raid 0, 1TB HDD, EVGA SuperNOVA 1300W PS, G930 Wireless SS Headset, TrackIR5/Wireless Proclip, TM Warthog, Saitek Pro Combat Pedals, 75" Samsung 4K QLED, Oculus S, Win 10

Link to post
Share on other sites

Hi all,

 

apologies this issue has been open to long, I will try and chase it up

 

thank you

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites
  • 2 months later...

Hi Bignewy! Any update on this? With the rockets coming to the P-47 we need trains to blow up in multiplayer.

i7 7700K @ 4,8 Ghz | Corsair Vengeance 2x16 gb @ 3200 Mhz | EVGA RTX 2080 XC ULTRA | Acer XB271HU 1440P 144HZ | Virpil T-50 CM throttle | Virpil WarBRD Base + MongoosT-50 CM2 Grip | MFG Crosswind | TrackIR 5

Bf 109 K-4 | Fw 190 A-8 | Spitfire LF Mk. IX | P-51D | Fw 190 D-9 | P-47D | F/A 18C | F-14 A/B | F-16C | MiG-15bis | MiG-21bis | M-2000C | A-10C | AJS-37 Viggen | UH-1H | Ka-50 | C-101 | Flaming Cliffs 3

Caucasus | Persian Gulf | Nevada | Normandy | The Channel | Syria

Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...
  • 2 months later...

I have this problem with the channel mapn in a "instant mission" called "train staffe" with the P-51D mustang.

I see that this is a long term waiting problem of some kind. Never the less, shouldn't this be sorted by now?

Please respond ED team.

 

Leo.

Link to post
Share on other sites
23 hours ago, LPsniper said:

I have this problem with the channel mapn in a "instant mission" called "train staffe" with the P-51D mustang.

I see that this is a long term waiting problem of some kind. Never the less, shouldn't this be sorted by now?

Please respond ED team.

 

Leo.

The problem you are seeing is new, only since the last update. Prior to that trains were reliably visible in all Single Player missions, the problem reported in this post has been there since the Assets Pack was released, trains have never worked in Multiplayer.  Now that it is also a Single Player issue as well, it has been reported and might be fixed soon.

Georgian Spring Server: Join the Revolution!

http://georgianspring.enjin.com/

 

Training for Sabre Pilots

http://1-fighter-otu.enjin.com/

 

http://www.il2aceshigh.com/

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...