Jump to content

Recommended Posts

  • Replies 607
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I've done the exact same thing and had fun setting up the mission and leveraging the RAT functionality (thanks @funkyfranky)  One bookmark I use quite a bit is this one for MOOSE.  The documentation i

Hi guys,   I have been working on a new implementation - simply named RAT - to generate random air traffic. This is something I was missing a lot in many of my missions :)   So what is RAT about? R

Hello,   The actual script that is inside the mission isn't the one you show above .. .it is this one:   local yak=RAT:New("RAT_YAK") yak:Spawn(5)   When you edit a scr

2 hours ago, tmansteve said:

Is it possible to set formations for the aircraft and how do we set the speed?

 

Not sure of the answer to that, maybe you should check its documentation:

 

https://flightcontrol-master.github.io/MOOSE_DOCS_DEVELOP/Documentation/Functional.Rat.html

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites

Got some things working but now have a problem when I spawned 5 F18s at Sochi-Adler and every time the 1st plane leaves its hanger, a second spawns in its place and tries to leave breaking the nose and then all other planes stay put. There are many hangers there making me think to start again as maybe got stuck.

 

I also tried using an airfield with no hangers and after the 1st spawned, again as soon as it left its parking, another plane spawned in its place. As there was no hanger, the plane followed the others.

 

I set the Max Speed to 350knots but they all flew at 172knots.  Any ideas?


Edited by tmansteve
Link to post
Share on other sites
  • 2 weeks later...

I have a WWII mission set up where I'm using RAT to populate the sky with fighters, but even with CAP and SEARCH and ENGAGE advanced waypoints they still ignore each other

 

Is this because they are RAT generated? or am i missing something?

skunk160 | Win10 PRO 64bit | i7-4770K 3.50 GHz | 32GB DDR3/1866MHz | GIGABYTE GeForce GTX 1080 x2 | Oculus Rift S | Virpil MongoosT-50CM2 | Virpil F-14B grip | Virpil 200m Curved Extension | PointCTRL | Delta Sim TM Slew | Sim Bandit AHCP | MFG Crosswind Pedals | //FOX2 Switch Boxes | RECARO SPG Seat | AuraSound AST-2B-4 Pro Bass Transducer x2

//FOXTWO Multi-Role Combat Pit Build http://forums.eagle.ru/showthread.php?t=134745

Link to post
Share on other sites
18 minutes ago, skunk160 said:

... or am i missing something?

 

I really have no idea, as I have used RAT only to generate background air traffic between my airbases (or from one side of the map to the other, in the case of civil airliners) ... I never did think on using RAT to generate aerial battles.

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites

@Rudel_chw

 

Found it, they now go for it!

 

setROE ("free")

setROT ("passive")

 

and with RespawnAfterCrahON () ..........its a Forever War


Edited by skunk160
  • Thanks 1

skunk160 | Win10 PRO 64bit | i7-4770K 3.50 GHz | 32GB DDR3/1866MHz | GIGABYTE GeForce GTX 1080 x2 | Oculus Rift S | Virpil MongoosT-50CM2 | Virpil F-14B grip | Virpil 200m Curved Extension | PointCTRL | Delta Sim TM Slew | Sim Bandit AHCP | MFG Crosswind Pedals | //FOX2 Switch Boxes | RECARO SPG Seat | AuraSound AST-2B-4 Pro Bass Transducer x2

//FOXTWO Multi-Role Combat Pit Build http://forums.eagle.ru/showthread.php?t=134745

Link to post
Share on other sites

Read the documentation. I remember, that all RAT planes are by the default set as neutral to each other and everything around. Im sure the is a way to adjust this.

Link to post
Share on other sites

Please help!  For the life of me, I cannot make this work! I must be missing something very basic.  Cannot get aircraft to spawn.

 

I am using DCS 2.5.6.59625

 

I created a mission in NTTR. Inserted an aircraft (in the air with late activation).

 

I created my lua file just like the template. 

 

In ME, I loaded the moose.lua with my rat lua, per the instructions.

 

Nothing shows in the mission.

 

Please help?  I've been at this for hours!

 

File attached.

 

Thanks - Dave

 

 

RAT Script.lua

Link to post
Share on other sites
6 minutes ago, jsr9597 said:

... Nothing shows in the mission.

 

Please help?  I've been at this for hours!

 

Attach the mission, to look at it.

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites
22 minutes ago, jsr9597 said:

Here's my mission file.

 

Hi, your problem is that you are executing your RAT script just when the mission loads. Since Moose is a large script, at that moment in time it is not fully intialized yet, so your script is never actually run.  I edited your Mission so that Moose loads 2 seconds after the mission has started, and the RAT script is run 4 seconds after that. That solves the issue.

Syria Training.miz

  • Thanks 1

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites

Sir - thanks so much for your hep!  Very much appreciated!

Quick follow-up - how do enable the differint skins on the aircraft?  I didnt quite understand those instructions.

My best - Dave

Link to post
Share on other sites
5 minutes ago, jsr9597 said:

Quick follow-up - how do enable the differint skins on the aircraft?  I didnt quite understand those instructions.

 

Add on your RAT script a line like this:

 

local b757skins={"AA", "BA", "C-32", "Delta", "DHL", "easyJet", "Swiss", "Thomson"}

 

The name of each livery is the exact name of its folder, like this:

 

dcT29sK.jpg

 

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites
36 minutes ago, jsr9597 said:

Where in the script do I place it?  Above the spawn line?


yes, above.

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites
1 minute ago, jsr9597 said:

Is there a link to the documentation?

 

On the first post of the thread

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites

Question about liveries.  

When I use this --> local b757skins={"AA", "BA", "C-32", "Delta", "DHL", "easyJet", "Swiss", "Thomson"}.......if I spawn five aircraft should each aircraft have a different livery when spawned?  For me, all aircraft have the same livery and don't change.

Link to post
Share on other sites
1 hour ago, jsr9597 said:

Question about liveries.  

When I use this --> local b757skins={"AA", "BA", "C-32", "Delta", "DHL", "easyJet", "Swiss", "Thomson"}.......if I spawn five aircraft should each aircraft have a different livery when spawned?  For me, all aircraft have the same livery and don't change.


sorry, I forgot that you need to add this line before spawning the aircrafts:

 

b757:Livery(b757skins)

 

it will assign a random livery from the set.

 

For work: iMac mid-2010 of 27" - Core i7 870 - 6 GB DDR3 1333 MHz - ATI HD5670 - SSD 256 GB - HDD 2 TB - macOS High Sierra

For Gaming: 34" Monitor - Ryzen 3600 - 32 GB DDR4 2400 - nVidia GTX1070ti - SSD 1.25 TB - HDD 10 TB - Win10 Pro - TM HOTAS Cougar - Oculus Rift CV1

Mobile: iPad Pro 12.9" of 256 GB

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...