Jump to content

DCE Campaigns


PB0_CEF

Recommended Posts

I've done two reinstalls of the P-51 Normandy campaign -

 

I receive the following error upon running firtmission.bat

 

H:\Eagle Dynamics\DCS World\bin\luae.exe: cannot open ../../../ScriptsMod."20.38.01/UTIL_Functions.lua: Invalid argument

stack traceback:

[C]: in function 'dofile'

..\..\..\ScriptsMod.20.38.01\BAT_FirstMission.lua:43: in main chunk

[C]: ?

 

 

 

 

STT Radar issue is leftover code.

Link to comment
Share on other sites

I've done two reinstalls of the P-51 Normandy campaign -

 

I receive the following error upon running firtmission.bat

 

H:\Eagle Dynamics\DCS World\bin\luae.exe: cannot open ../../../ScriptsMod."20.38.01/UTIL_Functions.lua: Invalid argument

stack traceback:

[C]: in function 'dofile'

..\..\..\ScriptsMod.20.38.01\BAT_FirstMission.lua:43: in main chunk

[C]: ?

 

 

 

 

man.. if you figure it out let me know. I was DYING to fly a p51 in DCE and never got it to work =(

Link to comment
Share on other sites

I've done two reinstalls of the P-51 Normandy campaign -

 

I receive the following error upon running firtmission.bat

 

H:\Eagle Dynamics\DCS World\bin\luae.exe: cannot open ../../../ScriptsMod."20.38.01/UTIL_Functions.lua: Invalid argument

stack traceback:

[C]: in function 'dofile'

..\..\..\ScriptsMod.20.38.01\BAT_FirstMission.lua:43: in main chunk

[C]: ?

 

 

 

Hey folks,

 

This is an easy fix to make this work correctly. Navigate to, then open path.bat (the one where you set your installation paths) using Notepad++ or advanced text editor.

 

Now, Line 8 looks like this:

 

set "versionPackageICM=ScriptsMod.20.38.01"

 

You need to delete: ScriptsMod.

 

So, Line 8 should now look exactly like:

 

set "versionPackageICM=20.38.01"

 

The author mistakenly left those characters in, so the batch file was effectively looking for:

 

ScriptMods.ScriptMods.20.38.01

 

which does not exist, hence the error.

 

So, remember to correctly set your installation paths in this file while you are there, then run the FirstMission.bat to reinitialise the campaign.

 

Let me know if it works for you.

 

Cheers!

 

 

Sent from my SM-G950F using Tapatalk

 

 

W10 Home 64Bit, Intel Skylake I5 6600K 3.50GHz, ASUS ROG Stryx Z270F MoBo, 32GB G.Skill RipJaws V DDR4 3200 RAM, Samsung 960 Pro 512GB M.2 SSD (OS), Samsung 850 Pro 512GB SSD, 2TB Seagate SDHD, 2TB WD Green HDD, GALAX GTX GeForce 1070 EXOC Sniper White 8GB VRAM

Link to comment
Share on other sites

Hi all. Having some issues with the India-Pakistan war campaigns. DCS won't load past 11% on startup when Indo-Pak War Mod-DCE is activated. With some trial and error it seems like it might be something with the db_countries.lua file.

 

Thanks!

 

Please can you try this new db_countries.lua : db_countries.lua

[/url]All known Dynamic Campaign Engine Campaigns

Last DCE news : DCS bug with AV-8 wingmen on Tarawa not taking off FIXED !!! (09/20/2021)

New ScriptsMod available with DCE_Manager : 20.47.132

Link to comment
Share on other sites

Scotch,

 

I've looked at both lines and have previously removed "scriptmod" from the paths file. That's not the issue.

 

The error isn't within the paths file - the error is within either of the following two files,

UTIL_Functions.lua - Doesnt have a specific line specified

 

but

 

 

BAT_FirstMission.lua:43 is the following line:

dofile("../../../ScriptsMod."..versionPackageICM.."/UTIL_Functions.lua")

 

I've tried replacing /ScriptsMod." with the 20.xx.xx.xx as my current package is, but that doesn't seem to fix the problem either.

 

Messed around and found a few things out of place within UTIL_Functions and the BAT first mission file.

 

Successfully generated and ran through first missions, however, I get the following error when ending a mission:

 

 

DCEError.thumb.png.6de14aa755290a1cbd639bee3d87c7dc.png

 

 

Hey folks,

 

This is an easy fix to make this work correctly. Navigate to, then open path.bat (the one where you set your installation paths) using Notepad++ or advanced text editor.

 

Now, Line 8 looks like this:

 

set "versionPackageICM=ScriptsMod.20.38.01"

 

You need to delete: ScriptsMod.

 

So, Line 8 should now look exactly like:

 

set "versionPackageICM=20.38.01"

 

The author mistakenly left those characters in, so the batch file was effectively looking for:

 

ScriptMods.ScriptMods.20.38.01

 

which does not exist, hence the error.

 

So, remember to correctly set your installation paths in this file while you are there, then run the FirstMission.bat to reinitialise the campaign.

 

Let me know if it works for you.

 

Cheers!

 

 

Sent from my SM-G950F using Tapatalk

 

 

STT Radar issue is leftover code.

Link to comment
Share on other sites

Scotch,

 

I've looked at both lines and have previously removed "scriptmod" from the paths file. That's not the issue.

 

The error isn't within the paths file - the error is within either of the following two files,

UTIL_Functions.lua - Doesnt have a specific line specified

 

but

 

 

BAT_FirstMission.lua:43 is the following line:

dofile("../../../ScriptsMod."..versionPackageICM.."/UTIL_Functions.lua")

 

I've tried replacing /ScriptsMod." with the 20.xx.xx.xx as my current package is, but that doesn't seem to fix the problem either.

 

Messed around and found a few things out of place within UTIL_Functions and the BAT first mission file.

 

Successfully generated and ran through first missions, however, I get the following error when ending a mission:

 

 

[ATTACH=JSON]{"data-align":"none","data-size":"full","title":"DCEError.png","data-attachmentid":7149696}[/ATTACH]

 

 

 

Hhhhmm ok. Mine is working fine in both generating and ending missions. I think (educated guess...) you may get that error you posted when nothing actually happens in the mission, so it gets stuck in an endless loop (ie trying to "divide by zero").

 

I'll check those two files when my computer is up and running again (I've just moved house today).

 

Cheers!

 

 

Sent from my SM-G950F using Tapatalk

 

 

W10 Home 64Bit, Intel Skylake I5 6600K 3.50GHz, ASUS ROG Stryx Z270F MoBo, 32GB G.Skill RipJaws V DDR4 3200 RAM, Samsung 960 Pro 512GB M.2 SSD (OS), Samsung 850 Pro 512GB SSD, 2TB Seagate SDHD, 2TB WD Green HDD, GALAX GTX GeForce 1070 EXOC Sniper White 8GB VRAM

Link to comment
Share on other sites

Hi all. I am playing the Desert Tiger campaign and noticed an issue where the F4's never take off. They just kinda get backed up on the entrance to the runway. I have to 'steer' around them to be able to take off. Then I had an escort mission but I think the planes I was supposed to escort where the ones stuck on the runway. Only tried 2 missions, but happened in both.

 

Figured i'd let you know.

 

Thanks again!

Link to comment
Share on other sites

Hey folks,

 

This is an easy fix to make this work correctly. Navigate to, then open path.bat (the one where you set your installation paths) using Notepad++ or advanced text editor.

 

Now, Line 8 looks like this:

 

set "versionPackageICM=ScriptsMod.20.38.01"

 

You need to delete: ScriptsMod.

 

So, Line 8 should now look exactly like:

 

set "versionPackageICM=20.38.01"

 

The author mistakenly left those characters in, so the batch file was effectively looking for:

 

ScriptMods.ScriptMods.20.38.01

 

which does not exist, hence the error.

 

So, remember to correctly set your installation paths in this file while you are there, then run the FirstMission.bat to reinitialise the campaign.

 

Let me know if it works for you.

 

Cheers!

 

 

Sent from my SM-G950F using Tapatalk

 

 

no joy. as in none of my path.bat had the line to delete. im not good with this stuff, again Miguel or P80 had to do remote access for 2 mins to fix my DCE .after yes after long explanation i could sorta get it

but this.. and the previous post by designer epically failed.

thanks for even caring though

Link to comment
Share on other sites

 

no joy. as in none of my path.bat had the line to delete. im not good with this stuff, again Miguel or P80 had to do remote access for 2 mins to fix my DCE .after yes after long explanation i could sorta get it

but this.. and the previous post by designer epically failed.

thanks for even caring though

Ok, if that line does not exist in Path.bat, you have to do a re-install of the campaign, as something has gone wrong there.

 

 

Sent from my SM-G950F using Tapatalk

 

 

W10 Home 64Bit, Intel Skylake I5 6600K 3.50GHz, ASUS ROG Stryx Z270F MoBo, 32GB G.Skill RipJaws V DDR4 3200 RAM, Samsung 960 Pro 512GB M.2 SSD (OS), Samsung 850 Pro 512GB SSD, 2TB Seagate SDHD, 2TB WD Green HDD, GALAX GTX GeForce 1070 EXOC Sniper White 8GB VRAM

Link to comment
Share on other sites

I'd love to see the A10CII retrofitted to DCE, I've tried as outlined several posts back, but no joy

10900K O/C 5.2GHz | Maximus Hero XII | EVGA 3090 FTW Ultra | 64GB DDR4 3600 | DCS on 2TB NVMe | WarBRD+Warthog Stick | CM3 | TM TPR's | Reverb G2

Link to comment
Share on other sites

Ok, if that line does not exist in Path.bat, you have to do a re-install of the campaign, as something has gone wrong there.

 

 

Sent from my SM-G950F using Tapatalk

 

 

thanks for even caring. unfortunately I tried that. Let me be very clear as well. IM TERRIBLE AT THIS STUFF

Ive basically given up on it. I wish i hadnt boiught the channel map but Im from that region of europe and those were the best yrs of my life before I was moved to america =/

all that said.. Id be happy if my goddamn f14 camps work and my F14 IRanian campaign used the A now, even if its not the iranian A yet

Link to comment
Share on other sites

Hi guys,

How do the "interception" missions work? You start with a hot plane and have to wait until something happens? How long does that take, usually?

Thanks!

 

hot plane. in briefing has ab earing and range for enemy. take off and head to tthem

BE WARY - if youre american go bold. If youre NOT american, I heavily advise going full burner to meet the foe. for example Miguel was very nice and modded the su27 camp to a JF17. Id head to the Americans, esp if i only saw F18 RWRs as theyre way more vulnerable. F14s Id run or avoid. however, that said, I would only go feet wet around 20 miles out. no more. you want the us to fight your sams, or at least have all sorts of radar pings, and hopefully friendly planes will scramble!

also very important. DONT GET GREEDY

use any long range missiles you have and GTFO

 

JF17 this means going to 40k feet so your fox 3s have ooptimal range, firing them as fast as possible, and Going full burner in a dive homeward bound. I take ALL FLARES out of a2a intended Jf17s as the most dangerous US missiles are amraams and aim54s.

if youre flying the F14 I advise going high, and bugging out when phoenixes are gone

If youre in a lesser plane than that, then yes I advise flying noe etc

But in the JF or F14, flying super low level for suprise attacks doesnt work very well. Idk why.. but it doesnt., the F14 is sorta clear, youre taking away alot of its advantages.

Link to comment
Share on other sites

Trying to get the Afghan Bear Trap - Ka-50 campaign working for several hours now and I'm stumped.

The firstmission.bat file works fine, I can see the files it creates, but DCS refuses to see them in the game's library. I've tried to open the individual .miz files in mission editor and I've copied and moved all the files generated by the .bat file all over the campaign directory tree with no luck.

 

I would like to know what map it uses, and if maybe I just don't own the proper asset?

Everything seems to work fine, with the exception of DCS recognizing any of the generated files.

 

Thanks in advance.

 

REM Core or Main DCS ou DCS.beta path, always end the line with \

set "pathDCS=D:\Eagle Dynamics\DCS World OpenBeta"

 

REM DCS or DCS.beta saved game path, always end the line with \

set "pathSavedGames=Saved Games\DCS.openbeta"

 

REM DCE ScriptMod version not any / or \ and no space before and after =

set "versionPackageICM=20.38.01_S-AW"

 

 

I have slashes \ at the end. The forum seems to be dropping them.

 

camp.init

updated the path to reflect dcs.openbeta in three places

--path = "Saved Games/DCS.openbeta/Mods/tech/DCE/Missions/Campaigns/Afghan Bear Trap - Ka-50/", --path of campaign folder

 

AfghanBearTrap.cmp updated various paths to replace users\david\ with my path.

 

Thanks

 

Hi CW4.. It uses the NTTR map. Your paths look correct. I'm not sure why its not showing up. Can you find the first mission in ME and fly the mission from ME?

Hi CW. I am having the same problem. Have you been able to fix it?

Link to comment
Share on other sites

all my dce are totally broken =(

no idea how to fix them or what went wrong

They dont give error messages even

they simply dont work

I never got the p51 to work which I really wanted

But at the very least I was hoping my precious F14 campaigns at least would save.

Someone help pleeeease

Better yet, someone help pleeease, just help me get IRIAF tomcats to A so I can fly against the against US one and iran iraq war. yes Id love to fly US off carrier too, but at the least those??

anyone??!

Pleeeease?

Link to comment
Share on other sites

On 11/28/2020 at 3:57 PM, sublime said:

all my dce are totally broken =(

no idea how to fix them or what went wrong

They dont give error messages even

they simply dont work

I never got the p51 to work which I really wanted

But at the very least I was hoping my precious F14 campaigns at least would save.

Someone help pleeeease

Better yet, someone help pleeease, just help me get IRIAF tomcats to A so I can fly against the against US one and iran iraq war. yes Id love to fly US off carrier too, but at the least those??

anyone??!

Pleeeease?

For campaigns to last over time, you also have to stop "tinkering" them ....

Well, come on, throw out the usual info...
On ONE campaign only
script version
version of the campaign
screen printout of the DCE installation in the directories etc etc...

You know the music...

FAQ DCE (Cef & Miguel'version)

In case of problem with a mission generated by CEF's DCEs, please post as many elements as possible:

  • - the mission + the tacview + a screenshot of the bug window + Give the name of the campaign + version of the scriptsMod

DCE_Manager

News : 52 campaign update (06/08/2021)

Link to comment
Share on other sites

On 11/26/2020 at 10:35 AM, Lukas_DZ said:

Hi man. Campaingn is great , bit is possible enable SEAD mission for F-16CM .. im try it, but firstmission.bat write me error if im change lodouts to sead for F 16 .. thnx

I believe there is no SEAD loadout yet in DCE for the F-16C_50.
That's why you have a mistake.

What campaign is this for?

FAQ DCE (Cef & Miguel'version)

In case of problem with a mission generated by CEF's DCEs, please post as many elements as possible:

  • - the mission + the tacview + a screenshot of the bug window + Give the name of the campaign + version of the scriptsMod

DCE_Manager

News : 52 campaign update (06/08/2021)

Link to comment
Share on other sites

On 11/25/2020 at 7:43 PM, solidGad said:

Hi all. I am playing the Desert Tiger campaign and noticed an issue where the F4's never take off. They just kinda get backed up on the entrance to the runway. I have to 'steer' around them to be able to take off. Then I had an escort mission but I think the planes I was supposed to escort where the ones stuck on the runway. Only tried 2 missions, but happened in both.

 

Figured i'd let you know.

 

Thanks again!

Thank you,
Can you give us the version of the script used?

FAQ DCE (Cef & Miguel'version)

In case of problem with a mission generated by CEF's DCEs, please post as many elements as possible:

  • - the mission + the tacview + a screenshot of the bug window + Give the name of the campaign + version of the scriptsMod

DCE_Manager

News : 52 campaign update (06/08/2021)

Link to comment
Share on other sites

On 11/20/2020 at 8:53 PM, Luse said:

I've done two reinstalls of the P-51 Normandy campaign -

 

I receive the following error upon running firtmission.bat

 

H:\Eagle Dynamics\DCS World\bin\luae.exe: cannot open ../../../ScriptsMod."20.38.01/UTIL_Functions.lua: Invalid argument

stack traceback:

[C]: in function 'dofile'

..\..\..\ScriptsMod.20.38.01\BAT_FirstMission.lua:43: in main chunk

[C]: ?

 

 

 

 

Can you give your Init/path.bat file
And an image of your DCE folder layout with the ScriptMod folders tree on the left side

FAQ DCE (Cef & Miguel'version)

In case of problem with a mission generated by CEF's DCEs, please post as many elements as possible:

  • - the mission + the tacview + a screenshot of the bug window + Give the name of the campaign + version of the scriptsMod

DCE_Manager

News : 52 campaign update (06/08/2021)

Link to comment
Share on other sites

On 11/18/2020 at 7:01 AM, mynameismatt said:

I'm trying to use a DCE campaign for the fist time, but stuck during installation. WHen I load up the campaign (TF-71 Tomcat), I get the following error:

 

sanitize.JPG.7e056ad3d5e0b2de0b93e7c0241c0432.JPG

 

However, I thought I did the correct changes to the MissionScripting.lua file:

scripting.thumb.JPG.c875262f9c6de7407c3107bcc9c6f45d.JPG

 

What am I doing wrong?

Salut,
you may be editing the wrong file (the OpenBeta file is not the same as the DCSWorld file)

You edit with notepad, it's better to do it with notepad++ and make sure that the encoding of the file is in ANSI or UTF8, and especially not UTF8-BOM.

Otherwise, post here a screen print of the file location and the DCS installation.

FAQ DCE (Cef & Miguel'version)

In case of problem with a mission generated by CEF's DCEs, please post as many elements as possible:

  • - the mission + the tacview + a screenshot of the bug window + Give the name of the campaign + version of the scriptsMod

DCE_Manager

News : 52 campaign update (06/08/2021)

Link to comment
Share on other sites

On 11/15/2020 at 6:40 AM, Niehorst said:

1.

Yesterday I tried the Hornet over Persian Gulf SuperCarrier (20.38.01) in Multiplayer with one other pilot.

 

So I klicked the FirstMission.bat, "m" for multiplayer, said I want 4 clients in the Hornets (didn't want to have AI wingmen in the flight) and selected 0 players in other aircrafts.

 

Mission was created and looked good. After the mission was launched and unpaused, it was only me (Host) sitting on the deck of the carrier and our escort flights of 6 F-14's were already circling around the carrier. My mate wasn't able to get in the cockpit. Tried "select role" several times:

 

"You're flight is delayed, please wait!"

(Also tried it with a longer time for takeoff preparation and with 2 clients, same result! Didn't try it with cold start option yet.)

 

At the end I had to edit a Single Player mission and made my wingman client and unchecked the "delayed start" options for our flight. That way it worked well.

 

 

2.

Another strange thing: I saw two Tomcats catch a wire on the LHA Tarawa! :blink:

Didn't happen before. Perhaps a new bug after the last update?

 

 

3.

Is it possible to prevent the carrier group from turning at all?

This "turn in the wind option" is already set to false, but it keeps turning quiet often, messes up the ship formation completely and is really "challenging" if it starts turning after you just called the ball! :crazy:

 

As always: Keep up this outstanding work, fly safe and stay healthy!:v:

Hi,
-1- We rewrote the multiplayer code, I hope it will improve this problem.
In any case, if you have a pb with a mission, please post it here and with the context, and eventually the tacview

-2- The planes which land on the TARAWA it is a DCS bp, the planes land on the carrier closest to the point envisaged in their flight plan, and ignores complement the assignment of the identifier in the mission file.
For the moment, by placing the TARAWA forward, it simplifies this pb, but creates other pb ^^ ^
I have an idea for a script to fix it, but it will be long, very long ^^

-3- interesting, we have adapted the code in the wind to have it in menu F10, 10mn before landing, you can ask that the CVN turns in the wind, and it will stay there for 30mn (renewable).

But your remark is interesting, because despite the order to prohibit turning in the wind, Mbot has equipped the naval aeronautical group with different WPT, I have to see if I can't warn the player that the CVN is approaching a WPT...


Thanks for your encouragement, and sorry I'm not more often on the forum, but I code a bit and it takes time.

A new version is in preparation ^^

Translated with www.DeepL.com/Translator (free version)

FAQ DCE (Cef & Miguel'version)

In case of problem with a mission generated by CEF's DCEs, please post as many elements as possible:

  • - the mission + the tacview + a screenshot of the bug window + Give the name of the campaign + version of the scriptsMod

DCE_Manager

News : 52 campaign update (06/08/2021)

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...