Jump to content

Creator's Update & TM-Target issue ?!


Recommended Posts

If anyone is tired of the TARGET script crashes on W10 and would like to fallback to TARGET v1, here ya go. Some devices such as the TFRP Rudders and T.16000M FCS may not be compatible.

 

http://virtualthunderbirds.com/library/thrustmaster/TARGET_v1.0.exe

ASUS Z590-E : Intel 11900K : 64GB G.Skill RipjawsV 4000 : ASUS 3090 Strix OC

TM HOTAS Warthog : TM Pendulum Rudders : TM Cougar MFD's : HP Reverb G2

Link to post
Share on other sites
  • 8 months later...
same after de-install & re-install

 

TM and Creator's Update have a possible sad.gif

I'm Having the same problem...

 

This didn't help:

Hi all,

 

 

The workaround is, just copy d3d9.dll from c:\windows\system32 to the folder where program that is crashing is installed C:\Program Files (x86)\Thrustmaster\TARGET\x64

Is there any other fix by now?

Link to post
Share on other sites

This fix ^^ also works if your SRS wont install or open !

 

Place that file into the main folder of those apps to fix it.

 

 

Maverick, if that d3d9.dll wont fix your issue, you likely suffer a different issue. Try reinstalling Target and then place the d3d9.dll file ( 1.54MB ) in the x64 subfolder of target, or main folder of SRS. This really fixed my issues with said apps.


Edited by BitMaster

Asus Z370-E - 8700K@5G_delidded - 32GB - 1080GTX-Ti EK-waterblock - 1x 960Evo 250GB - 3x Samsung 850/860Pro 256GB Raid-0 - 1x Samsung 870 Evo 1TB - 2x Seagate 2TB - 32GB PageFile - Heatkiller IV - MoRa3-360LT@4x180mm fans - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win10Pro64 

Link to post
Share on other sites
Interesting, without any devices plugged in it starts, as soon as i plug any of the sticks in (Warthog, T16000) it won't start anymore...

 

Wow, that is certainly very strange. Hope you can get it sorted soon.

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | 

Link to post
Share on other sites

You could try deinstalling the devices thoroughly and start over.

 

"usbdeview" is a very handy tool that lists all your ever connected USB devices, even from years back if your OS is running for that long. In there, delete any Thrustmaster that you can find, as well as any other obsolete USB device that you may find. I would certainly deinstall any Thrustmster software BEFORE I would clean out with usbdeview.

 

Then, I would run this tool from macecraft.com, also free to use for 60 days, jv16powertools.

This is the tool that has stayed with me ever since, it saved quite a few PC lifes and pulled hair.

Install the tool, let it start and then use the registry tool to clean your registry in default settings, make a BAckup as prompted ( only needed in once in 15+ years ) and let it work, THEN, when it has found the errors, MARK THEM, with SELECT ALL, and say FIX it. It may be able to fix some and delete the rest. When done, REBOOT for changes to take effect.

If you had "compact registry" enabled, it will pause for a sec in the middle of the booting and compact your reg, then it will proceed, all cool.

 

Once this has be done, reinstall TM as usual. Maybe leave as many other USB disconnected as possible. Something must have caused your disaster, try to avoid falling into the same pit again..and this is far from unlikely to happen, sadly.

 

 

USBDEVIEW: http://www.nirsoft.net/utils/usb_devices_view.html free

jv16powertools: https://www.macecraft.com/ 60-day trial

 

*jv16 is actually worth paying for imho. It has till today beaten any other reg cleaner I tested, even MS licensed it, think about that one.

Asus Z370-E - 8700K@5G_delidded - 32GB - 1080GTX-Ti EK-waterblock - 1x 960Evo 250GB - 3x Samsung 850/860Pro 256GB Raid-0 - 1x Samsung 870 Evo 1TB - 2x Seagate 2TB - 32GB PageFile - Heatkiller IV - MoRa3-360LT@4x180mm fans - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win10Pro64 

Link to post
Share on other sites
the Script editor works just fine., so i guess i'll just switch to the scripting variant...even though it's more work, i luckily know enough about coding to get this done :thumbup:

 

Well that is not a bad thing, it certainly is a lot more powerful with what one can do with it.

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | 

Link to post
Share on other sites

I only need the whole damn suite to turn those LED's off, nothing more :megalol:

Asus Z370-E - 8700K@5G_delidded - 32GB - 1080GTX-Ti EK-waterblock - 1x 960Evo 250GB - 3x Samsung 850/860Pro 256GB Raid-0 - 1x Samsung 870 Evo 1TB - 2x Seagate 2TB - 32GB PageFile - Heatkiller IV - MoRa3-360LT@4x180mm fans - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win10Pro64 

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...