Jump to content

Mission Editor: Simulate naval landing


Recommended Posts

EDIT: Uhm ok. I renamed all my units and moved my triggerzone a bit and now it works. The only two things I can think of is that 1/ Trigger one was just too close to the shore and no actual ship made it into it for some reason. 2/ the triggerzone intersected with the "spawning" of the tanks? Sounds like an odd reason but that was the difference.

 

--------------------

 

Hej

 

I´m building a mission with some boats in the pond heading for shore. Stop them before they get there or they will unload a bunch of angry T-90´s!

 

However, I can´t get it to work.

 

Ive set up a triggerzone by the shore. And the trigger looks like this:

 

TYPE: 1 Once, no event

COND: Unit Inside Zone

ACTION: Group Activate.

 

The T90 group is ticked with Late Activation.

 

I have no idea what im doing, im actually just guessing or trying to apply some logic to it.

Anyone have an idea what might be wrong?


Edited by sgtpancake
Fixed it
Link to comment
Share on other sites

Hi, I created this previously for a showcase mission for the Landing ship my friend created with me, the Alligator. But I've swapped out the ships to normal tankers. I spent a long time adjusting the triggers and distances and this is about as close as you can get it, but its basically smoke and mirrors, I despawn then respawn to get them closer and so on.

 

This demo gives you everything you need to know and gets as close as the current engine allows for what you ask. GL.

EDIT: Uhm ok. I renamed all my units and moved my triggerzone a bit and now it works. The only two things I can think of is that 1/ Trigger one was just too close to the shore and no actual ship made it into it for some reason. 2/ the triggerzone intersected with the "spawning" of the tanks? Sounds like an odd reason but that was the difference.

 

--------------------

 

Hej

 

I´m building a mission with some boats in the pond heading for shore. Stop them before they get there or they will unload a bunch of angry T-90´s!

 

However, I can´t get it to work.

 

Ive set up a triggerzone by the shore. And the trigger looks like this:

 

TYPE: 1 Once, no event

COND: Unit Inside Zone

ACTION: Group Activate.

 

The T90 group is ticked with Late Activation.

 

I have no idea what im doing, im actually just guessing or trying to apply some logic to it.

Anyone have an idea what might be wrong?

Landingshipexample.miz

___________________________________________________________________________

SIMPLE SCENERY SAVING * SIMPLE GROUP SAVING * SIMPLE STATIC SAVING *

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...