Jump to content

New to this amazing flight sim, how do I get v2.0 though?


Hairy_Teabags
 Share

Recommended Posts

Hi guys, as title would suggest really, I'm pretty new to the franchise, bought myself alot of gear to fully enjoy this etc. Downloaded the free trial in steam with the 2 starter planes which I believe is running 1.5 at the moment.

 

Sorry for noobness, Do i need to download the 2.0 alpha through the DCS site? Can I have both running together?

Link to comment
Share on other sites

Hi and welcome to the forum.

 

for DCS 2 which is currently in open alpha you need to purchase the NTTR terrain ( NOT CURRENTLY ON STEAM https://www.digitalcombatsimulator.com/en/shop/terrains/nttr_terrain/ )

 

DCS 1.5 is the release version where you will find everything you need, except the new terrain

 

Some info here

 

https://forums.eagle.ru/showthread.php?t=147711

 

https://forums.eagle.ru/showthread.php?t=147127


Edited by BIGNEWY

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

Hi guys, as title would suggest really, I'm pretty new to the franchise, bought myself alot of gear to fully enjoy this etc. Downloaded the free trial in steam with the 2 starter planes which I believe is running 1.5 at the moment.

 

Sorry for noobness, Do i need to download the 2.0 alpha through the DCS site? Can I have both running together?

You don't have to appologize for "noobness", that's what the forums are here for; to help each other ;)

 

Sometime in the future 1.5 and 2.0 will be combined in a 2.5 version. Currently you only need 2.0 if you're running the NTTR NEVADA map (runs only on 2.0), which I doubt you have unless you've purchased it. By default you have the Caucasus map, the Su-25T and the P-51 trainer. These free products run on 1.5. Read the manuals, do the training missions and ask any time anything you don't understand or check out the forums because you can find so much help there.

 

Me personally... I don't have the NTTR NEVADA map so I don't need 2.0. Once 2.5 is out (no idea when) I'll get it though.

 

Happy flying and welcome to the club!

 

S!

Alpenwolf

[sIGPIC][/sIGPIC]

Cold War 1947 - 1991

Helicopters Tournaments

Combined Arms Tournaments

You can help me with keeping up the server via PayPal donations: hokumyounis@yahoo.com

Link to comment
Share on other sites

thank you very much for the kind welcome guys :)

 

I'll just mess around with 1.5 for the time being then until 2.5 drops. I've probably played this 6 hours a day since I bought it about a week ago haha. I spend all day on youtube watching tutorials and learning new things. Getting a little more confident now, can land really well now which at first was a scrambling mess haha. Combat is coming along nicely now, or it is now I've realised that certain weapons have a minimum height requirement needed to drop :( spent ages in the one tutorial mission not understanding why, even though I was locked on, I would not get a Launch Approval.

 

Game is a piece of art though, so so good. The wife bought me the T16000FCS HOTAS for Star Citizen at Christmas, it hasn't seen much space combat since lol.

Link to comment
Share on other sites

As said by the other guys here, version 1.5 with the free aircraft is OK for the beginning. As soon as you have accomodated, I would recommend one of the full modules with clickable cockpit. They are so much fun. :thumbup:

 

A good module with clickable cockpit is the F-5E Tiger II. It's quite easy to learn and fly. A-10C is the best in my opinion, but it takes a lot more time to understand and use all the systems. It still is no problem if you really like the warthog, because there are good training missions and a very extensive flight manual. After many hours of training and :book: it's showtime!!! :smilewink:

A-10A, A-10C, A-10C II, AV-8B, F-5E, F-16C, F/A-18C, F-86F, Yak-52, Nevada, Persian Gulf, Syria, Supercarrier, Combined Arms, FW 190 A-8, FW 190 D-9, Spitfire LF Mk. IX, Normandy + WWII Assets Pack

 

Link to comment
Share on other sites

Guys, may I add a short question here:

 

Im fully aware about 1.5 and 2.0 differences, but have no clue if there was anything mentioned in the past when the "2.5 merge" will take place.

 

Was there any timeframe mentioned by ED Team so far ? Will it happen in 2017 ?

 

cheers

CPU: Intel I5-2400 @ 3,1GHz

RAM: 28GB Corsair XMS DDR3

GPU: Gainward Geforce GTX 1060 6GB

Win 7 - 64 Pro

Mad Catz Saitek Cyborg V.1

/ Track IR5

 

Running DCS 2.5 on dedicated Sandisk 240GB SSD

Modules: FC3/CA/Gazelle/P51/F5/FA-18C/A4-Community Mod

Link to comment
Share on other sites

Hi Guys,

 

Last weekend i transferred all my Steam modules to stand alone and now i'm installing everything (A-10C, Mig21bis and Su-25). I also bought The Nevada map and so i installed DCS World 2.0. If i want to fly on the Caucasus map, do i need to install DCS World 1.5 separately? And do i need to install the plane modules there again?

 

Thnx

 

Martijn

Link to comment
Share on other sites

Hi Guys,

 

Last weekend i transferred all my Steam modules to stand alone and now i'm installing everything (A-10C, Mig21bis and Su-25). I also bought The Nevada map and so i installed DCS World 2.0. If i want to fly on the Caucasus map, do i need to install DCS World 1.5 separately? And do i need to install the plane modules there again?

 

Thnx

 

Martijn

 

yes currently you need them both and keep them separate

 

1.5 is release build

 

2.0 open alpha is for testing Nevada

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...