Jump to content

Activate module in 1.2.16?


Longjap
 Share

Recommended Posts

Hi LN and forum!

 

I have a question. I bought the MiG-21 back when the beta came out in version 1.2.10 I believe, and it was the steam version. I loved it to bits.

 

Now, a problem arises. Steam updates the game like it doesn't need confirmation of the user so it rammed through the update 1.5 DCS World. I had no idea this would render the sim unplayable for me on my old machine. As I'm currently saving to buy me a nice rig that can handle this hobby better, I would still like to play the old version that worked just fine on my oldie PC.

 

Thing is, you can't revert updates in steam. Sigh.. So 150 Eu investment becomes unplayable. I was pretty pissed actually and left it to rest some time.

 

I discovered recently you can actually revert the normal ED download of DCS World to 1.2.x so I was relieved to start DCS again and I'm soaring through virtual skies like a boss again with my hog and FC3 material. Yay!

 

But... I can't seem to find or activate the MiG-21 module in this version.

I know everybody has moved on, but man, life's expensive. Help a pilot in need! I need to fly the Mig in 1.2.16 a little longer. Is this still possible? I tried it through the updater but nothing worked yet. Please help. :cry:

Link to comment
Share on other sites

IMHO your best bet would be to use a your Steam key(s) in a 1.2.16 stand-alone install

 

GUIDE: Using DCS Updater to Update, Revert, Repair, or Install Modules

https://forums.eagle.ru/showthread.php?t=114030

 

SkateZilla's DCS Updater GUI Utility

https://forums.eagle.ru/showthread.php?t=160053

 

You may also want to add/edit dcs_variant.txt with 1216, 1_2_16, etc. so you keep your settings separate i.e. USER\Saved Games\DCS.1216

 

https://forums.eagle.ru/showpost.php?p=2368599&postcount=2

 

Most modules will run in either DCS version without losing an activation, however IIRC the MiG-21's Starforce protection was updated in 1.5 and triggers an activation if you run the module switching between versions. So pick one version to run the MiG-21 in and stick with it.

 

Note: I run both 1.2.16 (for backward compatibility with some A-10C, etc. missions) and 1.5.5 Steam Beta without issue. MiG-21 module is only installed in 1.5.5 to avoid triggering activation requests in 1.2.16, etc.

 

It's possible to copy a Steam install to a new folder and run a standalone update/repair to reduce the size of the download but, if you are reverting from 1.5.5 -> 1.2.16 it might be best to start afresh.


Edited by Ramsay

i9 9900K @4.7GHz, 32GB DDR4, RTX2070 Super 8GB, 1TB NVMe, 6+4TB HD, 1+1TB SSD, MSFFB2 joystick, X52 Pro Throttle, TIR5, Win 10 Pro x64, 1920X1080

Link to comment
Share on other sites

Thanks for your replies! Haven't looked in the beta tab I must admit. But being annoyed by the rigid steam install I have moved the install outside of steam.

 

So I uninstalled the steam version and have downloaded the 1.5 DCS World from ED website and reverted it using the guide you provided Ramsay and started afresh. It worked. The program recognised the two modules I had bought before in the module manager; A-10C and FC3. Installing through the module manager in game didn't work though, it CTD'd or hanged while trying to download. Through the use of command prompt and updater.exe I managed to install A-10C and FC3.

 

Only the Mig-21 I can't seem to get installed. I've tried numerous variables in the command line like:

 

DCS_updater.exe install Mig-21bis

DCS_updater.exe install Mig-21

DCS_updater.exe install M-21

 

etc.

Maybe I need to use another variable?

Weird thing is also as the modules of a-10c and FC3 are visible in-game in the module manager as possible downloads but the Mig isn't in the list. It is at the bottom of the home screen though saying version 1.2.15 and is coloured with low saturation? Bit weird.

Anyway I'm going to try Skatezilla's DCS updater.

Link to comment
Share on other sites

Using DCS_updater.exe v2.6.16.58 (from the web installer) the command line "DCS_updater.exe install MIG-21BIS" started the download process on my 1.2.16 install.

 

Note: the module name is case sensitive and the "Mig-21bis" update was not found.


Edited by Ramsay

i9 9900K @4.7GHz, 32GB DDR4, RTX2070 Super 8GB, 1TB NVMe, 6+4TB HD, 1+1TB SSD, MSFFB2 joystick, X52 Pro Throttle, TIR5, Win 10 Pro x64, 1920X1080

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...