Jump to content

Possible fix for stutters and low performance


xxJohnxx
 Share

Recommended Posts

Hi guys,

 

I was having some trouble (https://forums.eagle.ru/showthread.php?t=178985) with my upgraded PC build and spent a week or two investigating why I am getting stutters and sometimes worse performance than before:

 

 

 

For anyone not wanting to watch the video:

 

Problem:

Stutters ingame even if DCS is installed on a SSD and the system is way above minimum spec.

 

Likely cause:

Basically DCS seems to be hogging down one CPU core and is ignoring all the others which can cause performance issues like I was experiencing.

 

Solution:

(1) When DCS is running bring up the Task Manager and go to "Details".

(2) Find the DCS.exe and right-click.

(3) Click on "Set Affinity".

(4) Select more cores than the default threads. You can either go for all of them or set one per actual core (e.g: every second one on the list).

(5) Click on okay and go back to DCS.

 

Unfortunatly you have to do this every time you start DCS. Apparently there are some programs out there that can set the "CPU Affinity" automatically for you. Haven't tried any yet, so I can't recommend one!

 

Hope this helps for at least some of you!

 

Best regards,

 

John

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to comment
Share on other sites

My quad core already has all four cores checked off by default...what about increasing 'Set Priority' to a higher than the default 'normal' level? Would this help?

 

Not sure about that. Probably leave that at normal if you don't want to run into weird problems.

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to comment
Share on other sites

Hi John,

 

I was really hoping this would fix my stuttering issues but it did not. I've used 0 & 2 cores. I even used 0, 2, 4, & 6 cores and it still did not work. Does it matter which physical cores to use as pairs?

i9 9900k @5.1GHz h100i |Asus ROG Strix Z390 E-Gaming | Samsung NVMe m.2 970 Evo 1TB | LPX 64GB DDR4 3200MHz

EVGA RTX 2080ti FTW3 Ultra | Reverb G2 | HOTAS Warthog | Saitek Flight Pedals

Link to comment
Share on other sites

The software isn't programmed to use more cores. very few are. It has to be done at the program level.

 

Read up on it. In order to get this program to use more cores it would have to be completely re-written. The setting you are attempting to use doesn't do it.

  • Like 1

This was a Boutique Builder iBuypower rig. Until I got the tinker bug again i7 920 @3.6Mhz 12Gig Corsair XMS3 ram 1600 Nvidia 760 SLi w/4Gig DDR5 Ram Intel 310 SSD HDD 160 Gb + Western Digital 4Terabyte HDD Creative SB X-Fi HD Audio Logitech X-530 5.1 Surround Speaker System Dual Acer 32"Monitors. PSU 1200 w Thermaltake Win10 64Bit.

Link to comment
Share on other sites

Try 3 & 4.

Thanks, I just tried cores 3 & 4 but I still get the random stutters. Does it matter that I'm in 2.0? Is 1.5 that much more optimized?

i9 9900k @5.1GHz h100i |Asus ROG Strix Z390 E-Gaming | Samsung NVMe m.2 970 Evo 1TB | LPX 64GB DDR4 3200MHz

EVGA RTX 2080ti FTW3 Ultra | Reverb G2 | HOTAS Warthog | Saitek Flight Pedals

Link to comment
Share on other sites

I'll just leave this here, YMMV though.

 

https://forums.eagle.ru/showpost.php?p=3002764&postcount=126

 

Thanks for the input, will do some more testing on my end as well.

 

The software isn't programmed to use more cores. very few are. It has to be done at the program level.

 

Read up on it. In order to get this program to use more cores it would have to be completely re-written. The setting you are attempting to use doesn't do it.

 

Well, you didn't watch the video did you?

 

 

Thanks, I just tried cores 3 & 4 but I still get the random stutters. Does it matter that I'm in 2.0? Is 1.5 that much more optimized?

 

Could be that the problem for the stutters you get is something else. Do you have DCS on an SSD?

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to comment
Share on other sites

Could be that the problem for the stutters you get is something else. Do you have DCS on an SSD?

 

Yes, on my Samsung Pro. I even get stuttering in Mission Editor. Again, my stutters arent every 10 seconds or something like that. Their just random.


Edited by pimp

i9 9900k @5.1GHz h100i |Asus ROG Strix Z390 E-Gaming | Samsung NVMe m.2 970 Evo 1TB | LPX 64GB DDR4 3200MHz

EVGA RTX 2080ti FTW3 Ultra | Reverb G2 | HOTAS Warthog | Saitek Flight Pedals

Link to comment
Share on other sites

Yes, on my Samsung Pro. I even get stuttering in Mission Editor. Again, my stutters arent every 10 seconds or something like that. Their just random.

 

Hmm weird. Could it be CPU throttling? Or TurboBoost disabling briefly due to the max timer running down?

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to comment
Share on other sites

until we don't see the new graphic engine this problems will persist

 

No, this problem can be easily solved by setting the CPU affinity. Has nothing to do with the new graphics engine.

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to comment
Share on other sites

No, this problem can be easily solved by setting the CPU affinity. Has nothing to do with the new graphics engine.

 

All my CPU affinity was always ON in 1.5 and the FPS problems still there, is the old graphic engine of this game, that's it.

RYZEN 7 1800X 3.5ghz / 32 DDR4 RAM Crucial / Nvidia 2070 RTX EVGA / Samsung SSD 500 GB / Acer XB270H G-Sync / Trackir 5 / Thrustmaster Hotas Warthog / Oculus CV1

Link to comment
Share on other sites

All my CPU affinity was always ON in 1.5 and the FPS problems still there, is the old graphic engine of this game, that's it.

 

Well, then your problem is somewhere else. With the affinity set, 1.5 is perfectly smooth on my end.

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to comment
Share on other sites

until we don't see the new graphic engine this problems will persist

 

Not sure what you're seeing or not, but we received a new graphics engine going from v1.2 to v1.5 a while back - and said engine runs silky smooth on my rig too, it has to be said.

The DCS Mi-8MTV2. The best aviational BBW experience you could ever dream of.

Link to comment
Share on other sites

These threads are very hard to determine if the poster is talking about game breaking stutters or micro pauses which they want resolved.

 

If your stating the game runs like a console game stutter free. I'd say your lying. But the stutters I experience are not game breaking and runs smooth.

Intel i9-9900K 32GB DDR4, RTX 2080tiftw3, Windows 10, 1tb 970 M2, TM Warthog, 4k 144hz HDR g-sync.

Link to comment
Share on other sites

If your stating the game runs like a console game stutter free. I'd say your lying

 

Well mine does run silky smooth most of the time, no microstutters or anything, unless there're literally hundreds of units in a mission. Does stating this fact make me a liar?

The DCS Mi-8MTV2. The best aviational BBW experience you could ever dream of.

Link to comment
Share on other sites

My CPU affinity has been set as per the video and this problem is not solved.

 

What Settings are you running on?

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, 2x R7970 Lightnings Crossfired @ 1.1/6.0GHz,

3x ASUS VS248HP + Hanns·G HZ201HPB + Oculus HMD,

Thrustmaster Warthog HOTAS + MFDs, CH Fighterstick+Pro Throttle+Pro Pedals

Link to comment
Share on other sites

Hey John, I have annoying random stutters but happens almost all the time when zooming in, looking in a new direction and especially when firing (which is the absolute last thing you want when attacking ground targets so close to the ground!)

 

I looked at my CPU performance while flying and the workload was evenly distributed between the 4 cores. All of the cores in affinity was checked.

i5 4590 @ 3.77GHz | GTX 1060 6GB | 16GB 1600MHz DDR3 | 1TB HDD+500GB HDD | Win10 Home X64

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...