Jump to content

Recommended Posts

just tried to update DCS world. At the very end a notice said can't find exe file and can't launch the app. I checked E:/DCS/DCS World/bin\DCS.exe and sure enough the exe file is gone. A search of my computer cannot locate it. My DCS sim has been in this location (and working)for years.

 

Can somebody advise me on how to solve this?

Thermaltake View 71 Snow, Gigabyte Z390 Aorus Master, i9-9900K Coffee Lake,8core,16 Thread,3.6 GHz, Corsair Vengeance Pro 64 GB, NZXT Kraken X72 AIO CPU cooler, Gigabyte GeForce RTX 2080 Xtreme Waterforce, Win 10

Link to post
Share on other sites

I created an icon from exe-update file and moved it to the desktop. The 'target' of the old icon and the new one both point to the updater file, but neither will open it. I notice the the update log file and the error msg both use the pathway containing "...DCS World\bin/DCS.exe..." please note the slash marks. I believe somebody inserted a wrong slash after 'bin.'

 

Autoupdate temp log shows: "ERROR: Can't run E:\Game Apps\Digital Combat Simulator\DCS World\bin/DCS.exe: (2) The system cannot find the file specified."

 

I also can find no 'repair' file. Perhaps someone could advise how I would do a repair?

 

edit: I also notice that there is a "run.exe" file with an icon in the 'DCS World' folder. Is that the original exe file; (afraid to click it now).


Edited by xylem

Thermaltake View 71 Snow, Gigabyte Z390 Aorus Master, i9-9900K Coffee Lake,8core,16 Thread,3.6 GHz, Corsair Vengeance Pro 64 GB, NZXT Kraken X72 AIO CPU cooler, Gigabyte GeForce RTX 2080 Xtreme Waterforce, Win 10

Link to post
Share on other sites

[edited]

 

If you create a shortcut to your desktop of dcs_updater.exe

then right click it go to properties and add the word: repair

 

Then target would look something like:

..\DCS beta\bin\DCS_updater.exe" repair

 

apply and double click the shortcut.

then update will do a repair

 

oops te word in target should be: repair.....

 

 

:santa:


Edited by piXel496
oops wrong wordzzz
Link to post
Share on other sites

Thanks for your advice Pixel. Still having probs tho. clicking one of the icons on desk caused it to check for update; so I let the update run again. Now I have new items in my start menu, including a 'repair' file. But the app will still not load, so I ran the repair app: afterward it said DCS had been repaired.

 

I then ran DCS again and it tried to load the entry screen but after a few seconds gives up and and notifies that a 'problem with the program caused it to shut down.'

 

I have no idea what's happening, but the update file seems to have porked my comp. or maybe it's more Win 10 crap...

 

BTW -the new update is v 155 6053 215; is that correct?

 

Thanks....

Thermaltake View 71 Snow, Gigabyte Z390 Aorus Master, i9-9900K Coffee Lake,8core,16 Thread,3.6 GHz, Corsair Vengeance Pro 64 GB, NZXT Kraken X72 AIO CPU cooler, Gigabyte GeForce RTX 2080 Xtreme Waterforce, Win 10

Link to post
Share on other sites

ok, guys. Very grateful for your suggestions; and I agree that I should reinstall. It's been so long since I did this that I don't remember how I did it. I assume I uninstall just 'DCS world', and reinstall, correct? I also have LOMAC still installed from 10 or 12 yrs ago-can I uninstall that or do I still need it? I also have blackshark and assume I should keep it? I also bought A!0C and a number of missions and campaigns- will they be returned to my account or do I have to search for codes or receipts?

 

Sorry to be so nubish. And I really appreciate your help.....

Thermaltake View 71 Snow, Gigabyte Z390 Aorus Master, i9-9900K Coffee Lake,8core,16 Thread,3.6 GHz, Corsair Vengeance Pro 64 GB, NZXT Kraken X72 AIO CPU cooler, Gigabyte GeForce RTX 2080 Xtreme Waterforce, Win 10

Link to post
Share on other sites

LOMAC is old, and unsupported now.

 

Do you have the original blackshark? or blackshark 2, BS2 will work with the new DCSWorld BS1 will not

 

Yes un-install and also delete your DCS folder in saved game so you can start fresh C:\Users\yourname\Saved Games\DCS

 

 

Latest DCS can be found here https://www.digitalcombatsimulator.com/en/downloads/world/stable/

 

 

minimum / recommended specification here

 

Minimum system requirements: OS 64-bit Windows 7/8/10; DirectX11; CPU: Core i3; RAM: 8 GB; Free hard disk space: 30 GB; Video: 2 GB RAM card, DirectX11 - compatible; requires internet activation.

 

Recommended system requirements: OS 64-bit Windows 7/8/10; DirectX11; CPU: Core i5+; RAM: 16GB; Hard disk space: 30 GB; Video: NVIDIA GeForce GTX780 / ATI R9 290 DirectX11 or better; Joystick; requires internet activation.

 

 

Make sure all of your keys are bound to your ED account here https://www.digitalcombatsimulator.com/en/personal/licensing/

 

just login and check your keys are bound to your account correctly, then when you login ingame your modules will download via the ingame module manager

 

some FAQs Here https://www.digitalcombatsimulator.com/en/support/faq/

 

hope it helps

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites
  • 2 weeks later...

Hello BIGNEWY.

 

I was interrupted by the holidays but am back now trying to get DCS reinstalled. I followed your advice: uninstalled and deleted DCS folder in saved games. I D/L'd the program from your link and reinstalled.

 

I still have no success. When I try to run DCS I get a screen which is blank except for the words "DCS not responding." I also get a window screen saying "DCS has stopped working" and "problem caused PGm to stop working correctly."

 

I will enclose my log file. As you can see all errors are of the nature " VFS: can't mount...."

 

I am sorry to take up your time but I wonder if you could give me your advise on this problem?

 

Thanks....

 

edit: I also tried disabling both the anti-virus and firewall. The only difference is that instead of a blank screen I now get the black DCS splash screen, but all else is the same and program won't start. I have also tried the 'repair' function and that didn't help either.

Logs.zip


Edited by xylem

Thermaltake View 71 Snow, Gigabyte Z390 Aorus Master, i9-9900K Coffee Lake,8core,16 Thread,3.6 GHz, Corsair Vengeance Pro 64 GB, NZXT Kraken X72 AIO CPU cooler, Gigabyte GeForce RTX 2080 Xtreme Waterforce, Win 10

Link to post
Share on other sites

Hmmm. Never thought of that. This problem only started with the V155 update.

My machine is running DX12 and DxDiagnosis shows no problem, and all other programs run fine.

 

Can anyone suggest what video card would run on my machine?

 

Is there a way to run another version of DCS? If not I guess I'm out of the game for a while...

 

Thanks

Thermaltake View 71 Snow, Gigabyte Z390 Aorus Master, i9-9900K Coffee Lake,8core,16 Thread,3.6 GHz, Corsair Vengeance Pro 64 GB, NZXT Kraken X72 AIO CPU cooler, Gigabyte GeForce RTX 2080 Xtreme Waterforce, Win 10

Link to post
Share on other sites
Hmmm. Never thought of that. This problem only started with the V155 update.

My machine is running DX12 and DxDiagnosis shows no problem, and all other programs run fine.

 

Can anyone suggest what video card would run on my machine?

 

Is there a way to run another version of DCS? If not I guess I'm out of the game for a while...

 

Thanks

 

could you try to delete the fxo and metashader folder under saved game/dcs.xxx?

or if possible, delete the whole dcs.openalpha folder (or rename it)

 

then, reinstall DX, graphic driver, and vs redistribute packages (in dcs xxx installation folder/distr/) and try.

 

Can you play DCS 1.5.4?

[sIGPIC][/sIGPIC]

My DCS Mods, Skins, Utilities and Scripts

 

| Windows 10 | i7-4790K | GTX 980Ti Hybrid | 32GB RAM | 3TB SSD |

| TM Warthog Stick | CH Pro Throttle + Pro Pedal | TIR5 Pro | TM MFD Cougar | Gun Camera: PrtScn |

Link to post
Share on other sites

Hi uboats. several comments:

 

I assume I played v1.5.4 but not sure. I generally just update when a msg appears during load, and I just did that for 155. After that nothing worked.

 

I looked at the specs for my video card and you are correct- it does not indicate support for anything above DX 10. In fact my machine does seem to be getting along in age :) but I don't have time now to build another one. I did however order a new graphics card and it arrived today.

 

My plan is to install the new card and see if it resolves the problem. If it does not then I will try your other remedies. With regard to that I have a couple of questions: fxo is in 'saved games' but metashaders are in 'bazar' in the DCS install folder - Is that the folder I should delete? and I assume you ment 'vcredist_64.exe', is that correct?

 

In any case I should have the card in by next week. And I am very grateful for you help.

 

-Tom

 

btw- I served several years in the Submarine Service so I like your moniker :)

Thermaltake View 71 Snow, Gigabyte Z390 Aorus Master, i9-9900K Coffee Lake,8core,16 Thread,3.6 GHz, Corsair Vengeance Pro 64 GB, NZXT Kraken X72 AIO CPU cooler, Gigabyte GeForce RTX 2080 Xtreme Waterforce, Win 10

Link to post
Share on other sites

It will be the card, directx 10.1 users seemed to get away with it for a while but as 1.5 progressed only Directx 11 cards will do now.

 

Enjoy your new card when it arrives :)

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites

fxo is in 'saved games' but metashaders are in 'bazar' in the DCS install folder - Is that the folder I should delete?

Yes fxo under saved game, but for 1.5.x no metashader in saved game.

My suggestion is to delete the bin folder of DCS, and fxo/metashader and missioneditor folder (all in dcs installation folder). And then make a repair. Then try DCS again.

 

'vcredist_64.exe', is that correct?

correct.

also try to repair your windows config. Install/uninstall other software may change the system config, and subsequently affect other software.

also try to re-install DX, graphic driver (latest)

[sIGPIC][/sIGPIC]

My DCS Mods, Skins, Utilities and Scripts

 

| Windows 10 | i7-4790K | GTX 980Ti Hybrid | 32GB RAM | 3TB SSD |

| TM Warthog Stick | CH Pro Throttle + Pro Pedal | TIR5 Pro | TM MFD Cougar | Gun Camera: PrtScn |

Link to post
Share on other sites

OK. And thanks for your help guys.

 

regards

Thermaltake View 71 Snow, Gigabyte Z390 Aorus Master, i9-9900K Coffee Lake,8core,16 Thread,3.6 GHz, Corsair Vengeance Pro 64 GB, NZXT Kraken X72 AIO CPU cooler, Gigabyte GeForce RTX 2080 Xtreme Waterforce, Win 10

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...