Jump to content

Handicapping radar bug


TomCatMucDe
 Share

Recommended Posts

I hesitated before reporting this confirmed back from my side since a friend flying with me in MP was noticing the same thing. I hope Razbam can reproduce it.

 

The bug is pretty simple yet very annoying. I saw it only in MP and not the instant action mission.

 

Sometimes, after take off I simply can't lock anybody although contacts are right in front of me. This goes the same for far away and nearby contacts. Worse, sometimes my radar shows no contact at all.

Hitting the return to search button (unlock) doesn't help. The only workaround is to go to cycle through CCM modes, hit return to search, and suddenly contact are lockable, or if they weren't appearing they appear.

 

I hope this can be fixed soon. For now enjoy your holidays and merry xmas Razbam!

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

I have seen this twice in 4 missions. Unable to lock on anything (close range contacts with high closing speed). Once I was even unable to enter the close combat modes. Cycled every radar switch with no effect. After like 10 mins, suddenly it worked again.

 

Is there any actual radar function that should make me unable to lock on anything and enter the CCM modes? If not, this is a pretty serious bug.

Win10 x64 | SSDs | i5 2500K @ 4.4 GHz | 16 GB RAM | GTX 970 | TM Warthog HOTAS | Saitek pedals | TIR5

Link to comment
Share on other sites

Hi

 

Be aware that max_lock_distance is ~80% of max_detection_distance.

 

Thas being said, without a track, I don't feel this can be investigated.

Or at last a "recipe" to reproduce the bug most/100% of the time?

 

 

 

Hi Azyran,

 

I have been flying the Mirage since it's out. I can safely say I'm not a newbie and quite proficient in it. I am talking about issues that are at all distances including very close.

 

Again simply switching to CCM and hitting return to search by magic everything works again.

Since this issue is on MP a track is not possible but I promise to do to a video for you. I'm afraid i won't touch my cockpit before the first.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Hi TomCatMucDe,

 

It's not a "confidence" issue, I'm ready to believe you.

 

It's a "replication" issue. For Razbam guys to catch the problem, the better way is to make them experience it themselves. For that to happen, either a track (which will replay on their own systems) or a "recipe" is needed.

 

I'm not sure a video will be enough, cause it doesn't show all of the inputs you may do.

 

My 2 cents

++

spacer.png

Link to comment
Share on other sites

Since this issue is on MP a track is not possible

 

You get tracks from MP as well. When you have the issue, exit the server. A track will be generated automatically in \savedgames\DCS\Tracks\Multiplayer

Specs:

 

 

i9 10900K @ 5.1 GHz, EVGA GTX 1080Ti, MSI Z490 MEG Godlike, 32GB DDR4 @ 3600, Win 10, Samsung S34E790C, Vive, TIR5, 10cm extended Warthog on WarBRD, Crosswinds

 

Link to comment
Share on other sites

I'm having the problem I described earlier right now. I can't lock contacts (13 miles out, 0.5 closing speed in this example, so clearly I should be able to) NOR can I switch to the close combat modes. The switch I have bound just doesn't do anything (and I know the switch is working, have tested).

 

To be completely clear, is there any good reason I shouldn't be able to enter the CCM modes (and, this is Special Modes in the controls list right?)

 

 

EDIT: Aaah, found my problem. I had rockets selected! Then, even if the safety is on, the radar can't lock and can't enter CCM modes. I wonder if this applies to all AG weapons, and if there are some other people above who have been having the same thing as me.


Edited by Corrigan

Win10 x64 | SSDs | i5 2500K @ 4.4 GHz | 16 GB RAM | GTX 970 | TM Warthog HOTAS | Saitek pedals | TIR5

Link to comment
Share on other sites

Yeah, there's still something weird going on. Attaching a screenshot that hopefully shows how my radar is configured right now, and I cannot lock the contact in front of me or change to CCM modes. Ideas?

 

Toggling selection of one of a missile solved the issue --- I wonder if this might be related to selective jettison of a fuel tank, which I did just before. Is locking and CCM possible with a fuel tank selected, can anyone check?

radar.thumb.png.8c987784c5034d6841ba35e60d05ddf4.png


Edited by Corrigan

Win10 x64 | SSDs | i5 2500K @ 4.4 GHz | 16 GB RAM | GTX 970 | TM Warthog HOTAS | Saitek pedals | TIR5

Link to comment
Share on other sites

Yeah, there's still something weird going on. Attaching a screenshot that hopefully shows how my radar is configured right now, and I cannot lock the contact in front of me or change to CCM modes. Ideas?

 

Toggling selection of one of a missile solved the issue --- I wonder if this might be related to selective jettison of a fuel tank, which I did just before. Is locking and CCM possible with a fuel tank selected, can anyone check?

Yep this is an old problem that exists since the module was released. When you empty a store (drop the tank, fire all missiles of a type,...) its entry in the PCA disappears inclulding the little light (S) below that shows that it's selected. This is misleading though, the store remains selected until you either press the now dark button once more (de-select) or switch to another store.

Since the radar only locks if nothing or A/A missiles are selected I'm sure that's the issue here (same goes for special modes).


Edited by spiddx

Specs:

 

 

i9 10900K @ 5.1 GHz, EVGA GTX 1080Ti, MSI Z490 MEG Godlike, 32GB DDR4 @ 3600, Win 10, Samsung S34E790C, Vive, TIR5, 10cm extended Warthog on WarBRD, Crosswinds

 

Link to comment
Share on other sites

Yep this is an old problem that exists since the module was released. When you empty a store (drop the tank, fire all missiles of a type,...) its entry in the PCA disappears inclulding the little light (S) below that shows that it's selected. This is misleading though, the store remains selected until you either press the now dark button once more (de-select) or switch to another store.

Since the radar only locks if nothing or A/A missiles are selected I'm sure that's the issue here (same goes for special modes).

 

Yep, seems to be correct. I tested that as soon as I found myself with a drop tank again, and you writing this confirms my suspicion.

 

I mean, for all I know, this might be a bug/bad design in the actual system which the sim imitates. But yeah, whether this is a (fairly minor!) bug in the sim or bad system design it's obviously pretty shitty that it looks like I have nothing selected but the aircraft "remembers" the jettisoned/expended previous selection.


Edited by Corrigan

Win10 x64 | SSDs | i5 2500K @ 4.4 GHz | 16 GB RAM | GTX 970 | TM Warthog HOTAS | Saitek pedals | TIR5

Link to comment
Share on other sites

I ran into the radar not picking up a contact again in multiplayer. Apparently my Tacview export isn't working right, so I don't have a replay to show you, but I did capture a video. The contact doesn't appear on my radar until I lock him using CCM mode. After I exit CCM, it loses the contact again shortly after.

 

Hopefully this helps. I'll try to get a track next time I play.

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...