Jump to content

Recommended Posts

Hi,

 

I just upgareded my PC with a new CPU and Motherboard and after spending some time performing a fresh install of W10 and all drivers and other software I am getting a weird problem with DCS:

 

I can start DCS just fine and it will run. However, once I shut down DCS and restart it, it will crash as soon as the loading screen reaches 100%. See the attached logs.

 

I found another user has the same problem: https://forums.eagle.ru/showthread.php?t=177076

 

I tried so far:

 

  • Deleting the folder in 'Saved Games'
  • Repairing DCS
  • Running DCS as an admin
  • Reinstalling DCS completly
  • Reinstalling my graphic drivers (tried both 376.19 and 376.33)

Any thoughts?

 

 

Best regards,

 

 

John

Logs.zip


Edited by xxJohnxx

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to post
Share on other sites

I figured another intresting condition out right now as well...

 

After launching and closing DCS World 1.5:

 

If I launch the DCS World 2 Open Alpha and then close it a again I can then start the DCS World 1.5 version again.

 

DCS World 2 Open Alpha doesn't suffer from this issue at all, however it seems to somehow affect DCS World 1.5 to temporarily fix the problem.

 

EDIT: This might actualy be a fluke. Just tried it again and now I can't get DCS World 1.5 to restart even if starting DCS World 2 Open Alpha inbetween.


Edited by xxJohnxx

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to post
Share on other sites

Lack of any (official) answers to this thread makes me believe I am the only one with this problem. :noexpression:

 

Anyway, I did a lot more testing and trying to get it working. I even spend another couple hours reinstalling W10 and all the drivers for my rig.

 

Even after the W10 reinstall and re-installing DCS twice from scratch the problem was still there... However, at one point, after I deleted the Saved Games folder for the 25th time the problem stopped occuring most of the time and DCS launches again if it has run before.

 

 

HOWEVER:

 

The root issue still seems to exist. While DCS will now start every time, there is a performance hit recognizable on the second launch, resulting in stutters and low fps.

 

I have attached a track-file of a short flight of the Mi-8 at Batumi.

 

If I play back this track file at the first start of a Windows session, everything runs smooth (~60fps) and there is no issue.

 

If I now restart DCS and play the track file again, DCS will run much worse. While the peak-framerate still hits ~55fps, it dips down to less than 20fps every second or so, resulting in visible stutter.

 

I used MSI Afterburner to create a graph of my GPU load:

 

attachment.php?attachmentid=153712&stc=1&d=1482102668

 

RUN 1:

 

You can see that for the whole duration of the Track-replay my GPU was maxed out, hence limiting the FPS I was getting.

 

RUN 2:

 

After the DCS restart, during replay of the very same Track, my GPU load was dropping every now and then.

At the end of the Track-replay DCS crashed with similar log errors like in the issue described in my first post (attached logs are of this crash after the track replay).

 

------------------

 

This issue is 100% reproducable on my end.

 

This issue is not reproducable in 2.0.

TestTrack.trk

GPULoad.png.0e206fac04a8f44d7acde8428bccb9d1.png

dcs2.zip

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to post
Share on other sites

One other thing I just noticed:

 

I downloaded the 1.5 Open Beta and installed the Mi-8 for a quick test. After 4-5 DCS restarts without any issues, I first assumed the Open Beta version is not affected by this problem.

 

However, I then downloaded and installed all my other modules to have the same testing conditions like in 1.5 Release and the problem re-occured....

 

I then tried to remove one module after the other to pinpoint the culprit causing this problem, however I couldn't pinpoint a module as there was no definate point where the problem stopped.

 

However, the fewer modules I had installed, the more DCS restarts I could perform without the problem occuring. As I returned back at one module, the Mi-8, the problem is pretty much gone, and I can restart the 1.5 OpenBeta a couple of times without the problem occuring.

 

I also realized, with only a few modules installed I did not have to restart my PC, as a DCS repair was enough to temporarily fix the problem and allow another sucessfull run of DCS...

 

This seems very weird to me. Maybe something staying in the memory causing a problem.

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to post
Share on other sites

Hi

 

thanks for the PM, this is an unusual one, We are testing internally for this issue, we hope it will be resolved in future patches.

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites
Hi

 

thanks for the PM, this is an unusual one, We are testing internally for this issue, we hope it will be resolved in future patches.

 

Thank you! If you need any more info or if you want me to try something, let me know! :thumbup:

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to post
Share on other sites
  • 2 weeks later...

Just to finish this up:

 

Setting the CPU affinity to more than one core got rid of the problem. :thumbup:

 

You can see that here: https://forums.eagle.ru/showthread.php?t=180025

 

The only question that remains is why DCS was set to only use one core. Over at reddit some people confirmed that their DCS was also set to only use one core instead of all, which is apparently the default for most people.

 

Maybe something the team can look into?

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to post
Share on other sites

That is interesting.

 

Is this System Over clocked?

This was a Boutique Builder iBuypower rig. Until I got the tinker bug again i7 920 @3.6Mhz 12Gig Corsair XMS3 ram 1600 Nvidia 760 SLi w/4Gig DDR5 Ram Intel 310 SSD HDD 160 Gb + Western Digital 4Terabyte HDD Creative SB X-Fi HD Audio Logitech X-530 5.1 Surround Speaker System Dual Acer 32"Monitors. PSU 1200 w Thermaltake Win10 64Bit.

Link to post
Share on other sites
That is interesting.

 

Is this System Over clocked?

 

Yes. However, this problem occured on a fresh windows install without any overclock applied. Downclocking to default values does not change anything as well.

 

It is the CPU affinity setting that causes this problem for me as well as several other users.

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to post
Share on other sites

Do you have some custom affinity management active? (or is it default for Intel) I think, or am pretty sure, DCS checks another process to find out how many cores/threads are available. If that process has the affinity set to 1 core/thread you end up having your issues i guess.

-

If man were meant to fly he'd be filled with helium.

Link to post
Share on other sites
Do you have some custom affinity management active? (or is it default for Intel) I think, or am pretty sure, DCS checks another process to find out how many cores/threads are available. If that process has the affinity set to 1 core/thread you end up having your issues i guess.

 

No, nothing like that. Happened on two fresh Windows installation with noting but necessary drivers installed.

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to post
Share on other sites
Hi John,

 

What bios are you running? Because the latest 1003 is very buggy, best go back to 901 or 801.

I also uninstalled AI+ Charger as that gave me blue screens as well.

 

Huub.

 

I updated to 1003 before installing Windows. Had some problems with the OC but got it working in the end. 1003 being buggy would explain that.

 

Damn you ASUS, great hardware, shitty software.

 

Not sure if that is related to the CPU Affinity Mask for a single program though.

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to post
Share on other sites
  • 5 months later...

Hi everybody,

 

Glad to join your community

 

Hello John, I have exacly the same problem as you : crash at second time and affinity mask problem.

 

On a very fresh install Windows 10 Pro 1703 x64, DCS world 1.5.6 and 2.1.0 as only softwares except for Eset Nod32 Antivirus 9 with Eagle Dynamics folders exclusions

 

Here the exact configuration :

 

Asus Rampage V Edition 10 (bios 1701)/ i7-6850k @4.4 / 16 Gb Ballistix 2400 / Asus Strix GTX 1080 x2 SLI / NVme SSD Samsung Pro 512 for Os & DCS / SSD Samsung Pro 128 for swap file

G-Sync 3440x1440

 

I precise I didn't install any asus sofwares

 

Also, I didn't have this problem with my previous configuration :

 

Asus X-99a / i7-5820k / Samsung Pro 512 (Sata but no NVme) with Windows 10 1607 and the rest all the same

 

I was pretty sure it was a Windows 10 Creator Update 1703 problem since I saw you post...

 

We have the same motherboard and almost the same CPU (Broadwell-E).

If I don't create an autoexec.cfg and set manually affinity mask, only core 0 is selected.

 

Same, if I set affiniy mask to 0, only the core 0 is selected

The strange thing is when I set affinity mask to 63 (all core with HT off in bios) game crash 9/10 time and when it launch and I start tasks manager, I see that only core 0 is selected.

 

The only way to play with all core activated is to set Hyper Threading ON and set affinity mask to 1365 (010101010101)

The problem is exactly the same for both versions : 1.5.6.5199 and 2.1.0.6002

 

The second strange thing is if I disable pagefile (swap memory) the game crash at startup and it wasn't the case with my previous configuration with the same amount of RAM.

 

I really don't understand... mystery, mystery.. lol

 

Sorry for my english

 

Cordially


Edited by paradox64

 

Asus Rampage V Edition 10 / i9-9900k @5Ghz / 32Gb DDR4 @3200Mhz / Samsung 960 Pro M.2 / RTX2080ti / Vive Pro / ROG 3440x1440

 

You maybe saw I often edit my post. I want to tell you it's to correct spelling cause I only speak english a little and sometimes it's quite unclear... so forgive me !

 

Link to post
Share on other sites

I precise because I hesitated, the difference between x99-A/5820k/SSD AHCI and R5e10/6850k/SSD NVMe is spectacular.

 

No stutters at all. A real pleasure.

 

But all that only with the affinity mask tweak.


Edited by paradox64

 

Asus Rampage V Edition 10 / i9-9900k @5Ghz / 32Gb DDR4 @3200Mhz / Samsung 960 Pro M.2 / RTX2080ti / Vive Pro / ROG 3440x1440

 

You maybe saw I often edit my post. I want to tell you it's to correct spelling cause I only speak english a little and sometimes it's quite unclear... so forgive me !

 

Link to post
Share on other sites
  • 2 weeks later...

Did tweaking the Affinity Mask fix the crash-on-second-launch issue? I have the same issue (on the same motherboard, which is kind of suspicious). I know ED is working on this one, but if there's a workaround, that would be nice to discover.

System Specs: Origin PC Genisis; Core i7 6950; 64 GB Corsair Dominator Platinum; Windows 10 Pro; 2x NVidia GTX 1080 Ti (SLI); Boot drive Intel 750 1.2 TB PCIe SSD; Game drive 4 TB Samsung 850 Evo SSD; Warthog; Dell UP 3216Q; Liquid Cooling

Link to post
Share on other sites

Yes, no problem at all with affinitymask at 1365 (HT = on on bios)

 

I created a autoexec.cfg in C:\Users\MYNAME\Saved Games\DCS\Config with this only line : affinity_mask = 1365

 

Sure it's a MotherBoard or a CPU architecture problem

 

Asus Rampage V Edition 10 / i9-9900k @5Ghz / 32Gb DDR4 @3200Mhz / Samsung 960 Pro M.2 / RTX2080ti / Vive Pro / ROG 3440x1440

 

You maybe saw I often edit my post. I want to tell you it's to correct spelling cause I only speak english a little and sometimes it's quite unclear... so forgive me !

 

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...