Jump to content

How do I make Ka-50 skins work?!


Cybermat47
 Share

Recommended Posts

Okay, so I recently made a new skin for the Blackshark using GIMP.

 

All textures are renamed, flattened, given an alpha layer, and given box mipmaps, just as in a working user-made skin I used for reference.

 

The description.lua file is, again, set up correctly according to the working user-made skin. Here it is:

livery = {
{"KA-50-lamp", 0, "KA-50-PAINT2_AS", false},
{"KA-50-PAINT1", 0, "KA-50-PAINT1_AS", false},
{"KA-50-PAINT1_M", 0, "KA-50-PAINT1_AS", false},
{"KA-50-PAINT2", 0, "KA-50-PAINT2_AS", false},
{"KA-50-PAINT3", 0, "KA-50-PAINT3_AS", false},
{"KA-50-PAINT4", 0, "KA-50-PAINT4_AS", false},
{"KA-50-PAINT5", 0, "KA-50-PAINT5_AS", false},
{"KA-50-PAINT6", 0, "KA-50-PAINT6_AS", false},
{"KA-50-Vtulka_met", 0, "KA-50-PAINT2_AS", false},
{"SOPLA_KA-50-PAINT3", 0, "KA-50-PAINT3_AS", false},
{"KA-50-gear-rubber", 0, "KA-50-PAINT5_AS", false},
{"KA-50_ST-rm_paint1", 0, "Ka-50_St_Paint1_AS", false},
{"KA-50_Lifting_rotor_mast", 0, "KA-50-LRMpart_AS", false},
{"KA-50_LRM_Part", 0, "KA-50-LRMpart_AS", false},
{"KA-50_LRM-CENTRE", 0, "KA-50-LRM_centre_AS", false},
{"KA-50-LRM_B", 0, "KA-50-LRM_B_AS", false},
{"KA-50_BORT_NUMBERs", 0, "empty", true},
{"KA-50_Turkey_Numbers", 0, "empty", true},
}
id = 10
name = "Abkhazian Support"
countries = {
"RUS",
}

 

Yet for some reason, the skin has the following issues:

 

- The skin does not appear in-game.

- The skin is listed as being available for all countries.

- The skin is listed in the mission planner, but the actual textures do not appear.

 

Please, I will be very grateful to anyone who can tell me what I'm doing wrong! :joystick:

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Please name the files/textures what you are using for your new skin.

Where did you put those files ? Into a zip file or where the description.lua is placed ?

(use "false" only for your new files if you put next to description.lua)

Show some screenshots of your (faulty) skin. A modelviewer or an in-sim image would be good.


Edited by NRG-Vampire

sign-pic4.jpg

Link to comment
Share on other sites

Please name the files/textures what you are using for your new skin.

 

KA-50-PAINT1_AS.dds

KA-50-PAINT2_AS.dds

KA-50-PAINT3_AS.dds

KA-50-PAINT4_AS.dds

KA-50-PAINT5_AS.dds

KA-50-PAINT6_AS.dds

Ka-50_St_Paint1_AS.dds

KA-50-LRMpart_AS.dds

KA-50-LRM_centre_AS.dds

KA-50-LRM_B_AS.dds

 

Where did you put those files ? Into a zip file or where the description.lua is placed ?

(use "false" only for your new files if you put next to description.lua)

 

I placed them in the same folder as description.lua, DCS World\Bazar\Liveries\ka-50\Russia Abkhazian Support.

 

Show some screenshots of your (faulty) skin. A modelviewer or an in-sim image would be good.

 

I'm afraid I can't do that. The skin does not load at all, which I believe is caused by an issue in description.lua.

 

Thank you for the assistance, by the way :)

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

I'm afraid I can't do that. The skin does not load at all, which I believe is caused by an issue in description.lua.

 

would be good to know how looks your deficient skin. it's important. (sometimes PS save/export able to screw up textures)

 

so is that the greenish missing texture on it ? or is it white/light gray, or maybe black/dark gray ?

 

or send me the texture files and I will fix it to you. ;)


Edited by NRG-Vampire

sign-pic4.jpg

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...