Jump to content

Bugs and Problems


baltic_dragon
 Share

Recommended Posts

Looks good now! I tried the other method to startup the aircraft without the IP's help and we were able to takeoff.

 

Didn't know the IP needs to taxi first but at that time I had no idea why he stopped at those S-3 Viking's before then. I hope these bugs get fixed fast because they create a lot of confusion and frustration at the first time for a brand new campaign.

Link to comment
Share on other sites

okay, I found the problem - I was turning too sharp after touch-and-go. Didn't reach the village. The communications went on after I reached the village ...

 

damn it

Glad you got it sorted! Unfortunately the mission editor is a bit limited when it comes to trigger zones and such. Maybe BD could enlarge it a bit to give more leeway.

 

Looks good now! I tried the other method to startup the aircraft without the IP's help and we were able to takeoff.

 

Didn't know the IP needs to taxi first but at that time I had no idea why he stopped at those S-3 Viking's before then. I hope these bugs get fixed fast because they create a lot of confusion and frustration at the first time for a brand new campaign.

The problem is that these types of bugs are mostly out of control of the mission designer. You can come up with workarounds and such, but with the current fast ED development cycle you never know when something unexpected will break your carefully planned interactions.
Link to comment
Share on other sites

Hey gentlemen,

 

Sorry to hear that you have all this trouble& glad to see most has been sorted out. Unfortunately many things are out of my hands when it comes to mission editor and as Gliptal says options are very limited. I strived to create a realistic experience, so I had to use unconventional ways to make the IP stop before entering the active etc. I am aware that this is quite fragile and prone to problems, however sticking to the instructions and remarks given in the main campaign post should help a lot. Now to concrete problems:

 

Do you remember how to trigger the actions in mission 2 ? I tried numerous time without success.

Can you tell me which channel shall be used to contact Colt ?

 

You should get to WP 2 (IIRC) where Colt is anchored and then try to get close to him, you will get an F10 menu option to proceed. Unless last update messed something with trigger zones (1.55 did). Let me know if it works, I know it is frustrating. I will also check it when I get back home.

 

okay, I found the problem - I was turning too sharp after touch-and-go. Didn't reach the village. The communications went on after I reached the village ...

 

damn it

 

Glad to hear it worked in the end. I can't stress enough how important it is to stick to given flight plan, speeds, distances etc - as it would be in real life military. First few missions are not challenging because of numbers of enemies. They are because they require you to handle lots of systems, radios and instructions at the same time. How it will be a smooth sailing from now on!

 

Looks good now! I tried the other method to startup the aircraft without the IP's help and we were able to takeoff.

 

Didn't know the IP needs to taxi first but at that time I had no idea why he stopped at those S-3 Viking's before then. I hope these bugs get fixed fast because they create a lot of confusion and frustration at the first time for a brand new campaign.

 

Make sure to carefully check all the briefing pages. They will tell you who leads the element - if it is you or the IP. Also check the initial remarks in main campaign thread and keep your spacing from the AI...And I agree it can cause confusion, hence the starting remarks which really are important!

 

Glad you got it sorted! Unfortunately the mission editor is a bit limited when it comes to trigger zones and such. Maybe BD could enlarge it a bit to give more leeway.

 

The problem is that these types of bugs are mostly out of control of the mission designer. You can come up with workarounds and such, but with the current fast ED development cycle you never know when something unexpected will break your carefully planned interactions.

 

Exactly. I spent several hours to fix things that got broken in 1.55, and I do unerstand that these things will happen with ambitious update circle. I am fine with that. I have two options - dumb the missions down a lot and go with something safer, but simple. Or keep trying to make them much more complex and interesting, risking additional problems. I'll stick with the latter - and hope you guys will approve it and bear with me :thumbup:

 

Now as for ME options during taxi, these are extremely limited at the moment, so I needed to come up with a few workarounds. They are working quite well (apart from the wingman-refuses-to-taxi bug, which is out of my hands). But aplease continue to report anything you find.

 

Now good news is that since this is not a DLC I will be able to fix missions and post them here for you to download and replace manually in the campaign folder before they get to official update. But so far it seems there is not much to fix from my side!

 

And thanks for your answers here, Gliptal. Gliptal knows the campaign inside-out and added a lot of good ideas / content to it!

ce535d_9d347b62819c4372b3c485a4f95d2004~mv2.png
Link to comment
Share on other sites

Just finished mission 4 but didn't really finish it. Said 60 percent complete but never got prompted to merge with the L-39's. Intercepeted the transport and was told to go back to waypoint 3 which I did, with no prompts. Decided to go to wpt 4 which put me across the ACL and was told to turn around. Went to F10 and found the L-39's and joined up on them as well. No prompt. Tried different green and red freqs as on the brief still nothing. Decided to go thru the rest of the waypoints, no joy. Looked to join up on the tanker, no tanker airborne and not available via communication that was on the briefing. Here's a link to the flight recorded on twitch.

Look at past broadcast Mission 4 Radar look at 40:19 and on

That's odd, I can't see anything wrong. I've checked and we've never seen this problem during testing either.

 

Would you mind reflying it, to see if it happens again? Might be an heisenbug.

Link to comment
Share on other sites

How it will be a smooth sailing from now on!

first mission was a real stumbling block, huge pain :)

but after that, 4 missions in a row went on a high gear :P real smooth sailing

complete immersion

I especially love that I don't need to enter frequencies by myself, those presets !!

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

That's odd, I can't see anything wrong. I've checked and we've never seen this problem during testing either.

 

Would you mind reflying it, to see if it happens again? Might be an heisenbug.

 

Looks like running the mission again worked until the unknown merge, DCS crash but.....Tanker was avail and L-39 merge occurred.

on

Link to comment
Share on other sites

Having trouble with Mission 9, Pontiac 1-1 doesn't seem to even start up his engine. I confirm ready to roll, he says he's rolling, then as I taxi towards the runway there's some banter about the Tornados and F-16s, but he's still chillin in his hanger with RPM at 0%.

 

Dying to get back into this campaign! I love it!

Link to comment
Share on other sites

Having trouble with Mission 9, Pontiac 1-1 doesn't seem to even start up his engine. I confirm ready to roll, he says he's rolling, then as I taxi towards the runway there's some banter about the Tornados and F-16s, but he's still chillin in his hanger with RPM at 0%.

 

Dying to get back into this campaign! I love it!

Seems like the startup bug affecting 1.5.5: try and request the ingame ATC the permission to startup as quickly as possible.
Link to comment
Share on other sites

Hey gentlemen,

 

Do you remember how to trigger the actions in mission 2 ? I tried numerous time without success.

Can you tell me which channel shall be used to contact Colt ?

 

You should get to WP 2 (IIRC) where Colt is anchored and then try to get close to him, you will get an F10 menu option to proceed. Unless last update messed something with trigger zones (1.55 did). Let me know if it works, I know it is frustrating. I will also check it when I get back home.

 

 

I flew to WP1 then turn and climb to WP2 at 16000 feet. There I reached Colt and stay with them for an entire circle, I was quite close but nothing triggered.

 

I asked the ATC the permission to startup/rolling/take-off before switching to CH3 just after airbone, is it a problem ?

 

 

Hey gentlemen,

And thanks for your answers here, Gliptal. Gliptal knows the campaign inside-out and added a lot of good ideas / content to it!

 

Thanks to both of you to take time to help us :thumbup:.

Link to comment
Share on other sites

Every mission comes with all the necessary information, that is great :)

 

But something caught my eye in mission 2 (I haven't paid attention to that in 1 to be honest), the METAR mentions QNH1009 (1009 mbar), but in the briefing the QNH is 31.10 (in Hg) or 790 Torr which corresponds to 1053 mbar. Though UG27 is the ICAO code for Viziani, so it's the same airfield.

 

I can't interpret most of it anyway so it's probably just me, however it seems it's the METAR of another mission. The "SCT099" is "Scattered clouds at 9,900 feet", but in the briefing it says the base is at 3300 ... ft? or are those meters? I know that DCS has bugs with mixing both imperial and metric units on the map and perhaps in the brief panel, but in this case the conversion doesn't match either.

 

There's a "299/04", but there is no runway 29 so it must be something else, I'm not sure what, it's not temperature and dewpoint either (or 299 in °K?).

 

 

EDIT: I must set 1045 mbar for the altitude to match what is shown on the map for my aircraft, I've already noticed those discrepencies in 2.0, so this part is probably a DCS issue, or perhaps I misunderstand the data given in the brief panel (I suppose that for this mission the weather is the same for the whole map, since it is version 1.5.x).


Edited by Redglyph

System specs: Win7 x64 | CPU: i7-4770K | RAM: 16 GB | GPU: GTX 980 Ti 6 GB | Thrustmaster HOTAS | MFG rudder pedals | SATA3 SSD | TrackIR

Link to comment
Share on other sites

Yes the METARS might be slightly off. Most of the DCS auto-briefing's units are also in meters (for some reason).

 

"299/04" is the wind (299° for 4 knots).

 

It's a bit more than "slightly" ;) But yeah, if you select metrics in the general options, then it's a mix of both, and in the ME it's even more confusing because some units must be in meters. It could also be interesting to get mbars on the briefing panel (I know that's handled by DCS), but the conversion is easy enough. I'm always slightly off, though, it's weird.

 

Now that you mention the wind for the METAR, it seems obvious :D Thanks!

 

 

 

I've got something else, but I do feel a bit silly. During mission 2, Colt 1-1 says "The shooting takes place 5 miles to the North from the following coordinates: N 42 42 3, E 44 43 15.", and I assumed that was the destination. But it's quite far and I'm not sure how the guy could have spotted fire there, on the other side of the mountains, more than 50 nm away. On the map, a much closer location contains ground units, I suppose it's there, but the coordinates are entirely different.

 

What am I missing with those coordinates? :huh:

System specs: Win7 x64 | CPU: i7-4770K | RAM: 16 GB | GPU: GTX 980 Ti 6 GB | Thrustmaster HOTAS | MFG rudder pedals | SATA3 SSD | TrackIR

Link to comment
Share on other sites

Nice catch. The coordinates might be simply wrong, they should point to the shooting going on below you. The mission was mostly tested when the INS was still non-functional, so nobody thought of punching those coords in and cheching they pointed at the right place. It may also have been a typo in the script.

 

EDIT: Heh, sniped.

Link to comment
Share on other sites

After complete mission 1 with score 100, campaign don't want me take to mission 2.

 

Now that is really weird, no idea how that could happen.. there is no mission branching, so it should take you directly to M2.. I will try to see the structure, but nobody else had this kind of a problem I think... if anyone had, let me know!

ce535d_9d347b62819c4372b3c485a4f95d2004~mv2.png
Link to comment
Share on other sites

Having trouble with Mission 9, Pontiac 1-1 doesn't seem to even start up his engine. I confirm ready to roll, he says he's rolling, then as I taxi towards the runway there's some banter about the Tornados and F-16s, but he's still chillin in his hanger with RPM at 0%.

 

Dying to get back into this campaign! I love it!

 

This is the taxi problem which is out of my hands.

 

A workaround:

 

Open the mission in mission editor (bucking it up beforehand). Take Pontiac 1-1 and move him to different spot or even make him start on the runway. It should not ruin anything in the mission and let you move forward.

ce535d_9d347b62819c4372b3c485a4f95d2004~mv2.png
Link to comment
Share on other sites

I flew to WP1 then turn and climb to WP2 at 16000 feet. There I reached Colt and stay with them for an entire circle, I was quite close but nothing triggered.

 

I asked the ATC the permission to startup/rolling/take-off before switching to CH3 just after airbone, is it a problem ?

 

Thanks to both of you to take time to help us :thumbup:.

 

Hey, did you manage to solve your problem and get through M2?

ce535d_9d347b62819c4372b3c485a4f95d2004~mv2.png
Link to comment
Share on other sites

I flew to WP1 then turn and climb to WP2 at 16000 feet. There I reached Colt and stay with them for an entire circle, I was quite close but nothing triggered.

 

I asked the ATC the permission to startup/rolling/take-off before switching to CH3 just after airbone, is it a problem ?

 

 

 

 

Thanks to both of you to take time to help us :thumbup:.

 

Did you get any dialogue when flying above Kutaisi? I think this one: "[PLAYER] Colt. Pontiac. Overhead TACAN station in Kutaisi, turning to follow outbound radial 18."

 

The first time I flew close, but not close enough, and nothing triggered after, I also did some flying in circles with the rest of the flight as you did ;) Then I got back and tried to fly more precisely above the TACAN, and sure enough, I got this message out, and it worked from that moment on!

 

EDIT: nevermind, I see your problem is happening before that. Still, I'm leaving my comment here in case someone stumbles on it later.

 

Did you use the F10 menu, once at WP2?


Edited by Redglyph

System specs: Win7 x64 | CPU: i7-4770K | RAM: 16 GB | GPU: GTX 980 Ti 6 GB | Thrustmaster HOTAS | MFG rudder pedals | SATA3 SSD | TrackIR

Link to comment
Share on other sites

I got nothing at WP2, no F10 menu.

Maybe I'm following the wrong trajectory, I went to WP1 then turned to WP2, depending on how long I take too start up Colt is at WP2 or somewhere else on is circle.

 

Is there a solution to change/understand the trigger myself in the mission editor.

Link to comment
Share on other sites

Let me have a look at the mission tonight, we will find a solution. Also, if you have a track from mission please post it. Finally, IIRC trigger zone is linked to Colt so try to find him (visually or using the radar) and get close to him.

 

Thanks a lot, I will do the mission again and post the track.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...