Jump to content

A bunch of 1.5.5 problems, stuck loading screens, exploding tyres, missing mouse etc


Recommended Posts

Hello all.

 

This has been by far the worst update experience I have had in DCS.

 

- Upon updating, the game would constantly crash on start. Disabling all mods, doing a repair and then re-applying the mods fixed the problem.

 

- The mouse cursor keeps disappearing (everyone has this). Its specially problematic in non-FC3 aircraft where you dont map every single key and fiddle around in the cockpit. I have noticied that if I do not chat at all, I get to keep the mouse pointer longer. Also, if I do not die, I get to keep it longer. (hopefully thats not intentional as I am very chatty and very killable :)

 

- Random crashes constantly. I keep getting crashes every few minutes. Its almost impossible to play a full hour without the game crashing. Where before it was perfect.

 

- Ground movement jerkiness. I am getting some jerkiness from what I assume is the physics engine when on the ground. This is very noticeable on the Mig29 and Su27. Better modeled aircraft seem to hold on better, but I believe it might be the dampening code from the landing gear simulation making it smoother. The mig21 and the A10 seem to be much more smooth than the other aircraft.

 

- Exploding tyres. On takeoff I am getting my tyres exploding constantly. I get it more often on Mig21 and Su27 where at the moment its almost guaranteed that the tyres will blow out on takeoff. Some suggested that I was pulling back on the stick too early, but rolling down the runway will also cause tyres to blow out. Hopefully this will be fixed soon.

 

 

PS: the graphics seem to look better with this update. Or maybe thats just me. Also it seems to run smoother. I have GTX 680, 16GB ram and a intel i5 3550 by the way.

 

Thank you,

Joao

Proud owner of DCS: FC3, A-10C Warthog, F-14A/B Tomcat, F-5E Tiger, Mig21bis Fishbed, Mirage 2000C, Nevada Test Site, Normandy, Ka-50 Black Shark, Mi-8MTV2 Magnificent Eight, UH-1H Huey, SA342 Gazelle, Bf 109 K-4 Kurfurst, FW 190 D-9 Dora, Spitfire LF Mk. IX, P-51D Mustang Combined Arms, Hawk T.1A, L-39 Albatros, NS 430 Nav System, F-86F Sabre, MiG-15bis, AV-8B Night Attack V/STOL, F/A-18C Hornet, Yak-52 and the mighty AJS-37 Viggen! :music_whistling:

Link to post
Share on other sites

The first point you make is not the fault of DCS World. If you try and update without first disabling all mods, then running a repair BEFORE you start the update, then you are bound to encounter issues. ED simply has no control whatsoever in how the mods change the files present, and there is bound to be problems, so you need to change the way you approach updating.

 

It may also account for the random crashes you still get, as you didn't start with a clean copy of DCS World to begin with.

 

I have had no issues at all, and have a stable product, so it may be that you'll now need to start with a fresh install to rule out file corruptions as a possible cause.

 

Are the jerkiness issues not related to frame rates? the load is far higher on the ground, and it may simply be that. The last paragraph backs this up I think?

Link to post
Share on other sites

I have to admit I experienced yesterday the very first tyre blow-out in MiG-21 since the release of the module (all three of them!), even though, as checked on the replay, the rotate and liftoff speeds were below limitations mentioned in the manual.

 

The only mods I use for this plane are related to FoV, hint localizer and cannon sounds, so they shouldn't affect gear physics I guess. Will obviously test unmodded later. Whether it's a plane or DCS related problem, remains to be tested and seen. I'd think the former, but If someone notices the same on Su-27, maybe it's the latter?

i7 9700K @ stock speed, single GTX1070, 32 gigs of RAM, TH Warthog, MFG Crosswind, Win10.

Link to post
Share on other sites
I have to admit I experienced yesterday the very first tyre blow-out in MiG-21 since the release of the module (all three of them!), even though, as checked on the replay, the rotate and liftoff speeds were below limitations mentioned in the manual.

 

The only mods I use for this plane are related to FoV, hint localizer and cannon sounds, so they shouldn't affect gear physics I guess. Will obviously test unmodded later. Whether it's a plane or DCS related problem, remains to be tested and seen. I'd think the former, but If someone notices the same on Su-27, maybe it's the latter?

 

 

I had never experienced a tyre blowout before. But now it has happened in the Hawk, F5, and I think in the F86. Whew!! I thought I had developed a bad habit on takeoffs or something.

 

:joystick:

Link to post
Share on other sites

i can confirm all the bugs listed by SilentWarrior except the game crashing.

I used to play with the mirage 2000 and since the last update i always experience the mouse cursor bug which is absolutely annoying not only if i want to interact in the cockpit but also when I just want to quit the game!!

 

Terrible update.

Link to post
Share on other sites

I have the opposite problem with my cursor. In single player, after Esc out to make adjustments, when I resume, the cursor is still where it was when I hit OK after making the adjustment. I can still move it with my mouse, so I just put it in a corner where it doesn't distract me. I've only had time to try the A-10A and the Su25A. Tomorrow I'll try the Su27 and the 33.

MJ

msi Z170A MB, i7-6700k @ 4.0GHz, 32GB DDR4

GeForce GTX 970 4GB, Samsung 850 EVO 500 GB

Acer Predator Z271, 650w PSU, Corsair Carbon500R, MS FFB 2

Link to post
Share on other sites
I just picked up the F-5 and upon my 1st takeoff in it, blew both my rear tires. Something indeed does seem off about this behavior since the update.

 

Or something wrong with the way you take off, which wasn't visible before the tyre parameters were made more accurate possibly?

 

It is always assumed that the changes are for the worse just because they're appearing now. Have you ruled out over speed on the ground as a possibility?

 

I'm not suggesting this is the case, but has it been ruled out before a bug was declared?

Link to post
Share on other sites

Well,

 

I can totaly confirm the exploding tire. I had it happend within the F-15, Su-27 and now the A-10C too.

 

The disappearing Mousecursor is......yea.....not funny :(

My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

Link to post
Share on other sites

Yeah, having these problems too, plus I can no longer connect to multiplayer servers.

 

I downgraded to 1.54. and connected with no problem on 104th. Then immediately upgraded to 1.5.5 without doing ANY changes to my Windows, other apps or anything, but after having updated the game I can no longer connect to servers. :( Sometimes I wonder if it's really worth all the problems.

Link to post
Share on other sites

The servers you are trying to connect to have to be running the same version of DCS World as yourself.

 

It is simply a fact that a lot of servers like to run as stable a version of DCS World as they can, which means they delay applying updates for quite a long time.

 

You are not having trouble connecting to servers at all, you are simply trying to connect to incompatible ones.

Link to post
Share on other sites

uh1h campaign, got screwed up. every once in 2 or 3 missions, triggers dont work properly. and everytime i had to quit the game open the mission in mission editor and find and change the broken triggers and play the same mission allover again.

oh and the patch deleted my campaign progress.

EDIT: I dont have any mods installed.

Link to post
Share on other sites

I'm really curious as to what could be causing the tire blowouts for some people.

 

I've taken off as I usually do in the F-5, Su-27, and MiG-21 since the update, which means pulling full aft stick shortly before predicted nose wheel liftoff speed, then holding the nose at a certain angle until the mains unstick.

 

In the F-15 you should pull half stick at 130 kts then hold the W between the 10 and 15 degree lines. It's what they do IRL, and it works damn well in the sim. I often see people with the nose still down while accelerating through 200 knots, which may not blow the tires but they sure won't be happy.

DCS modules are built up to a spec, not down to a schedule.

 

In order to utilize a system to your advantage, you must know how it works.

Link to post
Share on other sites
The servers you are trying to connect to have to be running the same version of DCS World as yourself.

 

They are. If they weren't I wouldn't be able to see them in the list. With 1.5.4 I can only see that 104 server that is basically empty and a few locked private servers, but in 1.5.5 I see 121 servers. I try the ones where it says latest patch 1.5.5 and fail, can't connect.

 

In 1.5.4 I can connect, but a few minutes later in 1.5.5 I can't. Thus the problem can not be with my computer or any of my apps, but with the patch.

 

I also tried deleting my Saved Games/DCS folder, but same result.

Link to post
Share on other sites

Are you certain you can't see 1.5.4 servers under 1.5.5? They are the same version, but a slightly different build.

 

We were running 1.5.5 on our usual mission night last night, and we didn't have a single server issue under 1.5.5.

 

The issue is your end, not the update. Did you do a clean update with no mods installed? That usually lays behind problems that are not universal.

 

I always uninstall all mods, then repair, then update.

Link to post
Share on other sites

I never installed any mods whatsoever and I am having the same issues. It is not his mods.

 

Specific issues that are outstanding are the disappearing mouse which also leads to no backslash radio menu which renders the game unplayable in clickable modules.

 

The extent of my experience in 1.5.5 is the KA-50 as I sat down and convinced myself to finally learn the module shortly before.

 

side note: I don't understand why some people are so quick to try and pin the bugs on the user; especially after a substantial update.

Link to post
Share on other sites

Just because you have no mods installed and are experiencing known and reported issues doesn't mean that others have not experienced them. Mods are always going to be problematic during the upgrade process because they are not tested by ED when they chase bugs - they are 3rd party add ons that can, and often do get borked by updates.

 

And as the bug in question relates to joining servers - which isn't a know universal bug, but affects only a few users, then the obvious place to start looking for a fix is to check out the individual installation. The biggest variable (apart from hardware which is a bit expensive to swap just to find bugs) is to look at non-standard files in the install, and eliminate them as a cause.

 

It clearly won't help with bugs that affect everyone, but the majority reported turn out to have causes like (this time at least) uninstalling the TF-51D, or updating without uninstalling mods.

 

Does that clear up why mods are suggested as a possible cause?

Link to post
Share on other sites

- I did disable all mods, applied update, re-enabled all mods. It would crash constantly, so then I disabled all mods again, did a repair and re-applied. Some sound mods were causing crashes on startup so i disabled those and it started to work again. Now, i have re-applied the sound mods and they work perfectly. (Devrim sound mods for example)

 

- I am experiencing tyre blowouts on every aircraft. I tested last night all the airplanes I have except for the choppers. And they all blow tyres.

 

The one I have had most luck with is the Mirage 2000. It seems to be the most stable. The F-5, F15 and Su27 seem to blow tyres on almost all takeoffs.

 

I have tried very shallow highspeed landings with Mig21 and Mirage without tyre blow out.

 

When the tire blows, I have to pull hard back, hard left or hard right depending on what tire blows. If I instantly do that to remove weight off that wheel I will get a damage landing gear that wont come up completely.

 

 

As far as disapearing mouse problem. Its not a problem of very few people. Nearly everyone is complaining on multiplayer servers. This cant be a single users problem as suggested.

 

 

To my non-programming folk: computers are not made of magic. Everything has a cause related to some piece of code. Bugs are just that, code that is behaving how it was written but not how the programmer intended it to be written. Thus, those bugs can be fixed with finding the faulty piece of code.

 

Normally, the faulty piece of code is not code that already exists but its code that is missing to handle some specific combination of events.

 

Cleaning your game, doing a repair, uninstalling modules one by one over and over again, calling Professor Magungo and asking him to do some voodoo dance so your game will fix itself wont really work.

 

A specific case where the game consistently fails to act like it should must be found and then properly debugged. I know closing your eyes and blaming the users is easier but wont fix the problem.

 

 

PS: Made a quick list of all problems reported in this thread :

 

1 - Mouse disapearing. Opening the chat window to write something causes the bug at least 70% of the time. Sometimes mashing control+tab for opening and closing the chat window will cause the mouse to come back. Probably an IF statement that is too loose or an event/action that is failing to be executed on time.

 

2 - Comms menu (the slash key) will sometimes also not appear, this has happen to me a on few ocasions but I assume, not as constantly as the disapearing mouse, since its a less used feature than the mouse, even if the problem happens consistently, it wont get noticied as much.

 

3 - Exploding tires, specially the front tire. Possible solution, smooth out spikes in rudder controller input such that it wont cause the front tire to rotate more than it should. If exploding back tires are being caused by wrong rotation speed, and is as intended, keep the "bug". This happens on takeoff slight underspeed and slight overspeed and anywhere in between.

 

4 - Ground movement jerkiness. I am getting some jerkiness from what I assume is the physics engine when on the ground. This will worsen the exploding tires problem.

 

5 - Random crashes. Cant really help you there as crashes are super destructive events that can stem from many varied problems. Sometimes even an malformed internet packet.

 

6 - FalconPlot16 has also reported that KA50 ABRIS search function no longer works (I havent tested this)

 

7 - Kylekatarn720 reports that in the UH1H campaign, every once in 2 or 3 missions, triggers wont work. Also, that the patch has erased the campaign progress. (did not test)


Edited by SilentWarrior

Proud owner of DCS: FC3, A-10C Warthog, F-14A/B Tomcat, F-5E Tiger, Mig21bis Fishbed, Mirage 2000C, Nevada Test Site, Normandy, Ka-50 Black Shark, Mi-8MTV2 Magnificent Eight, UH-1H Huey, SA342 Gazelle, Bf 109 K-4 Kurfurst, FW 190 D-9 Dora, Spitfire LF Mk. IX, P-51D Mustang Combined Arms, Hawk T.1A, L-39 Albatros, NS 430 Nav System, F-86F Sabre, MiG-15bis, AV-8B Night Attack V/STOL, F/A-18C Hornet, Yak-52 and the mighty AJS-37 Viggen! :music_whistling:

Link to post
Share on other sites
Are you certain you can't see 1.5.4 servers under 1.5.5? They are the same version, but a slightly different build.

 

We were running 1.5.5 on our usual mission night last night, and we didn't have a single server issue under 1.5.5.

 

The issue is your end, not the update. Did you do a clean update with no mods installed? That usually lays behind problems that are not universal.

 

I always uninstall all mods, then repair, then update.

 

Aerobatics Online that I see has this disclaimer: "Aerobatics Online Server - 1.5.5 Updated mission for current version." It's actually the server I most want to fly on. Can't connect.

 

I always disable all mods when updating, updated and even tried repair option.

 

EDIT: for some reason when I disable TF-51 and other modules I can't enter the server browser anymore. It shows me the login window, but nothing happens when I press the arrow to login and when I try to go into the module window it shows me the mission loading screen and freezes at something like 15%. Nothing happens then.

 

I'll try disabling TF-51, see if it brings anything.

 

Oh hell, I might even try to disable all modules and reinstall the entire game while I'm at it. :(


Edited by tovivan
Link to post
Share on other sites

Or just downgrade to 1.5.4 and play with the other kids who've rolled back until ED fixes it.

[sIGPIC][/sIGPIC]

 

Commodore 64 | MOS6510 | VIC-II | SID6581 | DD 1541 | KCS Power Cartridge | 64Kb | 32Kb external | Arcade Turbo

Link to post
Share on other sites

Just as a sidenote, disabling/removing TF-51D and/or Su-25T will usually cause various stability issues in unforeseen scenarios. They're considered to be part of the core game and must be installed and active whether you use them or not.

i7 9700K @ stock speed, single GTX1070, 32 gigs of RAM, TH Warthog, MFG Crosswind, Win10.

Link to post
Share on other sites
Just as a sidenote, disabling/removing TF-51D and/or Su-25T will usually cause various stability issues in unforeseen scenarios. They're considered to be part of the core game and must be installed and active whether you use them or not.

 

Yes, I can definitely confirm disabling TF-51 causes some stability issues. Like major. For example game not loading module manager and so on.

 

I reinstalled the entire game without any mods or modules, deleted saved games directory and so on, still same problem. It can't be anything on my computer's side because 1.5.4 works flawlessly and if it was my computer at fault then it wouldn't work either.

 

I rolled back to 1.5.4 in hopes that maybe, someday ED fixes this and I'll be able to fly online again.

Link to post
Share on other sites

I've never had, nor complained of any performance issues, stutters, stoppages, poor frame rates, etc with my computers running DCS World. Every new update has so far been a great improvement in every way beginning with ver 1.2.... until now. Release version 1.5.5 is giving us fits with this new occasional stuttering issue. I can't seem to determine what is happening at the time of the stutters, before I could always attribute a stutter to something going on in the game like before when the CBU's were causing massive slowdownd. Now my game and others in our Squadron seem to have these frequent stutters in multiplayer.

 

I've not made any changes to my system or server since 1.5.4 where this problem did not exist.

 

I hope this general issue is diagnosed and repaired by ED soon as the sim is getting to be frustrating to play for me, for the first time ever and I can't see a reason or cause for these to be happening. They seem to be oh so random, intermittent and frequent.

CPU: i7 980x @ 4.2GHz RAM: 24gb Corsair Vengeance

MB: Gigabyte Sniper X58 w/onboard Soundblaster X-Fi

HD: SanDisk 480gb SSD OS: Win7 Pro 64bit

VIDEO CARD: EVGA GTX 980ti FTW

MONITOR: LG 34" Ultrawide 2560x1080

MP SERVER: ibuypower i7-4810MQ w/Win7 Home 64bit

GEAR: Saitek X-52 Pro; Combat Rudder Pedals; Throttle Quadrants. Thrustmaster MFD's, TrackIR 5 w/Pro Clip, Turtle Beach X-12 Headset

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...