Jump to content

Need help configuring OpenTrack


Recommended Posts

After getting fed up with using the 3DOF EDtracker, especially having to calibrate it every time I connect it, I bought HAV's excellent UTC https://forums.eagle.ru/showthread.php?t=159647

 

My PS3 Eye picks it up no problem but I'm having issues with Opentrack generating X, Y, Z output when only yawing or pitching my head. I've done the calibration routine in OT as shown here

but that hasn't helped.

 

I've uploaded a video showing the problems. After centering, I yawed left and right, then pitched up and down, then rolled left and right.

 

The camera is on top of my monitor, so a bit above my head but I imagine most people have it there and with pits with large screen TVs the camera would be even more above the pilot's head than mine is, so I wouldn't have thought that could be the problem.

 

I've attached screenshots of my settings along with my OT config file in case it's easier to examine that. If anyone could assist me I'd be grateful.

 

attachment.php?attachmentid=151156&d=1478383686

 

attachment.php?attachmentid=151157&d=1478383686

DCS (Pointtracker).ini.txt

Main rig: i5-4670k @4.4Ghz, Asus Z97-A, Scythe Kotetsu HSF, 32GB Kingston Savage 2400Mhz DDR3, 1070ti, Win 10 x64, Samsung Evo 256GB SSD (OS & Data), OCZ 480GB SSD (Games), WD 2TB and WD 3TB HDDs, 1920x1200 Dell U2412M, 1920x1080 Dell P2314T touchscreen

Link to comment
Share on other sites

Thanks Len62, I tried your config but after calibrating I still have similar problems with incorrect axis output. I can't get OBS to work at the moment, so couldn't make a video but will reboot and try again ASAP.

 

I noticed that the settings from the custom tab are copied to the clip tab automatically (other than the -5 X settings which aren't available on the clip tab) so I'm not sure how OT decides which settings to use. Maybe it uses the settings from the last selected tab.


Edited by doveman

Main rig: i5-4670k @4.4Ghz, Asus Z97-A, Scythe Kotetsu HSF, 32GB Kingston Savage 2400Mhz DDR3, 1070ti, Win 10 x64, Samsung Evo 256GB SSD (OS & Data), OCZ 480GB SSD (Games), WD 2TB and WD 3TB HDDs, 1920x1200 Dell U2412M, 1920x1080 Dell P2314T touchscreen

Link to comment
Share on other sites

I noticed that the settings from the custom tab are copied to the clip tab automatically (other than the -5 X settings which aren't available on the clip tab) so I'm not sure how OT decides which settings to use. Maybe it uses the settings from the last selected tab.

 

I had not noticed that, probably because I don't use the custom tab, but it is interesting. I won't be available for the next day or so. If you get the video done I would be glad to take a look at it. Also, a pic of your mapping and accela filter settings. (Edit) I took a quick look at my PT settings and the custom tab shows all zeros, maybe if you try the clip tab you should set the custom settings back to zero.


Edited by Len62
Link to comment
Share on other sites

Sorry for the delay, I had some trouble getting OBS to work again.

 

I've uploaded a new video using your settings here

 

It seems I was wrong about the settings being copied from the Custom to Clip tabs automatically, they just happened to coincide it seems as I zeroed the Custom settings and the Clip settings remained.

 

I recalibrated at 1:20 but still have the same problem with lots of X,Y,Z output on Yaw and Pitch movements. In fact, when I pitch up I only get Z output!

 

I tried to show the mappings from about 3:25 but the screen got clipped by OBS so ignore that part. You can see what's happening from the data output numbers on the main screen anyway.

Main rig: i5-4670k @4.4Ghz, Asus Z97-A, Scythe Kotetsu HSF, 32GB Kingston Savage 2400Mhz DDR3, 1070ti, Win 10 x64, Samsung Evo 256GB SSD (OS & Data), OCZ 480GB SSD (Games), WD 2TB and WD 3TB HDDs, 1920x1200 Dell U2412M, 1920x1080 Dell P2314T touchscreen

Link to comment
Share on other sites

Certainly the calibration doesn't put the red centre cross in the centre of my head!

 

If I manually input -70, 20, 0 for the calibration settings that puts it roughly where it should be but the calibration gives me -15, 711, 292, which puts it way above my head.

 

Even using manual settings it doesn't work properly though, with yaw also producing roll and pitching also producing X, Y and Z.

Main rig: i5-4670k @4.4Ghz, Asus Z97-A, Scythe Kotetsu HSF, 32GB Kingston Savage 2400Mhz DDR3, 1070ti, Win 10 x64, Samsung Evo 256GB SSD (OS & Data), OCZ 480GB SSD (Games), WD 2TB and WD 3TB HDDs, 1920x1200 Dell U2412M, 1920x1080 Dell P2314T touchscreen

Link to comment
Share on other sites

A couple of things to look at. On the PointTracker tabs under camera go to the point settings and adjust the pixel size so they display around 7 or 8 pts, set the min to 4 and the max to 15 (at :33 in your video you can see 2 points merging which screws up the tracking). Next, on the model tab for the clip you have to measure your clip and enter the correct dimensions, you are using the default measurements. On the options, camera tab uncheck "Use Camera Center as Translation Offset". Your center head position does look to be way off the mark. Take a look at this short video:

and this one:
I'll get back with you later, I want to take another look at your mapping settings.
Link to comment
Share on other sites

OK, I'm officially a dumbass!

 

Turns out I had the clip attached upside down, so the short leg was at the bottom instead of the top. I guess I thought it should go this way as otherwise the LED is on the inside and hard to see but it only lights up when charging anyway, not when switched on, so I don't really need to see it.

 

The dimensions of the UTC are pretty much the default TrackIR settings, except for the -5 on the Z axis, as shown here http://s25.postimg.org/qq7ych3vj/ftn2.jpg so I think I had the right dimensions on the clip tab. Now I've got the clip the right way up, I've gone back to using the custom tab though, as it makes sense to use the exact dimensions.

 

It's working much better now thanks. I've recorded two videos, the first with "Use camera center as translation effect" ticked and the second with it unticked but I don't think there's much difference. There's still a bit of crosstalk between the axis (I tested in this order: yaw, pitch, roll, Z, Y, X) but it's much better than before.

 

 

 

I've had to mount the clip pointing up towards the camera as otherwise the top and middle LEDs were merging when I looked down. The calibration is still weird, as it now has the center of my head off to the right of my right ear where the clip is mounted. A friend told me they had trouble calibrating with OT, so did it with FTNoIR and just copied the numbers across, so I'll try that and see if that comes up with the right settings.

 

EDIT: The FTNoIR calibration settings were a bit different but still put the center cross to the right of my head. I found that your mappings had been wiped due to me opening your config in an older version of OT though and now I've restored them there's a lot less crosstalk between the axis. I'll record another video showing the current results,


Edited by doveman

Main rig: i5-4670k @4.4Ghz, Asus Z97-A, Scythe Kotetsu HSF, 32GB Kingston Savage 2400Mhz DDR3, 1070ti, Win 10 x64, Samsung Evo 256GB SSD (OS & Data), OCZ 480GB SSD (Games), WD 2TB and WD 3TB HDDs, 1920x1200 Dell U2412M, 1920x1080 Dell P2314T touchscreen

Link to comment
Share on other sites

The red cross should be to the right if you wear the clip on the right, the image is reversed. Make sure on your mappings that you have some deadspace set for each axis, you need to experiment with how much, but it can help with the crosstalk. Finally, if you use the Camera Center as Translation setting, you can adjust the settings to compensate for camera location. Can you try mounting the clip on the left side?

Link to comment
Share on other sites

Ah OK, if the red cross is mean to be there that's fine. I can't really fit the clip to the left of my headphones as I have my mic there and my PC is on the left, so I need the mic lead to be as well but it doesn't really matter.

 

It's really working pretty well now with your mappings now that I've got it the right way up, as you can see in this video

 

The main remaining crosstalk is on the Z axis when doing some other movements but maybe that's caused by having my camera quite high and having to point the clip up at it. Perhaps I can use the Camera offset settings to help with that. I only got Z output when moving in the Y axis but I see you have a large deadzone in the Y mapping, so I probably just need to reduce that.

Main rig: i5-4670k @4.4Ghz, Asus Z97-A, Scythe Kotetsu HSF, 32GB Kingston Savage 2400Mhz DDR3, 1070ti, Win 10 x64, Samsung Evo 256GB SSD (OS & Data), OCZ 480GB SSD (Games), WD 2TB and WD 3TB HDDs, 1920x1200 Dell U2412M, 1920x1080 Dell P2314T touchscreen

Link to comment
Share on other sites

I don't generally move in the Y or Z axis in game. I use zoom for the Z and don't worry about the Y. There are some more changes being incorporated into OpenTrack but no new preview/release version yet. I think there is still a link at the GitHub site for doing the camera offset settings, there was a link embedded in OT but it was removed a couple of versions back. Just checked the OT wiki and the link has been removed. Basically, you start OT with Center on Startup unchecked, then open the camera offset tab and manually adjust the numbers until the main readout shows 0 for Yaw/Pitch/Roll. I can try and do a short vid for you if you like. Would be later tonight, somewhat busy this afternoon.

Link to comment
Share on other sites

Sorry for the delay. I had to move my PC in order to decorate so haven't been able to do much testing. I did try adjusting the camera offset as per your instructions and found around 12 (or maybe -12) on roll was needed to zero it but that didn't solve the problems with the X, Y, Z axis. I'll make another video when I can.

Main rig: i5-4670k @4.4Ghz, Asus Z97-A, Scythe Kotetsu HSF, 32GB Kingston Savage 2400Mhz DDR3, 1070ti, Win 10 x64, Samsung Evo 256GB SSD (OS & Data), OCZ 480GB SSD (Games), WD 2TB and WD 3TB HDDs, 1920x1200 Dell U2412M, 1920x1080 Dell P2314T touchscreen

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...