Jump to content

Question for owners of X1950XTX video cards...


Kuky
 Share

Recommended Posts

I recently bought a Sapphire X1950XTX video card and when trying to install official ATI Catalyst 6.9 drivers, I get an error message, something in a line that the GPU is not recognised.

 

Anyway, after googling bit on the internet, I found that this video card is not compatible with standard Catalyst drivers and that in the mean time, before Catalyst 6.10 are out, I should use drivers supplied on the CD that came with the card.

 

Those drivers are Catalyst 6.8, and I think they are just modified to recognise R580+ GPU in X1950XTX.

 

The drivers are working fine, but I bit concerned and puzzled because GPU and RAM frequency are not showing as specified 650MHz and 1000MHz respectively.

 

Catalyst Control Centre (overclocking page) is showing frequencies of 500MHz for GPU and... hm... can't remeber now what the RAM frequency was shown as, I think it's around 600MHz or something, but it surely aint 1000MHz:doh:

 

I am thinking this could be just a driver issue not recognising the propper frequency, but I am scared that maybe I just got a dodgy card??

 

Anyone else having the same issue?

 

Edit: Looks like this is a feature of latest ATI and nVidia cards, when in 2D mode the cards throttles back to lower speeds to save on power and prolong card's life span, etc as high performance is not required but when running a 3D application such as games it crancks up to propper speeds... hmm, I wish they would state this in the card's specs or something :/

No longer active in DCS...

Link to comment
Share on other sites

Guest IguanaKing

Yup...that's normal. It says "INF file missing". Apparently, ATI botched the driver release of Cat 6.9 and it leaves out the 1950XTX. We'll just have to run on 6.8 until they come out with a fix. :(

Link to comment
Share on other sites

 

The drivers are working fine, but I bit concerned and puzzled because GPU and RAM frequency are not showing as specified 650MHz and 1000MHz respectively.

 

Catalyst Control Centre (overclocking page) is showing frequencies of 500MHz for GPU and... hm... can't remeber now what the RAM frequency was shown as, I think it's around 600MHz or something, but it surely aint 1000MHz:doh:

 

Nothing wrong, the Catalyst doesnt run at Vmax during regular 2d applications. It only goes to full specified ram/gpu speed when you run a 3d application.

:Core2Duo @ 435FSB x 7 3.05GHz : ATI x1900xtx: 2GB Patriot @ 435Mhz : WD 250Gb UATA: Seagate 320Gb SATA2: X-Fi Platinum:

Link to comment
Share on other sites

I read somewhere that Catalyst 6.10 Beta are not quite good and owners of X1950XTX are advised to stick with CD drivers that came with the card, and wait till official Catalyst 6.10 is released.

No longer active in DCS...

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...