Jump to content

[Official] SimShaker for Aviators


f4l0

Recommended Posts

I've just bought a Jetseat, installed the Gametrix and SSA software but now get no joy - the seat is working but it doesn't fire up for DCS. Any helpful thoughts?

 

Thanks for your help

 

  • The jetseat tests just fine using the test buttons in both Gametrix and SSA – vibrates as it should

  • In SSA it is set to DCS and does show the three generic modes -jet, piston and heli – but no others even after I have flown each in DCS (AV8, F18, P47 and F5 so far)

  • Gametrix is in USB mode

  • Seat is plugged in and registers in the DCS control settings as a device along with my joy, throttle and pedals

  • Seat power is on and turned up high

  • I’ve scoured the manual for both the seat and SSA and then checked this forum page for clues but nothing is apparent

  • Andre suggests that SSA is not receiving the telemetry data from DCS

  • Snip of the debug log is attached but doesn't seem to suggest any obvious failures
  • I’ve uninstalled and reinstalled SSA 3 times now. Using the stable version of SSA and open beta of DCS. But I did try open beta of SSA too at one point – still no joy

Simshaker Aviators no working.JPG

Link to comment
Share on other sites

18 hours ago, Ala12Rv-Tundra said:

Does SSA work with Mi8 helicopter? it doesn´t show on the list, so I guess I will have to adjust generic effects

 

Yes it should work...

 

8 hours ago, MrShooty said:

I've just bought a Jetseat, installed the Gametrix and SSA software but now get no joy - the seat is working but it doesn't fire up for DCS. Any helpful thoughts?

 

Thanks for your help

 

  • The jetseat tests just fine using the test buttons in both Gametrix and SSA – vibrates as it should

     

  • In SSA it is set to DCS and does show the three generic modes -jet, piston and heli – but no others even after I have flown each in DCS (AV8, F18, P47 and F5 so far)

     

  • Gametrix is in USB mode

     

  • Seat is plugged in and registers in the DCS control settings as a device along with my joy, throttle and pedals

     

  • Seat power is on and turned up high

     

  • I’ve scoured the manual for both the seat and SSA and then checked this forum page for clues but nothing is apparent

     

  • Andre suggests that SSA is not receiving the telemetry data from DCS

     

  • Snip of the debug log is attached but doesn't seem to suggest any obvious failures
  •  

    I’ve uninstalled and reinstalled SSA 3 times now. Using the stable version of SSA and open beta of DCS. But I did try open beta of SSA too at one point – still no joy

Simshaker Aviators no working.JPG

Could you please show me your export.lua?

f4l0

Developer of Simshaker for Aviators

 

Feel the brrrrttt:

[Official] SimShaker for Aviators Forums thread at ED forums

SimShaker blog - transfer game effects into the real world

SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

 

DCS Toggle Switches

 

System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs

Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

Link to comment
Share on other sites

9 hours ago, MrShooty said:

These are the two export files I found in scripts/simshaker-export-core. Are these the ones you meant? Thanks for your advice.

ExportCore.lua 1.82 kB · 0 downloads ExportDevice.lua 1006 B · 0 downloads

There should be a Export.lua in your DCS profile folder.

f4l0

Developer of Simshaker for Aviators

 

Feel the brrrrttt:

[Official] SimShaker for Aviators Forums thread at ED forums

SimShaker blog - transfer game effects into the real world

SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

 

DCS Toggle Switches

 

System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs

Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

Link to comment
Share on other sites

8 hours ago, f4l0 said:

There should be a Export.lua in your DCS profile folder.

This is the only other export.lua that comes up with a search. It's in my saved games/dcsopenbeta/scripts folder but does contain mention of simshaker. Any good? If not can you be more specific about the directory I should be searching? Thanks again for your help.

 

Contents read:

 

pcall(function() local dcsSr=require('lfs');dofile(dcsSr.writedir()..[[Mods\Services\DCS-SRS\Scripts\DCS-SimpleRadioStandalone.lua]]); end,nil);


local SimShakerlfs=require('lfs'); dofile(SimShakerlfs.writedir()..'Scripts/SimShaker.lua')

dofile(lfs.writedir()..[[Scripts\SimShaker-export-core\ExportCore.lua]])

 

 

Export.lua

Link to comment
Share on other sites

16 hours ago, MrShooty said:

This is the only other export.lua that comes up with a search. It's in my saved games/dcsopenbeta/scripts folder but does contain mention of simshaker. Any good? If not can you be more specific about the directory I should be searching? Thanks again for your help.

 

Contents read:

 

pcall(function() local dcsSr=require('lfs');dofile(dcsSr.writedir()..[[Mods\Services\DCS-SRS\Scripts\DCS-SimpleRadioStandalone.lua]]); end,nil);


local SimShakerlfs=require('lfs'); dofile(SimShakerlfs.writedir()..'Scripts/SimShaker.lua')

dofile(lfs.writedir()..[[Scripts\SimShaker-export-core\ExportCore.lua]])

 

 

Export.lua 319 B · 0 downloads

 

Could you try to change the file to:

 

local SimShakerlfs=require('lfs'); dofile(SimShakerlfs.writedir()..'Scripts/SimShaker.lua')
dofile(lfs.writedir()..[[Scripts\SimShaker-export-core\ExportCore.lua]]) 

pcall(function() local dcsSr=require('lfs');dofile(dcsSr.writedir()..[[Mods\Services\DCS-SRS\Scripts\DCS-SimpleRadioStandalone.lua]]); end,nil);

 

f4l0

Developer of Simshaker for Aviators

 

Feel the brrrrttt:

[Official] SimShaker for Aviators Forums thread at ED forums

SimShaker blog - transfer game effects into the real world

SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

 

DCS Toggle Switches

 

System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs

Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

Link to comment
Share on other sites

11 hours ago, f4l0 said:

 

Could you try to change the file to:

 


local SimShakerlfs=require('lfs'); dofile(SimShakerlfs.writedir()..'Scripts/SimShaker.lua')
dofile(lfs.writedir()..[[Scripts\SimShaker-export-core\ExportCore.lua]]) 

pcall(function() local dcsSr=require('lfs');dofile(dcsSr.writedir()..[[Mods\Services\DCS-SRS\Scripts\DCS-SimpleRadioStandalone.lua]]); end,nil);

 

Thanks F410. I copied and pasted into a new export folder (and  renamed and saved the old one as a backup) but still no joy.

 

I checked in the Scripts/Hooks folder and noticed that both SRS and Tacview have a hooks lua file but SSA does not. Could that be the issue?

 

My flight log snip s attached

 

Any other ideas? This is killing me so thanks for your help.

Simshaker Aviators no working 3Jun21.JPG

Link to comment
Share on other sites

On 6/3/2021 at 9:04 PM, MrShooty said:

Thanks F410. I copied and pasted into a new export folder (and  renamed and saved the old one as a backup) but still no joy.

 

I checked in the Scripts/Hooks folder and noticed that both SRS and Tacview have a hooks lua file but SSA does not. Could that be the issue?

 

My flight log snip s attached

 

Any other ideas? This is killing me so thanks for your help.

Simshaker Aviators no working 3Jun21.JPG

You might backup your export.lua and hit the "DCS Repair Export" button...

f4l0

Developer of Simshaker for Aviators

 

Feel the brrrrttt:

[Official] SimShaker for Aviators Forums thread at ED forums

SimShaker blog - transfer game effects into the real world

SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

 

DCS Toggle Switches

 

System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs

Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

Link to comment
Share on other sites

On 6/5/2021 at 7:55 AM, f4l0 said:

You might backup your export.lua and hit the "DCS Repair Export" button...

Thanks. I tried that too and no joy in DCS. I also tried turning off virus scans and still not working. Any other thoughts?

 

I've gotten IL2 working with Simshaker Wings so I know that the seat can do it.

Link to comment
Share on other sites

On 6/6/2021 at 10:11 PM, MrShooty said:

Thanks. I tried that too and no joy in DCS. I also tried turning off virus scans and still not working. Any other thoughts?

 

I've gotten IL2 working with Simshaker Wings so I know that the seat can do it.

Can you show me you DCS log file?

f4l0

Developer of Simshaker for Aviators

 

Feel the brrrrttt:

[Official] SimShaker for Aviators Forums thread at ED forums

SimShaker blog - transfer game effects into the real world

SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

 

DCS Toggle Switches

 

System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs

Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

Link to comment
Share on other sites

9 hours ago, MrShooty said:

This is today's log. Again, no joy from SSA with the jetseat directly plugged into the PC (no hub). Thanks again.

dcs.log 4.73 MB · 0 downloads

The log contains an error:

 

2021-06-08 19:56:09.590 ERROR   Lua::Config: Call error LuaExportStart:<LUA_TTABLE>
stack traceback:
	[C]: ?
	[C]: in function 'try'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\Network.lua"]:110: in function 'send'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\Network.lua"]:241: in function 'sendMessage'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\Protocol.lua"]:62: in function 'newUnit'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\Protocol.lua"]:18: in function 'init'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\ExportCore.lua"]:14: in function 'init'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\ExportCore.lua"]:26: in function <[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\ExportCore.lua"]:25>.

 

The Network.lua script tries to send a multicast message to 239.255.50.10 on port 12843. So, something is blocking the communication. Might be a firewall issue. However, you could try to fix the firewall issue or to add "--" in front of the code line 110 in the C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\Network.luanetwork.lua file:

 

--socket.try(self.conn:sendto(msg, "239.255.50.10", 12843))

 

Maybe  I'll rework the network.lua in the future, the multicast is not necessary for SSA.

f4l0

Developer of Simshaker for Aviators

 

Feel the brrrrttt:

[Official] SimShaker for Aviators Forums thread at ED forums

SimShaker blog - transfer game effects into the real world

SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

 

DCS Toggle Switches

 

System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs

Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

Link to comment
Share on other sites

Hi all,

 

I am unable to get the SimShaker to work on DCS. I went into the Service tab in the SimShaker Version 2.2.0.0, and in there I can see all the code lines changing when I am in DCS, however it does not work when I am in the game. Any idea why? Thanks for your help!

 

Scrat

Link to comment
Share on other sites

Posted (edited)

Yes, I confirm that SSA stopped working for me as well. Might that be something related to the latest patch?

 

I also get this error from SSA when DCS loads the mission:

 

image.png

 

If I then close and reopen SSA with DCS already loaded, it seems to work


Edited by =36=Witcher
Link to comment
Share on other sites

14 hours ago, f4l0 said:

The log contains an error:

 


2021-06-08 19:56:09.590 ERROR   Lua::Config: Call error LuaExportStart:<LUA_TTABLE>
stack traceback:
	[C]: ?
	[C]: in function 'try'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\Network.lua"]:110: in function 'send'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\Network.lua"]:241: in function 'sendMessage'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\Protocol.lua"]:62: in function 'newUnit'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\Protocol.lua"]:18: in function 'init'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\ExportCore.lua"]:14: in function 'init'
	[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\ExportCore.lua"]:26: in function <[string "C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\ExportCore.lua"]:25>.

 

The Network.lua script tries to send a multicast message to 239.255.50.10 on port 12843. So, something is blocking the communication. Might be a firewall issue. However, you could try to fix the firewall issue or to add "--" in front of the code line 110 in the C:\Users\qjman\Saved Games\DCS.openbeta\Scripts\SimShaker-export-core\Network.luanetwork.lua file:

 


--socket.try(self.conn:sendto(msg, "239.255.50.10", 12843))

 

Maybe  I'll rework the network.lua in the future, the multicast is not necessary for SSA.

Sorry to ask but does that Network file autocorrect itself somehow? I've tried literally ten times to alter line 110 as you suggest using several different lua editors. When I save a open, the alteration (adding "--" to line 110 to make it a comment) then the edit it there. After I run DCS it is back as was. I've even deleted the line completely and it returns. So I'm thinking that the line in the network.lua file is getting written each time DCS runs and I need to edit a source file. Any thoughts as to where that source file is? Thanks again.

Link to comment
Share on other sites

grafik.png.d2d19de74d949fe56519cec7f3982b14.png
Its the canopy shaking filter...

For anyone else trying to solve this problem for the F-14 in the future, just wanted to note that setting the Canopy Shaking filter to 5 solved it for me.

i7-9700K / MSI MPG Z390 Gaming PRO Carbon AC / 32GB DDR4 / RTX 2080 Ti / TrackIR5 / MFG Crosswind Rudder Pedals / VKB Gunfighter MkIII base + MCG Ultimate grip / LG 48" OLED

Link to comment
Share on other sites

9 hours ago, MrShooty said:

Sorry to ask but does that Network file autocorrect itself somehow? I've tried literally ten times to alter line 110 as you suggest using several different lua editors. When I save a open, the alteration (adding "--" to line 110 to make it a comment) then the edit it there. After I run DCS it is back as was. I've even deleted the line completely and it returns. So I'm thinking that the line in the network.lua file is getting written each time DCS runs and I need to edit a source file. Any thoughts as to where that source file is? Thanks again.

Hmm, yeah. SSA updates this file on each launch... You could set the file to "write protect".

 

 

11 hours ago, =36=Witcher said:

Yes, I confirm that SSA stopped working for me as well. Might that be something related to the latest patch?

 

I also get this error from SSA when DCS loads the mission:

 

image.png

 

If I then close and reopen SSA with DCS already loaded, it seems to work

 

 

I'll check on my side...

 

 

15 hours ago, -Scrat- said:

Hi all,

 

I am unable to get the SimShaker to work on DCS. I went into the Service tab in the SimShaker Version 2.2.0.0, and in there I can see all the code lines changing when I am in DCS, however it does not work when I am in the game. Any idea why? Thanks for your help!

 

Scrat

 

Could you please show me your export.lua and dcs.log file?

f4l0

Developer of Simshaker for Aviators

 

Feel the brrrrttt:

[Official] SimShaker for Aviators Forums thread at ED forums

SimShaker blog - transfer game effects into the real world

SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

 

DCS Toggle Switches

 

System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs

Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

Link to comment
Share on other sites

@f4l0Just stopping by to remind myself to say "Thank You!" for this great tool. It bumped my immersive experience up so much for DCS and those "full body" haptics really improve flying by enhancing informative feedback for each aircraft.

  • Like 6

i9 10920X @4.8GHz, X299X HEDT mainboard, RTX3090 OC, quad channel 64 GB RAM @3600, Valve Index, HOTAS & Rudder: all Virpil with FFB base mod (G940), DCS: all modules

Link to comment
Share on other sites

On 6/10/2021 at 5:47 AM, f4l0 said:

Hmm, yeah. SSA updates this file on each launch... You could set the file to "write protect".

 

 

 

I'll check on my side...

 

 

 

Could you please show me your export.lua and dcs.log file?

I tried setting the network file to write protect but it just sends up an error and then doesn't fix the issue. Here's the log from doing that. As ever, any tips or tricks are most welcome - I really want to get simshaker running for DCS.

Export.lua dcs.log

Link to comment
Share on other sites

10 hours ago, MrShooty said:

I tried setting the network file to write protect but it just sends up an error and then doesn't fix the issue. Here's the log from doing that. As ever, any tips or tricks are most welcome - I really want to get simshaker running for DCS.

Export.lua 325 B · 1 download dcs.log 232.93 kB · 0 downloads

The log looks clean to me. Which error did you get?

f4l0

Developer of Simshaker for Aviators

 

Feel the brrrrttt:

[Official] SimShaker for Aviators Forums thread at ED forums

SimShaker blog - transfer game effects into the real world

SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

 

DCS Toggle Switches

 

System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs

Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

Link to comment
Share on other sites

Good morning. I have a problem with simshaker aviator beta and release last version.

 

I had to disconnect the PC to change a faulty RAM module, I reconnected it and now both the simshaker for aviators beta and release are closed after a few seconds of starting it, I understand that it may be that it is not connected to the same USB as before the realteus pad.

 

I deleted all the remnants of the simshaker for aviators software and reinstalled it again but I still have the same problem. Any suggestions as to where the problem may come from?. thanks


Edited by Werewolf_fs
Link to comment
Share on other sites

9 hours ago, MrShooty said:

image.png

Ah ok,
I'll have a look what I can do and release a new beta in the next days 🙂

f4l0

Developer of Simshaker for Aviators

 

Feel the brrrrttt:

[Official] SimShaker for Aviators Forums thread at ED forums

SimShaker blog - transfer game effects into the real world

SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

 

DCS Toggle Switches

 

System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs

Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

Link to comment
Share on other sites

hace 13 horas, Werewolf_fs dijo:

Good morning. I have a problem with simshaker aviator beta and release last version.

 

I had to disconnect the PC to change a faulty RAM module, I reconnected it and now both the simshaker for aviators beta and release are closed after a few seconds of starting it, I understand that it may be that it is not connected to the same USB as before the realteus pad.

 

I deleted all the remnants of the simshaker for aviators software and reinstalled it again but I still have the same problem. Any suggestions as to where the problem may come from?. thanks

 

 

I answer myself. I had to reinstall in a different folder than the default or different from the previous installation and fixed. (V2.2.0 and 2.2.1/2.2.2 beta)

Curiously versions 2.0 and earlier if they worked without problems.


Edited by Werewolf_fs
Link to comment
Share on other sites

  • Recently Browsing   1 member

×
×
  • Create New...