Jump to content

SU-27 Constant Up-Pitch


Luse
 Share

Recommended Posts

Hello!

 

It's been a while since I've been around these parts.. anyway.

 

Fresh install of DCS:W + MiG-21. F-86. M200C, A-10C and L-39. Everything is great! Seriously ED, Good shit. I left before :World was even out and and it's been impressive how far the sim has come. I thank you guys for all of the work that's been put in so far.

 

However, I'm not sure this can be replicated - here goes.

 

In the Flanker, Whenever I get in the air I have around 2.3G of constant upwards pitch at 230-XXX KMh. I've double checked in every other aircraft and this isn't present. Only the flanker. It's not there with ACS enabled but then we all know what happens. I've triple checked my controls, deleted the files and have completely re-done them and assigned axis as well. Axis tracker doesn't show any movement from my Stick either, everything shows dead center.

 

AND - To add to that, the M2000C is the only A/C that is responding to ANY trim inputs ( Via Keyboard or Assigned in game. ) Everything else just ignores it. I've been watching through the Axis Tracker ( RCrtl + enter ) and the only A/C that will recognize either keyboard or stick inputs for trim is the Mirage. - I know this last one isn't a Flanker bug, but it's been a frustrating past few hours.

 

Any ideas? I'm uploading videos right now.

STT Radar issue is leftover code.

Link to comment
Share on other sites

Not sure if this helps, but after take-off, when not in any autopilot mode, the Flanker needs to be heavily trimmed nose down.

 

I think the main difference between other DCS modules and the Su-27's trimmer behavior is rather straight forward - it requires a much longer initial press of the pitch-down trimmer button than other DCS jets. Once you get the nose down sufficiently after take off, the 27 can be trimmed with smaller inputs, just like the other DCS aircraft.

 

For the 27, right after take off, I try to line up the edge of the flight stick with the bottom edge of the VSI - or rather, the white line underneath it.

 

This works for me as a rough estimate; from here on out, I use smaller trimmer inputs for the pitch axis - but again, the 27 needs that initial long trimmer push.

 

Made a little animation to show you what I mean...


Edited by rrohde

PC: Intel Core i7-7700K 4.2GHz | MSI GTX 1080 TI | ASUS Maximus IX Hero | 32GB DDR4 RAM | 2TB Samsung 870 EVO SSD | Win10 Pro 64bit

Gear: HP Reverb | JetPad FSE | MTX Sim Rig | VKB Gunfighter Pro Mk.III w/ MCG Ultimate (center) | VKB Gunfighter Mk.III w/ SCG-R Premium (side)

 

VKBNA_LOGO_SM.png

VKBcontrollers.com

Link to comment
Share on other sites

With some joysticks, the SU-27 is not triming, is a reported bug since 1.5.4 openbeta

 

Hello!

 

It's been a while since I've been around these parts.. anyway.

 

Fresh install of DCS:W + MiG-21. F-86. M200C, A-10C and L-39. Everything is great! Seriously ED, Good shit. I left before :World was even out and and it's been impressive how far the sim has come. I thank you guys for all of the work that's been put in so far.

 

However, I'm not sure this can be replicated - here goes.

 

In the Flanker, Whenever I get in the air I have around 2.3G of constant upwards pitch at 230-XXX KMh. I've double checked in every other aircraft and this isn't present. Only the flanker. It's not there with ACS enabled but then we all know what happens. I've triple checked my controls, deleted the files and have completely re-done them and assigned axis as well. Axis tracker doesn't show any movement from my Stick either, everything shows dead center.

 

AND - To add to that, the M2000C is the only A/C that is responding to ANY trim inputs ( Via Keyboard or Assigned in game. ) Everything else just ignores it. I've been watching through the Axis Tracker ( RCrtl + enter ) and the only A/C that will recognize either keyboard or stick inputs for trim is the Mirage. - I know this last one isn't a Flanker bug, but it's been a frustrating past few hours.

 

Any ideas? I'm uploading videos right now.

Link to comment
Share on other sites

Not sure if this helps, but after take-off, when not in any autopilot mode, the Flanker needs to be heavily trimmed nose down.

 

 

 

Absolutely! However it doesn't matter how much trim- nose down I encourage. The sim isn't detecting any. From default keyboard settings OR stick. I also just saw the thread below this one :doh: mods if you want, feel free to merge this into that thread.

EDIT: Alright, Something very goofy - Been reading up on this, I've disabled FFB and still unable to trim on ED A/C ONLY.

 

EDIT 2 I've been using my G27 pedals as rudder ( clutch , brake and gas ). I've unplugged them once, still had the issue.

 

Replugged them, same issue.

 

Unplugged them. Issue fixed - The issue is only present on ED Aircraft and Modules ( FC3, L-39 Etc )

 

Any 3rd party module is fine with the G27 plugged in. Tested and verified with Mirage, MiG-21, F-86

 

I hope this has helped, it's really irritating as I dislike having a twist rudder. - Any ideas?


Edited by Luse
I've been working through this shit all day.

STT Radar issue is leftover code.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...