Jump to content

Low performance in recent patch?


Recommended Posts

Since the last patch (V1.5 non-beta) a few days back I am getting terrible performance in a number of aircraft. I am getting around 10 frame rates in the F-15s cockpit. Lots of stutters. Viewing external views I am also experiencing a lot of stutters when panning around. Is anyone else experiencing these problems?

Link to comment
Share on other sites

As I mentioned in the original post, it happens in a number of aircraft as well as external views to a lower extent. Previously I had a smooth 60+ frame rates in normal conditions. Exceptions being 20+ aircraft at an air field, which seems to bring the engine to its knees.

 

Specs:

GTX 970

4670K @ 4GHZ

8GB DDR3

Win 10 Pro

Installed on SSD

Link to comment
Share on other sites

Yesterday I upgraded from a 2GB 770 to a 4GB 980 and I have actually seen a reduction in performance. I will post my settings later but it is a mixture of high(textures, scenes and viability) and medium (water and shadows) with low heat blur, low cig traffic, no mirrors, no HDR, no flat shadows, No lenses effect and only 4x MSAA and 4x Anisiotropic Filtering. This is at 1920x1080 with sweetfx and starways new caucaus textures.

 

Performance in 2.0 seems to have improved and I can now fly down the strip at a solid 60FPS but with 1.5 (release version) in the Mi-8 free flight mission I get around 60 frames without vsync and on the first mission in the gazelle campaign I get 30FPS when looking at the FARP. I also get 40 FPS when sat on the pan at Tbilisi in the Gazelle on the Blue Flag server whereas I used to get 50FPS here with the 770 using the same settings.

 

Also I have noticed more flickering from shadows and distant buildings :-(

 

Jacks


Edited by Jacks

System Specs: i7 8700k @ 5.0GHz (not delidded), ASRock Extreme4 Z370 MOBO, EVGA GTX 1080 SC 8GB, 32GB Corsair Vengeance LPX 3200MHz DDR4 RAM, Samsung Evo 240GB SSD, Samsung Evo 500GB SSD, 1TB HDD, Noctura NH-D15S Heat Sink, Acer VE278H 27" 1080p Monitor, Ocukus Rift CV1.

 

Controllers: TrackIR 5, Thrustmaster HOTAS X, Saitek Throttle Quadrant (with DIY removable collective mod), Saitek Pro Flight Rudder Pedals.

 

Just trying to keep my number of takeoffs and landings equal!

Link to comment
Share on other sites

Jacks; Just checking, but did you properly reinstall the drivers for the 980?

 

I have thought when going nvidia>nvidia that the driver would just pick it up, but I had issues similar to what you describe until I did a full reinstall/reboot...

Link to comment
Share on other sites

Yeah I downloaded the drivers and did a clean install. The wierd thing is that there is a definite improvement in NTTR.

 

When installing drivers I don't install nvidia experience, 3D vision or 3D audio as I don't need them. I just clean install the drivers and physix

 

A new driver was released yesterday so will try that.


Edited by Jacks

System Specs: i7 8700k @ 5.0GHz (not delidded), ASRock Extreme4 Z370 MOBO, EVGA GTX 1080 SC 8GB, 32GB Corsair Vengeance LPX 3200MHz DDR4 RAM, Samsung Evo 240GB SSD, Samsung Evo 500GB SSD, 1TB HDD, Noctura NH-D15S Heat Sink, Acer VE278H 27" 1080p Monitor, Ocukus Rift CV1.

 

Controllers: TrackIR 5, Thrustmaster HOTAS X, Saitek Throttle Quadrant (with DIY removable collective mod), Saitek Pro Flight Rudder Pedals.

 

Just trying to keep my number of takeoffs and landings equal!

Link to comment
Share on other sites

Some more quick testing using the frame rate counter. Frame rates report well over 100 in most instances. Panning around with my HOTAS or arrow keys looks normal. The only time I get slow panning performance is when using the mouse. Frame rates seem to drop, but still stay above 80 or so. There seems to be a stuttering problem that is not related to frame rates.

 

It is worse in cockpits, but also occurs when panning in external views. In cockpits it takes around 6 seconds from looking at the HUD to looking down at the seat with the mouse. In game frame rate counter reports 80, but it looks like 10 or so frame rates. Essentially, panning around the cockpit is not feasible if you want to use a mouse.

 

I've tried this in the following three planes:

F-15C

Su-27

MIG-21

 

All with the same issues, both cockpit and external. Empty map. I used to have Bartharks (spelling) texture pack installed which ran perfectly fine, although I removed that and I am using the default features & .LAU files.

 

Is anyone else having these issues? I may consider re-installing, but the slow download times, DRM problems and re-configuring of controls will be a pain I don't want to go through yet again. I don't want to do that only to find out it is a general bug effecting most users.

 

I am also on Nvidia's latest official drivers.

Link to comment
Share on other sites

I was having similar stuttering after the last update. If you're having the same issue it's coming from the number of ground units you have in your missions. Something in the last update seems to have raised the overhead on ground units. I used to be able to run 500 plus ground units without a problem. In the current version 200 is about the max I can do without performance issues. Make a mission without ground units and see if you still have performance issues. If not then your seeing the same issue. The good news is that if you have the same issue you can go back to last open beta and it will fix the problem.

 

AOG


Edited by AOG
Link to comment
Share on other sites

I was having similar stuttering after the last update. If you're having the same issue it's coming from the number of ground units you have in your missions. Something in the last update seems to have raised the overhead on ground units. I used to be able to run 500 plus ground units without a problem. In the current version 200 is about the max I can do without performance issues. Make a mission without ground units and see if you still have performance issues. If not then your seeing the same issue. The good news is that if you have the same issue you can go back to last open beta and it will fix the problem.

 

AOG

 

Map is empty aside from my aircraft.

Link to comment
Share on other sites

I did some testing using the settings in the attached image and found that at times my FPS dropped to 45 yet my CPU never went above 87% (CPU 4 peaked at 87% and the other 3 did not go above 45%) on any of the cores and the GPU load never exceeded 60%. Why am I getting low frames if both the CPU and GPU are not maxed out?

 

I have also attached my MSI afterburner logs and the test I conducted using Gazelle Campaign Mission 1 is the second log down.

Screen_160608_230945.thumb.jpg.71b1233010d12ef92063f3e2a1265a05.jpg

MSI Log.zip


Edited by Jacks

System Specs: i7 8700k @ 5.0GHz (not delidded), ASRock Extreme4 Z370 MOBO, EVGA GTX 1080 SC 8GB, 32GB Corsair Vengeance LPX 3200MHz DDR4 RAM, Samsung Evo 240GB SSD, Samsung Evo 500GB SSD, 1TB HDD, Noctura NH-D15S Heat Sink, Acer VE278H 27" 1080p Monitor, Ocukus Rift CV1.

 

Controllers: TrackIR 5, Thrustmaster HOTAS X, Saitek Throttle Quadrant (with DIY removable collective mod), Saitek Pro Flight Rudder Pedals.

 

Just trying to keep my number of takeoffs and landings equal!

Link to comment
Share on other sites

Did you try the ALT-ENT keys for full screen? I remember they had an issue with being in windowed mode even though full screen is checked in the options... Worth a shot...

 

Thanks for the reply. I always run in full screen so that isn't the problem. For FC3 aircraft I can get by as I pan my mouse with the joystick, although I am no longer able to smoothly view around via the mouse when I want to. But for clickable cockpits which require the mouse the game is essentially unplayable at the moment.

Link to comment
Share on other sites

Yes I have done that too.

System Specs: i7 8700k @ 5.0GHz (not delidded), ASRock Extreme4 Z370 MOBO, EVGA GTX 1080 SC 8GB, 32GB Corsair Vengeance LPX 3200MHz DDR4 RAM, Samsung Evo 240GB SSD, Samsung Evo 500GB SSD, 1TB HDD, Noctura NH-D15S Heat Sink, Acer VE278H 27" 1080p Monitor, Ocukus Rift CV1.

 

Controllers: TrackIR 5, Thrustmaster HOTAS X, Saitek Throttle Quadrant (with DIY removable collective mod), Saitek Pro Flight Rudder Pedals.

 

Just trying to keep my number of takeoffs and landings equal!

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...