Jump to content

Vsync ON or Off ?


Lenux
 Share

Recommended Posts

How would you recommend to have the V-Sync ? On or Off ?

If the monitor ( tv 4k ) has only 60 Hz, and i play with Vsync off - about 130 fps average, no tearing at all, in this case, what's the real fps ?? 60 or 130 ?

I7 9700K@5.1 GHz | 32 GB DDR4 | Gigabyte Z390 AORUS Ultra | RTX 3090 | 6 TB SSD + 8 TB HDD | 4K Samsung Q90R 55" | VKB MK III PRO L | Virpil Throttle MONGOOST-50 | MFG Crosswind | TrackIR5

Link to comment
Share on other sites

If the monitor ( tv 4k ) has only 60 Hz, and i play with Vsync off - about 130 fps average, no tearing at all, in this case, what's the real fps ?? 60 or 130 ?

 

Both are real, but the measurements are made at different places.

 

You seem to be running borderless window mode so the pipeline looks roughly like this:

1. The game and graphics card render 130 frames per second.

2. Those frames are received by the Windows renderer because you are not running exclusive fullscreen mode.

3. Windows is always v-synced no matter what your in-game setting is, so it will discard a lot of the frames it receives. The monitor then only receives one frame per v-blank, which is 60fps in your case.

 

This is a really inefficient way to do things. I recommend you run exclusive fullscreen mode instead. Press alt+enter after you have launched DCS to make that happen. This will bypass the windows renderer, so there's nothing in between DCS, the graphics driver, graphics card and the monitor that is interfering. This also means that the v-sync option in DCS settings will work like intended.

Link to comment
Share on other sites

Both are real, but the measurements are made at different places.

 

You seem to be running borderless window mode so the pipeline looks roughly like this:

 

Everytime when i launch the game, it's in full screen.

What's the difference between borderless and fullscreen ?!

And by the way : every DCS player is using this alt+enter method after the game is launched ?

Thank you

I7 9700K@5.1 GHz | 32 GB DDR4 | Gigabyte Z390 AORUS Ultra | RTX 3090 | 6 TB SSD + 8 TB HDD | 4K Samsung Q90R 55" | VKB MK III PRO L | Virpil Throttle MONGOOST-50 | MFG Crosswind | TrackIR5

Link to comment
Share on other sites

Everytime when i launch the game, it's in full screen.

What's the difference between borderless and fullscreen ?!

 

No, DCS defaults to borderless window, which is just a window without borders that covers the entire screen, but it is not true fullscreen even if it looks like it is.

 

Borderless window forces the frames to go through the windows renderer.

Exclusive fullscreen mode bypasses the Windows renderer which means the game and graphics card is in full control of how the frames are presented on your monitor.

 

And by the way : every DCS player is using this alt+enter method after the game is launched ?

 

Everyone that know what they are doing, yes. The benefits are less latency, properly working v-sync, zero discarded frames and thus also better power consumption, less heat, less fan noise etc...


Edited by Brisse
Link to comment
Share on other sites

Thanks a million, Brisse, didn't know that

I wish i could use some mod for this alt + enter method, it should do that automatically when i launch the game

I7 9700K@5.1 GHz | 32 GB DDR4 | Gigabyte Z390 AORUS Ultra | RTX 3090 | 6 TB SSD + 8 TB HDD | 4K Samsung Q90R 55" | VKB MK III PRO L | Virpil Throttle MONGOOST-50 | MFG Crosswind | TrackIR5

Link to comment
Share on other sites

I wish i could use some mod for this alt + enter method, it should do that automatically when i launch the game

 

Most game's do. Sadly, DCS stopped doing it after the 1.5 update. I hope they change it in the future, but it's really not much work to press alt+enter once every session :)

Link to comment
Share on other sites

Your TV is doing some kind of input processing to achieve Vsync if you are not getting any tearing at all.

 

If your TV is 60hz, then all you can see is 60FPS. All the other frames are not seen and thus "wasted".

 

You could try Vsync and see if it works ok. If it does, your gpu will run cooler, as it will not render frames you will never see. If Vsync causes problems, you can try using a framerate limiter of some kind.

 

Every computer and monitor is different, so you really have to experiment.

Practice makes perfect.

Link to comment
Share on other sites

When i use Vsync, i have about 55-60 fps average, so i'm pretty hapy for now.When i play with the SU25T, for some reasons, this aircraft / missiles / is a fps killer. I dont understand why only this aircraft.

I7 9700K@5.1 GHz | 32 GB DDR4 | Gigabyte Z390 AORUS Ultra | RTX 3090 | 6 TB SSD + 8 TB HDD | 4K Samsung Q90R 55" | VKB MK III PRO L | Virpil Throttle MONGOOST-50 | MFG Crosswind | TrackIR5

Link to comment
Share on other sites

Your TV is doing some kind of input processing to achieve Vsync if you are not getting any tearing at all.

 

No, that's not what's happening. Read the posts on page one. Basically it comes down to this:

 

The game was running borderless window mode which forces the game to send the frames to the Windows renderer before they are sent to the monitor and Windows is always v-synced no matter what the ingame setting is. The Windows renderer is also responsible for discarding the extra frames that are rendered by the game in between every v-blank.

Link to comment
Share on other sites

I also have a two screen setup and run DCS Windowed. Alt-Enter does fill the primary monitor but the mouse won't work directly over the buttons, the alignment is off for clicking stuff.

 

WC

Visit the Hollo Pointe DCS World server -- an open server with a variety of COOP & H2H missions including Combined Arms. All released missions are available for free download, modification and public hosting, from my Wrecking Crew Projects site.

Link to comment
Share on other sites

Both are real, but the measurements are made at different places.

 

You seem to be running borderless window mode so the pipeline looks roughly like this:

1. The game and graphics card render 130 frames per second.

2. Those frames are received by the Windows renderer because you are not running exclusive fullscreen mode.

3. Windows is always v-synced no matter what your in-game setting is, so it will discard a lot of the frames it receives. The monitor then only receives one frame per v-blank, which is 60fps in your case.

 

This is a really inefficient way to do things. I recommend you run exclusive fullscreen mode instead. Press alt+enter after you have launched DCS to make that happen. This will bypass the windows renderer, so there's nothing in between DCS, the graphics driver, graphics card and the monitor that is interfering. This also means that the v-sync option in DCS settings will work like intended.

 

 

VSYNC OFF:

GPU Renders 130 FPS

VPU Sends ALL to TV, in Which only 60 are Displayed,

- Or -

VPU Throws Away All but 60, Causing Stutters or Partial Frames in the Feed.

 

Rendering Resources, Power, 70 FPS, Etc: Wasted

 

VSYNC ON:

GPU Renders 60 FPS

VPU Sends All to TV, All 60 Frames are Displayed.

No Wasted Power, No Wasted Frames.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, 2x R7970 Lightnings Crossfired @ 1.1/6.0GHz,

3x ASUS VS248HP + Hanns·G HZ201HPB + Oculus HMD,

Thrustmaster Warthog HOTAS + MFDs, CH Fighterstick+Pro Throttle+Pro Pedals

Link to comment
Share on other sites

when should I press alt + enter ? to activate exclusive fullscreen mode ?

when I am in the cockpit of the helicopter ? or before?

thanks.

 

I usually hit left alt + enter once i'm on the main menu screen, it usually flashes briefly indicating the change.

Link to comment
Share on other sites

I wonder if we could use a small mod for this.

Sometime i forget to press alt + enter

I7 9700K@5.1 GHz | 32 GB DDR4 | Gigabyte Z390 AORUS Ultra | RTX 3090 | 6 TB SSD + 8 TB HDD | 4K Samsung Q90R 55" | VKB MK III PRO L | Virpil Throttle MONGOOST-50 | MFG Crosswind | TrackIR5

Link to comment
Share on other sites

I remember when I start recording with Shadow Play. If not in full screen the image flickers at the start of recording displaying also the DCS logo. :)

[sIGPIC][/sIGPIC]

I5 4670k, 32GB, GTX 1070, Thrustmaster TFRP, G940 Throttle extremely modded with Bodnar 0836X and Bu0836A,

Warthog Joystick with F-18 grip, Oculus Rift S - Almost all is made from gifts from friends, the most expensive parts at least

Link to comment
Share on other sites

  • 2 weeks later...
What does full screen option do in the settings? I always thought it was to prevent running in windowed mode.

At the moment it sets DCS to run in frameless window mode only.

 

To force DCS to run true fullscreen, press Alt+Enter when in game.

It usually makes it run smoother.

System specs:

 

Gigabyte Aorus Master, i7 9700K@std, GTX 1080TI OC, 32 GB 3000 MHz RAM, NVMe M.2 SSD, Oculus Quest VR (2x1600x1440)

Warthog HOTAS w/150mm extension, Slaw pedals, Gametrix Jetseat, TrackIR for monitor use

 

Link to comment
Share on other sites

Alt + Enter is much smoother.

HP pro Reverb.

Current settings:

Windows VR setting: IPD is 64.5mm, High image quality, 90Hz refresh rate.

Steam: VR SS set to 100%, motionReprojectionMode set to "motionreproduction" and Locked in at 45 Hz display,

DCS: Pixel Density 1.0, Forced IPD at 55 (perceived world size), 2 X MSAA, 0 X SSAA.

My real IPD is 64.5mm. Prescription VROptition lenses installed.

VR Driver system:

I9-9900KS 5Ghz CPU. XI Hero motherboard and 2080ti graphics card, 32 gigs Ram 3

[code][code][code][code]

[/code][/code][/code][/code]200 Hz. No OC at the mo.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...