Jump to content

Link to SLI requests on Nvidia Forums and Crossfire on AMD Forums


Lt_Maverick
 Share

Recommended Posts

Even though I don't run SLI, an update from Eagle Dynamics on SLI would indeed be very welcome. Im thinking about the future of course, if SLI could give me improved performance in the future it would be a much cheaper upgrade solution then for example buying a completely new graphics card.


Edited by OnlyforDCS

Current specs: Windows 10 Home 64bit, i5-9600K @ 3.7 Ghz, 32GB DDR4 RAM, 1TB Samsung EVO 860 M.2 SSD, GAINWARD RTX2060 6GB, Oculus Rift S, MS FFB2 Sidewinder + Warthog Throttle Quadrant, Saitek Pro rudder pedals.

Link to comment
Share on other sites

We've all been talking about how our SLI or XFire does not work properly in game. I started a thread on Nvidia's forums to petition for a profile. There is also an existing request thread though it's pretty bloated:

 

Petition: https://forums.geforce.com/default/topic/903615/sli/dcs-series-sli-/

 

Official NVidia SLI Profile Request forum: https://forums.geforce.com/default/topic/477765/sli/official-nvidia-sli-profile-request-thread/

 

I created a question on the AMD website also but it requires a moderator's approval.

 

If you get time, please make a statement on each thread.

 

Edit: Here is the thread for AMD Users

 

 

https://community.amd.com/message/2693166#2693166

[sIGPIC][/sIGPIC]

 

"The first time I ever saw a jet, I shot it down."- General Chuck Yeager, USAF, describing his first confrontation with a Me262.

 

 

JayRac3r/Lt_Mav YouTube Channel

Link to comment
Share on other sites

bump....:thumbup:

P-51, 190-D9, 109-K4, Spitfire MK IX, Normandy, and everything else:joystick:

i7 4770K, 4.3ghz, 32gb ram, Windows-10 Pro, Z87 Exstreme4, Corsair 850w psu, Samsung Evo 1T SSD & 250 SSD, Titan-X 12gb OC, Asus ROG Swift 27"/1440p/144hz/1ms monitor, Trackir 5, TM Warthog & 10cm extension, Saitek TPM, MFG crosswind pedals

Link to comment
Share on other sites

We've all been talking about how our SLI or XFire does not work properly in game. I started a thread on Nvidia's forums to petition for a profile. There is also an existing request thread though it's pretty bloated: Petition: https://forums.geforce.com/default/topic/903615/sli/dcs-series-sli-/ Official NVidia SLI Profile Request forum: https://forums.geforce.com/default/topic/477765/sli/official-nvidia-sli-profile-request-thread/ I created a question on the AMD website also but it requires a moderator's approval. If you get time, please make a statement on each thread. Edit: Here is the thread for AMD Users https://community.amd.com/message/2693166#2693166

[sIGPIC][/sIGPIC]

 

"The first time I ever saw a jet, I shot it down."- General Chuck Yeager, USAF, describing his first confrontation with a Me262.

 

 

JayRac3r/Lt_Mav YouTube Channel

Link to comment
Share on other sites

Nvidia 361.43 - DCS SLI malfunction

 

I am wondering if my problem affects other people too.

 

Since installed last Nividia drivers 361.43 the SLI functionality with DCS is literally destroyed for my GTX770 cards. I cannot go higher then 30 FPS no matter settings I was tried with Nvidia inspector. It works much better when is using single card and I have easily 45 FPS. (these FPS ratings are for 4K resolution)

 

As to complicate things even more, Arma3 for example is working a lot more smoother now.

Romanian Community for DCS World

HW Specs: i7-8700K@5GHz,ASUS Maximus X Hero, 32GB RAM 3000MHz, MSI Nvidia GTX 1080TI watercooled, Creative SoundBlaster Z, Intel/Samsung M.2 , VKB MCG Pro + Virpil Throttle + Leo Bodnar BU0836(A and X), MFG Crosswind, Logitech G13, TrackIR 5, Oculus Rift S, Stream Deck

Link to comment
Share on other sites

It hasn't truly worked for anybody yet... at least not that I know of. Even the folks that are showing some usage on both cards will not see an FPS increase over using a single card.

 

There is a petition on the nvidia forums to get an official DCS SLI profile.... http://forums.eagle.ru/showthread.php?t=155674

5900X - 32 GB 3600 RAM - 1080TI

My Twitch Channel

~Moo

Link to comment
Share on other sites

I do agree with you, however I encountered an signifigant performance degradation with last set of drivers from Nvidia.

Romanian Community for DCS World

HW Specs: i7-8700K@5GHz,ASUS Maximus X Hero, 32GB RAM 3000MHz, MSI Nvidia GTX 1080TI watercooled, Creative SoundBlaster Z, Intel/Samsung M.2 , VKB MCG Pro + Virpil Throttle + Leo Bodnar BU0836(A and X), MFG Crosswind, Logitech G13, TrackIR 5, Oculus Rift S, Stream Deck

Link to comment
Share on other sites

Just popped it in! Excellent action!:thumbup:

New system:I9-9900KS, Kingston 64 GB DDR4 3200Mhz, RTX 3080(OC 2070 Mhz), Corsair H150 Pro RGB, Samsung 970 EVO 1 Tb, Scandisk m2 500 MB, 2 x Crucial 1 Tb, T16000M HOTAS, HP Reverb Professional, Corsair 750 Watt.

 

Old system:I7-4770K(OC 4.5Ghz), Kingston 24 GB DDR3 1600 Mhz,MSI RTX 2080(OC 2070 Mhz), 2 * 500 GB SSD, 3,5 TB HDD, 55' Samsung 3d tv, Trackir 5, Logitech HD Cam, T16000M HOTAS. All DCS modules, maps and campaigns:pilotfly:

Link to comment
Share on other sites

Link to SLI requests on Nvidia Forums and Crossfire on AMD Forums

 

If you haven't already, please make an informal request on the Nvidia and AMD request links:

 

 

We've all been talking about how our SLI or XFire does not work properly in game. I started a thread on Nvidia's forums to petition for a profile. There is also an existing request thread though it's pretty bloated: Petition: https://forums.geforce.com/default/topic/903615/sli/dcs-series-sli-/ Official NVidia SLI Profile Request forum: https://forums.geforce.com/default/topic/477765/sli/official-nvidia-sli-profile-request-thread/ I created a question on the AMD website also but it requires a moderator's approval. If you get time, please make a statement on each thread. Edit: Here is the thread for AMD Users https://community.amd.com/message/2693166#2693166

[sIGPIC][/sIGPIC]

 

"The first time I ever saw a jet, I shot it down."- General Chuck Yeager, USAF, describing his first confrontation with a Me262.

 

 

JayRac3r/Lt_Mav YouTube Channel

Link to comment
Share on other sites

Heyyo,

 

[uPDATE6]

Hmm, turns out SLI bit 04 causes clouds to flicker yet it's the most important bit for SLI performance... so it's up to the game developers to patch their game engine to stop clouds from flickering and also patch out that fake fullscreen crap they're using which prevents downsampling and causes the first GPU not to reach full GPU usage too.

http://forums.eagle.ru/showthread.php?t=155674&page=5

 

PLEASE! Reply to this thread on the geforce forums if you have any issues with the test SLI bits as I might not check this thread:

https://forums.geforce.com/default/topic/903615/sli/dcs-series-sli-/3/

 

So I wanted to test DCS 2.0 since it's going to be the latest build as you said... and WTH!!! It says on their website free-to-play for DCS 2.0 so I downloaded it and says two free aircraft... but you have to buy the terrain DLC and it's $50!? :(

 

So I at least tested the main menu in SLI hahaha... Just waiting for DCS 1.5 to download meow. Luckily it seems DCS 2.0 content is getting copied to 1.5 thank god I don't have to waste too much bandwidth re downloading everything...

 

Anywho? DX1x SLI bits 0x080000F5 seem to work good on the main menu... Try those out on DCS 2.0 please. Just use NVIDIA Inspector and change the DX1x SLI bits to that 0x080000F5 is all I did. It seems to be the most compatible SLI bits for most DirectX 11 games anyways.

 

Like this:

Kxy6yVv.png

 

Don't worry about the title of the game, it seems like the DCS series all use that same dcs.exe so that's all that matters for NVIDIA driver profiles tbh.

 

If you have any graphical artifacts please post results here and use MSI Afterburner in your screenshots if you can too please to give me an idea if scaling, GPU usage and clock speeds are ok.

 

Here's DCS 2.0 SLI tests on main menu with single-GPU:

OooHCXot.png

 

Here it is with DX1x SLI bits 0x080000F5:

BaBGQjKt.png

 

So 21.6fps single GPU and 40.4fps with those SLI bits... that's good news as DCS 2.0 should be SLI friendly.

 

 

Here's more info on how to use NVIDIA Inspector in case you're new to it:

http://steamcommunity.com/sharedfiles/filedetails/?id=570718026

 

Just follow the examples but of course use "Digital Combat Simulator: Black Shark" profile instead.

 

[uPDATE1]

Yep! Looks like DCS 1.5 also likes DX1x SLI bits 0x080000F5 as I'm not getting any artifacting and it runs great.

 

If you have a DCS 1.5 replay recommendation I could further test with to ensure it's working good that would be appreciated too... this flight sim is definitely too hardcore for me lol. :P

 

Here's my test settings:

BurlXt2t.png

 

Here's single-GPU at the starting training area:

iUcr5Ibt.png

 

Here's multi-GPU same area:

E2MxKD2t.png

 

So 110.7 FPS to 181.6 FPS. Pretty darn good gain. ;)

 

But yeh... any graphical anomalies with those SLI bits? Please post a screenshot on here. I use imgur since it's free and doesn't have crappy compression like some other image sharing sites but up to you what you use.

 

[uPDATE2]

Yeah I must be dumb or something as I can't seem to find DCS 1.5 replay downloads to better test these SLI bits haha I saw missions and qualification training thingies on that user files portion but no replays... @j123vanhoog, can ya point me in the right direction please or link me one of your replays? :P

 

Lol it's honestly the first and only SLI bits I've tested so far. It looks like ED did a fantastic job of their DirectX 11 implementation on DCS that is super SLI friendly. Maybe in the past they did work with NVIDIA to get SLI support in DirectX 9 by the looks of it and it luckily still holds true in DirectX 11.

 

Here's my super short test notes heh:

https://drive.google.com/file/d/0B7RnSWm3LBorVUxjY2FYV2NDa2s/view?usp=sharing

 

[uPDATE3]

nevermind lol after more testing 0x080000F5 is still the best bits. 0x081000F5 does give a slight framerate boost but shadows flicker a little when looking around the cockpit.

 

[uPDATE4]

Hmm, there is a slight flicker I noticed on the cockpit shadows after the loading screen on the training mission but as soon as you click "fly" it disappears. Very minor artifact that doesn't affect gameplay so that's lucky... to fix that though? ED would need to patch it. Tweaking SLI bits does not make it go away.

 

So yeah... my first SLI bit tests were the best and everything else either causes shadows to be non-transparent, flickering or "heat stroke" as I'm calling it since your vision goes blurry like your brain is melting from the sun. :P

 

Not too shabby! Only about three hours of smashing face on keyboard to test it all to see if it could be improved over my first test which it could not without sacrificing artifacting.

 

[uPDATE5]

Heyyo,

 

 

 

It "should" be... for the most part. It works great on my rig and on EntropySG's computer it sounds like it works with VSYNC On.

 

But as I stated above? I don't have tri-SLI or Quad-SLI so I can't confirm it works for them... but the last bit in that SLI string? the 5? That should add support for three and four GPU setups. Usually if an SLI compatibility bit ends with 1 it'll only work with two-way SLI... so yeah, that still needs to be tested.

 

I was going to try dynamic super resolution but apparently DCS hates downsampling... trying to do 3840x2160 to 1920x1080 has the user interface not scaling properly and I can't click on the menus hahaha... so I cry myself to sleep every night that I don't have a proper QHD or UHD monitor. :P

 

Luckily? Screenshots grabbed by MSI Afterburner are in the native QHD 3840x2160 resolution! So I can at least test the main menu in 4K QHD hahaha. :pilotfly:

 

Settings tested for 4K UHD:

TvoyFzVt.png

 

Single-GPU 4K UHD:

LgOTX2dt.png

 

SLI On 4K UHD:

naJLKx8t.png

 

So from 8.3FPS to 16.2FPS on the main menu clouds! Fantastic! That's a 200% performance gain! :)

 

So these SLI bits should REALLY benefit those with 4K UHD and 2K QHD monitors at least from what I can see on the main menu hahaha... so yeah, if someone has a native 4K UHD monitor? Please test the SLI bits as I can't even load the training missions or anything. :joystick:


Edited by ThE_MarD
Link to comment
Share on other sites

Hey People. I think The MarD is on to something here. Haven't looked at it critically yet but both cards running with significant bump in frames.

Thanks T MarD for giving this a go.

A Co, 229th AHB, 1st Cav Div

ASUS Prime Z370-A MB, Intel Core i7 8700K 4.9GHz OC'd, GeForce GTX 1080 Ti 11GB OC'd, 32GB DDR4, 1TB SSD, Windows 10 (64-bit)

Samsung 65" 4K Curved Display (Oculus Rift occaisionally), Track IR5, VoiceAttack, Baur's BRD-N Cyclic base/Virpil T-50CM Grip, UH-1h Collective by Microhelis & OE-XAM Pedals. JetSeat & SimShaker for Aviators.

JUST CHOPPERS

Link to comment
Share on other sites

I do agree with you, however I encountered an signifigant performance degradation with last set of drivers from Nvidia.

 

 

Precisely why there's a need for a profile.

[sIGPIC][/sIGPIC]

 

"The first time I ever saw a jet, I shot it down."- General Chuck Yeager, USAF, describing his first confrontation with a Me262.

 

 

JayRac3r/Lt_Mav YouTube Channel

Link to comment
Share on other sites

Hi The Mard and all,

 

I am testing these SLI Compatibilty Bits in DCS 2.0 and DCS 1.5 as of the last two or so hours with two GTX 770 2GB and so far this is what I found.

Yes there is a noticeable FPS increase in both versions of DCS, I have V-Sync forced on through inspector(on-smooth)and when I use the good old alt-enter proper full screen mode I get a very steady 60fps on my 4K monitor(but running in 2560x1440 at 60hz), but and it is a big but, I am getting an awful lot of flickering especially in DCS 1.5 mainly on the clouds and some ground textures, this sometimes disappears when you zoom right out and back in again but it seems in my tests it keeps reappearing and this is not pretty at all.

In DCS 2.0 I find with v-sync forced on through inspector again I get a nice steady 60fps and I have noticed it is a darn sight smoother but with v-sync off(by pressing alt-enter again) yes I get good frame rates9high 90's to 120's at times) but the infernal stuttering is the worst I've seen in DCS 2.0 so far and again I get flickering clouds and even entire textures missing replaced by awful flickering corrupted ground textures, sometimes they disappear sometimes they don't. I have fiddled with the anistropic settings in both versions but cannot get the flickering to stop entirely.

I was also running Re-Shade but turning this on and off made no difference at all.

Now I am no expert in graphic settings whatsoever but in my opinion although there is an improvement in overall FPS with v-sync turned off with v-sync turned on via alt-enter there is very little difference at all maybe a little smoother and steadier at least with my rig. I f anyone knows orfinds out how to stop the flickering then the Mard is on to a winner!!!!

 

My Rig:I-7 4690K oc to 4.5ghz.Two GTX 770's.32GB DDR3 1800MHZ RAM,HOTAS Warthog.Asus 4k 60HZ 28" Monitor and god knows how many Velociraptor HDD'S.Saitek Combat rudder pedals.

Link to comment
Share on other sites

Heyyo,

 

Hi The Mard and all,

 

I am testing these SLI Compatibilty Bits in DCS 2.0 and DCS 1.5 as of the last two or so hours with two GTX 770 2GB and so far this is what I found.

Yes there is a noticeable FPS increase in both versions of DCS, I have V-Sync forced on through inspector(on-smooth)and when I use the good old alt-enter proper full screen mode I get a very steady 60fps on my 4K monitor(but running in 2560x1440 at 60hz), but and it is a big but, I am getting an awful lot of flickering especially in DCS 1.5 mainly on the clouds and some ground textures, this sometimes disappears when you zoom right out and back in again but it seems in my tests it keeps reappearing and this is not pretty at all.

In DCS 2.0 I find with v-sync forced on through inspector again I get a nice steady 60fps and I have noticed it is a darn sight smoother but with v-sync off(by pressing alt-enter again) yes I get good frame rates9high 90's to 120's at times) but the infernal stuttering is the worst I've seen in DCS 2.0 so far and again I get flickering clouds and even entire textures missing replaced by awful flickering corrupted ground textures, sometimes they disappear sometimes they don't. I have fiddled with the anistropic settings in both versions but cannot get the flickering to stop entirely.

I was also running Re-Shade but turning this on and off made no difference at all.

Now I am no expert in graphic settings whatsoever but in my opinion although there is an improvement in overall FPS with v-sync turned off with v-sync turned on via alt-enter there is very little difference at all maybe a little smoother and steadier at least with my rig. I f anyone knows orfinds out how to stop the flickering then the Mard is on to a winner!!!!

 

My Rig:I-7 4690K oc to 4.5ghz.Two GTX 770's.32GB DDR3 1800MHZ RAM,HOTAS Warthog.Asus 4k 60HZ 28" Monitor and god knows how many Velociraptor HDD'S.Saitek Combat rudder pedals.

 

Hmm! Thanks for the update man. That would explain why Dynamic Super Resolution is so messed up then! It's not "true" fullscreen and why I can't seem to get GeDoSaTo Tools to work for testing downsampling... I have no idea how injecting hashes work on GeDoSaTo Tools so I can't fix that... but maybe if Durante can check this out he can resolve the issue?

 

http://blog.metaclassofnil.com/?page_id=582

 

His fantastic GeDoSaTo Tool can override resolutions and everything so maybe Durante or someone here could tinker with it to force true fullscreen which could potentially fix the issue! ;)

 

Otherwise? Without the alt-enter for true fullscreen I wasn't getting any stuttering or flickering minus the UI after loading a mission. Have you tried playing at your monitor's native resolution without alt-enter?

 

But ultimately if that doesn't fix it? Sadly it looks like it's up to ED to fix it in their game engine...

 

[EDIT1]

Please also try 0x000000F5

 

and 0x000000F1

 

same with... 0x00000055

 

and 0x00000051

 

Ultimately? SLI bits 00, 04 and 06 are the most important bits. I enabled bits 05, 07 and 27 since they tend to aid compatibility but could be causing your cloud flickering.


Edited by ThE_MarD
Link to comment
Share on other sites

Does this still require forcing AFR2 ?

Current Flight Rig

 

i7 4960X @ 4.6Ghz

ASUS Rampage IV Formula

G.SKILL TridentX 2400Mhz 32GB DDR3

Crucial 1TB MX300 SSD

MSI Gaming X 1080Ti

Samsung 55" JS8000 SUHD 4K

Windows 10 x64

TrackIR 5, Warthog HOTAS

Saitek Pro Flight Combat Pedals

Custom Akers-Barnes, MkI eyeball.

 

Link to comment
Share on other sites

Hi MarD,

Just tried at native resolution(full 4k) no difference here I'm afraid, in fact in DCS 1.5 the cloud flickering was even worse than 2560 x 1440 and FPS to be expected wasn't great but i'll put that down to my 770's.I'll now try the different SLI Compat bits you suggested.

Rob.

Link to comment
Share on other sites

Ok MarD,

Tried F1 and F5 and even F6 I couldn't find 55 and 51 as I'm using older drivers(tried and tested 358.87's) but to no avail all the clouds flickered some worse than others. Maybe the newer NVidia drivers will bring better results for some people I don't know but it didn't work for me sadly but keep up the investigating.

Rob.

Link to comment
Share on other sites

Heyyo,

 

Ok MarD,

Tried F1 and F5 and even F6 I couldn't find 55 and 51 as I'm using older drivers(tried and tested 358.87's) but to no avail all the clouds flickered some worse than others. Maybe the newer NVidia drivers will bring better results for some people I don't know but it didn't work for me sadly but keep up the investigating.

Rob.

 

Ah I see how I can test it meow by going instant action and free flight (I have no idea how to fly in this game haha that's why I was doing training missions).

 

Hmm dang! After more testing? Bit 04 causes the cloud flickering... which is sadly the most important SLI bit for getting the framerate boost... I've tried circumventing it to no avail... looks like ED's implementation of DirectX 11 is solid but will still need SLI compatibility patched into the game engine.

 

Mainly, it needs "true" fullscreen for the best performance scaling and not this fake borderless windowed or whatever they have going on and also they'd need to fix the flickering clouds caused by SLI bit 04. :(

 

So close... and yet so far... since clouds are everywhere in a flight sim. :doh:

 

So looks like NVIDIA SLI is indeed in the same boat as AMD's CrossFire for full Multi-GPU support? ED need to patch their game engine.

Link to comment
Share on other sites

Heyyo,

 

 

 

Hmm! Thanks for the update man. That would explain why Dynamic Super Resolution is so messed up then! It's not "true" fullscreen and why I can't seem to get GeDoSaTo Tools to work for testing downsampling... I have no idea how injecting hashes work on GeDoSaTo Tools so I can't fix that... but maybe if Durante can check this out he can resolve the issue?

 

http://blog.metaclassofnil.com/?page_id=582

 

His fantastic GeDoSaTo Tool can override resolutions and everything so maybe Durante or someone here could tinker with it to force true fullscreen which could potentially fix the issue! ;)

 

Otherwise? Without the alt-enter for true fullscreen I wasn't getting any stuttering or flickering minus the UI after loading a mission. Have you tried playing at your monitor's native resolution without alt-enter?

 

But ultimately if that doesn't fix it? Sadly it looks like it's up to ED to fix it in their game engine...

 

[EDIT1]

Please also try 0x000000F5

 

and 0x000000F1

 

same with... 0x00000055

 

and 0x00000051

 

Ultimately? SLI bits 00, 04 and 06 are the most important bits. I enabled bits 05, 07 and 27 since they tend to aid compatibility but could be causing your cloud flickering.

 

 

Is this Durante the same Durante as Dsfix?

[sIGPIC][/sIGPIC]

 

"The first time I ever saw a jet, I shot it down."- General Chuck Yeager, USAF, describing his first confrontation with a Me262.

 

 

JayRac3r/Lt_Mav YouTube Channel

Link to comment
Share on other sites

Heyyo,

 

Is this Durante the same Durante as Dsfix?

 

Yeah that dude. I tried tweaking a bunch of stuff with GeDoSaTo Tool and I can't get it to override the fake fullscreen that DCS uses... so I dunno if there'd need to be custom injection hashes to make it work. :\

 

But ultimately to fix the flickering clouds and stuttering will be up to ED though... It's their game engine that isn't 100% SLI compatible as the main SLI bit that gives the performance boost being bit 04 when enabled makes the clouds flicker and other bits don't affect the clouds at all.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...