Jump to content

SLI and 2.0


Recommended Posts

+1 on the notion to get ED to comment on all of this!

PC: Intel Core i7-7700K 4.2GHz | MSI GTX 1080 TI | ASUS Maximus IX Hero | 32GB DDR4 RAM | 2TB Samsung 870 EVO SSD | Win10 Pro 64bit

Gear: HP Reverb | JetPad FSE | MTX Sim Rig | VKB Gunfighter Pro Mk.III w/ MCG Ultimate (center) | VKB Gunfighter Mk.III w/ SCG-R Premium (side)

 

VKBNA_LOGO_SM.png

VKBcontrollers.com

Link to comment
Share on other sites

  • Replies 325
  • Created
  • Last Reply

Top Posters In This Topic

SLI and 2.0

 

In the meantime, I really do think it has something to do with Nvidia/Xfire as well. DCS is not that large of a community. So please comment on these links.

 

Link to SLI requests on Nvidia Forums and Crossfire on AMD Forums

http://forums.eagle.ru/showthread.php?t=155674

[sIGPIC][/sIGPIC]

 

"The first time I ever saw a jet, I shot it down."- General Chuck Yeager, USAF, describing his first confrontation with a Me262.

 

 

JayRac3r/Lt_Mav YouTube Channel

Link to comment
Share on other sites

  • 2 weeks later...

Hi Outlaw saw your comment I also pulled Sli and put in a Zotac gtx 980ti amp extreme but had micro stutter / judder dcs2 was not as smooth as my 980 . Note you put the MSI 980ti is it fully smooth and which MSI version was it. Sent back my 980ti as could not resolve the stutter/judder

F/A-18C Campaigns : The Serpent’s Head / The Serpent’s Head 2

-------------------------------------------------------------------------

I9 9900K @ 5.0Ghz / Gigabyte 2080ti water force extreme / 32 Gb RAM Corsair Dominator Platinum 3600 / 2Tb Samsung 970 Evoplus NVMe M.2 / Thrustmaster Warthog Hotas / Thrustmaster Pedals / Valve Index.

Link to comment
Share on other sites

Oh great... hadn't had time to fly in a while, installed 2.0 and no SLI. I don't care if it's called Alpha, Beta or Omega, it's 2015 and no SLI on 4K is just ridiculous and stupid. It's should be priority number 1.

 

This isn't Farm Simulator!

Link to comment
Share on other sites

Heyyo,

 

PLEASE! Reply to this thread on the geforce forums if you have any issues with the test SLI bits as I might not check this thread:

https://forums.geforce.com/default/topic/903615/sli/dcs-series-sli-/3/

 

So I wanted to test DCS 2.0 since it's going to be the latest build as you said... and WTH!!! It says on their website free-to-play for DCS 2.0 so I downloaded it and says two free aircraft... but you have to buy the terrain DLC and it's $50!? :(

 

So I at least tested the main menu in SLI hahaha... Just waiting for DCS 1.5 to download meow. Luckily it seems DCS 2.0 content is getting copied to 1.5 thank god I don't have to waste too much bandwidth re downloading everything...

 

Anywho? DX1x SLI bits 0x080000F5 seem to work good on the main menu... Try those out on DCS 2.0 please. Just use NVIDIA Inspector and change the DX1x SLI bits to that 0x080000F5 is all I did. It seems to be the most compatible SLI bits for most DirectX 11 games anyways.

 

Like this:

Kxy6yVv.png

 

Don't worry about the title of the game, it seems like the DCS series all use that same dcs.exe so that's all that matters for NVIDIA driver profiles tbh.

 

If you have any graphical artifacts please post results here and use MSI Afterburner in your screenshots if you can too please to give me an idea if scaling, GPU usage and clock speeds are ok.

 

Here's DCS 2.0 SLI tests on main menu with single-GPU:

OooHCXot.png

 

Here it is with DX1x SLI bits 0x080000F5:

BaBGQjKt.png

 

So 21.6fps single GPU and 40.4fps with those SLI bits... that's good news as DCS 2.0 should be SLI friendly.

 

 

Here's more info on how to use NVIDIA Inspector in case you're new to it:

http://steamcommunity.com/sharedfiles/filedetails/?id=570718026

 

Just follow the examples but of course use "Digital Combat Simulator: Black Shark" profile instead.

 

[uPDATE1]

Yep! Looks like DCS 1.5 also likes DX1x SLI bits 0x080000F5 as I'm not getting any artifacting and it runs great.

 

If you have a DCS 1.5 replay recommendation I could further test with to ensure it's working good that would be appreciated too... this flight sim is definitely too hardcore for me lol. :P

 

Here's my test settings:

BurlXt2t.png

 

Here's single-GPU at the starting training area:

iUcr5Ibt.png

 

Here's multi-GPU same area:

E2MxKD2t.png

 

So 110.7 FPS to 181.6 FPS. Pretty darn good gain. ;)

 

But yeh... any graphical anomalies with those SLI bits? Please post a screenshot on here. I use imgur since it's free and doesn't have crappy compression like some other image sharing sites but up to you what you use.

 

[uPDATE2]

Yeah I must be dumb or something as I can't seem to find DCS 1.5 replay downloads to better test these SLI bits haha I saw missions and qualification training thingies on that user files portion but no replays... @j123vanhoog, can ya point me in the right direction please or link me one of your replays? :P

 

Lol it's honestly the first and only SLI bits I've tested so far. It looks like ED did a fantastic job of their DirectX 11 implementation on DCS that is super SLI friendly. Maybe in the past they did work with NVIDIA to get SLI support in DirectX 9 by the looks of it and it luckily still holds true in DirectX 11.

 

Here's my super short test notes heh:

https://drive.google.com/file/d/0B7RnSWm3LBorVUxjY2FYV2NDa2s/view?usp=sharing

 

[uPDATE3]

nevermind lol after more testing 0x080000F5 is still the best bits. 0x081000F5 does give a slight framerate boost but shadows flicker a little when looking around the cockpit.

 

[uPDATE4]

Hmm, there is a slight flicker I noticed on the cockpit shadows after the loading screen on the training mission but as soon as you click "fly" it disappears. Very minor artifact that doesn't affect gameplay so that's lucky... to fix that though? ED would need to patch it. Tweaking SLI bits does not make it go away.

 

So yeah... my first SLI bit tests were the best and everything else either causes shadows to be non-transparent, flickering or "heat stroke" as I'm calling it since your vision goes blurry like your brain is melting from the sun. :P

 

Not too shabby! Only about three hours of smashing face on keyboard to test it all to see if it could be improved over my first test which it could not without sacrificing artifacting.

 

[uPDATE5]

http://forums.eagle.ru/showpost.php?p=2628130&postcount=188


Edited by ThE_MarD
  • Like 1
Link to comment
Share on other sites

Any other info on the other settings used in the NVIDIA Inspector Profile Settings? Especially the SLI and Common sections? Thanks!

PC: Intel Core i7-7700K 4.2GHz | MSI GTX 1080 TI | ASUS Maximus IX Hero | 32GB DDR4 RAM | 2TB Samsung 870 EVO SSD | Win10 Pro 64bit

Gear: HP Reverb | JetPad FSE | MTX Sim Rig | VKB Gunfighter Pro Mk.III w/ MCG Ultimate (center) | VKB Gunfighter Mk.III w/ SCG-R Premium (side)

 

VKBNA_LOGO_SM.png

VKBcontrollers.com

Link to comment
Share on other sites

Heyyo,

 

Any other info on the other settings used in the NVIDIA Inspector Profile Settings? Especially the SLI and Common sections? Thanks!

 

Nope! I just left the rest as auto. If you run into any issues? Just set it to..

 

DX1x SLI mode = SLI_PREDEFINED_MODE_DX10_FORCE_AFR

 

And set the DX1x number of GPUs to two. I don't have more than Two-Way SLI so I can't vouch if it'll work on three way or quad SLI.

Link to comment
Share on other sites

Heyyo,

 

I just tried it and it seems to be working. I get full SLI (both 970s are used at 40% now) and also the SLI indicator shows. I get no increased FPS however at my settings, so there does not seem to be any benefit to it.

 

Are you playing with VSYNC On? That would limit your framerate to probably 60fps. For example on World of Tanks I play with VSYNC on and my framerate locks to 60fps and my GPU utilization only goes up to 60% each.

 

In my test screenshots I was playing with VSYNC Off, hence the 100fps and then 180fps... screen-tearing like crazy haha since I only have a 60Hz monitor but... y'know... PcMasterRace testing. :P

Link to comment
Share on other sites

Heyyo,

 

[uPDATE6]

Hmm, turns out SLI bit 04 causes clouds to flicker yet it's the most important bit for SLI performance... so it's up to the game developers to patch their game engine to stop clouds from flickering and also patch out that fake fullscreen crap they're using which prevents downsampling and causes the first GPU not to reach full GPU usage too.

http://forums.eagle.ru/showthread.php?t=155674&page=5

 

so... SLI situation = "solved"

 

??

 

It "should" be... for the most part. It works great on my rig and on EntropySG's computer it sounds like it works with VSYNC On.

 

But as I stated above? I don't have tri-SLI or Quad-SLI so I can't confirm it works for them... but the last bit in that SLI string? the 5? That should add support for three and four GPU setups. Usually if an SLI compatibility bit ends with 1 it'll only work with two-way SLI... so yeah, that still needs to be tested.

 

I was going to try dynamic super resolution but apparently DCS hates downsampling... trying to do 3840x2160 to 1920x1080 has the user interface not scaling properly and I can't click on the menus hahaha... so I cry myself to sleep every night that I don't have a proper QHD or UHD monitor. :P

 

Luckily? Screenshots grabbed by MSI Afterburner are in the native QHD 3840x2160 resolution! So I can at least test the main menu in 4K QHD hahaha. :pilotfly:

 

Settings tested for 4K UHD:

TvoyFzVt.png

 

Single-GPU 4K UHD:

LgOTX2dt.png

 

SLI On 4K UHD:

naJLKx8t.png

 

So from 8.3FPS to 16.2FPS on the main menu clouds! Fantastic! That's a 200% performance gain! :)

 

So these SLI bits should REALLY benefit those with 4K UHD and 2K QHD monitors at least from what I can see on the main menu hahaha... so yeah, if someone has a native 4K UHD and/or 2K QHD monitor? Please test the SLI bits as I can't even load the training missions or anything. :joystick:


Edited by ThE_MarD
  • Like 1
Link to comment
Share on other sites

HOLY SHIT THIS IS REALLY WORKING!

 

ThE MarD, youre a superstar!!!

 

The only reson why I did not see a FPS increase in the first place was because my 970 card was simply not the limiting factor. Now I cranked everything up to the max, including resolution to true 4k+USB screen for a total of 5206 x 2160 which I could not run before.

 

a stable 65 fps in 4k, WITH SLI and about 40 FPS without!!!

 

THANKS!

Link to comment
Share on other sites

What we need is a SLI profile which supports the borderless windowed mode too, for running with Helios and multiple displays.

This seems possible for some other games which were optimized by Nvidia...

ASROCK X79 Extreme11 (WC), i7-4930K (WC), 32GB G.Skill TridentX, Vertex 3 120GB, GTX 980ti, 3x 39,5" Philips 4K, TrackIR 5, TM Warthog with PeterP´s FFB2 Mod, 2xSaitek Throttle, 2x Thrustmaster Cougar MFD Bezel, Simped Vario Pedals modded with toe brakes, Opencockpit Cards, 4x Soundcard, 2x Buttkicker Gamer 2, 4x GTX 950 with tons of touchscreens...

Link to comment
Share on other sites

Heyyo,

 

Hmm dang, after more testing and conversation in another thread? There's cloud flickering issues I can't fix from within the NVIDIA driver... it's an issue with the game engine from Eagle Dynamics.

 

Read on this thread for more info:

http://forums.eagle.ru/showthread.php?t=155674&page=5

 

Yo, I had crazy cloud flicker too, but then I noticed that I still had the SLI mode force AFR2 somewhere on, which caused it.

 

When I select everything to autoselect, I do have no cloud flicker, or I should say almost none, just very occasional. Im an A10C guy, so I dont look into the clouds too much heh. The only thing I noticed is some flicker in the TGP in FLIR mode... but then, I take it for the additional graphic power that allows me to utilize my 4k screen with display exports etc

Link to comment
Share on other sites

Yo, I had crazy cloud flicker too, but then I noticed that I still had the SLI mode force AFR2 somewhere on, which caused it.

 

When I select everything to autoselect, I do have no cloud flicker, or I should say almost none, just very occasional. Im an A10C guy, so I dont look into the clouds too much heh. The only thing I noticed is some flicker in the TGP in FLIR mode... but then, I take it for the additional graphic power that allows me to utilize my 4k screen with display exports etc

 

 

ah crap disregard.

It worked when I played singleplayer. As soon as I join the 132nd dedicated server, I get the crazy cloud flicker too. Damn

Link to comment
Share on other sites

Heyyo,

 

Yeah sorry EntropySG, ED need to fix their game engine. :(

 

Yeah be sure to submit a support ticket directly with ED... that's your best bet for SLI compatibility tbh. It's definitely their game engine which is usually the case anyways with all games...

 

  • They should fix clouds flickering and some minor shadow flickering to improve NVIDIA SLI compatibility with either SLI bits 0x081000F5 preferrably... or at least 0x080000F5
  • They should fix stuttering issues with NVIDIA SLI enabled. Same goes for AMD CrossFire from everything I've seen on the forums
  • They should add "True" fullscreen instead of just borderless windowed and windowed modes which would improve SLI scaling as the first GPU never matches the second GPU in usage due to borderless windowed. It also prevents resolution downsampling from working (NVIDIA Dynamic Super Resolution & AMD's Virtual Super Resolution)

 

Use this link amigo:

https://www.digitalcombatsimulator.com/en/support/

 

Here's what Mine looked like. Essentially just copied and pasted all my stuff. :P

ceOZVckt.png

Link to comment
Share on other sites

The devs have been COMPLETELY MIA with regard to this topic which tells me they know what's going on and probably can't or won't fix it. I have enough experience with devs to know when they are MIA that there is a serious problem. I may at some point be grabbing another 980ti so this topic still concerns me.

  • Like 1

ROTORCRAFT RULE

 

GB Aorus Ultra Z390| 8700K @ 4.9GHz | 32 GB DDR4 3000 | MSI GTX 1080ti | Corsair 1000HX | Silverstone FT02-WRI | Nvidia 3D Vision Surround | Windows 10 Professional X64

 

Volair Sim Cockpit, Rift S, Saitek X-55 HOTAS, Saitek Pro Flight Rudder Pedals, Microsoft FF2, OE-XAM Bell 206 Collective, C-Tek anti-torque pedals

 

UH-1, SA342, Mi-8, KA50, AV8B, P-51D, A-10C, L39, F86, Yak, NS-430, Nevada, Normandy, Persian Gulf

Link to comment
Share on other sites

The devs have been COMPLETELY MIA with regard to this topic which tells me they know what's going on and probably can't or won't fix it. I have enough experience with devs to know when they are MIA that there is a serious problem. I may at some point be grabbing another 980ti so this topic still concerns me.

 

Dont Assume.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, 2x R7970 Lightnings Crossfired @ 1.1/6.0GHz,

3x ASUS VS248HP + Hanns·G HZ201HPB + Oculus HMD,

Thrustmaster Warthog HOTAS + MFDs, CH Fighterstick+Pro Throttle+Pro Pedals

Link to comment
Share on other sites

yeah, they see this

 

this is just their way - they don't come out and list everything they're working on and publish a timeline ---- it takes time but they do go after issues that are sticking up

i7-4790K | Asus Sabertooth Z97 MkI | 16Gb DDR3 | EVGA GTX 980 | TM Warthog | MFG Crosswind | Panasonic TC-58AX800U

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

I tested this and didn't notice any improvement compared to forcing AFR2. If anything it introduced unwanted flickering.

 

The biggest hit I've found is tree visibility, setting to max 25000 I lose 20fps, I gain it back by setting at half way or lower, with mirrors on, most settings max. There I have 60fps or higher T 2560x1440.

Current Flight Rig

 

i7 4960X @ 4.6Ghz

ASUS Rampage IV Formula

G.SKILL TridentX 2400Mhz 32GB DDR3

Crucial 1TB MX300 SSD

MSI Gaming X 1080Ti

Samsung 55" JS8000 SUHD 4K

Windows 10 x64

TrackIR 5, Warthog HOTAS

Saitek Pro Flight Combat Pedals

Custom Akers-Barnes, MkI eyeball.

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...