Jump to content

DCS World 1.2.15 Release Build Discussion


*Rage*
 Share

Recommended Posts

  • Replies 179
  • Created
  • Last Reply

Top Posters In This Topic

Nope, just the wrong exe file, see my edit :)

 

After i finished downloading the Beta the normal 1.2.15 update came.:doh:

 

You should install and keep it, so you've got it the next time an update comes.

 

€dit again: now I'm doing it anyway because of this ;)

 

Guys remember to click on "repair install" once you finished downloading and installing the patch. Otherwise, you're gonna have an issue with the MiG-21. You can see it with the missing background on the desktop and the icon in the main menu that is a white eagle on green font.

 

My repair size was about 300 mb and it fixed the issue.

 

Thanks!


Edited by Eldur

dcsdashie-hb-ed.jpg

 

Link to comment
Share on other sites

Mine is dead too.

 

Ran the update, now it won't start at all. Tried repair, tried exe in main bin folder just flashes the start pic and dies.

 

Do I need to re-install the whole thing? I hope not, as I have all the add-ons but one.


Edited by willys
spelling error
Link to comment
Share on other sites

automatic updater? How to use it?

 

Hello,

 

I just received an e-mail about the release of DCS World 1.2.15. It states

"You can download DCS World 1.2.15 using the automatic updater".

I just wonder how to use the automatic updater and where it's located inside the program.

 

I moved few days ago from Steam installation to DCS site, so this is my first time I must go after a non automatic udpate of the game outside Steam.

 

BTW, I searched this forum for automatic updater without results.

 

Thanks in advance.

Link to comment
Share on other sites

"IMPORTANT:

Star Force ProActive has recently implemented a deactivation option for DCS: MiG-21bis. In order to avoid an unneeded activation of previously activated module due to Start Force protection changes, please:

Deactivate the module

Exit DCS

Start DCS again

Activate the module after starting a MiG-21BIS mission

 

Exactly how am I to deactivate the module (as in the first step) when there currently is no deactivate function?

Link to comment
Share on other sites

Hi there,

 

after installing the update and everything else, the MiG-21 is working, as the rest - but my A10-C is not working anymore! :cry:

 

Just starting, loading ground objects and a few things, than stops and back to the mission editor...

 

I repaired a couple of times; deactivated any Mod in JSGME... nothing seems to work.

 

Any idea if I may ask? :music_whistling:

 

SineTimore :pilotfly:

Space Aviator Cavalary



58th Squadron, 5th Wing. USS Saratoga

Wildcards - Expect No Mercy!



Link to comment
Share on other sites

Thanks for this patch, only one question... I installed the patch, run the repair (for the MiG-21 Problem) and now...

 

I'm missing the Flaming Cliffs Manual in german language.

I searched in DCS\Mods\aircraft\Flaming Cliffs\Doc without success.

I'm using DCS in english but to my best knowledge all language versions were installed in the past!?


Edited by FSKRipper

i9 9900K @ 5,0GHz | 1080GTX | 32GB RAM | 256GB, 512GB & 1TB Samsung SSDs | TIR5 w/ Track Clip | Virpil T-50 Stick with extension + Warthog Throttle | MFG Crosswind pedals | Gametrix 908 Jetseat

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

This update just wrecked my DCS totally.

My wingman is experiencing some wierd stuff as well.

 

Me before:

60-120 fps average

Me now: 10 and laggy as hell. Totally unplayable.

 

Wingman:

Ka-50 crashes his game

 

Without mods - instant action - quick missions. All tested.

 

My system:

Win8 64x

i7-4770K

2x8GB DDR3 Corsair Dominator platinum 1866mhz cl9 RAM

GTX 690 (Multi-GPU off for DCS although it made no difference this time. It cant get worse I suppose)

 

Something in this update has seriously messed my DCS up.

 

EDIT: Im gonna have to make a game performance support thread for this.


Edited by <Grizzly>
Link to comment
Share on other sites

The DCS_updater that I can find inside the bin folder just starts the game up with the 1.2.14 version, as if there were no updates available I assume, but the auto-updater that you can download separately, also called DCS_updater.exe with the DCS icon, actually does update the game. Funny.

Link to comment
Share on other sites

I'm not sure if I'm imagining things here, but this version seems to run better than any _ever_ on this machine - FPS at constant 30 now, regardless of how big a mission is running. And the GFX seem subtly different and better too; the lighting seems improved somehow, as do the explosion effects. Overall, the experience is totally hiccup-free and fluid now.

 

Is it just me? Or did they _really_ change something profound in v1.2.15?

 

PS. It should be mentioned however that DCS has always run pretty well for me, so I dunno really... SEEMS more fluid anyhow.


Edited by msalama

The DCS Mi-8MTV2. The best aviational BBW experience you could ever dream of.

Link to comment
Share on other sites

Can anyone actually fly the MiG-21Bis or Hawk T.1A in 1.2.15? The MiG-21Bis displays to me what looks like I'm sunk into the fuselage and is completely unresponsive to controls. Selecting a T.1A just drops me in an A-10C....

 

No! I do have the MiG21Bis but it seems porked. All of it's Instant Missions are totally just gone. The list is empty. :cry:

 

And if I Create Fast Mission, my view is way in front of the cockpit. I can just see the tip of the nose and pitot tube. I have no controls. Not even the keyboard works. I cannot press ESC to get out even after I crash!:doh:

 

So, if I 'try' to fly the MiG21 I have to End Task to get out of the mission. :mad:

Intel I9-10850K (OC @ 5.0ghz) │ Asus Maximus XII Hero │ G.Skill Ripjaws 64GB (4x16GB) DDR4 3200 │ Thermaltake Water 360mm

Gigabyte RTX 3080 Gaming OC 10gb │ 2TB M.2 EVO Pro; 1T M.2 EVO; Sandisk SSD Drives │ 3x Acer 28" │ 1x 28" Touchscreen
- ҉ - Blackshark Cockpit Trainer - ҉ -    Thread   | Download
Link to comment
Share on other sites

I did a repair that downloaded almost 400MB and the MiG-21Bis works now. Weird, but whatever. I don't have any mods or weirdness installed, but it works now, so not complaining. Agree on the Hawk; was just surprised to have problems with both instead of just the one.

 

Thanks xao!! That fixed it.

 

And this patch gave me some fps back! I had been wondering why my fps dropped from 45 to 25 several weeks ago. I've been playing with all kinds of settings on my 660Ti 3g, but none helped. I couldn't figure out why my game was slow. So it gave me the kick in the pants go order a GTX 980 4gb a few days ago... And now with this patch I am getting 30-45fps in dogfights! :lol:


Edited by Snacko

Intel I9-10850K (OC @ 5.0ghz) │ Asus Maximus XII Hero │ G.Skill Ripjaws 64GB (4x16GB) DDR4 3200 │ Thermaltake Water 360mm

Gigabyte RTX 3080 Gaming OC 10gb │ 2TB M.2 EVO Pro; 1T M.2 EVO; Sandisk SSD Drives │ 3x Acer 28" │ 1x 28" Touchscreen
- ҉ - Blackshark Cockpit Trainer - ҉ -    Thread   | Download
Link to comment
Share on other sites

Yes it seems to have done for quite a few people. I still cannot get it repaired or started, all this after it supposedly updated itself to 1.2.15

 

I can't say I'm impressed really as I have now read that people with the closed beta had the same problems....so why release it as open beta.

 

I'm currently downloading the whole 1.2.15 which is a whopping 8.98Gb on a Friday night net connection shared with someone watching streaming TV.

 

All with a view to re-installing the whole thing. Not my plan for the weekend really.

 

Some say 1.2.15 is great, others say it's a frame rate disaster....I hope not !

 

And the whole thing is going down without a word from anyone involved in making it happen.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...