Jump to content

MOOSE - Mission Object Oriented Scripting Framework


Recommended Posts

  • Replies 2.2k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Ok. I'll check it tomorrow xcom.

Yes 👍

I've narrowed it to CVN-75, the newest addition to the Supercarrier series. Can anyone confirm if they have AIBOSS working on CVN-75?

Correct, CVN-75 has been added to the master and development branches of MOOSE but is not in the latest release v2.5.1 included.

A warrior's mission is to foster the success of others.

i7-8700K | Asus RTX 2080Ti Strix OC | 32 GB Ram 3200 MHz DDR-4 | Asus Maximus Hero X | Samung EVO 960 Pro SSD | VKB Gunfighter Pro | MFG Crosswind | Rift S

RAT - On the Range - Rescue Helo - Recovery Tanker - Warehouse - Airboss

Link to post
Share on other sites
  • 3 weeks later...

Hi guys,

 

Maybe I'm overthinking this...

 

The goal is to have an "IED" object explode when a blue ground unit is within a given distance of 10-15m.

 

I have a number of red IED objects, named IED-(n) These will be dynamically spawned, and will have unpredictable names.

 

They are collected into a SET_GROUP.

 

I've tried creating zones & triggers in the ME for the explosion, and using ZONE_RADIUS:SetVec2(vec2), and while that DOES relocate the zone (verified with bounding), the ME triggers don't recognize the change.

 

Also tried using detection (from the IED) which appears to be an unreliable dead end road.

 

Is there another high level approach here that you see possibly working?

 

It's already a very large and very busy & frame-rate-taxing mission, so I'd like to avoid creating a 1 second scheduler for each of these devices.

 

Thank you!

 

[sIGPIC][/sIGPIC]

Are you ready to take your chopper flying skills to the next level?

Then check out http://www.blacksharkden.com/ Or visit us on Discord https://discord.gg/kaayJ5z and talk to some of our awesome pilots today.

Link to post
Share on other sites

I can't get MOOSE Zone Class to work anymore. I built my Polygon Zones like I usually do with MOOSE, but getting nothing. I went through the script a few times, everything was right, so I ran some of the test missions that deal with polygon zones, none of them worked either,

did something in recent update break zone class?

Hebrews 13:2

 

“Be not forgetful to entertain strangers: for thereby some have entertained angels unawares.”

Link to post
Share on other sites
I can't get MOOSE Zone Class to work anymore. I built my Polygon Zones like I usually do with MOOSE, but getting nothing. I went through the script a few times, everything was right, so I ran some of the test missions that deal with polygon zones, none of them worked either,

did something in recent update break zone class?

 

Any log errors?

Link to post
Share on other sites
Hi guys,

 

Maybe I'm overthinking this...

 

The goal is to have an "IED" object explode when a blue ground unit is within a given distance of 10-15m.

 

I have a number of red IED objects, named IED-(n) These will be dynamically spawned, and will have unpredictable names.

 

They are collected into a SET_GROUP.

 

I've tried creating zones & triggers in the ME for the explosion, and using ZONE_RADIUS:SetVec2(vec2), and while that DOES relocate the zone (verified with bounding), the ME triggers don't recognize the change.

 

Also tried using detection (from the IED) which appears to be an unreliable dead end road.

 

Is there another high level approach here that you see possibly working?

 

It's already a very large and very busy & frame-rate-taxing mission, so I'd like to avoid creating a 1 second scheduler for each of these devices.

 

Thank you!

 

Probably should take this to Moose Discord for help. I assume you have read the Moose User Guide?? As for general help, why not dynamically spawn both objects and zones, or only the zones, as the objects themselves may be superfluous. The only practical method of triggering time-related actions is by means of a scheduler, either scripted or ME-triggered, both of which employ an API scheduler.

Link to post
Share on other sites

 

Any log errors?

 

This is the included "Zone Polygon" sample mission from MOOSE, the log file and a screen cap that shows that the zone smoke isn't there.

 

 

 

 

 

 

polygon.thumb.png.8fea0725b2ea2aa003b43e8ee59f47ba.pngwAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

 

2020-11-15 04:49:40.649 ERROR SCRIPTING: Mission script error: [string "C:\Users\Bishop\AppData\Local\Temp\DCS.openbeta\/~mis0000077C.lua"]:2: attempt to index global 'Include' (a nil value)
stack traceback:

Hebrews 13:2

 

“Be not forgetful to entertain strangers: for thereby some have entertained angels unawares.”

Link to post
Share on other sites

The last update now incorporates the F14A, and I do see it listed in Moose. However Airboss is not recognizing it. I'm sure it's a naming convention error, how can I verify Moose is including the proper name?

 

AIRBOSS.AircraftCarrier={

AV8B="AV8BNA",

HORNET="FA-18C_hornet",

A4EC="A-4E-C",

F14A="F-14A_tomcat",

F14B="F-14B",

F14A_AI="F-14A",

FA18C="F/A-18C",

S3B="S-3B",

S3BTANKER="S-3B Tanker",

E2D="E-2C",

C2A="C2A_Greyhound",

}


Edited by Reccelow
Added pertinent part of moose.lua
Link to post
Share on other sites

patch was only released yesterday, moose will catch up soon

 

you can edit this to fix it for now

 

AIRBOSS.AircraftCarrier=

 

{ F14A="F-14A_tomcat"

 

should be

 

F14A="F-14A-135-GR"

 

 

Click here for tutorials for using Virpil Hardware and Software

 

Click here for Virpil Flight equipment dimensions and pictures.

.

Link to post
Share on other sites

Can someone help me? Trying to implement the Airboss script for Moose to use with supercarrier, I was able to load up the moose.lua file so i have "other/settings" in the comm menu but no Airboss, I tried loading the airboss.lua after the moose.lua with no luck. The guides are a little confusing to me as I just only want airboss nothing more.

Link to post
Share on other sites

Hi, folks,

 

I'm pretty familiar with the ME, and have done a lot of programming. MOOSE seems awesome, but as I'm starting to work with it (very basic test scripts to this point), I'm seeing some behaviors that I don't understand.

 

First question is timing. I'm using the following code to spawn a group and then change its waypoint. If I schedule the SwitchWayPoint after delay it works fine, but without the scheduler it doesn't work:

-- Spawn the group and make a group object
local HS1 = SPAWN:New('Huey')
HS1:InitRandomizePosition(true, 1600*5, 0) -- ~5 mile radius
HS1:Spawn()
local HG1 = GROUP:FindByName('Huey#001')

-- Try to switch waypoint...THIS DOES NOT WORK
HG1:SetCommand(HG1:CommandSwitchWayPoint(3,5))

-- But if I schedule the waypoint switch it works
HG1:ScheduleOnce(5,
 function()
   HG1:SetCommand(HG1:CommandSwitchWayPoint(3,5))
 end, {}
)

 

I have also found that the unscheduled WP switch works fine if I put in a separate script that runs later, or if I it is applied to a group that is present at the start of the mission. What gives? Does it take some time to "finish" the spawn process, and it's simply not done by the time the subsequent code is run?

 

Second, why do some things have to be within SetCommand() while others can be done directly:

HG1:SetCommand(HG1:CommandSwitchWayPoint(3,5)) -- This works
HG1:CommandSwitchWayPoint(3,5) -- This does not work

HG1:CommandSetCallsign(3,2,0) -- This works
HG1:SetCommand(HG1:CommandSetCallsign(3,2,0)) -- This works, but throws an error in the log

 

I feel like there are some basic things I'm missing here.

 

Any help appreciated, thanks!

ColdFront_WI

Home-built Hornet pit, detailed plans available on GitHub

Virpil WarBRD base, TM Hornet/Warthog grip, TM Warthog Throttle, Logitech G Pro rudder pedals

MSI MPG Z390M, i9-9900k @ 5.0GHz with Noctua NH-D15, RTX 2080ti FE, 32GB DDR4 @ 3200MHz, 1TB NVMe M.2 SSD, HP Reverb

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

So, is MOOSE zone class broken?      still can't create polygon zones, tried with late activated unit.    sample polygon zone missions included in MOOSE Missions, not working either.

Hebrews 13:2

 

“Be not forgetful to entertain strangers: for thereby some have entertained angels unawares.”

Link to post
Share on other sites

I will state that I have never used this Moose Time class; however, s ince it is based on the Moose Scheduler class, clues to its use can likely be found there. The a and b parameters are included only if required by myfunction, I believe. I find this non-Moose script very useful for simple timed actions:

timer.scheduleFunction( NewBandit, {}, timer.getTime() + 5 )  - - NewBandit is some function

This script frag executes function NewBandit delayed by 5 sec. from the time the line is read by DCS.

Link to post
Share on other sites
2 hours ago, hancerPL said:

Yes, that's how I use it, but maybe ''myfunction'' will be simple.

Assume you have read the class docs carefully and the Moose User Guide. Note that TIMER:New() creates the TIMER object, but TIMER:Start() makes it go.

Link to post
Share on other sites

Hello,

 

I'm trying to use the MOOSE Cargo system, but I don't seem to understand it correctly, unfortunately.

 

What I'd like to do is just creating transportable troops with human-controlled helicopters, without using task dispatching or any other particular logic. It would be up to the players on the server to land near an infantry group, load it, transport it somewhere else, and unload it there.

 

I read the documentation at https://flightcontrol-master.github.io/MOOSE_DOCS/Documentation/Cargo.Cargo.html, and after reading the following section:

"

5.2) The #CARGO tag to create CARGO_GROUP objects:

You can also use the #CARGO tag on group objects of the mission editor.

For example, the following #CARGO naming in the group name of the object, will create a CARGO_GROUP object when the mission starts.

Infantry #CARGO(T=Workmaterials,RR=500,NR=25)

This will create a CARGO_GROUP object:

  • with the group name Infantry #CARGO
  • is of type Workmaterials
  • will report when a carrier is within 500 meters
  • will board to carriers when the carrier is within 500 meters from the cargo object
  • will dissapear when the cargo is within 25 meters from the carrier during boarding

So the overall syntax of the #CARGO naming tag and arguments are:

GroupName #CARGO(T=CargoTypeName,RR=Range,NR=Range)

  • T= Provide a text that contains the type name of the cargo object. This type name can be used to filter cargo within a SET_CARGO object.
  • RR= Provide the minimal range in meters when the report to the carrier, and board to the carrier. Note that this option is optional, so can be omitted. The default value of the RR is 250 meters.
  • NR= Provide the maximum range in meters when the cargo units will be boarded within the carrier during boarding. Note that this option is optional, so can be omitted. The default value of the RR is 10 meters."

I thought I only had to name my infantry group with something like "USTroop01 #CARGO(T=Workmaterials,RR=500,NR=25)", for example, and then I would automatically get submenu options under the F10 menu for loading/unloading when my helicopter would be landed near enough. But I don't get any submenu under F10, so I guess my understanding is not correct (?)

 

Would anyone be so kind as to help me achieve what I'm trying to do, please? Or maybe it's not possible and using task dispatching is mandatory?

 

Thanks for your help, and sorry if I missed anything when searching the forum and documentation.

 

 

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
  • 2 weeks later...
On 12/22/2020 at 5:46 AM, hancerPL said:

After the last update, Moose does desync on the servers.

 

It is impossible to use the scripts correctly. I had to remove it and it is mission and server independent.

 

 

We have hundreds of people using Moose daily and haven't heard from anyone else having issues like this. It could be something specific you are using in your mission. Try slimming down various parts of what you are using to see if you can pinpoint the issue.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...