Jump to content

Kneeboard Builder (windows app)


Recommended Posts

  • Replies 1.5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

he has not connected since November 20th .. hopefully it’s just real life issues and not a health one.

What version of windows do you have?

 

Try this earlier version and see if it works:

 

Version 1.2.1

 

(Click 'no' when it asks you if you want to update)

 

 

EDIT:

 

It appears the 'drag and drop' feature is not working for you for some reason. I am working on a quick fix that adds a browse button so you can manually browse to the file if you cannot drag and drop.


Edited by AlaskanGrizzly
Link to post
Share on other sites

AlaskanGrizzly

Much to my amazement ( because of the lack of my ability), I actually got your program to work and added an A10-C start up checklist to the kneeboard. However, I do have some questions.

When I activate the A10 Kneeboard, the first few pages include some maps and stuff that I assume are in the default kneeboard created by PeterP. Correct? I further assume that I can just delete them-correct?

The issue of subfolders is confusing to me. I would like to create an A10C subfolder for just certain checklists. If I create such a subfolder, how do I get it to appear in the kneeboard when I activate the kneeboard?

 

I think that I figured out the subfolder issue. You just make another folder under the game name and then simply change the folder to be used by your program. If you want to go back to your regular folder, again you would use your program to simply change folders. Correct?


Edited by sobe
answered my subfolder question.

Trackir4 using the latest Trackir 5 software, Win10 Pro [Creator Update] updated from Win7Pro Pro 64Bit, Intel® Core™ i5-2500 3.30 GHz 6M Intel Smart Cache LGA115 , GigaByte GA-Z68XP-UD4 Intel Z68 Chipset DDR3 16GB Ram, GTX MSI Gaming 1060 [6 GB] Video Card, Main Monitor 1 on left 1920x1080 Touchscreen Monitor 2 on right 1920x1080 .

Link to post
Share on other sites

When I activate the A10 Kneeboard, the first few pages include some maps and stuff that I assume are in the default kneeboard created by PeterP. Correct? I further assume that I can just delete them-correct?

 

The maps that appear in the default kneeboard are included at runtime in DCS and cannot be removed. The airport charts, however, can be removed. You can use my program to modify the default kneeboard as well.

 

To completely clear the default kneeboard:

 

1) In the 'Create Custom Kneeboard' tab under 'Select Aircraft' select 'Default Kneeboard'.

2) Make sure the 'Groups for Selected Kneeboard' section is empty.

3) Click on the 'Clear Default Kneeboard' button directly below the 'Groups for Selected Kneeboard' section.

4) A message box will appear telling you the Default Kneeboard has been cleared.

 

To restore the airport charts to the default kneeboard:

 

1) In the 'Create Custom Kneeboard' tab under 'Select Aircraft' select 'Default Kneeboard'.

2) Add the 'Default' group from the 'Available Groups' section to the 'Groups for Selected Custom Kneeboard' section.

3) Click on the 'Build Default Kneeboard' button.

4) A message box will appear telling you the default kneeboard has been built.

 

If you only want some of the default airport charts in the default kneeboard, you can copy the 'Default' group and modify the copy to only contain the charts you want. Then just add the copy group by itself to the 'Groups Selected' section and click on the 'Build Default Kneeboard' button.

 

 

The issue of subfolders is confusing to me. I would like to create an A10C subfolder for just certain checklists. If I create such a subfolder, how do I get it to appear in the kneeboard when I activate the kneeboard?

 

I think that I figured out the subfolder issue. You just make another folder under the game name and then simply change the folder to be used by your program. If you want to go back to your regular folder, again you would use your program to simply change folders. Correct?

 

After you have created your subfolders (called 'Groups' in my program), just add the ones you want to be included in your kneeboard to the "Groups Selected' section and click on the 'Build Custom Kneeboard' button. Whenever you build a kneeboard for an aircraft it completely clears the existing kneeboard and the newly built kneeboard will only include the 'Groups' you have added to the 'Groups Selected' section.

 

For example, you have the following groups: 'Startup Checklist', 'Gun Employment Checklist' and 'Maverick Employment Checklist'.

 

Lets say you want to practice your startup and gun strafing skills. With 'A-10C' as the selected aircraft, only add the 'Startup Checklist' and 'Gun Employment Checklist' to the 'Groups Selected' section and click 'Build Custom Kneeboard for A-10C'. Your A-10C kneeboard will then only contain the 'Startup' and 'Gun' checklists.

 

After completing that mission, you decide you just want to practice using mavericks. Once again you would make sure 'A-10C' is your selected aircraft and then add the 'Maverick Employment Checklist' by itself to the 'Groups Selected' section. Click on the 'Build Custom Kneeboard' button and your A-10C kneeboard will now only contain the 'Maverick Employment Checklist'

 

 

I hope all of that makes sense. Once I get the program feature complete and bug free I plan on making some youtube videos demonstrating all of the program's features with some tips and tricks.

Link to post
Share on other sites
What version of windows do you have?

 

Try this earlier version and see if it works:

 

Version 1.2.1

 

(Click 'no' when it asks you if you want to update)

 

 

EDIT:

 

It appears the 'drag and drop' feature is not working for you for some reason. I am working on a quick fix that adds a browse button so you can manually browse to the file if you cannot drag and drop.

 

Windows 7 64 bit

 

The link you gave me is unavailable. So I can't see if 1.2.1 is working.

 

The drag and drop feature is standard with your program me design. So I think its really interesting to figure out why its not working. Especially since, if you remember, I stated that the first time I use your program me, the feature on your program me worked fine.

 

So this is a mystery worthy of Shylock Holmes. I'm hoping you are a mystery lover too, maybe (with some help from the Lord :smartass:) we can solve this one.

Link to post
Share on other sites

AlaskanGrizzly

Great post and a great program. What is your computer background?

Trackir4 using the latest Trackir 5 software, Win10 Pro [Creator Update] updated from Win7Pro Pro 64Bit, Intel® Core™ i5-2500 3.30 GHz 6M Intel Smart Cache LGA115 , GigaByte GA-Z68XP-UD4 Intel Z68 Chipset DDR3 16GB Ram, GTX MSI Gaming 1060 [6 GB] Video Card, Main Monitor 1 on left 1920x1080 Touchscreen Monitor 2 on right 1920x1080 .

Link to post
Share on other sites
Windows 7 64 bit

 

The link you gave me is unavailable. So I can't see if 1.2.1 is working.

 

 

Sorry the link is available again now.

 

AlaskanGrizzly

Great post and a great program. What is your computer background?

 

I am self taught in C#, VB, HTML, PHP, Javascript and a little bit of LUA. It is mostly a hobby of mine right now; my current job is actually a police officer.


Edited by AlaskanGrizzly
Link to post
Share on other sites

Version 1.4.1.0 Released

 

Version 1.4.1.0 is now available.

 

Version 1.4.1.0 Changelog:

-added button to manually browse .pdf files for import for situations where 'drag and drop' does not work

-fixed bug preventing .pdf files from being added to the import queue if the .pdf extension is capitalized (.PDF)

Link to post
Share on other sites
I am self taught in C#, VB, HTML, PHP, Javascript and a little bit of LUA. It is mostly a hobby of mine right now; my current job is actually a police officer.

Kick Ass!

 

As a self-taught programmer myself I have to say that your stuff is so polished that I would never have guessed. Thanks for your service as a cop as well.

 

S!

Link to post
Share on other sites

works like a charm grizz. Thanks.

 

Now ... to test it in the cockpit.

 

p.s Ok first test shows the positioning of the Kneeboard on the screen is not working. I moved it from the default left to the right side - the result in cockpit showed the kneeboard in the centre left of the screen. So it did move, just not the right position. The screen size was reported correctly in the program me. If I may ask, which file is modified to change position? I can then use the program me and go and check what changes are actually being made.


Edited by eyusuf
Link to post
Share on other sites

p.s Ok first test shows the positioning of the Kneeboard on the screen is not working. I moved it from the default left to the right side - the result in cockpit showed the kneeboard in the centre left of the screen. So it did move, just not the right position. The screen size was reported correctly in the program me. If I may ask, which file is modified to change position? I can then use the program me and go and check what changes are actually being made.

 

Thanks for catching that. It was a math conversion typo in the program. It is fixed and will be released with the next update soon.

 

FYI it modifies the 'ViewportHandling.lua' located here:

 

"....\Eagle Dynamics\DCS World\Scripts\Aircrafts\_Common\Cockpit\ViewportHandling.lua"

 

Also, are you still unable to drag and drop with the most recent update?

Link to post
Share on other sites

I also don't have any ink ... because the bankers stole all the factors of production by printing money.

 

Be that as it may ... updating (and patching to version 1.4.2.0 breaks the program me successfully. Reverting to 1.4.1.0 still appears to work if I manually import pdf's.

 

Thanks again Grizzly.


Edited by eyusuf
Link to post
Share on other sites

Something I noticed at the weekend is when I accidently toggled cockpit off in the A10c the right MFCD is displayed exactly where I have my kneeboard when I activate kneeboard it pops up infront of the MFCD, just curious as to how on earth that happened does the right MFCD share something with the kneeboard.

Eagles may soar high but weasel's don't get sucked into jet engines.

 

 

System Spec.

Monitors: Samsung 570DX & Rift CV1

Mobo: MSI Godlike gaming X-99A

CPU: Intel i7 5930K @ 3.50Ghz

RAM: 32gb

GPU: EVGA Nvidia GTX 980Ti VR Ready

Cooling: Predator 360

Power Supply: OCZ ZX Series 80 Plus Gold

Drives: Samsung SSD's 1tb, 500g plus others with OS Win10 64 bit

 

Link to post
Share on other sites

Hey,

 

just downloaded the file and GS64 but kneeboard wont run, no error presented but this from Windows Event Log:

 

Protokollname: Application

Quelle: Application Error

Datum: 15.09.2014 19:06:15

Ereignis-ID: 1000

Aufgabenkategorie:(100)

Ebene: Fehler

Schlüsselwörter:Klassisch

Benutzer: Nicht zutreffend

Computer: Mac7

Beschreibung:

Name der fehlerhaften Anwendung: KneeboardBuilder.exe, Version: 1.4.2.0, Zeitstempel: 0x54163896

Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 6.1.7601.18409, Zeitstempel: 0x5315a05a

Ausnahmecode: 0xe0434352

Fehleroffset: 0x000000000000940d

ID des fehlerhaften Prozesses: 0xd34

Startzeit der fehlerhaften Anwendung: 0x01cfd1075b4736b7

Pfad der fehlerhaften Anwendung: C:\Users\Lars\Desktop\Neuer Ordner (2)\KneeboardBuilder.exe

Pfad des fehlerhaften Moduls: C:\Windows\system32\KERNELBASE.dll

Berichtskennung: 99cec031-3cfa-11e4-8faf-a8206600046b

Ereignis-XML:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

<System>

<Provider Name="Application Error" />

<EventID Qualifiers="0">1000</EventID>

<Level>2</Level>

<Task>100</Task>

<Keywords>0x80000000000000</Keywords>

<TimeCreated SystemTime="2014-09-15T17:06:15.000000000Z" />

<EventRecordID>8665</EventRecordID>

<Channel>Application</Channel>

<Computer>Mac7</Computer>

<Security />

</System>

<EventData>

<Data>KneeboardBuilder.exe</Data>

<Data>1.4.2.0</Data>

<Data>54163896</Data>

<Data>KERNELBASE.dll</Data>

<Data>6.1.7601.18409</Data>

<Data>5315a05a</Data>

<Data>e0434352</Data>

<Data>000000000000940d</Data>

<Data>d34</Data>

<Data>01cfd1075b4736b7</Data>

<Data>C:\Users\Lars\Desktop\Neuer Ordner (2)\KneeboardBuilder.exe</Data>

<Data>C:\Windows\system32\KERNELBASE.dll</Data>

<Data>99cec031-3cfa-11e4-8faf-a8206600046b</Data>

</EventData>

</Event>

 

 

 

Any ideas ?

 

 

Bit

Asus Z370-E - 8700K@5G_delidded - 32GB - 1080GTX-Ti EK-waterblock - 1x 960Evo 250GB - 3x Samsung 850/860Pro 256GB Raid-0 - 32GB PageFile - 2x Seagate 2TB - Heatkiller IV - MoRa3-360LT@4x180mm fans - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win10Pro64 

Link to post
Share on other sites
Hey,

 

just downloaded the file and GS64 but kneeboard wont run, no error presented but this from Windows Event Log:

 

Protokollname: Application

Quelle: Application Error

Datum: 15.09.2014 19:06:15

Ereignis-ID: 1000

Aufgabenkategorie:(100)

Ebene: Fehler

Schlüsselwörter:Klassisch

Benutzer: Nicht zutreffend

Computer: Mac7

Beschreibung:

Name der fehlerhaften Anwendung: KneeboardBuilder.exe, Version: 1.4.2.0, Zeitstempel: 0x54163896

Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 6.1.7601.18409, Zeitstempel: 0x5315a05a

Ausnahmecode: 0xe0434352

Fehleroffset: 0x000000000000940d

ID des fehlerhaften Prozesses: 0xd34

Startzeit der fehlerhaften Anwendung: 0x01cfd1075b4736b7

Pfad der fehlerhaften Anwendung: C:\Users\Lars\Desktop\Neuer Ordner (2)\KneeboardBuilder.exe

Pfad des fehlerhaften Moduls: C:\Windows\system32\KERNELBASE.dll

Berichtskennung: 99cec031-3cfa-11e4-8faf-a8206600046b

 

Any ideas ?

 

Bit

 

Disregard the suggestions I gave you earlier.

 

Apparently there is a bug where the program settings sometimes become corrupted after the program is updated. I am working on a fix.

 

For now, if the program does not want to start right after an update, delete the 'settings.xml' and 'KneeboardBuilder.exe.config' files and try starting it again. You will then need to verify your directory settings in Options -> Preferences.

 

Sorry for steering you down the wrong path earlier.


Edited by AlaskanGrizzly
Provided incorrect solution
Link to post
Share on other sites
Something I noticed at the weekend is when I accidently toggled cockpit off in the A10c the right MFCD is displayed exactly where I have my kneeboard when I activate kneeboard it pops up infront of the MFCD, just curious as to how on earth that happened does the right MFCD share something with the kneeboard.

 

It modifies the 'ViewportHandling.lua' located here:

 

"....\Eagle Dynamics\DCS World\Scripts\Aircrafts\_Common\Cockpit\ViewportHandling.lua"

 

I suppose the right MFCD could possible use the same viewport settings. I don't know of a way to prevent that from happening . . .

Link to post
Share on other sites
I also don't have any ink ... because the bankers stole all the factors of production by printing money.

 

Be that as it may ... updating (and patching to version 1.4.2.0 breaks the program me successfully. Reverting to 1.4.1.0 still appears to work if I manually import pdf's.

 

Thanks again Grizzly.

 

You may have a corrupt system .dll that is not working correctly.

 

Try running Microsoft's System Checker Tool by following these instructions:

http://support.microsoft.com/kb/929833

Link to post
Share on other sites
It modifies the 'ViewportHandling.lua' located here:

 

"....\Eagle Dynamics\DCS World\Scripts\Aircrafts\_Common\Cockpit\ViewportHandling.lua"

 

I suppose the right MFCD could possible use the same viewport settings. I don't know of a way to prevent that from happening . . .

 

It doesn't bother me i never run in cockpit off it was just an accident thought i would let you know that it was there.

But its got me thinking in a new direction towards exporting the MFCDS from the cockpit.

Eagles may soar high but weasel's don't get sucked into jet engines.

 

 

System Spec.

Monitors: Samsung 570DX & Rift CV1

Mobo: MSI Godlike gaming X-99A

CPU: Intel i7 5930K @ 3.50Ghz

RAM: 32gb

GPU: EVGA Nvidia GTX 980Ti VR Ready

Cooling: Predator 360

Power Supply: OCZ ZX Series 80 Plus Gold

Drives: Samsung SSD's 1tb, 500g plus others with OS Win10 64 bit

 

Link to post
Share on other sites

Hi,

 

I also have trouble running this application. The problem reported in the windows event log is (windows 8.1, 64 bit, .net 4.5 installed):

 

Application: KneeboardBuilder.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: System.Reflection.TargetInvocationException

Stack:

at System.Windows.Markup.WpfXamlLoader.Load(System.Xaml.XamlReader, System.Xaml.IXamlObjectWriterFactory, Boolean, System.Object, System.Xaml.XamlObjectWriterSettings, System.Uri)

at System.Windows.Markup.WpfXamlLoader.LoadBaml(System.Xaml.XamlReader, Boolean, System.Object, System.Xaml.Permissions.XamlAccessLevel, System.Uri)

at System.Windows.Markup.XamlReader.LoadBaml(System.IO.Stream, System.Windows.Markup.ParserContext, System.Object, Boolean)

at System.Windows.Application.LoadBamlStreamWithSyncInfo(System.IO.Stream, System.Windows.Markup.ParserContext)

at System.Windows.Application.LoadComponent(System.Uri, Boolean)

at System.Windows.Application.DoStartup()

at System.Windows.Application.<.ctor>b__1(System.Object)

at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)

at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)

at System.Windows.Threading.DispatcherOperation.InvokeImpl()

at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)

at System.Windows.Threading.DispatcherOperation.Invoke()

at System.Windows.Threading.Dispatcher.ProcessQueue()

at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)

at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)

at MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object)

at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)

at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)

at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)

at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)

at MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)

at MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)

at System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)

at System.Windows.Application.RunInternal(System.Windows.Window)

at System.Windows.Application.Run()

at KneeboardBuilder.App.Main()

 

Does somebody perhaps have a clue why it is failing?

 

Some more info: I unzipped again and this time did not choose to install the update (so I'm at version 1.4.1.0 now) and now it does work.

 

Thanks, Marcel


Edited by huppel
Link to post
Share on other sites

I have no idea why yours is not working mine is working fine apart from what i noticed in post above.

Eagles may soar high but weasel's don't get sucked into jet engines.

 

 

System Spec.

Monitors: Samsung 570DX & Rift CV1

Mobo: MSI Godlike gaming X-99A

CPU: Intel i7 5930K @ 3.50Ghz

RAM: 32gb

GPU: EVGA Nvidia GTX 980Ti VR Ready

Cooling: Predator 360

Power Supply: OCZ ZX Series 80 Plus Gold

Drives: Samsung SSD's 1tb, 500g plus others with OS Win10 64 bit

 

Link to post
Share on other sites
You may have a corrupt system .dll that is not working correctly.

 

Try running Microsoft's System Checker Tool by following these instructions:

http://support.microsoft.com/kb/929833

 

 

C:\Windows\system32>sfc /scannow

 

Beginning system scan. This process will take some time.

 

Beginning verification phase of system scan.

 

Windows Resource Protection did not find any integrity violations.

 

 

Verification 100% complete. Between the last version and this one something went broke ....

 

I remember running this before, but it finds nothing, even though something clearly isn't working ...

Link to post
Share on other sites
Hi,

 

I also have trouble running this application. The problem reported in the windows event log is (windows 8.1, 64 bit, .net 4.5 installed):

 

Does somebody perhaps have a clue why it is failing?

 

Some more info: I unzipped again and this time did not choose to install the update (so I'm at version 1.4.1.0 now) and now it does work.

 

Thanks, Marcel

 

The program will not start immediately after the update, is that correct? If the program does not want to start right after an update, delete the 'settings.xml' and 'KneeboardBuilder.exe.config' files and try starting it again. You will then need to verify your directory settings in Options -> Preferences.

 

For some reason, sometimes it doesn't like to use the current user settings after an update. Let me know if that was the problem.

 

 

eyusuf: This might fix your problem as well after the latest update.


Edited by AlaskanGrizzly
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...