Jump to content

Master disconnect when testing missions with 2 PCs


FlightControl
 Share

Recommended Posts

During the testing of my missions, I use a dedicated server PC, which i configure as a DCS server with proper port forwarding etc on my router.

I also use a separate machine, which i configure as my DCS client, connecting to the server.

 

Since version 1.2.9, i am experiencing errors on the server side: disconnects from the master. When I join the client on the server (on the same LAN), the server disconnects after a minute or so from the master. The server gives the error: "Cannot connect to Master". Also the client stops working.

 

The method used to work for all versions since 1.2.8.

 

Therefore, i have two questions:

 

1. Am I allowed to install the purchased DCS modules on two PCs that I own, with the same license key? Or, do I need to purchase for each PC separate licenses (I really hope not, because that is going to cost me a fortune!)

 

2. Is somebody else in the community experiencing this kind of problem? (Xcom, ENO?)

 

Sven


Edited by FlightControl

[TABLE][sIGPIC][/sIGPIC]|

[/TABLE]

Link to comment
Share on other sites

Two PC with same license can`t go online in same time. So, you need separate licenses in your case. Or on server install only DCS World and you don`t need FC3, F15C, A10C...etc license, clients have it. Just in mission desing make client slots for F86, F15C... actually, come to think of it, maybe I'm wrong.


Edited by Falcon_S
Quote

Немој ништа силом, узми већи чекић!

MSI Tomahawk MAX | Ryzen 7 3700x | 32GB DDR4 3200MHz | RX 5700 XT OC Red Dragon 8GB | VPC Throttle CM3 + VPC Constellation ALPHA on VPC WarBRD Base | HP Reverb G2

Falcon's Twitch Bar Discord  | Youtube Follow Me on TWITCH!Falcon's flight zone FB page

Link to comment
Share on other sites

Aha, i think you are right... Ill try that. I just got a brand new pc, you see... And was trying out the same testing concept, but with a different configuration. I'll uninstall modules gradually on the server and see what happens. I'll keep you posted. I will have to "unprotected" these modules.

[TABLE][sIGPIC][/sIGPIC]|

[/TABLE]

Link to comment
Share on other sites

...I'll uninstall modules gradually on the server and see what happens...

No need to do it "gradually". All what server needs is DCS-World, which you can get free (no license/key required). IIRC you still need to have different (unique) DCS-account for server, but again, that's not a problem.

Link to comment
Share on other sites

The thing is, I have all these modules registered. So I need to unregister them first. Simply uninstalling DCS does not unregister the modules.

[TABLE][sIGPIC][/sIGPIC]|

[/TABLE]

Link to comment
Share on other sites

The thing is, I have all these modules registered. So I need to unregister them first. Simply uninstalling DCS does not unregister the modules.

Use a clean DCS World installation without any modules and with a new account as server.

Use your main account with installed modules to play with.

This should work with no problems.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...