Jump to content

Problem with TrackIR 60% off coupon


starsky396
 Share

Recommended Posts

I tried to buy the DCS F-86F module, I used the coupon and it was valid. I was transferred over to sagepay as usual and I accidently had explorer closed. No problem I thought, however once I tried to re enter the coupon into DCS's store, the coupon is no longer valid. Is there anyway to fix this?

Link to comment
Share on other sites

You might have to open a Support Ticket, I don't think this can be worked on through the forums.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, 2x R7970 Lightnings Crossfired @ 1.1/6.0GHz,

3x ASUS VS248HP + Hanns·G HZ201HPB + Oculus HMD,

Thrustmaster Warthog HOTAS + MFDs, CH Fighterstick+Pro Throttle+Pro Pedals

Link to comment
Share on other sites

I had a problem very similar. It won't let me enter the coupon code, again. I've also opened a support ticket. I hope they can help. :/

 

EDIT: I seem to have found a fix!!!!! All I had to do was go onto their website (not the forums) and click on the Personal section > My orders and you get the option to 'PAY' at the bottom.


Edited by Rise Tragedy

 

Intel i5 6600k @4.2 Ghz

NVIDIA GeForce GTX 1050 Ti

8GB DDR3

Windows 10 64 bit

Samsung SyncMaster S24B300HL 24"

Saitek X52

CH Products Pro Flight Pedals

TrackIR 5 with Track Clip

Logitech G930 Wireless Gaming Headset

 

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...