Jump to content

Unable to use mouse clicks for aircraft control when using 3 screens


Recommended Posts

G'day all,

 

Just bought myself a new desktop system and when I try to use DCS in 3 screen mode I cannot use the mouse to toggle any controls. I do get the full cockpit view in 3 screen mode. If I go to single screen there are no problems using the mouse..

 

DCS and all of the modules I have are up to date. I have A-10C, Black Shark 2 and UH-1H.

 

My system is;

 

Win 8.1,

Intel i7 4770,

16 GB Ram,

nVidia GeoForce GTX 365 (2 MB),

3 x LG 23EA63 monitors,

Saitek Pro Flight combat pedals (works fine),

Cyborg X V 5 joystick for my cyclic / flight stick (works fine), and

Cyborg X V 1 joystick for my collective / engine controls (works fine).

 

So any ideas folks ?

 

Many thanks for any help in advance.

Slow is smooth. Smooth is fast.

 

Win 8.1 64 bit | i7 4470 @ 3.4 GHz | 16 GB DDR3 RAM | GeoForce GTX 645 2 GB VRAM | X-55 Rhino HOTAS | Saitek Pro Combat Pedals | TrackIR 5 | iControl

Link to post
Share on other sites

Mate, I am new to the sim.

 

So I thought that if I had 3 screens, I had to set up DCS World to run in 3 screens. So if I run the sim in 1 screen mode, how do I get the program to display on 3 screens ?

 

BTW, I i watched your YouTube vid and blown away with your set-up. It was the A-10 start up procedure.

 

More info would be most helpful.

 

Many thanks.

Slow is smooth. Smooth is fast.

 

Win 8.1 64 bit | i7 4470 @ 3.4 GHz | 16 GB DDR3 RAM | GeoForce GTX 645 2 GB VRAM | X-55 Rhino HOTAS | Saitek Pro Combat Pedals | TrackIR 5 | iControl

Link to post
Share on other sites

I tried changing the video options to;

 

Res 1920 x 1080,

Aspect 1.777777,

Monitors 1,

Cockpit res 256.

 

I still get the marker for the mouse(the + symbol) but, it will not do anything.

 

Any other suggestions anyone ?

Slow is smooth. Smooth is fast.

 

Win 8.1 64 bit | i7 4470 @ 3.4 GHz | 16 GB DDR3 RAM | GeoForce GTX 645 2 GB VRAM | X-55 Rhino HOTAS | Saitek Pro Combat Pedals | TrackIR 5 | iControl

Link to post
Share on other sites

You probably have the set up wrong in windows. You need your left screen to be the main display, and it'll all work fine.

 

The video you saw wasn't mine I am afraid. Very good though wasn't it. It's what made me want a 4 screen setup

Link to post
Share on other sites

Hello Noumcea wellcome to the forum.

 

My experiance with this problem has been somthing not set up right.

 

When useing multi screens you must un check full screen mode in the options menu.

 

3 screen mode is for a "U" shaped setup, for very large screens, Projectors.

The left and right screens are to mounted on the left and right side of your head, center screen is straight ahead. to look out the left window, you turn your head 90 degs to the left and peer at the left monitor straight on. at this point , your right monitor is facing the back of your head.

 

You have 2 options. 1 Configure / edit your screen lua. ,

or 2, use Easy Monitor Cofigurator " EMC" This is in the mod section of the forum , you download it from the mod section of this forum. It makes setup easy.

 

Hope this helps .

Mark.

Home built X-58FTW,i7 950, 3 x GTX570oc,

screens; 3 x 22", 19", 17", 9" :D

My pit. http://forums.eagle.ru/showthread.php?t=121598

Link to post
Share on other sites

Everyone,

 

Many thanks for your help, the problem is now sorted. I selected 1 monitor and unchecked full screen mode. works like a charm !!!

 

So I got through the Huey start-up procedures, then went to the take-off tutorial. Crappy take off but I got the bird in the air. Then my wife comes in and wanted to know what a button on my collective stick did. She dropped my throttle to 0% and I went out in a ball of flame....

 

We had a good laugh though.

 

Happy simming all and I hope to meet you on the servers one day, when I learn how to fly.

Slow is smooth. Smooth is fast.

 

Win 8.1 64 bit | i7 4470 @ 3.4 GHz | 16 GB DDR3 RAM | GeoForce GTX 645 2 GB VRAM | X-55 Rhino HOTAS | Saitek Pro Combat Pedals | TrackIR 5 | iControl

Link to post
Share on other sites

3 screen mode is for a "U" shaped setup, for very large screens, Projectors.

The left and right screens are to mounted on the left and right side of your head, center screen is straight ahead. to look out the left window, you turn your head 90 degs to the left and peer at the left monitor straight on. at this point , your right monitor is facing the back of your head.

 

I was wondering about this, how to tell DCS to render a specific view on the side monitors so that they show the left and right windows. I presume there's somewhere I'd need to specify some sort of 3D coordinate to tell it which part of the world view to render?

 

I see lots of people have threee screens in a line but the outer two angled in a bit. Are all three monitors just rendering the view in front of the aircraft, i.e. all in the same z-plane, in which case surely angling in the two outer monitors is distorting the view as they're not showing any of the side view but are positioned as if they were? Is there a way to specify where the side monitor's render starts and ends in the x, y and z planes, so that the view rendered accurately matches their positioning/angle?

Main rig: i5-4670k @4.4Ghz, Asus Z97-A, Scythe Kotetsu HSF, 32GB Kingston Savage 2400Mhz DDR3, 1070ti, Win 10 x64, Samsung Evo 256GB SSD (OS & Data), OCZ 480GB SSD (Games), WD 2TB and WD 3TB HDDs, 1920x1200 Dell U2412M, 1920x1080 Dell P2314T touchscreen

Link to post
Share on other sites
  • 9 months later...

I also cant get my mouse to work when I try to click on the Dora to open up the

circuit breaker cover or anything. I did a " Repair DCS " and it did not fix the

problem. Left Alt C just makes my screens go crazy because of the trackir5.

 

Not sure what to do as it normally works just fine ????

 

I did not change anything that I know of.

********************************************************************

 

So I switched from full screen, and everything worked ok.

Of course I crashed the dora, but nothing unusual there.

 

So if I take off full screen, the edges of my three monitors dont have

any DCS and that does not look good.

 

I guess I will have to look up windowed mode or some other thing

as I cant get DCS to let my mouse work at all if Im not out of full screen.

 

This has never happened before, and I dont know why its happening now ?


Edited by ctguy1955
problem is not solved
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...